aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/ubridge/APKBUILD37
-rw-r--r--testing/ubridge/musl-fixes.patch24
2 files changed, 61 insertions, 0 deletions
diff --git a/testing/ubridge/APKBUILD b/testing/ubridge/APKBUILD
new file mode 100644
index 00000000000..9a8712b4ca3
--- /dev/null
+++ b/testing/ubridge/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ubridge
+pkgver=0.9.3
+pkgrel=0
+pkgdesc="Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces."
+url="https://github.com/GNS3/ubridge"
+arch="all"
+license="GPL3"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libpcap-dev linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${pkgname}/archive/v${pkgver}.tar.gz
+ musl-fixes.patch"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 ${srcdir}/${pkgname}-${pkgver}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
+ install -m644 ${srcdir}/${pkgname}-${pkgver}/README.rst -t ${pkgdir}/usr/share/doc/${pkgname}
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+md5sums="e78a53a4a0d9301059c86fe5d67297fb ubridge-0.9.3.tar.gz
+91dc8e9c293ae71b1b4e662f2cd83dcb musl-fixes.patch"
+sha256sums="913691f64e36626ad7182d7be88452e87145f4e8dfdfc628e8591d2e298f46f3 ubridge-0.9.3.tar.gz
+cd4c6e8aae9a9f822627bc747a935191cb2ef7373af4a81ea538d600b6778d0d musl-fixes.patch"
+sha512sums="95283c977054742c2fa7ad4ee0d5e8bff42b0b3a7aa2d16cc683b7a0ab40b55595679b124ffca9766af7ec055d632755c10aa2fe6aec48bf1b466966a5bbcaf8 ubridge-0.9.3.tar.gz
+748a33f8c9e6841febcecc6d1fbad7eb5a07dbd05c61bc338dedced04adf8085d4386ae4461bcc406d0975b78ac5a656c260c2443a7369d6876f963ae8e7f128 musl-fixes.patch"
diff --git a/testing/ubridge/musl-fixes.patch b/testing/ubridge/musl-fixes.patch
new file mode 100644
index 00000000000..42640805101
--- /dev/null
+++ b/testing/ubridge/musl-fixes.patch
@@ -0,0 +1,24 @@
+diff --git a/netlink/nl.c b/netlink/nl.c
+index 7a11506..5e7df80 100644
+--- a/netlink/nl.c
++++ b/netlink/nl.c
+@@ -29,6 +29,7 @@
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <linux/netlink.h>
++#include <sys/types.h>
+ #include <linux/rtnetlink.h>
+ #include "nl.h"
+
+diff --git a/netlink/nl.h b/netlink/nl.h
+index 34aeb36..d25a65d 100644
+--- a/netlink/nl.h
++++ b/netlink/nl.h
+@@ -26,6 +26,7 @@
+ /*
+ * Use this as a good size to allocate generic netlink messages
+ */
++#include <sys/types.h>
+ #ifndef PAGE_SIZE
+ #define PAGE_SIZE 4096
+ #endif