aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/lsof/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/main/lsof/APKBUILD b/main/lsof/APKBUILD
index 07652bdcff5..4548d582005 100644
--- a/main/lsof/APKBUILD
+++ b/main/lsof/APKBUILD
@@ -1,15 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lsof
-pkgver=4.91
+pkgver=4.93.2
pkgrel=0
pkgdesc="LiSt Open Files"
url="https://people.freebsd.org/~abe"
arch="all"
-license="custom"
+license="lsof"
subpackages="$pkgname-doc"
makedepends="linux-headers"
-source="https://fossies.org/linux/misc/${pkgname}_${pkgver}_src.tar.xz"
-builddir="$srcdir/${pkgname}_${pkgver}_src"
+source="https://fossies.org/linux/misc/lsof-$pkgver.tar.xz"
prepare() {
default_prepare
@@ -17,23 +16,18 @@ prepare() {
sed -i "s|/\* #define\tHASSECURITY\t1 \*/|#define\tHASSECURITY\t1|" \
dialects/linux/machine.h
- sed -n 6,30p lsof.h > COPYING
}
-build () {
+build() {
cd "$builddir"
-
./Configure -n linux
make
}
package() {
cd "$builddir"
-
- install -D -m0755 -o root -g root lsof "$pkgdir"/usr/bin/lsof
- install -D -m0644 -o root -g root lsof.8 \
- "$pkgdir"/usr/share/man/man8/lsof.8
- install -D -m644 COPYING "$pkgdir"/usr/share/licenses/lsof/COPYING
+ install -Dm0755 lsof "$pkgdir"/usr/bin/lsof
+ install -Dm0644 Lsof.8 "$pkgdir"/usr/share/man/man8/lsof.8
}
-sha512sums="d6b378d65152708aa255a74a8bfc8c07ecf923aa4ef02212f7b2af6cb31394f3c11980e1b197cbc47e1b1881d3024a542982c3f67605d8bbb60e1c3df4fb3608 lsof_4.91_src.tar.xz"
+sha512sums="9ce751092bec5d2dccb79d92aa1d7c541819e0e24e56bd0a3ec0513bd7a403c3abb85a68aa5283f84aa44b4f71742ed18f5437cc039c13ce886bf22facd1557a lsof-4.93.2.tar.xz"