aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/weston/APKBUILD8
-rw-r--r--community/weston/timespec.patch10
2 files changed, 3 insertions, 15 deletions
diff --git a/community/weston/APKBUILD b/community/weston/APKBUILD
index f391066da83..e8dba31392e 100644
--- a/community/weston/APKBUILD
+++ b/community/weston/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=weston
-pkgver=10.0.0
+pkgver=10.0.1
pkgrel=0
_libname=lib$pkgname
_libdir=$_libname-${pkgver%%.*}
@@ -30,9 +30,7 @@ subpackages="$pkgname-dev $pkgname-doc $subpackages
$pkgname-clients $_libname-desktop:_libd $_libname:libs
$pkgname-xwayland $pkgname-desktop-x11:_x11:noarch
"
-source="https://wayland.freedesktop.org/releases/weston-$pkgver.tar.xz
- timespec.patch
- "
+source="https://gitlab.freedesktop.org/wayland/weston/-/releases/$pkgver/downloads/weston-$pkgver.tar.xz"
# weston-launch requires suid
options="!check suid"
install="$pkgname.pre-install"
@@ -124,6 +122,6 @@ _sub() {
}
sha512sums="
-77e05530751e4f743eebf015ab5b78a1fcc66b774713b5e296cfffc488be84e459f811c85ac4280b7b63eebf4ff5c958dd7306376ab343e6b80feae16c8c35a4 weston-10.0.0.tar.xz
+688d843096a95b463161b98e85ca3443b31ba2ee49fc8d456a2780cc96f576e9d097054e9f361997a66e9cc8373cf29e406a742dae3884b3b50b26acf1710c8c weston-10.0.1.tar.xz
3e596af4bf0a6b06a5d28376043db111fe1c161ead04501fa6d2c667b5a21889cca3354d1bdc4ac794841bef68ed5e1a7a84e44e7d510e947e3673195706caed timespec.patch
"
diff --git a/community/weston/timespec.patch b/community/weston/timespec.patch
deleted file mode 100644
index 7c2c8f62e96..00000000000
--- a/community/weston/timespec.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/tests/timespec-test.c
-+++ b/tests/timespec-test.c
-@@ -25,6 +25,7 @@
-
- #include "config.h"
-
-+#include <time.h>
- #include <stdlib.h>
- #include <stdint.h>
- #include <stdio.h>