aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/perl-test-class/APKBUILD36
-rw-r--r--testing/perl-test-class/APKBUILD39
2 files changed, 36 insertions, 39 deletions
diff --git a/community/perl-test-class/APKBUILD b/community/perl-test-class/APKBUILD
new file mode 100644
index 00000000000..ca3f6f3acae
--- /dev/null
+++ b/community/perl-test-class/APKBUILD
@@ -0,0 +1,36 @@
+# Automatically generated by apkbuild-cpan, template 3
+# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
+# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
+pkgname=perl-test-class
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
+_pkgreal=Test-Class
+pkgver=0.50
+pkgrel=2
+pkgdesc="Easily create test classes in an xUnit/JUnit style"
+url="https://metacpan.org/release/Test-Class/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-module-runtime perl-mro-compat perl-try-tiny"
+makedepends="perl-dev"
+checkdepends="perl-test-exception"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/Test-Class-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="27ae19f60a916f5a23cccdc02ff6168e76d5f1cee5df196df4fe50024f7270ee9eaffdf02e9b6de70565c9b6b30606ad0a30477ac8951164b87c641caf960dcc Test-Class-0.50.tar.gz"
diff --git a/testing/perl-test-class/APKBUILD b/testing/perl-test-class/APKBUILD
deleted file mode 100644
index 4218b288710..00000000000
--- a/testing/perl-test-class/APKBUILD
+++ /dev/null
@@ -1,39 +0,0 @@
-# Automatically generated by apkbuild-cpan, template 1
-# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
-# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
-pkgname=perl-test-class
-_pkgreal=Test-Class
-pkgver=0.50
-pkgrel=1
-pkgdesc="Easily create test classes in an xUnit/JUnit style"
-url="https://metacpan.org/release/Test-Class/"
-arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-try-tiny perl-mro-compat perl-module-runtime"
-cpanmakedepends=" perl-test-exception "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
-
-prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
-build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
-}
-
-sha512sums="27ae19f60a916f5a23cccdc02ff6168e76d5f1cee5df196df4fe50024f7270ee9eaffdf02e9b6de70565c9b6b30606ad0a30477ac8951164b87c641caf960dcc Test-Class-0.50.tar.gz"