aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/qt5-qtscxml/APKBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/community/qt5-qtscxml/APKBUILD b/community/qt5-qtscxml/APKBUILD
index 8a48a091e14..38a615c0b04 100644
--- a/community/qt5-qtscxml/APKBUILD
+++ b/community/qt5-qtscxml/APKBUILD
@@ -1,22 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qt5-qtscxml
-pkgver=5.15.2
-pkgrel=1
+pkgver=5.15.3_git20201027
+pkgrel=0
+_commit="7a15000f42c7a3171719727cd056f82a78244ed7"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url="https://www.qt.io/developers/"
license="LGPL-2.1-only AND LGPL-3.0-only AND GPL-3.0-only AND Qt-GPL-exception-1.0"
pkgdesc="Static and runtime integration of SCXML models into Qt code"
makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
subpackages="$pkgname-dev $pkgname-doc"
-builddir="$srcdir/qtscxml-everywhere-src-$pkgver"
+builddir="$srcdir/qtscxml-$_commit"
case $pkgver in
*_beta*|*_rc*) _rel=development_releases;;
*) _rel=official_releases;;
esac
-source="http://download.qt.io/$_rel/qt/${pkgver%.*}/$pkgver/submodules/qtscxml-everywhere-src-$pkgver.tar.xz"
+source="https://invent.kde.org/qt/qt/qtscxml/-/archive/$_commit/qtscxml-$_commit.tar.gz"
+
+prepare() {
+ default_prepare
+
+ # We need to make the build system think we're running in a git repository
+ # so it correctly symlinks during the build
+ mkdir .git
+}
build() {
qmake-qt5
@@ -37,4 +46,4 @@ package() {
install -d "$pkgdir"/usr/share/licenses
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/$pkgname
}
-sha512sums="2a4719af94baefe7f0ca5a23239d07a05285a1698b052d17bb87bc221bbbc8bc25a70ff06d70d41ed7ac6a7e6646be9c516d8187c9098da1158c08e27a4b0bb8 qtscxml-everywhere-src-5.15.2.tar.xz"
+sha512sums="2d99952208044db1405b456570d0a5e4d0ec7e9fd9aaf64935d81822218802f8ab6132276e52e4fa0ec4407f25e815a429c0b17c367665cb71a212c14b875654 qtscxml-7a15000f42c7a3171719727cd056f82a78244ed7.tar.gz"