aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/perl-test-nginx/APKBUILD30
1 files changed, 13 insertions, 17 deletions
diff --git a/community/perl-test-nginx/APKBUILD b/community/perl-test-nginx/APKBUILD
index bbb28490c91..976117dc886 100644
--- a/community/perl-test-nginx/APKBUILD
+++ b/community/perl-test-nginx/APKBUILD
@@ -1,41 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=perl-test-nginx
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Test-Nginx
pkgver=0.26
-pkgrel=1
+pkgrel=2
pkgdesc="Data-driven test scaffold for Nginx C module and Nginx/OpenResty-based libraries and applications"
-url="https://github.com/openresty/test-nginx"
+url="https://metacpan.org/release/Test-Nginx/"
arch="noarch"
-license="BSD"
-depends="perl perl-list-moreutils perl-http-message perl-test-longstring
- perl-text-diff perl-libwww perl-uri perl-test-base"
+# License appears to be BSD-3-Clause but there is a one
+# word difference s/HOLDER/OWNER in line 2 of the Disclaimer
+license="BSD-3-Clause(variant)"
+depends="perl perl-http-message perl-uri perl-test-longstring
+ perl-list-moreutils perl-libwww perl-text-diff perl-test-base"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/A/AG/AGENT/$_pkgreal-$pkgver.tar.gz
+source="https://cpan.metacpan.org/authors/id/A/AG/AGENT/Test-Nginx-$pkgver.tar.gz
set-temp-paths.patch"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
-
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}