aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/ympd/APKBUILD16
-rw-r--r--main/ympd/musl-missing-errorh.patch80
2 files changed, 6 insertions, 90 deletions
diff --git a/main/ympd/APKBUILD b/main/ympd/APKBUILD
index 74ce47d9a87..71cd0dd5e50 100644
--- a/main/ympd/APKBUILD
+++ b/main/ympd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ympd
-pkgver=1.2.2
+pkgver=1.2.3
pkgrel=0
pkgdesc="A standalone MPD Web GUI"
url="http://www.ympd.org/"
@@ -12,8 +12,7 @@ depends_dev="libmpdclient-dev"
makedepends="$depends_dev cmake"
install="$pkgname.pre-install"
subpackages="$pkgname-doc"
-source="ympd-${pkgver}.tar.gz::https://github.com/notandy/ympd/archive/v1.2.2.tar.gz
- musl-missing-errorh.patch
+source="ympd-${pkgver}.tar.gz::https://github.com/notandy/ympd/archive/v$pkgver.tar.gz
$pkgname.initd
$pkgname.confd"
@@ -45,15 +44,12 @@ package() {
"$pkgdir"/etc/conf.d/$pkgname || return 1
}
-md5sums="b1e33f8de8249a5229d4e25bd739095b ympd-1.2.2.tar.gz
-9b8da2890287a459fb9cbf2bc225da28 musl-missing-errorh.patch
+md5sums="865f4370ad26e3020809a274ad4f123d ympd-1.2.3.tar.gz
d6158ed50f19e9d4caa276b18e8535ef ympd.initd
9a71d20477e801cefd8398d1216bde9d ympd.confd"
-sha256sums="4643a4e0983feb2762a94071f264c107e46507d61baa23f705676b0aeab17dcb ympd-1.2.2.tar.gz
-fc0d7f76edd9b46359fdb697615b528b806a29d9498bdc74ec02b65584b18682 musl-missing-errorh.patch
+sha256sums="092c26c51166d1d1f025cd06742981783dea7e42bfe4f73f10c4418fc003de94 ympd-1.2.3.tar.gz
898c720a65358fe8f4f06e6dcf8cf92970d7b368d8b17619edbc5883eb25e8d3 ympd.initd
ea2eb0ae943cee4e6036f48f4cc5f31141447bbd685bda796261e3572da26e1c ympd.confd"
-sha512sums="0a671886c06744e92b1393a1a14eb08f322ad3b9a00ee057d057d91bf7755eaf0f58ad15e4f1811c8b403ff4cd70b66ab213398dd22b8fe3563e325f58306265 ympd-1.2.2.tar.gz
-9a55e34f73ba73e85ee9ad1feab3571f944ada4e6c7adbe619e851929aee7254bccb0fbf37668b2c32676daae92922db358350997c15701653f40cd61798f62a musl-missing-errorh.patch
+sha512sums="09b877981e4f190effaf17f59c5ae6858c18a5c139333fb85e952364d3724ae378b3ef405b58e878e3a46aff0b375a56169c4a50e4f79681310c7f7a708c108d ympd-1.2.3.tar.gz
c64f0f615cd238cf9d756ba7e153786cb80e0d29416281a60619643ff696cd67095659e0fa771997dc72bcc1cae6aeb2eb1ce43488eb5d26b33dd0216b69e9a4 ympd.initd
a2c87d45acfe46efbaea6636a6ea592d17054de7fa6820b26ddd61875700dae268f0ca11a1065c38ea86d910fb54566eb454bbb755ed758e3ff71db4464689c1 ympd.confd"
diff --git a/main/ympd/musl-missing-errorh.patch b/main/ympd/musl-missing-errorh.patch
deleted file mode 100644
index 960ca3fc112..00000000000
--- a/main/ympd/musl-missing-errorh.patch
+++ /dev/null
@@ -1,80 +0,0 @@
---- ympd-1.2.2/htdocs/mkdata.c
-+++ ympd-1.2.2/htdocs/mkdata.c
-@@ -7,7 +7,11 @@
-
- #include <stdlib.h>
- #include <stdio.h>
-+#if HAVE_ERROR_H
- #include <error.h>
-+#else
-+#include <stdarg.h>
-+#endif
- #include <errno.h>
- #include <string.h>
-
-@@ -53,6 +57,60 @@
- return "text/plain";
- }
-
-+/*
-+ * Program name.
-+ */
-+#ifndef HAVE_PROGRAM_INVOCATION_SHORT_NAME
-+# ifdef HAVE___PROGNAME
-+extern char *__progname;
-+# define program_invocation_short_name __progname
-+# else
-+# ifdef HAVE_GETEXECNAME
-+# define program_invocation_short_name \
-+ prog_inv_sh_nm_from_file(getexecname(), 0)
-+# else
-+# define program_invocation_short_name \
-+ prog_inv_sh_nm_from_file(__FILE__, 1)
-+# endif
-+static char prog_inv_sh_nm_buf[256];
-+static inline char *prog_inv_sh_nm_from_file(char *f, char stripext)
-+{
-+ char *t;
-+
-+ if ((t = strrchr(f, '/')) != NULL)
-+ t++;
-+ else
-+ t = f;
-+
-+ strncpy(prog_inv_sh_nm_buf, t, sizeof(prog_inv_sh_nm_buf) - 1);
-+ prog_inv_sh_nm_buf[sizeof(prog_inv_sh_nm_buf) - 1] = '\0';
-+
-+ if (stripext && (t = strrchr(prog_inv_sh_nm_buf, '.')) != NULL)
-+ *t = '\0';
-+
-+ return prog_inv_sh_nm_buf;
-+}
-+# endif
-+#endif
-+
-+#ifndef HAVE_ERROR_H
-+/* Emulate the error() function from glibc */
-+__attribute__((__format__(__printf__, 3, 4)))
-+static void error(int status, int errnum, const char *format, ...)
-+{
-+ va_list argp;
-+ fprintf(stderr, "%s: ", program_invocation_short_name);
-+ va_start(argp, format);
-+ vfprintf(stderr, format, argp);
-+ va_end(argp);
-+ if (errnum != 0)
-+ fprintf(stderr, ": error code %d", errnum);
-+ fprintf(stderr, "\n");
-+ if (status != 0)
-+ exit(status);
-+}
-+#endif
-+
- int main(int argc, char *argv[])
- {
- int i, j, buf;
-@@ -92,3 +150,4 @@
- fputs(footer, stdout);
- return EXIT_SUCCESS;
- }
-+