aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/yarn/APKBUILD14
-rw-r--r--community/yarn/add-apk-install-method.patch30
2 files changed, 8 insertions, 36 deletions
diff --git a/community/yarn/APKBUILD b/community/yarn/APKBUILD
index 2a1c803d172..68112f8578b 100644
--- a/community/yarn/APKBUILD
+++ b/community/yarn/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ed Robinson <ed@reevoo.com>
# Maintainer: Ed Robinson <ed@reevoo.com>
pkgname=yarn
-pkgver=0.20.3
+pkgver=0.21.3
pkgrel=0
pkgdesc="Fast, reliable, and secure dependency management for Node.js"
url="https://yarnpkg.com/"
@@ -52,12 +52,12 @@ package() {
ln -s /$destdir/bin/yarn "$pkgdir"/usr/bin/yarnpkg
}
-md5sums="9520b108ce17c2d3a0c8ce7e9b1e99ed yarn-v0.20.3.tar.gz
-d05646de21975bc27b58067d0cf63a2f add-apk-install-method.patch
+md5sums="779e0c868fbc2c8235d20755890202fc yarn-v0.21.3.tar.gz
+4b137b30af07e34dcb42cbc578bd9350 add-apk-install-method.patch
3f3440fa9a2f50df2ee083f5269e31e5 remove-support-for-legacy-nodejs.patch"
-sha256sums="e7d052aba18716616213a602d66528eda7a2bdda7962fc23644ce53e74b1e1d5 yarn-v0.20.3.tar.gz
-fab9750005b60229edd316b6e48a22b06ea46d41489df5a20fde093566a2592b add-apk-install-method.patch
+sha256sums="0946a4d1abc106c131b700cc31e5c3aa5f2205eb3bb9d17411f8115354a97d5d yarn-v0.21.3.tar.gz
+f94643fa30fd7f02e23f0bd0d73de644940d0bf6df21299fc5fc5f0941377bbd add-apk-install-method.patch
084958810b3f7a81bf6c6a9d7edae563722f8006134d28e82494892a795680d9 remove-support-for-legacy-nodejs.patch"
-sha512sums="a924ca7dc834a14be165a099337da07b4b18c7b3e29c60d7cad50632a95093ce0e7eb8b5373bd8f4192abee93ccdb1f64add9b5d6ef704d8c0413143183c00a8 yarn-v0.20.3.tar.gz
-e43e0db54dbc60541c6c0dd82f0d401c2de437a728848b931314a783fab68bda976f4877ebf98395ab37bc0aea0e4743fcc2ab2ff4d8f7016def34edcd43322b add-apk-install-method.patch
+sha512sums="dad7181c78dd1aaf2b07ff32055a8442b55ff9b68a73cf611f4142d612e95f43dcd376e6f2306a4cccc5249680bb82365a7e9ee3160e5c5083f50ee0791a448d yarn-v0.21.3.tar.gz
+4cc2c400f492a5ec7824e0ffd3c11857fdf1488ff21ffd61ad9b6d3135468f32e35cc9b34c496bc0fb07a939bfd635922ca0f574a46c42d117adc1ebf0e6ced4 add-apk-install-method.patch
d62bb07f1361039018ed0a3a3fbff5958c51430e21c356b265768eb494fc74c3c6977e4fdd4629d4914f9afd17864b4a13c8fcda9c92ba9c630badd2f9cea7ad remove-support-for-legacy-nodejs.patch"
diff --git a/community/yarn/add-apk-install-method.patch b/community/yarn/add-apk-install-method.patch
index 9577804bb62..966f075f2f6 100644
--- a/community/yarn/add-apk-install-method.patch
+++ b/community/yarn/add-apk-install-method.patch
@@ -1,31 +1,3 @@
-diff -urp dist/lib/cli/commands/install.js patched/lib/cli/commands/install.js
---- dist/lib/cli/commands/install.js 2017-02-01 00:36:23.000000000 +0000
-+++ patched/lib/cli/commands/install.js 2017-02-01 01:25:41.000000000 +0000
-@@ -226,6 +226,10 @@ function getUpdateCommand() {
- return 'choco upgrade yarn';
- }
-
-+ if (YARN_INSTALL_METHOD === 'apk') {
-+ return 'apk update && apk add -u yarn';
-+ }
-+
- return null;
- }
-
-diff -urp dist/lib-legacy/cli/commands/install.js patched/lib-legacy/cli/commands/install.js
---- dist/lib-legacy/cli/commands/install.js 2017-01-30 14:13:43.000000000 +0000
-+++ patched/lib-legacy/cli/commands/install.js 2017-02-01 01:32:32.000000000 +0000
-@@ -238,6 +238,10 @@ function getUpdateCommand() {
- return 'choco upgrade yarn';
- }
-
-+ if (YARN_INSTALL_METHOD === 'apk') {
-+ return 'apk update && apk add -u yarn';
-+ }
-+
- return null;
- }
-
diff -urp dist/package.json patched/package.json
--- dist/package.json 2017-02-01 01:23:37.000000000 +0000
+++ patched/package.json 2017-02-01 01:23:50.000000000 +0000
@@ -34,6 +6,6 @@ diff -urp dist/package.json patched/package.json
"name": "yarn",
- "installationMethod": "tar",
+ "installationMethod": "apk",
- "version": "0.20.3",
+ "version": "0.21.3",
"license": "BSD-2-Clause",
"preferGlobal": true,