aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/apache-mod-auth-gssapi/APKBUILD38
-rw-r--r--testing/apache-mod-auth-gssapi/mod-auth-gssapi.conf19
2 files changed, 41 insertions, 16 deletions
diff --git a/testing/apache-mod-auth-gssapi/APKBUILD b/testing/apache-mod-auth-gssapi/APKBUILD
index f593d5384fb..fb80a32b13f 100644
--- a/testing/apache-mod-auth-gssapi/APKBUILD
+++ b/testing/apache-mod-auth-gssapi/APKBUILD
@@ -1,31 +1,37 @@
-# Maintainer:
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=apache-mod-auth-gssapi
-pkgver=1.6.2
+pkgver=1.6.3
pkgrel=0
-pkgdesc="GSSAPI Authentication module for Apache"
-url="https://github.com/modauthgssapi/mod_auth_gssapi"
+pkgdesc="GSSAPI authentication for Apache"
+url="https://github.com/gssapi/mod_auth_gssapi"
arch="all"
license="MIT"
depends="apache2"
-makedepends="apache2-dev bison flex krb5-dev"
-source="https://github.com/modauthgssapi/mod_auth_gssapi/releases/download/v$pkgver/mod_auth_gssapi-$pkgver.tar.gz"
-
+makedepends="apache2-dev krb5-dev openssl-dev
+automake autoconf m4 libtool flex bison"
+options="!check" # some packages missing from Alpine, see: https://github.com/gssapi/mod_auth_gssapi/ on "Tests" paragraph
+source="$pkgname-$pkgver.zip::https://github.com/gssapi/mod_auth_gssapi/archive/v$pkgver.zip
+mod-auth-gssapi.conf"
builddir="$srcdir"/mod_auth_gssapi-$pkgver
+prepare() {
+ autoreconf -fi
+}
+
build() {
./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr
+ --prefix=/usr \
+ --enable-static=no
make
}
package() {
- mkdir -p "$pkgdir"/etc/apache2/conf.d \
- "$pkgdir"/usr/lib/apache2
- install -D -m755 ./src/.libs/*.so "$pkgdir"/usr/lib/apache2
- echo "LoadModule auth_gssapi_module modules/mod_auth_gssapi.so" \
- > "$pkgdir"/etc/apache2/conf.d/mod-auth-gssapi.conf
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ install -D -m644 ../../mod-auth-gssapi.conf "$pkgdir"/etc/apache2/conf.d/mod-auth-gssapi.conf
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
-sha512sums="b06810788ff0d9f809e88b14184f013ac9871ae13665a9f131f864615d84ac4e26e881d2d584f746c4a3049fa09cfdbe42df22fce9cd962779ebf223b1b78e0a mod_auth_gssapi-1.6.2.tar.gz"
+sha512sums="7cac212a32bd3b69627d60e0cccc996514df743fde6524750db3acbd4b41da9c1e3d98f7ff1040a773577516b850ecb2c8b12a1259749c5b4d94d347f08c1ffe apache-mod-auth-gssapi-1.6.3.zip
+45658d5446f18315de1a66b682a0669d15b0782e46e649b7d5c4bea2e1c9735909ee1b4d36e9eaa0e54bac68773bb68610d4a0bf68a9eccb368d569489246dfa mod-auth-gssapi.conf"
diff --git a/testing/apache-mod-auth-gssapi/mod-auth-gssapi.conf b/testing/apache-mod-auth-gssapi/mod-auth-gssapi.conf
new file mode 100644
index 00000000000..6be2dcc6f90
--- /dev/null
+++ b/testing/apache-mod-auth-gssapi/mod-auth-gssapi.conf
@@ -0,0 +1,19 @@
+LoadModule auth_gssapi_module modules/mod_auth_gssapi.so
+
+## example, see mod_auth_gssapi README for more options
+#<Directory "/var/www/private">
+# AuthType GSSAPI
+# AuthName "GSSAPI Single Sign On Login"
+# GssapiCredStore keytab:/etc/apache2/krb5.keytab
+# Require valid-user
+# GssapiBasicAuth On
+# GssapiAllowedMech krb5
+# GssapiNegotiateOnce On
+# GssapiLocalName On
+# GssapiUseSessions On
+# GssapiDelegCcacheDir /run/httpd/clientcaches
+# GssapiPublishErrors On
+# GssapiAcceptorName HTTP@{HOSTNAME}
+## See http://www.jfcarter.net/~jimc/documents/bugfix/41-auth-kerb.html for details
+#</Directory>
+