aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/isl22/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/main/isl22/APKBUILD b/main/isl22/APKBUILD
new file mode 100644
index 00000000000..31ffbb3cf94
--- /dev/null
+++ b/main/isl22/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+
+# this package needs special care since it is a part of the toolchain.
+# we need to be able to have the old version installed in parallel with
+# a new with ABI breaking change. That is why we have the version
+# as a part of the pkgname.
+
+pkgname=isl22
+pkgver=0.22
+pkgrel=0
+pkgdesc="An Integer Set Library for the Polyhedral Model"
+url="http://isl.gforge.inria.fr/"
+arch="all"
+license="MIT"
+depends_dev="gmp-dev"
+makedepends_host="$depends_dev"
+makedepends="$makedepends_host"
+subpackages="isl-dev:_dev"
+source="http://isl.gforge.inria.fr/isl-$pkgver.tar.bz2"
+
+builddir="$srcdir"/isl-$pkgver
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-sysroot=${CBUILDROOT}
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" INSTALL="install -D" install
+}
+
+_dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/share/gdb/python/auto-load/usr/lib
+ mv "$pkgdir"/usr/lib/*-gdb.py \
+ "$subpkgdir"/usr/share/gdb/python/auto-load/usr/lib/
+}
+
+sha512sums="fc2c9796979610dd51143dcefe4f5c989c4354571cc5a1fcc6b932fd41f42a54f6b43adfd289af61be7bd06f3a523fa6a7d7ee56680e32d8036beb4c188fa668 isl-0.22.tar.bz2"