aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libkeyfinder/APKBUILD46
-rw-r--r--community/libkeyfinder/add-missing-include-for-ppc64le.patch13
-rw-r--r--community/libkeyfinder/alpine-settings-to-pro.patch28
-rw-r--r--testing/libkeyfinder/APKBUILD37
4 files changed, 22 insertions, 102 deletions
diff --git a/community/libkeyfinder/APKBUILD b/community/libkeyfinder/APKBUILD
index 64411af069a..4c6bec279f4 100644
--- a/community/libkeyfinder/APKBUILD
+++ b/community/libkeyfinder/APKBUILD
@@ -1,39 +1,37 @@
# Contributor: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
# Maintainer: Jean-Louis Fuchs <jean-louis.fuchs@adfinis-sygroup.ch>
pkgname=libkeyfinder
-pkgver=2.2.2
+pkgver=2.2.5
pkgrel=0
pkgdesc="Musical key detection for digital audio"
-url="http://www.ibrahimshaath.co.uk/keyfinder/"
+url="https://mixxxdj.github.io/libkeyfinder/"
arch="all"
license="GPL-3.0-or-later"
-# Its just using qmake
-makedepends="qt5-qtbase-dev fftw-dev"
-subpackages="$pkgname-dev $pkgname-doc"
-source="libkeyfinder-$pkgver.tar.gz::https://github.com/ibsh/libKeyFinder/archive/v$pkgver.tar.gz
- alpine-settings-to-pro.patch
- add-missing-include-for-ppc64le.patch"
-builddir="$srcdir/libKeyFinder-$pkgver"
+makedepends="
+ catch2
+ cmake
+ fftw-dev
+ "
+subpackages="$pkgname-dev"
+source="https://github.com/mixxxdj/libkeyfinder/archive/v$pkgver/libkeyfinder-v$pkgver.tar.gz"
build() {
- qmake-qt5 PREFIX=/usr
- make
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
}
-package() {
- make INSTALL_ROOT="$pkgdir" install
- install -Dm644 "$builddir"/README.md \
- "$pkgdir"/usr/share/doc/$pkgname/README.md
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
-check() {
- cd "$builddir/tests"
- ln -s "$builddir" keyfinder
- qmake-qt5
- make
- LD_LIBRARY_PATH="$builddir" ./tests
+package() {
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="69981e94928ada5a51649cf7cf11fa91aa09480907355a364c491a42597922804b0d65744ef021e781807cfd1c7bdb5c8e152fdeda7120a93631d4e2573b6388 libkeyfinder-2.2.2.tar.gz
-580c968da0d24126d92b09cc4a970bb898fe020f2b9a9232d80ef63be8d3f90e618ea0b2f66ccde174a51dcf7160dfd62ab3b9428bf0ae6b11608b7dd7aede23 alpine-settings-to-pro.patch
-6292619361970bb85bb41a9ea94f12b2d70ca2b6d1957d9e27c56dbc3eaf55c49eb3616c0cbcd9b5855197f66c67064a8461c693e90a037e1019f0cd5da90587 add-missing-include-for-ppc64le.patch"
+sha512sums="
+54463d1f1111dc474d3e43723fddd5579ea1a3842f99f43e50e85622a1d6ee6fe42b22c300ce5ba5807cf6b2d7067af741773af95974a42c5d863c53165893eb libkeyfinder-v2.2.5.tar.gz
+"
diff --git a/community/libkeyfinder/add-missing-include-for-ppc64le.patch b/community/libkeyfinder/add-missing-include-for-ppc64le.patch
deleted file mode 100644
index 3ef2851f86e..00000000000
--- a/community/libkeyfinder/add-missing-include-for-ppc64le.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- libKeyFinder-2.2.1/fftadapter.cpp
-+++ libKeyFinder-2.2.1/fftadapter.cpp
-@@ -25,6 +25,10 @@
- #include <cmath>
- #include <fftw3.h>
-
-+#ifdef __powerpc64__
-+#include <string.h>
-+#endif
-+
- namespace KeyFinder {
-
- std::mutex fftwPlanMutex;
diff --git a/community/libkeyfinder/alpine-settings-to-pro.patch b/community/libkeyfinder/alpine-settings-to-pro.patch
deleted file mode 100644
index 36cfe6d9373..00000000000
--- a/community/libkeyfinder/alpine-settings-to-pro.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -ur a/LibKeyFinder.pro b/LibKeyFinder.pro
---- a/LibKeyFinder.pro 2017-03-12 23:41:10.000000000 +0100
-+++ b/LibKeyFinder.pro 2017-03-23 16:49:06.236738498 +0100
-@@ -30,7 +30,8 @@
- VERSION = 2.2.0
-
- CONFIG += c++11
--QMAKE_CXXFLAGS += -std=c++11
-+QMAKE_CXXFLAGS_RELEASE -= -O2
-+QMAKE_CXXFLAGS += -std=c++11 -Os -fomit-frame-pointer
-
- DEFINES += LIBKEYFINDER_LIBRARY
-
-diff -ur a/tests/tests.pro b/tests/tests.pro
---- a/tests/tests.pro 2017-03-23 16:47:17.280248215 +0100
-+++ b/tests/tests.pro 2017-03-23 16:48:28.386799769 +0100
-@@ -27,8 +27,9 @@
- CONFIG -= qt
-
- CONFIG += c++11
--LIBS += -stdlib=libc++
--QMAKE_CXXFLAGS += -std=c++11 -stdlib=libc++
-+LIBS += -L..
-+QMAKE_CXXFLAGS_RELEASE -= -O2
-+QMAKE_CXXFLAGS += -std=c++11 -Os -fomit-frame-pointer
-
- LIBS += -lkeyfinder
-
diff --git a/testing/libkeyfinder/APKBUILD b/testing/libkeyfinder/APKBUILD
deleted file mode 100644
index 3937f67f961..00000000000
--- a/testing/libkeyfinder/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=libkeyfinder
-pkgver=2.2.5
-pkgrel=0
-pkgdesc="Musical key detection for digital audio"
-url="https://mixxxdj.github.io/libkeyfinder/"
-arch="all"
-license="GPL-3.0-or-later"
-makedepends="
- catch2
- cmake
- fftw-dev
- "
-subpackages="$pkgname-dev"
-source="https://github.com/mixxxdj/libkeyfinder/archive/v$pkgver/libkeyfinder-v$pkgver.tar.gz"
-
-build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- cmake --build build
-}
-
-check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-54463d1f1111dc474d3e43723fddd5579ea1a3842f99f43e50e85622a1d6ee6fe42b22c300ce5ba5807cf6b2d7067af741773af95974a42c5d863c53165893eb libkeyfinder-v2.2.5.tar.gz
-"