aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/mozjs60/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/mozjs60/APKBUILD b/main/mozjs60/APKBUILD
index a8b9cc3a333..5d78481538d 100644
--- a/main/mozjs60/APKBUILD
+++ b/main/mozjs60/APKBUILD
@@ -34,11 +34,16 @@ build() {
touch configure
# Fix broken ARM_ARCH check which doesn't work with newer GCCs it seems.
+ # Disable JIT on MIPS, doesn't compile.
+ extra_args=""
case "$CTARGET" in
armv*)
ARM_ARCH=$(echo ${CTARGET#*armv} | sed "s|-.*||")
sed -i "s|ARM_ARCH=.*|ARM_ARCH=$ARM_ARCH|" "$builddir"/build/autoconf/arch.m4
;;
+ mips*)
+ extra_args="--disable-ion"
+ ;;
esac
export SHELL=/bin/ash
@@ -53,7 +58,7 @@ build() {
--enable-system-ffi \
--disable-optimize \
--disable-jemalloc \
- --enable-pie
+ --enable-pie $extra_args
make
}