aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/linux-tools/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/community/linux-tools/APKBUILD b/community/linux-tools/APKBUILD
index 271c10b5f53..90fa0ac628c 100644
--- a/community/linux-tools/APKBUILD
+++ b/community/linux-tools/APKBUILD
@@ -5,7 +5,7 @@
pkgname=linux-tools
pkgver=5.15.35
_kernver=${pkgver%.*}
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel tools meta package"
url="https://www.kernel.org/"
arch="all"
@@ -129,8 +129,16 @@ perf() {
"$pkgdir"/usr/bin/trace \
"$subpkgdir"/usr/bin
mv "$pkgdir"/usr/lib/traceevent \
+ "$pkgdir"/usr/lib/perf \
"$subpkgdir"/usr/lib/
mv "$pkgdir"/usr/libexec "$subpkgdir"/usr/
+
+ # /usr/share/perf-core is apprently not installed on all arches
+ if [ -e "$pkgdir"/usr/share/perf-core ]; then
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/perf-core \
+ "$subpkgdir"/usr/share/
+ fi
}
perf_bashcomp() {