aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/unibilium/APKBUILD13
-rw-r--r--community/unibilium/build-static-lib.patch37
2 files changed, 6 insertions, 44 deletions
diff --git a/community/unibilium/APKBUILD b/community/unibilium/APKBUILD
index 9f0b6892acd..31c3ec58e13 100644
--- a/community/unibilium/APKBUILD
+++ b/community/unibilium/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Marvin Preuss <marvin@xsteadfastx.org>
# Maintainer: Marvin Preuss <marvin@xsteadfastx.org>
pkgname=unibilium
-pkgver=2.1.0
-pkgrel=1
+pkgver=2.1.1
+pkgrel=0
pkgdesc="Terminfo parsing library"
url="https://github.com/neovim/unibilium/"
arch="all"
@@ -10,9 +10,7 @@ license="LGPL-3.0-or-later"
makedepends="libtool perl"
checkdepends="perl-utils"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/neovim/unibilium/archive/v$pkgver.tar.gz
- build-static-lib.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/neovim/unibilium/archive/v$pkgver.tar.gz"
build() {
make PREFIX=/usr
@@ -26,5 +24,6 @@ package() {
make PREFIX=/usr DESTDIR="$pkgdir" install
}
-sha512sums="c0074ff8431f82c92072b8c0c9d3cf38d759b4de996b168c6ab00e475b0a6204d9c29b0a6e48e62dd4fa4898f82246150ef7cd5e246893d2c225c50ec4d4ac68 unibilium-2.1.0.tar.gz
-68533c5e55997061ce71f1701490d078fd6a22ee83615d693e6b2fddda2d2b652ce73f5ff5335d3747f211845d4da4a80eb12733407ee071785624f94fa1d0e8 build-static-lib.patch"
+sha512sums="
+ebcdcddc6c3a540d086b113bb83470c1c17cf59056b28308a484b20dc3df71de0f5d6e5bf105f9e4a8347c78500c65ae46c2b53ec87692a898c321a047664ee2 unibilium-2.1.1.tar.gz
+"
diff --git a/community/unibilium/build-static-lib.patch b/community/unibilium/build-static-lib.patch
deleted file mode 100644
index 643421f98d0..00000000000
--- a/community/unibilium/build-static-lib.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -45,6 +45,7 @@
-
- OBJECTS=unibilium.lo uninames.lo uniutil.lo
- LIBRARY=libunibilium.la
-+LIBSTATIC=libunibilium.a
-
- PODS=$(wildcard doc/*.pod)
- MANPAGES=$(addprefix man/,$(notdir $(PODS:.pod=.3.gz)))
-@@ -54,7 +55,7 @@
- TESTS=$(wildcard t/*.c)
-
- .PHONY: all
--all: $(LIBRARY) build-man build-tools build-test
-+all: $(LIBRARY) $(LIBSTATIC) build-man build-tools build-test
-
- %.lo: %.c unibilium.h
- $(LIBTOOL) --mode=compile --tag=CC $(CC) -I. -Wall -std=c99 $(CFLAGS) $(CFLAGS_DEBUG) -o $@ -c $<
-@@ -65,6 +66,9 @@
- $(LIBRARY): $(OBJECTS)
- $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) -rpath '$(LIBDIR)' -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -o $@ $^
-
-+$(LIBSTATIC): $(OBJECTS)
-+ $(LIBTOOL) --mode=link $(CC) -o $@ $^
-+
- tools/%: $(LIBRARY) tools/%.lo
- $(LIBTOOL) --mode=link --tag=CC $(CC) $(LDFLAGS) -o $@ $^
-
-@@ -102,6 +106,7 @@
- install-lib:
- mkdir -p '$(DESTDIR)$(LIBDIR)'
- $(LIBTOOL) --mode=install cp $(LIBRARY) '$(DESTDIR)$(LIBDIR)/$(LIBRARY)'
-+ $(LIBTOOL) --mode=install install $(LIBSTATIC) $(DESTDIR)$(LIBDIR)/$(LIBSTATIC)
-
- .PHONY: install-man
- install-man: build-man