aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/telegram-desktop/APKBUILD8
-rw-r--r--community/telegram-desktop/remove-glibc.patch67
2 files changed, 72 insertions, 3 deletions
diff --git a/community/telegram-desktop/APKBUILD b/community/telegram-desktop/APKBUILD
index 5cdb053cfcc..cffa269e322 100644
--- a/community/telegram-desktop/APKBUILD
+++ b/community/telegram-desktop/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
# Contributor: Leo <thinkabit.ukim@gmail.com>
pkgname=telegram-desktop
-pkgver=2.1.7
+pkgver=2.1.8
pkgrel=0
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
@@ -44,6 +44,7 @@ source="
https://github.com/telegramdesktop/tdesktop/releases/download/v$pkgver/tdesktop-$pkgver-full.tar.gz
qt-plugin-path.patch
small-sizes.patch
+ remove-glibc.patch
"
builddir="$srcdir/tdesktop-$pkgver-full"
@@ -76,6 +77,7 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="f942ce93d9671f3bb95a8fbba107fc851bfe3f28871c9651f6f2d97d711602f8a671f7b74750894b2175d33a67c25017562cd4ee455da7aa9b86755d1c3f1cfb tdesktop-2.1.7-full.tar.gz
+sha512sums="6456f3c129742838410d7455854430bc5ba118990fe43e2e5bfce3a88963a4fc746ae2def8afc9e2cc50e465dbd0bf8907e997b27dbc48f8838da84d916c9e3b tdesktop-2.1.8-full.tar.gz
6126ba461cb4b3f5bfb864cac3270fe1b4cd8c2e88781e756959bdcf00830c4af3354d2d056411f1b69198f2b5eae968bee6908ab720bb90fbb6ac656e4e77c4 qt-plugin-path.patch
-3d1b8e6f870fc780f9ae8bc6a67eb676a5c5f686dc79e84cd6d64cb3cfafb1be626d0cc3960ffc67cecca21568764a0137c7303a89045fa59f91ba4eb5d8caed small-sizes.patch"
+3d1b8e6f870fc780f9ae8bc6a67eb676a5c5f686dc79e84cd6d64cb3cfafb1be626d0cc3960ffc67cecca21568764a0137c7303a89045fa59f91ba4eb5d8caed small-sizes.patch
+453e9d474a38609f928fc4fbe021d044ce0f80c5a4cb67ff914fbf159c8b9eb22116e75d8b4d518be95892a87f77360b9f310bff1ade05cd4abef42df07366b6 remove-glibc.patch"
diff --git a/community/telegram-desktop/remove-glibc.patch b/community/telegram-desktop/remove-glibc.patch
new file mode 100644
index 00000000000..999b6a8f156
--- /dev/null
+++ b/community/telegram-desktop/remove-glibc.patch
@@ -0,0 +1,67 @@
+Upstream: Unsuitable (requires re-work into something that doesn't break libc)
+Reason: This is Glibc specific and treating Linux == glibc is harmful
+
+diff --git a/Telegram/lib_base/base/platform/linux/base_info_linux.cpp b/Telegram/lib_base/base/platform/linux/base_info_linux.cpp
+index ea9ab61..bbef601 100644
+--- a/Telegram/lib_base/base/platform/linux/base_info_linux.cpp
++++ b/Telegram/lib_base/base/platform/linux/base_info_linux.cpp
+@@ -13,7 +13,6 @@
+ #include <QtCore/QVersionNumber>
+ #include <QtCore/QDate>
+ #include <QtGui/QGuiApplication>
+-#include <gnu/libc-version.h>
+
+ namespace Platform {
+ namespace {
+@@ -53,15 +52,6 @@ void FallbackFontConfig(
+ }
+ }
+
+-const std::optional<QVersionNumber> &GetLibCVersion() {
+- static const auto result = [&] {
+- const auto version = gnu_get_libc_version(); // #TODO log
+- const auto parsed = QVersionNumber::fromString(version);
+- return parsed.isNull() ? std::nullopt : std::make_optional(parsed);
+- }();
+- return result;
+-}
+-
+ } // namespace
+
+ QString DeviceModelPretty() {
+@@ -84,8 +74,7 @@ QString SystemVersionPretty() {
+ return "Linux "
+ + (list.isEmpty() ? QString() : list[0] + ' ')
+ + (IsWayland() ? "Wayland " : "X11 ")
+- + "glibc "
+- + GetGlibCVersion();
++ + "musl";
+ }
+
+ QString SystemCountry() {
+@@ -103,10 +92,6 @@ QString SystemLanguage() {
+ QDate WhenSystemBecomesOutdated() {
+ if (IsLinux32Bit()) {
+ return QDate(2020, 9, 1);
+- } else if (const auto version = GetGlibCVersion(); !version.isEmpty()) {
+- if (QVersionNumber::fromString(version) < QVersionNumber(2, 23)) {
+- return QDate(2020, 9, 1); // Older than Ubuntu 16.04.
+- }
+ }
+ return QDate();
+ }
+@@ -129,14 +114,6 @@ QString AutoUpdateKey() {
+ }
+ }
+
+-QString GetGlibCVersion() {
+- static const auto result = [&] {
+- const auto version = QString::fromLatin1(gnu_get_libc_version());
+- return QVersionNumber::fromString(version).isNull() ? QString() : version;
+- }();
+- return result;
+-}
+-
+ bool IsWayland() {
+ return QGuiApplication::platformName().startsWith("wayland", Qt::CaseInsensitive);
+ }