aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-kubernetes/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/testing/py3-kubernetes/APKBUILD b/testing/py3-kubernetes/APKBUILD
index 74d8024b353..7a9c807cb14 100644
--- a/testing/py3-kubernetes/APKBUILD
+++ b/testing/py3-kubernetes/APKBUILD
@@ -3,16 +3,17 @@
pkgname=py3-kubernetes
_pkgname=kubernetes
pkgver=12.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Official Python client library for kubernetes"
url="https://github.com/kubernetes-client/python"
arch="noarch"
license="Apache-2.0"
#github and pypi archives missing some test files (kubernetes/e2e_test)
options="!check"
-depends="py3-certifi py3-dateutil py3-google-auth py3-requests \
- py3-requests-oauthlib py3-setuptools py3-six py3-urllib3 \
+depends="py3-certifi py3-dateutil py3-google-auth py3-requests
+ py3-requests-oauthlib py3-six py3-urllib3
py3-websocket-client py3-yaml"
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/k/kubernetes/kubernetes-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"