aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/shotwell/APKBUILD44
-rw-r--r--community/shotwell/shotwell.post-install7
-rw-r--r--community/shotwell/shotwell.post-upgrade7
-rw-r--r--community/shotwell/shotwell.pre-deinstall7
4 files changed, 23 insertions, 42 deletions
diff --git a/community/shotwell/APKBUILD b/community/shotwell/APKBUILD
index d2b8e630a16..c5d1c0248e6 100644
--- a/community/shotwell/APKBUILD
+++ b/community/shotwell/APKBUILD
@@ -1,36 +1,38 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=shotwell
-pkgver=0.28.2
-pkgrel=1
+pkgver=0.30.7
+pkgrel=0
pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
url="https://wiki.gnome.org/Apps/Shotwell"
-arch="all !armhf !armv7"
-license="CC-BY-SA-3.0 LGPL-2.1-or-later"
-install="shotwell.post-upgrade shotwell.post-install shotwell.pre-deinstall"
+arch="all"
+license="CC-BY-SA-3.0 AND LGPL-2.1-or-later"
subpackages="$pkgname-lang $pkgname-doc"
-makedepends="intltool vala libgee-dev libunique3-dev webkit2gtk-dev libexif-dev
- sqlite-dev libgudev-dev dbus-glib-dev libgphoto2-dev
- gexiv2-dev libraw-dev librsvg-dev json-glib-dev gnome-doc-utils
- m4 gst-plugins-base-dev bash gtk+3.0-dev rest-dev desktop-file-utils
- gcr-dev itstool libgdata-dev"
-source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+makedepends="vala libgee-dev libunique3-dev webkit2gtk-dev libexif-dev
+ sqlite-dev libgudev-dev dbus-glib-dev libgphoto2-dev gexiv2-dev libraw-dev
+ librsvg-dev json-glib-dev gst-plugins-base-dev gtk+3.0-dev rest-dev
+ gcr-dev itstool libgdata-dev meson"
+checkdepends="desktop-file-utils appstream-glib"
+source="https://download.gnome.org/sources/shotwell/${pkgver%.*}/shotwell-$pkgver.tar.xz"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
- --enable-static=no \
- --disable-schemas-compile
- make
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dinstall-apport-hook=false \
+ . output
+ ninja -C output
}
check() {
- make check
+ ninja -C output test
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="dc00f45e55eabadaaf825de5a4152d40db2eb652f966b870a08d36006887a18aacf570b05d232a9fc7ef7df097a468a497778022bf7b86ae2143877c02540cc0 shotwell-0.28.2.tar.xz"
+sha512sums="960574212d622c29d7617b874466e639d5a292eefdd2cac00ebcbf96d7db06002b9423440ee47ed84da7064d3eb70ba388b573a94c9e44c07d3b8f87faf09c58 shotwell-0.30.7.tar.xz"
diff --git a/community/shotwell/shotwell.post-install b/community/shotwell/shotwell.post-install
deleted file mode 100644
index e6135da0452..00000000000
--- a/community/shotwell/shotwell.post-install
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-for i in shotwell.schemas; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
-done
diff --git a/community/shotwell/shotwell.post-upgrade b/community/shotwell/shotwell.post-upgrade
deleted file mode 100644
index e6135da0452..00000000000
--- a/community/shotwell/shotwell.post-upgrade
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-for i in shotwell.schemas; do
- echo "Installing GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/$i >/dev/null
-done
diff --git a/community/shotwell/shotwell.pre-deinstall b/community/shotwell/shotwell.pre-deinstall
deleted file mode 100644
index 9d3a0003005..00000000000
--- a/community/shotwell/shotwell.pre-deinstall
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-for i in shotwell.schemas; do
- echo "Uninstalling GConf2 schema $i."
- GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source` \
- /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/$i >/dev/null
-done