aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/knot-resolver/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/knot-resolver/APKBUILD b/community/knot-resolver/APKBUILD
index 03345ae780d..73d7dc11bf8 100644
--- a/community/knot-resolver/APKBUILD
+++ b/community/knot-resolver/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: tcely <knot-resolver+aports@tcely.33mail.com>
pkgname=knot-resolver
pkgver=3.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="Minimalistic caching DNS resolver implementation"
url="https://www.knot-resolver.cz/"
# luajit is not available for disabled arches
@@ -41,6 +41,10 @@ prepare() {
}
build() {
+ # strict-aliasing breaks stats module - variable "sa" in stats.c:495 is 0x0.
+ # (https://gitlab.labs.nic.cz/knot/knot-resolver/blob/v4.2.2/modules/stats/stats.c#L495)
+ export CFLAGS="$CFLAGS -fno-strict-aliasing"
+
make $_flags
}