aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/perl-test-without-module/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/perl-test-without-module/APKBUILD b/community/perl-test-without-module/APKBUILD
index 4b6b368ee92..36de290b45d 100644
--- a/community/perl-test-without-module/APKBUILD
+++ b/community/perl-test-without-module/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-test-without-module
_pkgreal=Test-Without-Module
-pkgver=0.18
+pkgver=0.19
pkgrel=0
pkgdesc="Test fallback behaviour in absence of modules"
url="http://search.cpan.org/dist/Test-Without-Module/"
@@ -16,26 +16,29 @@ makedepends="perl-dev perl-test-pod perl-file-slurp $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/C/CO/CORION/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="cd19ad26024e89fdfefb0ae0334ee500 Test-Without-Module-0.18.tar.gz"
-sha256sums="e2c3360b171d7db518ac39a0e1dcb285c784ea393c11708914a0655d66138c7f Test-Without-Module-0.18.tar.gz"
-sha512sums="005ad54ac77283cf3155befe77fdb887dbc2ebc9c154472a23982636bbe7728154f56fdf1990b833639cd687b38e4d62250edd6dd93d37408e971bb4bd49c4c2 Test-Without-Module-0.18.tar.gz"
+sha512sums="947f9a840622b00486d4942a84f26b5f40ce271da5ff3ca508017d6531a46c217935aa0cecba4cafa925621fa91b38c82876481f45d558b33e15b9b24afa44e8 Test-Without-Module-0.19.tar.gz"