aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/rust/0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch44
-rw-r--r--community/rust/APKBUILD24
2 files changed, 15 insertions, 53 deletions
diff --git a/community/rust/0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch b/community/rust/0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
index 04842dc5c3a..30cb66fc24b 100644
--- a/community/rust/0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
+++ b/community/rust/0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
@@ -13,52 +13,12 @@ diff --git a/src/libunwind/lib.rs b/src/libunwind/lib.rs
index 9182e349b19..0377fbb58fc 100644
--- a/library/unwind/src/lib.rs
+++ b/library/unwind/src/lib.rs
-@@ -48,7 +48,7 @@
+@@ -51,7 +51,7 @@
#[link(name = "unwind", cfg(not(target_feature = "crt-static")))]
extern "C" {}
} else {
-- #[link(name = "unwind", kind = "static", cfg(target_feature = "crt-static"))]
+- #[link(name = "unwind", kind = "static", modifiers = "-bundle", cfg(target_feature = "crt-static"))]
+ #[link(name = "gcc_eh", cfg(target_feature = "crt-static"))]
#[link(name = "gcc_s", cfg(not(target_feature = "crt-static")))]
extern "C" {}
}
-diff --git a/src/libunwind/build.rs b/src/libunwind/build.rs
-index f24d957..28828e5 100644
---- a/library/unwind/build.rs
-+++ b/library/unwind/build.rs
-@@ -10,7 +10,7 @@
- }
-
- if cfg!(feature = "llvm-libunwind")
-- && ((target.contains("linux") && !target.contains("musl")) || target.contains("fuchsia"))
-+ && (target.contains("linux") || target.contains("fuchsia"))
- {
- // Build the unwinding from libunwind C/C++ source code.
- llvm_libunwind::compile();
-@@ -18,9 +18,7 @@
- llvm_libunwind::compile();
- } else if target.contains("linux") {
- // linking for Linux is handled in lib.rs
-- if target.contains("musl") {
-- llvm_libunwind::compile();
-- } else if target.contains("android") {
-+ if target.contains("android") {
- let build = cc::Build::new();
-
- // Since ndk r23 beta 3 `libgcc` was replaced with `libunwind` thus
-@@ -92,15 +90,6 @@
- cc_cfg.flag("-std=c99");
- }
-
-- if target.contains("x86_64-fortanix-unknown-sgx") || target_env == "musl" {
-- // use the same GCC C compiler command to compile C++ code so we do not need to setup the
-- // C++ compiler env variables on the builders.
-- // Don't set this for clang++, as clang++ is able to compile this without libc++.
-- if cpp_cfg.get_compiler().is_like_gnu() {
-- cpp_cfg.cpp(false);
-- }
-- }
--
- for cfg in [&mut cc_cfg, &mut cpp_cfg].iter_mut() {
- cfg.warnings(false);
- cfg.flag("-fstrict-aliasing");
diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index b54398fccea..37aeeb75740 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -5,10 +5,10 @@
# Contributor: Ariadne Conill <ariadne@dereferenced.org>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=rust
-pkgver=1.55.0
+pkgver=1.56.1
_llvmver=12
-_bootver=1.54.0
-pkgrel=3
+_bootver=1.55.0
+pkgrel=0
pkgdesc="The Rust Programming Language"
url="https://www.rust-lang.org/"
arch="x86_64 armv7 armhf aarch64 x86 ppc64le"
@@ -88,6 +88,8 @@ source="https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.xz
builddir="$srcdir/rustc-$pkgver-src"
# secfixes:
+# 1.56.1-r0:
+# - CVE-2021-42574
# 1.52.1-r1:
# - CVE-2021-29922
# 1.51.0-r2:
@@ -222,14 +224,14 @@ package() {
-C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
tar xf "$builddir"/build/dist/cargo-${pkgver}-${_target}.tar.gz \
-C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
- tar xf "$builddir"/build/dist/clippy-${pkgver}-${_target}.tar.gz \
- -C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
+# tar xf "$builddir"/build/dist/clippy-${pkgver}-${_target}.tar.gz \
+# -C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
# tar xf "$builddir"/build/dist/miri-${pkgver}-${_target}.tar.gz \
# -C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
- tar xf "$builddir"/build/dist/rls-${pkgver}-${_target}.tar.gz \
- -C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
- tar xf "$builddir"/build/dist/rustfmt-${pkgver}-${_target}.tar.gz \
- -C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
+# tar xf "$builddir"/build/dist/rls-${pkgver}-${_target}.tar.gz \
+# -C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
+# tar xf "$builddir"/build/dist/rustfmt-${pkgver}-${_target}.tar.gz \
+# -C "$pkgdir/usr" --strip-components=2 --exclude=manifest.in --no-same-owner
# We don't want to include stuff like rust-llvm-* tools, as we will use the
# system tools.
@@ -348,7 +350,7 @@ _mv() {
}
sha512sums="
-7522f2fa95d5af92472404ecc97d7d9e745e88c933196a83fa373ce1efff6db3c295e0e2afdbfa1ff00644554efa0c3c7f6c11f9119ecf9010cb440b3f27c2da rustc-1.55.0-src.tar.xz
+193468e211cde9ebc5f6e30b8e3733b79bd8710fe6dd45c7ed8d4392f91010d30466787afd4d0b2041cd7dd994924fee8ad111048824e248bd994959e55bf15f rustc-1.56.1-src.tar.xz
4accbdf546e9f82f38d56169f65fcfb53839e1df89978b9a434a59a1dcb80b4d57c0272c0ece65530ce09ad0f7a7e880b4b97e2b8dd8f2bccace02a5874e6733 musl-fix-linux_musl_base.patch
2d401a01d2c2db92624d672018342907a41aa4a3842708c0a2ab694af0396d568aca4835d1075f244d77c0a4c45e67f893fd175fd97cd7f758090eba9972eba6 need-rpath.patch
bc28e1edae88f48eb0368cd0905280c323d521c7e13b6fc2bb1fb6e57274fa418afdc9cb3342f4928842e309d0573b98e82976159541c88b35694dceaf7a82e4 need-ssp_nonshared.patch
@@ -357,7 +359,7 @@ bc28e1edae88f48eb0368cd0905280c323d521c7e13b6fc2bb1fb6e57274fa418afdc9cb3342f492
7d59258d4462eba0207739a5c0c8baf1f19d9a396e5547bb4d59d700eb94d50ba6add2e523f3e94e29e993821018594625ea4ac86304fb58f7f8c82622a26ab0 install-template-shebang.patch
c31fdfe8a9b3411576c75da46645cf0465b9053000a2ab49cf9b2f2733f679d6d33acbf236d67a20e14935d094a685453b7f1840180249f39d610fd0902c3125 check-rustc
d5d3ccc5c3a73bf1816106ba00805346ea28f2e6337d960e9e9f776ba59d22abd8864382f163d32dd9a278df38c080949dafc70169728f44080ddc04f1e7f125 link-musl-dynamically.patch
-b17e9b1f1d2f9ab8aea7dc5f4a1adfde844ac1570d935804f293376a9b568e3760906192d1ea82f093736a28d157ad3f501932f9daae3be3954de2c3458a626d 0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
+d368c955b058e7b57d91f53fbebf1030f2d2826b0ffb0a85db5aa54baee7bd44371491cc373101846232f91fd383dd15aa1cd245fb8f439d35813ac4017be419 0006-Prefer-libgcc_eh-over-libunwind-for-musl.patch
7af23c34096f7a03c5a1b40aa07e00dd6193743c872881018a9baa900f240c6e44918e481ab5ed7787a70ef361e4aeec2a7719bcd695f52988262e23271b44e5 0007-do-not-install-libunwind-source.patch
4cb2592d30cd1a776375522631aa284dd077eaa39b109921d6ee5906fd0130b048e07d3adef1d7221f5c001d1df5187feb3e3687e0aa5d19279099065a7d4cb7 mips-softfloat.patch
"