aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/gutenprint/APKBUILD71
-rw-r--r--testing/gutenprint/fix-build.patch60
-rw-r--r--testing/gutenprint/gutenprint-O6.patch281
-rw-r--r--testing/gutenprint/musl-fix-header.patch12
-rw-r--r--testing/gutenprint/pagesize-name-clash.patch14
5 files changed, 88 insertions, 350 deletions
diff --git a/testing/gutenprint/APKBUILD b/testing/gutenprint/APKBUILD
index b6f6f9d1056..67cc5a55bb6 100644
--- a/testing/gutenprint/APKBUILD
+++ b/testing/gutenprint/APKBUILD
@@ -1,40 +1,30 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer:
pkgname=gutenprint
-pkgver=5.2.11
+pkgver=5.3.3
pkgrel=0
-pkgdesc="Printer Drivers Package"
+pkgdesc="Top quality printer drivers for POSIX systems"
url="http://gimp-print.sourceforge.net/"
arch="all"
license="GPL-2.0-or-later"
-depends=""
-depends_dev=""
-makedepends="$depends_dev cups-dev tiff-dev libjpeg-turbo-dev libpng-dev
- ghostscript-dev libusb-dev autoconf automake libtool gettext-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs
- $pkgname-cups $pkgname-samples"
-source="https://downloads.sourceforge.net/gimp-print/gutenprint-$pkgver.tar.bz2
- musl-fix-header.patch
- pagesize-name-clash.patch
- gutenprint-O6.patch
+makedepends="
+ cups-dev
+ tiff-dev
+ libjpeg-turbo-dev
+ libpng-dev
+ ghostscript-dev
+ libusb-dev
+ autoconf
+ automake
+ libtool
+ gettext-dev
+ bash
+ "
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs $pkgname-cups $pkgname-samples"
+source="https://downloads.sourceforge.net/gimp-print/gutenprint-$pkgver.tar.xz
+ fix-build.patch
"
-
-_builddir="$srcdir"/gutenprint-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- mkdir -p m4local
- autoreconf -vif || return 1
-}
build() {
- cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -44,25 +34,22 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-nls \
- --disable-cups-ppds \
- --enable-simplified-cups-ppds \
- || return 1
- make || return 1
+ --enable-cups-ppds \
+ --enable-simplified-cups-ppds
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
rm -r "$pkgdir"/usr/share/gutenprint/doc \
- "$pkgdir"/etc/cups/command.types \
- || return 1
+ "$pkgdir"/etc/cups/command.types
}
cups() {
pkgdesc="CUPS drivers for Canon, Epson, HP and compatible printers"
for d in usr/share usr/lib usr/bin usr/sbin etc; do
mkdir -p "$subpkgdir"/$d || return 1
- mv "$pkgdir"/$d/cups* "$subpkgdir"/$d/ || return 1
+ mv "$pkgdir"/$d/cups* "$subpkgdir"/$d/
done
}
@@ -70,12 +57,10 @@ samples() {
pkgdesc="Sample test pattern generator for gutenprint-dev"
mkdir -p "$subpkgdir"/usr/share/gutenprint "$subpkgdir"/usr/bin
mv "$pkgdir"/usr/share/gutenprint/samples \
- "$subpkgdir"/usr/share/gutenprint/ || return 1
- mv "$pkgdir"/usr/bin/testpattern "$subpkgdir"/usr/bin/ || return 1
+ "$subpkgdir"/usr/share/gutenprint/
+ mv "$pkgdir"/usr/bin/testpattern "$subpkgdir"/usr/bin/
}
-sha512sums="f4010e489dd6763b19113abf1d55e84cea8d36b920d03dbe204dba30ab0d3fb3e3391e739cd1a56e2f63581c8ce4a856a7f747deb6e7b18d7e1f7a3d87901c60 gutenprint-5.2.11.tar.bz2
-97c38aa2d7931af25e577e27949f659bd45be3e9deab0af86e437587a526d5d37006d0fddd57ad22e1bbe39f25dfa34926e75690a243c7736840cf85ca5ae2df musl-fix-header.patch
-8b17b4d3dd3f9dbeff7c3a3da38395cde8bea51abe5a8ebeac62b9e442dc451341b3571de02437d035a63da83d10316a4ce0da143cc90a935678a01fb5efb224 pagesize-name-clash.patch
-81cdbd3ff271fec2d7d17313772db6d2617da90bd532a6e2d834e8bfde9e5329a62b01876714be145dbf23071a053374b1b78dd173ea999d0e873b895b49d0a6 gutenprint-O6.patch"
+sha512sums="d2c47eb4ccc3c46ccb2f1042682edf7443f5c57439ead72f49ecd10537cf967251bacf7ca7da29fb8dceecc7eebd55ed021f2594ff9fb6509bab543fab1dc8d6 gutenprint-5.3.3.tar.xz
+47f782a4456d6a0b8776533581041b00253089d529f022a92870f588d361d45b2c97d3f099ada94665b1c9469f69a8b58d35a784871fca65801a1bffcd69c1ca fix-build.patch"
diff --git a/testing/gutenprint/fix-build.patch b/testing/gutenprint/fix-build.patch
new file mode 100644
index 00000000000..3f661aca3e4
--- /dev/null
+++ b/testing/gutenprint/fix-build.patch
@@ -0,0 +1,60 @@
+diff --git a/src/cups/backend_common.h b/src/cups/backend_common.h
+index 2decab2..b756e8c 100644
+--- a/src/cups/backend_common.h
++++ b/src/cups/backend_common.h
+@@ -58,25 +58,25 @@
+ #define le16_to_cpu(__x) __x
+ #define be16_to_cpu(__x) ntohs(__x)
+ #define be32_to_cpu(__x) ntohl(__x)
+-#define be64_to_cpu(__x) ((__uint64_t)( \
+- (((__uint64_t)(__x) & (__uint64_t)0x00000000000000ffULL) << 56) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x000000000000ff00ULL) << 40) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x0000000000ff0000ULL) << 24) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x00000000ff000000ULL) << 8) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x000000ff00000000ULL) >> 8) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x0000ff0000000000ULL) >> 24) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x00ff000000000000ULL) >> 40) | \
+- (((__uint64_t)(__x) & (__uint64_t)0xff00000000000000ULL) >> 56)))
++#define be64_to_cpu(__x) ((uint64_t)( \
++ (((uint64_t)(__x) & (uint64_t)0x00000000000000ffULL) << 56) | \
++ (((uint64_t)(__x) & (uint64_t)0x000000000000ff00ULL) << 40) | \
++ (((uint64_t)(__x) & (uint64_t)0x0000000000ff0000ULL) << 24) | \
++ (((uint64_t)(__x) & (uint64_t)0x00000000ff000000ULL) << 8) | \
++ (((uint64_t)(__x) & (uint64_t)0x000000ff00000000ULL) >> 8) | \
++ (((uint64_t)(__x) & (uint64_t)0x0000ff0000000000ULL) >> 24) | \
++ (((uint64_t)(__x) & (uint64_t)0x00ff000000000000ULL) >> 40) | \
++ (((uint64_t)(__x) & (uint64_t)0xff00000000000000ULL) >> 56)))
+ #else
+-#define le64_to_cpu(__x) ((__uint64_t)( \
+- (((__uint64_t)(__x) & (__uint64_t)0x00000000000000ffULL) << 56) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x000000000000ff00ULL) << 40) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x0000000000ff0000ULL) << 24) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x00000000ff000000ULL) << 8) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x000000ff00000000ULL) >> 8) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x0000ff0000000000ULL) >> 24) | \
+- (((__uint64_t)(__x) & (__uint64_t)0x00ff000000000000ULL) >> 40) | \
+- (((__uint64_t)(__x) & (__uint64_t)0xff00000000000000ULL) >> 56)))
++#define le64_to_cpu(__x) ((uint64_t)( \
++ (((uint64_t)(__x) & (uint64_t)0x00000000000000ffULL) << 56) | \
++ (((uint64_t)(__x) & (uint64_t)0x000000000000ff00ULL) << 40) | \
++ (((uint64_t)(__x) & (uint64_t)0x0000000000ff0000ULL) << 24) | \
++ (((uint64_t)(__x) & (uint64_t)0x00000000ff000000ULL) << 8) | \
++ (((uint64_t)(__x) & (uint64_t)0x000000ff00000000ULL) >> 8) | \
++ (((uint64_t)(__x) & (uint64_t)0x0000ff0000000000ULL) >> 24) | \
++ (((uint64_t)(__x) & (uint64_t)0x00ff000000000000ULL) >> 40) | \
++ (((uint64_t)(__x) & (uint64_t)0xff00000000000000ULL) >> 56)))
+ #define le32_to_cpu(x) \
+ ({ \
+ uint32_t __x = (x); \
+diff --git a/src/testpattern/testpatterny.h b/src/testpattern/testpatterny.h
+index 259ea29..fce45eb 100644
+--- a/src/testpattern/testpatterny.h
++++ b/src/testpattern/testpatterny.h
+@@ -43,6 +43,7 @@ extern int yydebug;
+ /* Token type. */
+ #ifndef YYTOKENTYPE
+ # define YYTOKENTYPE
++#undef PAGESIZE
+ enum yytokentype
+ {
+ tINT = 258,
diff --git a/testing/gutenprint/gutenprint-O6.patch b/testing/gutenprint/gutenprint-O6.patch
deleted file mode 100644
index 0c1084b66d4..00000000000
--- a/testing/gutenprint/gutenprint-O6.patch
+++ /dev/null
@@ -1,281 +0,0 @@
-diff -up gutenprint-5.2.7/configure.ac.O6 gutenprint-5.2.7/configure.ac
---- gutenprint-5.2.7/configure.ac.O6 2011-05-02 03:20:49.000000000 +0200
-+++ gutenprint-5.2.7/configure.ac 2011-05-05 12:40:29.000000000 +0200
-@@ -625,27 +625,6 @@ AH_TEMPLATE(PKGMODULEDIR,, [Package modu
- PKGMODULEDIR="${PACKAGE_LIB_DIR}/${GUTENPRINT_RELEASE_VERSION}/modules"
- AC_DEFINE_UNQUOTED(PKGMODULEDIR, ["$PKGMODULEDIR"])
-
--dnl Compiler flags
--if test x$ac_compiler_gnu = "xyes"; then
-- STP_ADD_COMPILER_ARGS([-Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072],, [GNUCFLAGS])
-- if test x${USE_MAINTAINER_MODE} = xyes ; then
-- STP_ADD_COMPILER_ARGS([-pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls],, [GNUCFLAGS])
-- fi
-- if test x$ENABLE_DEBUG = xyes ; then
-- STP_ADD_COMPILER_ARG([-g])
-- else
-- STP_ADD_FIRST_COMPILER_ARG([-O6 -O3 -O2 -O1 -O])
-- fi
--else
-- if test x$ENABLE_DEBUG = xyes ; then
-- STP_ADD_COMPILER_ARG([-g])
-- else
-- STP_ADD_FIRST_COMPILER_ARG([-O])
-- fi
--fi
--if test x$ENABLE_PROFILE = xyes ; then
-- STP_ADD_COMPILER_ARG([-pg])
--fi
- AC_SUBST(GNUCFLAGS)
-
- AH_TEMPLATE([HAVE_GCC_ATTRIBUTES],
-diff -up gutenprint-5.2.7/configure.O6 gutenprint-5.2.7/configure
---- gutenprint-5.2.7/configure.O6 2011-05-02 03:32:21.000000000 +0200
-+++ gutenprint-5.2.7/configure 2011-05-05 12:52:09.000000000 +0200
-@@ -16589,246 +16589,6 @@ cat >>confdefs.h <<_ACEOF
- #define PKGMODULEDIR "$PKGMODULEDIR"
- _ACEOF
-
--
--if test x$ac_compiler_gnu = "xyes"; then
--
-- for stp_ac_arg in -Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Wwrite-strings -Werror-implicit-function-declaration -Winline -Wformat=2 -finline-limit=131072 ; do
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
--$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
-- stp_acOLDCFLAGS="${CFLAGS}"
-- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--int
--main ()
--{
--
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; };
-- stp_newCFLAGS="$CFLAGS"
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; };
-- stp_newCFLAGS="$stp_acOLDCFLAGS"
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- CFLAGS="$stp_acOLDCFLAGS"
-- GNUCFLAGS="${stp_newCFLAGS}"
--
-- done
--
-- if test x${USE_MAINTAINER_MODE} = xyes ; then
--
-- for stp_ac_arg in -pedantic -Waggregate-return -Wcast-qual -Wshadow -Wredundant-decls ; do
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
--$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
-- stp_acOLDCFLAGS="${CFLAGS}"
-- CFLAGS="${GNUCFLAGS} ${stp_ac_arg}"
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--int
--main ()
--{
--
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; };
-- stp_newCFLAGS="$CFLAGS"
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; };
-- stp_newCFLAGS="$stp_acOLDCFLAGS"
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- CFLAGS="$stp_acOLDCFLAGS"
-- GNUCFLAGS="${stp_newCFLAGS}"
--
-- done
--
-- fi
-- if test x$ENABLE_DEBUG = xyes ; then
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -g" >&5
--$as_echo_n "checking if ${CC} supports -g... " >&6; }
-- stp_acOLDCFLAGS="${CFLAGS}"
-- CFLAGS="${CFLAGS} -g"
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--int
--main ()
--{
--
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; };
-- stp_newCFLAGS="$CFLAGS"
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; };
-- stp_newCFLAGS="$stp_acOLDCFLAGS"
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- CFLAGS="$stp_acOLDCFLAGS"
-- CFLAGS="${stp_newCFLAGS}"
--
-- else
--
-- for stp_ac_arg in -O6 -O3 -O2 -O1 -O ; do
-- stp_ac_save_CFLAGS="${CFLAGS}"
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
--$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
-- stp_acOLDCFLAGS="${CFLAGS}"
-- CFLAGS="${CFLAGS} ${stp_ac_arg}"
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--int
--main ()
--{
--
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; };
-- stp_newCFLAGS="$CFLAGS"
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; };
-- stp_newCFLAGS="$stp_acOLDCFLAGS"
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- CFLAGS="$stp_acOLDCFLAGS"
-- CFLAGS="${stp_newCFLAGS}"
--
-- test "${stp_ac_save_CFLAGS}" != "${CFLAGS}" && break
-- done
--
-- fi
--else
-- if test x$ENABLE_DEBUG = xyes ; then
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -g" >&5
--$as_echo_n "checking if ${CC} supports -g... " >&6; }
-- stp_acOLDCFLAGS="${CFLAGS}"
-- CFLAGS="${CFLAGS} -g"
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--int
--main ()
--{
--
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; };
-- stp_newCFLAGS="$CFLAGS"
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; };
-- stp_newCFLAGS="$stp_acOLDCFLAGS"
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- CFLAGS="$stp_acOLDCFLAGS"
-- CFLAGS="${stp_newCFLAGS}"
--
-- else
--
-- for stp_ac_arg in -O ; do
-- stp_ac_save_CFLAGS="${CFLAGS}"
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports ${stp_ac_arg}" >&5
--$as_echo_n "checking if ${CC} supports ${stp_ac_arg}... " >&6; }
-- stp_acOLDCFLAGS="${CFLAGS}"
-- CFLAGS="${CFLAGS} ${stp_ac_arg}"
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--int
--main ()
--{
--
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; };
-- stp_newCFLAGS="$CFLAGS"
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; };
-- stp_newCFLAGS="$stp_acOLDCFLAGS"
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- CFLAGS="$stp_acOLDCFLAGS"
-- CFLAGS="${stp_newCFLAGS}"
--
-- test "${stp_ac_save_CFLAGS}" != "${CFLAGS}" && break
-- done
--
-- fi
--fi
--if test x$ENABLE_PROFILE = xyes ; then
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if ${CC} supports -pg" >&5
--$as_echo_n "checking if ${CC} supports -pg... " >&6; }
-- stp_acOLDCFLAGS="${CFLAGS}"
-- CFLAGS="${CFLAGS} -pg"
-- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--int
--main ()
--{
--
-- ;
-- return 0;
--}
--_ACEOF
--if ac_fn_c_try_compile "$LINENO"; then :
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; };
-- stp_newCFLAGS="$CFLAGS"
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; };
-- stp_newCFLAGS="$stp_acOLDCFLAGS"
--fi
--rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
-- CFLAGS="$stp_acOLDCFLAGS"
-- CFLAGS="${stp_newCFLAGS}"
--
--fi
--
--
--
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking if $CC supports __attribute__ syntax" >&5
- $as_echo_n "checking if $CC supports __attribute__ syntax... " >&6; }
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
diff --git a/testing/gutenprint/musl-fix-header.patch b/testing/gutenprint/musl-fix-header.patch
deleted file mode 100644
index 8a74a56ac59..00000000000
--- a/testing/gutenprint/musl-fix-header.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/main/print-olympus.c b/src/main/print-olympus.c
-index 42c4897..b11b020 100644
---- a/src/main/print-olympus.c
-+++ b/src/main/print-olympus.c
-@@ -40,6 +40,7 @@
- #include <string.h>
- #include <stdio.h>
- #include <limits.h>
-+#include <endian.h>
-
- #ifdef __GNUC__
- #define inline __inline__
diff --git a/testing/gutenprint/pagesize-name-clash.patch b/testing/gutenprint/pagesize-name-clash.patch
deleted file mode 100644
index 932ae2da05b..00000000000
--- a/testing/gutenprint/pagesize-name-clash.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/testpattern/testpatterny.h b/src/testpattern/testpatterny.h
-index 010e17a..986d1d7 100644
---- a/src/testpattern/testpatterny.h
-+++ b/src/testpattern/testpatterny.h
-@@ -36,6 +36,9 @@
- /* Tokens. */
- #ifndef YYTOKENTYPE
- # define YYTOKENTYPE
-+#ifdef PAGESIZE
-+#undef PAGESIZE
-+#endif
- /* Put the tokens into the symbol table, so that GDB and other debuggers
- know about them. */
- enum yytokentype {