aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/knotifyconfig/APKBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/community/knotifyconfig/APKBUILD b/community/knotifyconfig/APKBUILD
index 3d9e8e612e4..ce394f997d7 100644
--- a/community/knotifyconfig/APKBUILD
+++ b/community/knotifyconfig/APKBUILD
@@ -4,11 +4,22 @@ pkgname=knotifyconfig
pkgver=5.82.0
pkgrel=0
pkgdesc="Configuration system for KNotify"
-arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
+# armhf blocked by extra-cmake-modules
+# mips64, s390x and riscv64 blocked by polkit
+arch="all !armhf !mips64 !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
-depends_dev="kcompletion-dev kconfig-dev ki18n-dev kio-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
+depends_dev="
+ kcompletion-dev
+ kconfig-dev
+ ki18n-dev
+ kio-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt5-qttools-dev
+ "
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/knotifyconfig-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
@@ -27,7 +38,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
d214d8019179c079a22f4076bb985f1528292c467cce36a18e2457a4051264f915f48a35ea2b508b900fded020bf20c8d3e784149e9be7993a80a027a70871e3 knotifyconfig-5.82.0.tar.xz