aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/phodav/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/community/phodav/APKBUILD b/community/phodav/APKBUILD
index ef9e11c6c5b..df0930ffcd4 100644
--- a/community/phodav/APKBUILD
+++ b/community/phodav/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=phodav
-pkgver=2.4
+pkgver=2.5
pkgrel=0
-pkgdesc="A WebDAV server using libsoup"
+pkgdesc="WebDAV server using libsoup"
url="https://wiki.gnome.org/phodav"
arch="all"
license="LGPL-2.0-or-later"
@@ -15,23 +15,16 @@ source="https://download.gnome.org/sources/phodav/$pkgver/phodav-$pkgver.tar.xz
"
build() {
- meson \
- --prefix=/usr \
- --datadir=share \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --buildtype=plain \
+ abuild-meson \
-Davahi=enabled \
-Dsystemd=disabled \
-Dudev=enabled \
. output
- ninja -C output
+ meson compile -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
rm -rf "$pkgdir"/usr/lib/systemd
}
@@ -62,5 +55,5 @@ spice_openrc() {
install "$srcdir"/spice-webdavd.initd "$subpkgdir"/etc/init.d/spice-webdavd
}
-sha512sums="63f21843ccf62382bc48aa0c7f9ae6882431e59f590da5047f06e8cbbfcf8195744dcfc3b268997bf24ccf1f82f643b8189243f1ec80e60652a03c8c6a0f9b9e phodav-2.4.tar.xz
+sha512sums="4b6cd6a40118bf9c042abcfc3e7cb593b620922aae4dd3daf77682bf9da2030a0958bc0206531d5950f85551ef8f5da21fb21c54b9bd5e56b880f54e0983bc01 phodav-2.5.tar.xz
1e10314f831840d9f54f38163bd518f42a378fe27b508639771b82610b4a434d4ec56c70a334dbfc7c8cd91160ba346751978f511c522577803248205dbcd211 spice-webdavd.initd"