aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/zimg/APKBUILD7
-rw-r--r--testing/zimg/musl-missing-include.patch12
2 files changed, 17 insertions, 2 deletions
diff --git a/testing/zimg/APKBUILD b/testing/zimg/APKBUILD
index b1249215d59..c1f04e5068c 100644
--- a/testing/zimg/APKBUILD
+++ b/testing/zimg/APKBUILD
@@ -10,7 +10,9 @@ license="WTFPL-2.0"
makedepends="autoconf automake libtool"
subpackages="$pkgname-doc $pkgname-dev"
source="zimg-$pkgver.tar.gz::https://github.com/sekrit-twc/zimg/archive/release-$pkgver.tar.gz
- zimg-gtest-1.8.0.tar.gz::https://github.com/google/googletest/archive/release-1.8.0.tar.gz"
+ zimg-gtest-1.8.0.tar.gz::https://github.com/google/googletest/archive/release-1.8.0.tar.gz
+ musl-missing-include.patch
+ "
builddir="$srcdir/zimg-release-$pkgver"
options="!check" # we run tests in the build stage
@@ -56,4 +58,5 @@ package() {
}
sha512sums="dfa5dd8f6f6335f6f5106e792774ae649d056c42c8f586627996be172d98b17e0583c41f1dc421edd0fc27793240df9f87217d8cdfc24a2367646e046109b196 zimg-2.9.3.tar.gz
-1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d zimg-gtest-1.8.0.tar.gz"
+1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d zimg-gtest-1.8.0.tar.gz
+06c1b1220e0418ed5051a6c594bbf48ba7ed10a4e2a95b51d6ae2451ba49b1f0be97347115c203fe82322c7f3b9f75756ba03eabe902898b3e3dd2c9e1765891 musl-missing-include.patch"
diff --git a/testing/zimg/musl-missing-include.patch b/testing/zimg/musl-missing-include.patch
new file mode 100644
index 00000000000..198ea6dbba1
--- /dev/null
+++ b/testing/zimg/musl-missing-include.patch
@@ -0,0 +1,12 @@
+Otherwise fails to build with missing size_t
+
+diff --git a/src/zimg/colorspace/matrix3.cpp b/src/zimg/colorspace/matrix3.cpp
+index 06e0e2f..bf849c0 100644
+--- a/src/zimg/colorspace/matrix3.cpp
++++ b/src/zimg/colorspace/matrix3.cpp
+@@ -1,4 +1,5 @@
+ #include "matrix3.h"
++#include <sys/types.h>
+
+ namespace zimg {
+ namespace colorspace {