aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/vectorscan/APKBUILD12
-rw-r--r--community/vectorscan/static.patch36
-rw-r--r--community/vectorscan/version.patch11
3 files changed, 17 insertions, 42 deletions
diff --git a/community/vectorscan/APKBUILD b/community/vectorscan/APKBUILD
index 618613788fd..8e5a519a56a 100644
--- a/community/vectorscan/APKBUILD
+++ b/community/vectorscan/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=vectorscan
-pkgver=5.4.2
-pkgrel=3
+pkgver=5.4.4
+pkgrel=0
pkgdesc="High-performance regular expression matching library"
url="https://www.hyperscan.io"
arch="x86 x86_64 aarch64" #requires SSSE3 or Neon
@@ -10,7 +10,8 @@ license="BSD-3-Clause"
makedepends="cmake ragel boost-dev pcre-dev sqlite-dev py3-breathe chrpath"
subpackages="$pkgname-doc $pkgname-dev $pkgname-utils"
source="$pkgname-$pkgver.tar.gz::https://github.com/vectorcamp/vectorscan/archive/v$pkgver+vectorscan.tar.gz
- static.patch"
+ version.patch
+ "
builddir="$srcdir/$pkgname-$pkgver-$pkgname"
build() {
local _march="-march=native"
@@ -53,7 +54,6 @@ package() {
done
mkdir -p usr/share/html
mv "$builddir"/build/doc/dev-reference/html usr/share/html/"$pkgname"
- mv usr/share/doc/hyperscan usr/share/doc/"$pkgname"
}
utils() {
@@ -61,6 +61,6 @@ utils() {
}
sha512sums="
-fcabf7d1459780c3df36504308b7d0669735c9336c72553dec2c02dbdb75bbccfd316492731e8216f0b6561ce64ea5964c817b4bd2d3debe6f676b7098bcb4da vectorscan-5.4.2.tar.gz
-f0cb6ccb52f561659042334e3bc9713633f7fbc7dbcb58d6e82e221290a98e09c99579b036c1f6c645b9855217d350d64e953ec949514a08b460fd19ddff29a4 static.patch
+68266b953a82962c6c8c5e5232a0932333967d18fd69aef2a1e58a25ded65f9b49ed863cea9824fe75e958999d5a64cdf35f63d19d5a4c566c5d1688642d5db5 vectorscan-5.4.4.tar.gz
+a85f94c5680e1af8a94ae91eacaae6be0f71c92d85102881e98329d9c8af394ee24b8d599d8f0f316a3480aa6117f14b88d585b608cc8a8b0a231df473e796e0 version.patch
"
diff --git a/community/vectorscan/static.patch b/community/vectorscan/static.patch
deleted file mode 100644
index bc0826b9dfb..00000000000
--- a/community/vectorscan/static.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Merged as:
-https://github.com/VectorCamp/vectorscan/pull/65
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -501,19 +501,9 @@
- configure_file(${CMAKE_MODULE_PATH}/config.h.in ${PROJECT_BINARY_DIR}/config.h)
- configure_file(src/hs_version.h.in ${PROJECT_BINARY_DIR}/hs_version.h)
-
--if (NOT WIN32)
-- # expand out library names for pkgconfig static link info
-- foreach (LIB ${CMAKE_CXX_IMPLICIT_LINK_LIBRARIES})
-- # this is fragile, but protects us from toolchain specific files
-- if (NOT EXISTS ${LIB})
-- set(PRIVATE_LIBS "${PRIVATE_LIBS} -l${LIB}")
-- endif()
-- endforeach()
--
-- configure_file(libhs.pc.in libhs.pc @ONLY) # only replace @ quoted vars
-- install(FILES ${CMAKE_BINARY_DIR}/libhs.pc
-- DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
--endif()
-+configure_file(libhs.pc.in libhs.pc @ONLY) # only replace @ quoted vars
-+install(FILES ${CMAKE_BINARY_DIR}/libhs.pc
-+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
-
- # only set these after all tests are done
- if (NOT FAT_RUNTIME)
---- a/libhs.pc.in
-+++ b/libhs.pc.in
-@@ -7,5 +7,4 @@
- Description: Intel(R) Hyperscan Library
- Version: @HS_VERSION@
- Libs: -L${libdir} -lhs
--Libs.private: @PRIVATE_LIBS@
- Cflags: -I${includedir}/hs
diff --git a/community/vectorscan/version.patch b/community/vectorscan/version.patch
new file mode 100644
index 00000000000..b843e110a6a
--- /dev/null
+++ b/community/vectorscan/version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,7 +3,7 @@
+
+ set (HS_MAJOR_VERSION 5)
+ set (HS_MINOR_VERSION 4)
+-set (HS_PATCH_VERSION 3)
++set (HS_PATCH_VERSION 4)
+ set (HS_VERSION ${HS_MAJOR_VERSION}.${HS_MINOR_VERSION}.${HS_PATCH_VERSION})
+
+ set(CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)