aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/qemu/APKBUILD9
-rw-r--r--community/qemu/fix-statx-translation.patch39
2 files changed, 4 insertions, 44 deletions
diff --git a/community/qemu/APKBUILD b/community/qemu/APKBUILD
index 699786488d5..3d8df366b06 100644
--- a/community/qemu/APKBUILD
+++ b/community/qemu/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
-pkgver=4.1.1
-pkgrel=2
+pkgver=4.2.0
+pkgrel=0
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="https://qemu.org/"
arch="all"
@@ -140,6 +140,7 @@ _modules="
ui-curses
ui-gtk
ui-sdl
+ ui-spice-app
"
for _mod in $_modules; do
subpackages="$subpackages $pkgname-$_mod:_module"
@@ -162,7 +163,6 @@ source="https://wiki.qemu-project.org/download/$pkgname-$pkgver.tar.xz
fix-sockios-header.patch
test-crypto-ivgen-skip-essiv.patch
guest-agent-shutdown.patch
- fix-statx-translation.patch
$pkgname-guest-agent.confd
$pkgname-guest-agent.initd
@@ -388,7 +388,7 @@ _all_modules() {
mkdir -p "$subpkgdir"
}
-sha512sums="13c8420f74fd7f043f2dd0774b88262327d22864b3fc7b5d5e7e651fb163de03ac51483abec703cd9914511049b125165875c27566bebfd9b6482d8d2c2ff108 qemu-4.1.1.tar.xz
+sha512sums="2a79973c2b07c53e8c57a808ea8add7b6b2cbca96488ed5d4b669ead8c9318907dec2b6109f180fc8ca8f04c0f73a56e82b3a527b5626b799d7e849f2474ec56 qemu-4.2.0.tar.xz
405008589cad1c8b609eca004d520bf944366e8525f85a19fc6e283c95b84b6c2429822ba064675823ab69f1406a57377266a65021623d1cd581e7db000134fd 0001-elfload-load-PIE-executables-to-right-address.patch
98db5e23397cfad4a7210f9f7e1c5fa5c48f065785439521c5b39325c429f2dc367c40925adff6aa8677b3192a1a98a30e93d5b9c879df523deb019c40edd9d9 0006-linux-user-signal.c-define-__SIGRTMIN-MAX-for-non-GN.patch
1ac043312864309e19f839a699ab2485bca51bbf3d5fdb39f1a87b87e3cbdd8cbda1a56e6b5c9ffccd65a8ac2f600da9ceb8713f4dbba26f245bc52bcd8a1c56 0001-linux-user-fix-build-with-musl-on-aarch64.patch
@@ -402,7 +402,6 @@ d7de79ea74e36702cac4a59e472564a55f0a663be7e63c3755e32b4b5dfbc04b390ee79f09f43f6a
39590476a4ebd7c1e79a4f0451b24c75b1817a2a83abaa1f71bb60b225d772152f0af8f3e51ff65645e378c536ffa6ff551dade52884d03a14b7c6a19c5c97d4 fix-sockios-header.patch
8b8db136f78bd26b5da171effa9e11016ec2bc3e2fc8107228b5543b47aa370978ed883794aa4f917f334e284a5b49e82070e1da2d31d49301195b6713a48eff test-crypto-ivgen-skip-essiv.patch
b8e58bcc409f25cc6ff59967ed68f4de0a8656ec4db71ab663cc77761f8210b3f85c475fceb32dec934dc02a5c4f679a8313edbcf84e149692a81764c8904f67 guest-agent-shutdown.patch
-41a33719e1d5cfc0d5554cd13d8177ebaa3be7986ce8a2f8641e0cf2922eeadeced5aa780f156861af2cceed5f4d9a4d996344816dfbebe071033ba51bb81d3c fix-statx-translation.patch
d90c034cae3f9097466854ed1a9f32ab4b02089fcdf7320e8f4da13b2b1ff65067233f48809911485e4431d7ec1a22448b934121bc9522a2dc489009e87e2b1f qemu-guest-agent.confd
1cd24c2444c5935a763c501af2b0da31635aad9cf62e55416d6477fcec153cddbe7de205d99616def11b085e0dd366ba22463d2270f831d884edbc307c7864a6 qemu-guest-agent.initd
9b7a89b20fcf737832cb7b4d5dc7d8301dd88169cbe5339eda69fbb51c2e537d8cb9ec7cf37600899e734209e63410d50d0821bce97e401421db39c294d97be2 80-kvm.rules
diff --git a/community/qemu/fix-statx-translation.patch b/community/qemu/fix-statx-translation.patch
deleted file mode 100644
index 2f6b3cfc393..00000000000
--- a/community/qemu/fix-statx-translation.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 5c39af4d742e06eb8af4822f26d5f389df37ce91 Mon Sep 17 00:00:00 2001
-From: Ariadne Conill <ariadne@dereferenced.org>
-Date: Fri, 22 Nov 2019 11:13:32 -0600
-Subject: [PATCH] linux-user: fix translation of statx structures
-
-All timestamps were copied to atime instead of to their respective
-fields.
-
-Signed-off-by: Ariadne Conill <ariadne@dereferenced.org>
----
- linux-user/syscall.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/linux-user/syscall.c b/linux-user/syscall.c
-index ce399a55f0..171c0caef3 100644
---- a/linux-user/syscall.c
-+++ b/linux-user/syscall.c
-@@ -6743,12 +6743,12 @@ static inline abi_long host_to_target_statx(struct target_statx *host_stx,
- __put_user(host_stx->stx_attributes_mask, &target_stx->stx_attributes_mask);
- __put_user(host_stx->stx_atime.tv_sec, &target_stx->stx_atime.tv_sec);
- __put_user(host_stx->stx_atime.tv_nsec, &target_stx->stx_atime.tv_nsec);
-- __put_user(host_stx->stx_btime.tv_sec, &target_stx->stx_atime.tv_sec);
-- __put_user(host_stx->stx_btime.tv_nsec, &target_stx->stx_atime.tv_nsec);
-- __put_user(host_stx->stx_ctime.tv_sec, &target_stx->stx_atime.tv_sec);
-- __put_user(host_stx->stx_ctime.tv_nsec, &target_stx->stx_atime.tv_nsec);
-- __put_user(host_stx->stx_mtime.tv_sec, &target_stx->stx_atime.tv_sec);
-- __put_user(host_stx->stx_mtime.tv_nsec, &target_stx->stx_atime.tv_nsec);
-+ __put_user(host_stx->stx_btime.tv_sec, &target_stx->stx_btime.tv_sec);
-+ __put_user(host_stx->stx_btime.tv_nsec, &target_stx->stx_btime.tv_nsec);
-+ __put_user(host_stx->stx_ctime.tv_sec, &target_stx->stx_ctime.tv_sec);
-+ __put_user(host_stx->stx_ctime.tv_nsec, &target_stx->stx_ctime.tv_nsec);
-+ __put_user(host_stx->stx_mtime.tv_sec, &target_stx->stx_mtime.tv_sec);
-+ __put_user(host_stx->stx_mtime.tv_nsec, &target_stx->stx_mtime.tv_nsec);
- __put_user(host_stx->stx_rdev_major, &target_stx->stx_rdev_major);
- __put_user(host_stx->stx_rdev_minor, &target_stx->stx_rdev_minor);
- __put_user(host_stx->stx_dev_major, &target_stx->stx_dev_major);
---
-2.24.0
-