aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/alpine-conf/0001-update-kernel-Make-path-for-tmpdir-changeable-via-cl.patch64
-rw-r--r--main/alpine-conf/APKBUILD4
2 files changed, 67 insertions, 1 deletions
diff --git a/main/alpine-conf/0001-update-kernel-Make-path-for-tmpdir-changeable-via-cl.patch b/main/alpine-conf/0001-update-kernel-Make-path-for-tmpdir-changeable-via-cl.patch
new file mode 100644
index 00000000000..f2b33e22058
--- /dev/null
+++ b/main/alpine-conf/0001-update-kernel-Make-path-for-tmpdir-changeable-via-cl.patch
@@ -0,0 +1,64 @@
+From 661f3b90f29f96a733aaff62ff0ca899ed34234d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Dennis=20G=C3=BCnnewig?= <dev@fedux.org>
+Date: Sun, 30 May 2021 15:16:17 +0200
+Subject: [PATCH] update-kernel: Make path for tmpdir changeable via cli flag
+
+On a Raspberry Pi 3B+ the memory is limited. Updating a kernel might be not possible due to "out of space" situations. This MR adds a flag to mitigate the problem for users facing this issue.
+---
+ update-kernel.in | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/update-kernel.in b/update-kernel.in
+index dce5006..51fed76 100644
+--- a/update-kernel.in
++++ b/update-kernel.in
+@@ -31,6 +31,7 @@ REPOSITORIES_FILE=/etc/apk/repositories
+ KEYS_DIR=/etc/apk/keys
+ SIGNALS="HUP INT TERM"
+ TMPDIR=
++TMPDIR_PATH="/tmp"
+ features=
+ modloopfw=
+
+@@ -55,6 +56,7 @@ usage() {
+ -F|--feature <feature> Enable initfs feature
+ -p|--package <package> Additional module or firmware package
+ -s|--modloopsign Sign modloop with abuild key
++ -t|--tmpdir <directory> Choose different (non RAM) temporary directory for build files etc.
+ -v|--verbose Verbose output
+ -k|--apk-pubkey <key> Include given key in initramfs
+ -K|--hostkeys Include host keys in initramfs
+@@ -68,8 +70,8 @@ usage() {
+ }
+
+ QUIET_OPT="--quiet"
+-OPTS=$(getopt -l arch:,build-dir:,flavor:,feature:,modloopfw:,help,package:,modloopsign,verbose,apk-pubkey:,hostkeys,compression:,media,repositories-file:,keys-dir: \
+- -n $SCRIPT -o a:b:f:F:hp:svk:KC:Md: -- "$@") || usage 1
++OPTS=$(getopt -l arch:,build-dir:,flavor:,feature:,modloopfw:,help,package:,modloopsign,tmpdir:,verbose,apk-pubkey:,hostkeys,compression:,media,repositories-file:,keys-dir: \
++ -n $SCRIPT -o a:b:f:F:hp:st:vk:KC:Md: -- "$@") || usage 1
+
+ eval set -- "$OPTS"
+ while :; do
+@@ -105,6 +107,10 @@ while :; do
+ -s|--modloopsign)
+ MODLOOPSIGN=1
+ ;;
++ -t|--tmpdir)
++ shift
++ TMPDIR_PATH="$1"
++ ;;
+ -v|--verbose)
+ QUIET_OPT=
+ ;;
+@@ -218,7 +224,7 @@ fi
+
+ [ "$ARCH" ] || ARCH=$(apk --print-arch)
+
+-TMPDIR=$(mktemp -d /tmp/$SCRIPT.XXXXXX)
++TMPDIR=$(mktemp -d "$TMPDIR_PATH/$SCRIPT.XXXXXX")
+ ROOT=$TMPDIR/root
+ BOOT=$ROOT/boot
+
+--
+2.31.1
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index 9ac19933277..4eeb08f6521 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=3.12.0
-pkgrel=0
+pkgrel=1
pkgdesc="Alpine configuration management scripts"
url="https://git.alpinelinux.org/alpine-conf/about"
arch="all"
license="MIT"
depends="openrc>=0.24.1-r6 busybox>=1.26.1-r3"
source="https://gitlab.alpinelinux.org/alpine/alpine-conf/-/archive/$pkgver/alpine-conf-$pkgver.tar.gz
+ 0001-update-kernel-Make-path-for-tmpdir-changeable-via-cl.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -26,4 +27,5 @@ package() {
sha512sums="
e776e79677a89d2538896fdf63eb37ee7bd2179cd8e4205df4b0577fa54cf9b3aceeda191eaad14cb51323e7d10c67bfd63c481f88766872c5c6ef229e9ab53c alpine-conf-3.12.0.tar.gz
+7c9c78f134853d56ef65900f89d2cf5da2a333700c70caacaa650577865935ecefd3467f221f9ec3deac0a108edbbfbd52e7f1c5f66d468dac7770d59ca4bf5b 0001-update-kernel-Make-path-for-tmpdir-changeable-via-cl.patch
"