aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/R/APKBUILD4
-rw-r--r--community/abiword/APKBUILD4
-rw-r--r--community/accerciser/APKBUILD4
-rw-r--r--community/accountsservice/APKBUILD4
-rw-r--r--community/acf-vlc-daemon/APKBUILD2
-rw-r--r--community/acme-redirect/APKBUILD4
-rw-r--r--community/adwaita-icon-theme/APKBUILD4
-rw-r--r--community/afl/APKBUILD2
-rw-r--r--community/aircrack-ng/APKBUILD2
-rw-r--r--community/aisleriot/APKBUILD2
-rw-r--r--community/akonadi-calendar-tools/APKBUILD4
-rw-r--r--community/akonadi-calendar/APKBUILD4
-rw-r--r--community/akonadi-contacts/APKBUILD4
-rw-r--r--community/akonadi-import-wizard/APKBUILD4
-rw-r--r--community/akonadi-mime/APKBUILD4
-rw-r--r--community/akonadi-search/APKBUILD4
-rw-r--r--community/akonadi/APKBUILD4
-rw-r--r--community/akonadiconsole/APKBUILD4
-rw-r--r--community/akregator/APKBUILD4
-rw-r--r--community/alkimia/APKBUILD6
-rw-r--r--community/amfora/APKBUILD5
-rw-r--r--community/angelfish/APKBUILD4
-rw-r--r--community/apache-ant/APKBUILD4
-rw-r--r--community/apparmor/APKBUILD3
-rw-r--r--community/appstream/APKBUILD2
-rw-r--r--community/ark/APKBUILD4
-rw-r--r--community/armadillo/APKBUILD2
-rw-r--r--community/arpack/APKBUILD2
-rw-r--r--community/artikulate/APKBUILD4
-rw-r--r--community/assimp/APKBUILD2
-rw-r--r--community/atril/APKBUILD4
-rw-r--r--community/audacious/APKBUILD4
-rw-r--r--community/audiocd-kio/APKBUILD4
-rw-r--r--community/aura-browser/APKBUILD4
-rw-r--r--community/awesome/APKBUILD2
-rw-r--r--community/aws-cli/APKBUILD3
-rw-r--r--community/babeltrace/APKBUILD2
-rw-r--r--community/babl/APKBUILD5
-rw-r--r--community/baloo-widgets/APKBUILD4
-rw-r--r--community/baloo/APKBUILD4
-rw-r--r--community/bandwhich/APKBUILD4
-rw-r--r--community/baobab/APKBUILD4
-rw-r--r--community/bareos/APKBUILD1
-rw-r--r--community/bcc/APKBUILD4
-rw-r--r--community/biber/APKBUILD2
-rw-r--r--community/biblatex/APKBUILD4
-rw-r--r--community/bird/APKBUILD2
-rw-r--r--community/bitcoin/APKBUILD3
-rw-r--r--community/blinken/APKBUILD4
-rw-r--r--community/bluedevil/APKBUILD4
-rw-r--r--community/bolt/APKBUILD4
-rw-r--r--community/bovo/APKBUILD4
-rw-r--r--community/bpfmon/APKBUILD2
-rw-r--r--community/brasero/APKBUILD4
-rw-r--r--community/breeze-gtk/APKBUILD4
-rw-r--r--community/buho/APKBUILD4
-rw-r--r--community/caerbannog/APKBUILD4
-rw-r--r--community/caja-extensions/APKBUILD2
-rw-r--r--community/caja/APKBUILD4
-rw-r--r--community/calamares-extensions/APKBUILD4
-rw-r--r--community/calindori/APKBUILD4
-rw-r--r--community/calls/APKBUILD4
-rw-r--r--community/cantor/APKBUILD4
-rw-r--r--community/capnproto/APKBUILD2
-rw-r--r--community/cargo-audit/APKBUILD4
-rw-r--r--community/cargo-edit/APKBUILD4
-rw-r--r--community/cargo-outdated/APKBUILD4
-rw-r--r--community/cargo-watch/APKBUILD4
-rw-r--r--community/ceph/APKBUILD2
-rw-r--r--community/cervisia/APKBUILD4
-rw-r--r--community/chatty/APKBUILD4
-rw-r--r--community/choqok/APKBUILD4
-rw-r--r--community/chromium/APKBUILD2
-rw-r--r--community/chromium/chromium-use-alpine-target.patch42
-rw-r--r--community/cinnamon-desktop/APKBUILD4
-rw-r--r--community/claws-mail/APKBUILD2
-rw-r--r--community/clip/APKBUILD4
-rwxr-xr-xcommunity/clojure/APKBUILD2
-rw-r--r--community/cloud-init/APKBUILD5
-rwxr-xr-xcommunity/cloud-utils/APKBUILD2
-rw-r--r--community/cloudi/APKBUILD4
-rw-r--r--community/collectd/APKBUILD4
-rw-r--r--community/colord-gtk/APKBUILD4
-rw-r--r--community/commons-daemon/APKBUILD4
-rw-r--r--community/communicator/APKBUILD4
-rw-r--r--community/consolekit2/APKBUILD4
-rw-r--r--community/consul/APKBUILD4
-rw-r--r--community/containerd/APKBUILD7
-rw-r--r--community/coreaction/APKBUILD4
-rw-r--r--community/corefm/APKBUILD4
-rw-r--r--community/coregarage/APKBUILD2
-rw-r--r--community/corestats/APKBUILD2
-rw-r--r--community/corestuff/APKBUILD4
-rw-r--r--community/coretoppings/APKBUILD4
-rw-r--r--community/corrosion/APKBUILD4
-rw-r--r--community/cppcheck/APKBUILD3
-rw-r--r--community/cpputest/APKBUILD2
-rw-r--r--community/cups-pk-helper/APKBUILD4
-rw-r--r--community/ddrescue/APKBUILD1
-rw-r--r--community/deja-dup/APKBUILD4
-rw-r--r--community/dep/APKBUILD3
-rw-r--r--community/dfrs/APKBUILD4
-rw-r--r--community/discover/APKBUILD4
-rw-r--r--community/dnsdist/APKBUILD4
-rw-r--r--community/docker/APKBUILD6
-rw-r--r--community/doctl/APKBUILD7
-rw-r--r--community/dolphin-plugins/APKBUILD4
-rw-r--r--community/dolphin/APKBUILD4
-rw-r--r--community/dpns/APKBUILD2
-rw-r--r--community/dragon/APKBUILD4
-rw-r--r--community/drawterm/APKBUILD2
-rw-r--r--community/drkonqi/APKBUILD4
-rw-r--r--community/dssim/APKBUILD2
-rw-r--r--community/dune/APKBUILD4
-rw-r--r--community/ebook-tools/APKBUILD4
-rw-r--r--community/ecl/APKBUILD3
-rw-r--r--community/eg25-manager/APKBUILD4
-rw-r--r--community/eigen/APKBUILD7
-rw-r--r--community/elisa/APKBUILD4
-rw-r--r--community/elogind/APKBUILD4
-rw-r--r--community/elogind/fix-mips-detection.patch13
-rw-r--r--community/emacs/APKBUILD4
-rw-r--r--community/engrampa/APKBUILD4
-rw-r--r--community/eog/APKBUILD2
-rw-r--r--community/eom/APKBUILD2
-rw-r--r--community/epiphany/APKBUILD4
-rw-r--r--community/eventviews/APKBUILD4
-rw-r--r--community/evince/APKBUILD4
-rw-r--r--community/evolution-data-server/APKBUILD4
-rw-r--r--community/exempi/APKBUILD2
-rw-r--r--community/falkon/APKBUILD4
-rw-r--r--community/faudio/APKBUILD2
-rw-r--r--community/ffcall/APKBUILD2
-rw-r--r--community/ffmpeg/APKBUILD1
-rw-r--r--community/ffmpegthumbs/APKBUILD4
-rw-r--r--community/fgt/APKBUILD3
-rw-r--r--community/file-roller/APKBUILD4
-rw-r--r--community/filelight/APKBUILD4
-rw-r--r--community/firefox/APKBUILD2
-rw-r--r--community/flatbuffers/APKBUILD2
-rw-r--r--community/flatpak-builder/APKBUILD4
-rw-r--r--community/flatseal/APKBUILD4
-rw-r--r--community/fluidsynth/APKBUILD2
-rw-r--r--community/font-manager/APKBUILD2
-rw-r--r--community/font-noto-emoji/APKBUILD2
-rw-r--r--community/frameworkintegration/APKBUILD4
-rw-r--r--community/freeimage/APKBUILD2
-rw-r--r--community/fs-uae-launcher/APKBUILD2
-rw-r--r--community/fs-uae/APKBUILD2
-rw-r--r--community/fwupd-efi/APKBUILD2
-rw-r--r--community/gcc-cross-embedded-stage1/APKBUILD2
-rw-r--r--community/gcc-cross-embedded/APKBUILD4
-rw-r--r--community/gcc6/APKBUILD3
-rw-r--r--community/gcompat/APKBUILD5
-rw-r--r--community/gdm/APKBUILD4
-rw-r--r--community/gegl/APKBUILD4
-rw-r--r--community/geoclue/APKBUILD2
-rw-r--r--community/geth/APKBUILD2
-rw-r--r--community/gimp/APKBUILD2
-rw-r--r--community/ginkgo/APKBUILD2
-rw-r--r--community/git-interactive-rebase-tool/APKBUILD2
-rw-r--r--community/gjs/APKBUILD4
-rw-r--r--community/gkraken/APKBUILD2
-rw-r--r--community/glib-networking/APKBUILD2
-rw-r--r--community/gnome-applets/APKBUILD4
-rw-r--r--community/gnome-authenticator/APKBUILD4
-rw-r--r--community/gnome-books/APKBUILD2
-rw-r--r--community/gnome-calculator/APKBUILD4
-rw-r--r--community/gnome-characters/APKBUILD4
-rw-r--r--community/gnome-chess/APKBUILD2
-rw-r--r--community/gnome-clocks/APKBUILD4
-rw-r--r--community/gnome-control-center/APKBUILD4
-rw-r--r--community/gnome-disk-utility/APKBUILD4
-rw-r--r--community/gnome-flashback/APKBUILD4
-rw-r--r--community/gnome-font-viewer/APKBUILD4
-rw-r--r--community/gnome-games/APKBUILD4
-rw-r--r--community/gnome-maps/APKBUILD2
-rw-r--r--community/gnome-mines/APKBUILD2
-rw-r--r--community/gnome-music/APKBUILD4
-rw-r--r--community/gnome-obfuscate/APKBUILD4
-rw-r--r--community/gnome-panel/APKBUILD4
-rw-r--r--community/gnome-passwordsafe/APKBUILD4
-rw-r--r--community/gnome-photos/APKBUILD4
-rw-r--r--community/gnome-podcasts/APKBUILD4
-rw-r--r--community/gnome-power-manager/APKBUILD4
-rw-r--r--community/gnome-remote-desktop/APKBUILD2
-rw-r--r--community/gnome-screenshot/APKBUILD4
-rw-r--r--community/gnome-session/APKBUILD4
-rw-r--r--community/gnome-settings-daemon/APKBUILD4
-rw-r--r--community/gnome-shell-extensions/APKBUILD4
-rw-r--r--community/gnome-shortwave/APKBUILD4
-rw-r--r--community/gnome-software/APKBUILD4
-rw-r--r--community/gnome-sound-recorder/APKBUILD2
-rw-r--r--community/gnome-system-monitor/APKBUILD2
-rw-r--r--community/gnome-taquin/APKBUILD2
-rw-r--r--community/gnome-terminal/APKBUILD4
-rw-r--r--community/gnome-themes-extra/APKBUILD4
-rw-r--r--community/gnome-tour/APKBUILD4
-rw-r--r--community/gnome-tweaks/APKBUILD4
-rw-r--r--community/gnome-usage/APKBUILD4
-rw-r--r--community/gnome-weather/APKBUILD4
-rw-r--r--community/gnome/APKBUILD2
-rw-r--r--community/gnumeric/APKBUILD4
-rw-r--r--community/go-bindata-assetfs/APKBUILD5
-rw-r--r--community/go/APKBUILD4
-rw-r--r--community/gocryptfs/APKBUILD3
-rw-r--r--community/goffice/APKBUILD4
-rw-r--r--community/gomuks/APKBUILD2
-rw-r--r--community/gparted/APKBUILD4
-rw-r--r--community/gpaste/APKBUILD2
-rw-r--r--community/gpodder-adaptive/APKBUILD2
-rw-r--r--community/gpodder/APKBUILD2
-rw-r--r--community/gradle/APKBUILD4
-rw-r--r--community/grafana/APKBUILD2
-rw-r--r--community/granatier/APKBUILD4
-rw-r--r--community/grantlee-editor/APKBUILD4
-rw-r--r--community/grantleetheme/APKBUILD4
-rw-r--r--community/greenbone-security-assistant/APKBUILD4
-rw-r--r--community/grilo-plugins/APKBUILD4
-rw-r--r--community/grpc-java/APKBUILD4
-rw-r--r--community/gst-plugins-bad/APKBUILD2
-rw-r--r--community/gtk4.0/APKBUILD2
-rw-r--r--community/gtkmm4/APKBUILD4
-rw-r--r--community/gtksourceview5/APKBUILD4
-rw-r--r--community/gvfs/APKBUILD4
-rw-r--r--community/gvmd/APKBUILD2
-rw-r--r--community/gwenview/APKBUILD7
-rw-r--r--community/h2o/APKBUILD2
-rw-r--r--community/haxe/APKBUILD2
-rw-r--r--community/hdf5/APKBUILD4
-rw-r--r--community/heirloom-doctools/APKBUILD2
-rw-r--r--community/hexyl/APKBUILD2
-rw-r--r--community/hfsprogs/APKBUILD2
-rw-r--r--community/hivemind-ptt/APKBUILD2
-rw-r--r--community/hugo/APKBUILD2
-rw-r--r--community/hugo/increase-timeout-pagebundler-test.patch17
-rw-r--r--community/hydroxide/APKBUILD2
-rw-r--r--community/icinga-php-library/APKBUILD2
-rw-r--r--community/icinga-php-thirdparty/APKBUILD2
-rw-r--r--community/icinga2/APKBUILD2
-rw-r--r--community/icingaweb2-module-director/APKBUILD2
-rw-r--r--community/icingaweb2-module-incubator/APKBUILD2
-rw-r--r--community/icingaweb2/APKBUILD2
-rw-r--r--community/ikona/APKBUILD2
-rw-r--r--community/imagemagick/APKBUILD1
-rw-r--r--community/imagemagick6/APKBUILD1
-rw-r--r--community/imv/APKBUILD2
-rw-r--r--community/incidenceeditor/APKBUILD4
-rw-r--r--community/index/APKBUILD4
-rw-r--r--community/influxdb/APKBUILD4
-rw-r--r--community/ion-shell/APKBUILD2
-rw-r--r--community/ipynb2html/APKBUILD2
-rw-r--r--community/isoimagewriter/APKBUILD4
-rw-r--r--community/itinerary/APKBUILD1
-rw-r--r--community/iwd/APKBUILD4
-rw-r--r--community/janet/APKBUILD5
-rw-r--r--community/janet/mips-64-bit.patch16
-rw-r--r--community/java-gcj-compat/APKBUILD2
-rw-r--r--community/java-jansi-native/APKBUILD2
-rw-r--r--community/java-jffi/APKBUILD4
-rw-r--r--community/java-jna/APKBUILD4
-rw-r--r--community/java-lz4/APKBUILD4
-rw-r--r--community/java-postgresql-jdbc/APKBUILD4
-rw-r--r--community/java-sigar/APKBUILD2
-rw-r--r--community/java-snappy/APKBUILD4
-rw-r--r--community/jenkins/APKBUILD4
-rw-r--r--community/jetty-runner/APKBUILD4
-rw-r--r--community/jgmenu/APKBUILD4
-rw-r--r--community/jool-modules-lts/APKBUILD2
-rw-r--r--community/jruby/APKBUILD2
-rw-r--r--community/juk/APKBUILD4
-rw-r--r--community/jwm/APKBUILD4
-rw-r--r--community/k9s/APKBUILD2
-rw-r--r--community/kaccounts-integration/APKBUILD4
-rw-r--r--community/kaccounts-providers/APKBUILD4
-rw-r--r--community/kactivitymanagerd/APKBUILD4
-rw-r--r--community/kaddressbook/APKBUILD4
-rw-r--r--community/kajongg/APKBUILD4
-rw-r--r--community/kalarm/APKBUILD4
-rw-r--r--community/kalarmcal/APKBUILD4
-rw-r--r--community/kalgebra/APKBUILD4
-rw-r--r--community/kalzium/APKBUILD4
-rw-r--r--community/kamera/APKBUILD4
-rw-r--r--community/kamoso/APKBUILD4
-rw-r--r--community/kanagram/APKBUILD4
-rw-r--r--community/kapman/APKBUILD4
-rw-r--r--community/kapptemplate/APKBUILD4
-rw-r--r--community/kate/APKBUILD4
-rw-r--r--community/katomic/APKBUILD4
-rw-r--r--community/kauth/APKBUILD4
-rw-r--r--community/kbackup/APKBUILD4
-rw-r--r--community/kblackbox/APKBUILD4
-rw-r--r--community/kblocks/APKBUILD4
-rw-r--r--community/kbookmarks/APKBUILD4
-rw-r--r--community/kbounce/APKBUILD4
-rw-r--r--community/kbreakout/APKBUILD4
-rw-r--r--community/kbruch/APKBUILD4
-rw-r--r--community/kcachegrind/APKBUILD4
-rw-r--r--community/kcalc/APKBUILD4
-rw-r--r--community/kcalutils/APKBUILD4
-rw-r--r--community/kcharselect/APKBUILD4
-rw-r--r--community/kclock/APKBUILD4
-rw-r--r--community/kcmutils/APKBUILD4
-rw-r--r--community/kcolorchooser/APKBUILD4
-rw-r--r--community/kconfigwidgets/APKBUILD4
-rw-r--r--community/kcron/APKBUILD4
-rw-r--r--community/kdav/APKBUILD4
-rw-r--r--community/kde-applications/APKBUILD2
-rw-r--r--community/kde-cli-tools/APKBUILD4
-rw-r--r--community/kde-dev-utils/APKBUILD4
-rw-r--r--community/kde-gtk-config/APKBUILD4
-rw-r--r--community/kdeclarative/APKBUILD4
-rw-r--r--community/kdeconnect/APKBUILD4
-rw-r--r--community/kdegraphics-mobipocket/APKBUILD4
-rw-r--r--community/kdegraphics-thumbnailers/APKBUILD2
-rw-r--r--community/kdelibs4support/APKBUILD4
-rw-r--r--community/kdenetwork-filesharing/APKBUILD4
-rw-r--r--community/kdenlive/APKBUILD4
-rw-r--r--community/kdepim-addons/APKBUILD4
-rw-r--r--community/kdepim-runtime/APKBUILD4
-rw-r--r--community/kdeplasma-addons/APKBUILD4
-rw-r--r--community/kdeplasma-applets-xrdesktop/APKBUILD4
-rw-r--r--community/kdesdk-kioslaves/APKBUILD4
-rw-r--r--community/kdesdk-thumbnailers/APKBUILD4
-rw-r--r--community/kdesignerplugin/APKBUILD4
-rw-r--r--community/kdevelop/APKBUILD4
-rw-r--r--community/kdf/APKBUILD4
-rw-r--r--community/kdialog/APKBUILD4
-rw-r--r--community/kdiamond/APKBUILD4
-rw-r--r--community/keditbookmarks/APKBUILD4
-rw-r--r--community/kfind/APKBUILD4
-rw-r--r--community/kfloppy/APKBUILD4
-rw-r--r--community/kfourinline/APKBUILD4
-rw-r--r--community/kgamma5/APKBUILD4
-rw-r--r--community/kgeography/APKBUILD4
-rw-r--r--community/kget/APKBUILD3
-rw-r--r--community/kgoldrunner/APKBUILD4
-rw-r--r--community/kgpg/APKBUILD4
-rw-r--r--community/kgx/APKBUILD4
-rw-r--r--community/khangman/APKBUILD4
-rw-r--r--community/khelpcenter/APKBUILD4
-rw-r--r--community/khotkeys/APKBUILD4
-rw-r--r--community/khtml/APKBUILD4
-rw-r--r--community/kiconthemes/APKBUILD4
-rw-r--r--community/kidentitymanagement/APKBUILD4
-rw-r--r--community/kig/APKBUILD4
-rw-r--r--community/kigo/APKBUILD4
-rw-r--r--community/kile/APKBUILD4
-rw-r--r--community/killbots/APKBUILD4
-rw-r--r--community/kimageformats/APKBUILD3
-rw-r--r--community/kimagemapeditor/APKBUILD4
-rw-r--r--community/kimap/APKBUILD4
-rw-r--r--community/kinfocenter/APKBUILD4
-rw-r--r--community/kinit/APKBUILD4
-rw-r--r--community/kio-extras/APKBUILD4
-rw-r--r--community/kio-fuse/APKBUILD4
-rw-r--r--community/kio-gdrive/APKBUILD4
-rw-r--r--community/kio/APKBUILD4
-rw-r--r--community/kipi-plugins/APKBUILD4
-rw-r--r--community/kiriki/APKBUILD4
-rw-r--r--community/kiten/APKBUILD4
-rw-r--r--community/kitty/APKBUILD2
-rw-r--r--community/kiwiirc/APKBUILD4
-rw-r--r--community/kjumpingcube/APKBUILD4
-rw-r--r--community/kldap/APKBUILD4
-rw-r--r--community/kleopatra/APKBUILD2
-rw-r--r--community/klettres/APKBUILD4
-rw-r--r--community/klickety/APKBUILD4
-rw-r--r--community/klines/APKBUILD4
-rw-r--r--community/kmag/APKBUILD4
-rw-r--r--community/kmail-account-wizard/APKBUILD4
-rw-r--r--community/kmail/APKBUILD4
-rw-r--r--community/kmailtransport/APKBUILD4
-rw-r--r--community/kmbox/APKBUILD4
-rw-r--r--community/kmediaplayer/APKBUILD2
-rw-r--r--community/kmenuedit/APKBUILD4
-rw-r--r--community/kmix/APKBUILD4
-rw-r--r--community/kmousetool/APKBUILD4
-rw-r--r--community/kmouth/APKBUILD4
-rw-r--r--community/kmplot/APKBUILD4
-rw-r--r--community/kmymoney/APKBUILD6
-rw-r--r--community/knavalbattle/APKBUILD4
-rw-r--r--community/knetwalk/APKBUILD4
-rw-r--r--community/knewstuff/APKBUILD4
-rw-r--r--community/knights/APKBUILD4
-rw-r--r--community/knotes/APKBUILD4
-rw-r--r--community/knotifyconfig/APKBUILD4
-rw-r--r--community/koko/APKBUILD4
-rw-r--r--community/kolf/APKBUILD4
-rw-r--r--community/kollision/APKBUILD4
-rw-r--r--community/kolourpaint/APKBUILD4
-rw-r--r--community/kompare/APKBUILD4
-rw-r--r--community/konqueror/APKBUILD4
-rw-r--r--community/konsole/APKBUILD4
-rw-r--r--community/kontact/APKBUILD4
-rw-r--r--community/kontactinterface/APKBUILD4
-rw-r--r--community/kontrast/APKBUILD4
-rw-r--r--community/konversation/APKBUILD4
-rw-r--r--community/kopete/APKBUILD4
-rw-r--r--community/korganizer/APKBUILD4
-rw-r--r--community/kparts/APKBUILD4
-rw-r--r--community/kpat/APKBUILD4
-rw-r--r--community/kpeoplesink/APKBUILD4
-rw-r--r--community/kphotoalbum/APKBUILD4
-rw-r--r--community/kpimtextedit/APKBUILD4
-rw-r--r--community/kpmcore/APKBUILD4
-rw-r--r--community/krapslog/APKBUILD2
-rw-r--r--community/krdc/APKBUILD4
-rw-r--r--community/krename/APKBUILD4
-rw-r--r--community/krfb/APKBUILD4
-rw-r--r--community/kross/APKBUILD4
-rw-r--r--community/kruler/APKBUILD4
-rw-r--r--community/krunner/APKBUILD4
-rw-r--r--community/kscreen/APKBUILD4
-rw-r--r--community/kscreenlocker/APKBUILD4
-rw-r--r--community/ksmtp/APKBUILD4
-rw-r--r--community/ksshaskpass/APKBUILD4
-rw-r--r--community/ksysguard/APKBUILD4
-rw-r--r--community/kteatime/APKBUILD2
-rw-r--r--community/ktexteditor/APKBUILD4
-rw-r--r--community/ktextwidgets/APKBUILD4
-rw-r--r--community/ktimer/APKBUILD4
-rw-r--r--community/ktimetracker/APKBUILD4
-rw-r--r--community/ktnef/APKBUILD4
-rw-r--r--community/ktorrent/APKBUILD3
-rw-r--r--community/ktouch/APKBUILD2
-rw-r--r--community/ktp-common-internals/APKBUILD4
-rw-r--r--community/ktrip/APKBUILD4
-rw-r--r--community/kturtle/APKBUILD4
-rw-r--r--community/kup/APKBUILD4
-rw-r--r--community/kwallet-pam/APKBUILD4
-rw-r--r--community/kwallet/APKBUILD8
-rw-r--r--community/kwalletmanager/APKBUILD4
-rw-r--r--community/kwave/APKBUILD4
-rw-r--r--community/kweather/APKBUILD2
-rw-r--r--community/kwin-effect-xrdesktop/APKBUILD4
-rw-r--r--community/kwin/APKBUILD4
-rw-r--r--community/kwordquiz/APKBUILD4
-rw-r--r--community/kxmlgui/APKBUILD4
-rw-r--r--community/kxmlrpcclient/APKBUILD4
-rw-r--r--community/lavalauncher/APKBUILD2
-rw-r--r--community/laz-perf/APKBUILD4
-rw-r--r--community/leiningen/APKBUILD2
-rw-r--r--community/lfs/APKBUILD2
-rw-r--r--community/libfm/APKBUILD2
-rw-r--r--community/libgravatar/APKBUILD4
-rw-r--r--community/libjxl/APKBUILD2
-rw-r--r--community/libkcddb/APKBUILD4
-rw-r--r--community/libkcompactdisc/APKBUILD4
-rw-r--r--community/libkdegames/APKBUILD4
-rw-r--r--community/libkdepim/APKBUILD4
-rw-r--r--community/libkeduvocdocument/APKBUILD4
-rw-r--r--community/libkgapi/APKBUILD4
-rw-r--r--community/libkipi/APKBUILD4
-rw-r--r--community/libkleo/APKBUILD4
-rw-r--r--community/libkmahjongg/APKBUILD4
-rw-r--r--community/libkomparediff2/APKBUILD4
-rw-r--r--community/libksane/APKBUILD2
-rw-r--r--community/libksieve/APKBUILD4
-rw-r--r--community/libksysguard/APKBUILD4
-rw-r--r--community/libktorrent/APKBUILD4
-rw-r--r--community/libldac/APKBUILD2
-rw-r--r--community/libmad/APKBUILD2
-rw-r--r--community/libmarisa/APKBUILD2
-rw-r--r--community/libnma/APKBUILD4
-rw-r--r--community/libnymphcast/APKBUILD2
-rw-r--r--community/libpinyin/APKBUILD4
-rw-r--r--community/libpostal/APKBUILD4
-rw-r--r--community/libquotient/APKBUILD2
-rw-r--r--community/libreoffice/APKBUILD2
-rw-r--r--community/libretro-beetle-psx/APKBUILD2
-rw-r--r--community/libretro-melonds/APKBUILD2
-rw-r--r--community/librsvg/APKBUILD2
-rw-r--r--community/libvirt-glib/APKBUILD4
-rw-r--r--community/libvirt/APKBUILD4
-rw-r--r--community/libxml++-2.6/APKBUILD2
-rw-r--r--community/lightdm-gtk-greeter/APKBUILD2
-rw-r--r--community/lightdm/APKBUILD2
-rw-r--r--community/lightsoff/APKBUILD4
-rw-r--r--community/lokalize/APKBUILD4
-rw-r--r--community/lollypop/APKBUILD2
-rwxr-xr-xcommunity/love/APKBUILD4
-rw-r--r--community/lttng-tools/APKBUILD2
-rw-r--r--community/lua-http/APKBUILD2
-rw-r--r--community/lxdm/APKBUILD2
-rw-r--r--community/lxpolkit/APKBUILD2
-rw-r--r--community/lxsession/APKBUILD4
-rw-r--r--community/mailcommon/APKBUILD2
-rw-r--r--community/mailimporter/APKBUILD4
-rw-r--r--community/maliit-keyboard/APKBUILD4
-rw-r--r--community/marble/APKBUILD4
-rw-r--r--community/marco/APKBUILD4
-rw-r--r--community/massif-visualizer/APKBUILD4
-rw-r--r--community/mate-applets/APKBUILD4
-rw-r--r--community/mate-control-center/APKBUILD4
-rw-r--r--community/mate-desktop-environment/APKBUILD2
-rw-r--r--community/mate-desktop/APKBUILD4
-rw-r--r--community/mate-indicator-applet/APKBUILD4
-rw-r--r--community/mate-media/APKBUILD4
-rw-r--r--community/mate-notification-daemon/APKBUILD4
-rw-r--r--community/mate-panel/APKBUILD4
-rw-r--r--community/mate-polkit/APKBUILD2
-rw-r--r--community/mate-power-manager/APKBUILD2
-rw-r--r--community/mate-screensaver/APKBUILD2
-rw-r--r--community/mate-sensors-applet/APKBUILD4
-rw-r--r--community/mate-session-manager/APKBUILD4
-rw-r--r--community/mate-settings-daemon/APKBUILD4
-rw-r--r--community/mate-system-monitor/APKBUILD2
-rw-r--r--community/mate-terminal/APKBUILD4
-rw-r--r--community/mate-utils/APKBUILD4
-rw-r--r--community/mauikit-accounts/APKBUILD4
-rw-r--r--community/mauikit-filebrowsing/APKBUILD4
-rw-r--r--community/mauikit-imagetools/APKBUILD4
-rw-r--r--community/mauikit-texteditor/APKBUILD4
-rw-r--r--community/mauikit/APKBUILD4
-rw-r--r--community/maven/APKBUILD4
-rw-r--r--community/mellowplayer/APKBUILD4
-rw-r--r--community/mercurial/APKBUILD2
-rw-r--r--community/mercury/APKBUILD2
-rw-r--r--community/messagelib/APKBUILD4
-rw-r--r--community/midori/APKBUILD4
-rw-r--r--community/milou/APKBUILD2
-rw-r--r--community/mimic1/APKBUILD4
-rw-r--r--community/mkvtoolnix/APKBUILD4
-rw-r--r--community/mmsd-tng/APKBUILD4
-rw-r--r--community/modemmanager-qt/APKBUILD4
-rw-r--r--community/modemmanager/APKBUILD2
-rw-r--r--community/moment/APKBUILD3
-rw-r--r--community/mongodb-tools/APKBUILD6
-rw-r--r--community/mongodb-tools/remove-buildflags.patch15
-rw-r--r--community/mousepad/APKBUILD2
-rw-r--r--community/msitools/APKBUILD3
-rw-r--r--community/musescore/APKBUILD4
-rw-r--r--community/mutter/APKBUILD2
-rw-r--r--community/mycroft-gui/APKBUILD4
-rw-r--r--community/mycroft-plasmoid/APKBUILD4
-rw-r--r--community/mygnuhealth/APKBUILD4
-rw-r--r--community/namecoin/APKBUILD4
-rw-r--r--community/nautilus/APKBUILD4
-rw-r--r--community/nemo/APKBUILD4
-rw-r--r--community/neochat/APKBUILD3
-rw-r--r--community/netcdf/APKBUILD3
-rw-r--r--community/network-manager-applet/APKBUILD4
-rw-r--r--community/networkmanager-elogind/APKBUILD4
-rw-r--r--community/networkmanager-l2tp/APKBUILD4
-rw-r--r--community/networkmanager-openvpn/APKBUILD4
-rw-r--r--community/networkmanager-qt/APKBUILD4
-rw-r--r--community/networkmanager/APKBUILD4
-rw-r--r--community/newlib-stage1/APKBUILD2
-rw-r--r--community/newlib/APKBUILD6
-rw-r--r--community/newsflash/APKBUILD2
-rw-r--r--community/nextcloud-client/APKBUILD4
-rw-r--r--community/nim/APKBUILD4
-rw-r--r--community/nodejs-clean-css/APKBUILD2
-rw-r--r--community/nodejs-current/APKBUILD5
-rw-r--r--community/nodejs-current/link-with-libatomic-on-mips32.patch28
-rw-r--r--community/nodejs-less-plugin-clean-css/APKBUILD2
-rw-r--r--community/nodejs-less/APKBUILD2
-rw-r--r--community/nomad/APKBUILD4
-rw-r--r--community/nota/APKBUILD4
-rw-r--r--community/numberstation/APKBUILD4
-rw-r--r--community/nx-libs/APKBUILD4
-rw-r--r--community/nymphcast/APKBUILD3
-rw-r--r--community/nymphrpc/APKBUILD3
-rw-r--r--community/obs-studio/APKBUILD4
-rw-r--r--community/ocaml-camlp4/APKBUILD4
-rw-r--r--community/ocaml-findlib/APKBUILD4
-rw-r--r--community/ocaml/APKBUILD5
-rw-r--r--community/ocamlbuild/APKBUILD4
-rw-r--r--community/octave/APKBUILD4
-rw-r--r--community/okteta/APKBUILD4
-rw-r--r--community/okular/APKBUILD4
-rw-r--r--community/olm/APKBUILD12
-rw-r--r--community/onboard/APKBUILD2
-rw-r--r--community/openbox/APKBUILD4
-rw-r--r--community/openjdk10/APKBUILD4
-rw-r--r--community/openjdk11/APKBUILD4
-rw-r--r--community/openjdk12/APKBUILD4
-rw-r--r--community/openjdk13/APKBUILD4
-rw-r--r--community/openjdk14/APKBUILD4
-rw-r--r--community/openjdk15/APKBUILD4
-rw-r--r--community/openjdk16/APKBUILD4
-rw-r--r--community/openjdk17/APKBUILD2
-rw-r--r--community/openjdk7/APKBUILD3
-rw-r--r--community/openjdk8/APKBUILD4
-rw-r--r--community/openjdk9/APKBUILD4
-rw-r--r--community/openlibm/APKBUILD3
-rw-r--r--community/openrc-settingsd/APKBUILD4
-rw-r--r--community/openrct2/APKBUILD2
-rw-r--r--community/openspecfun/APKBUILD4
-rw-r--r--community/osmscout-server/APKBUILD4
-rw-r--r--community/oxygen/APKBUILD4
-rw-r--r--community/par2cmdline/APKBUILD2
-rw-r--r--community/parley/APKBUILD4
-rw-r--r--community/partclone/APKBUILD2
-rw-r--r--community/partitionmanager/APKBUILD4
-rw-r--r--community/pcmanfm/APKBUILD2
-rw-r--r--community/pdal/APKBUILD2
-rw-r--r--community/pdns-recursor/APKBUILD2
-rw-r--r--community/perl-crypt-random/APKBUILD2
-rw-r--r--community/perl-math-pari/APKBUILD2
-rw-r--r--community/peruse/APKBUILD4
-rw-r--r--community/pev/APKBUILD5
-rw-r--r--community/phosh/APKBUILD4
-rw-r--r--community/php7/APKBUILD2
-rw-r--r--community/php8/APKBUILD2
-rw-r--r--community/pimcommon/APKBUILD4
-rw-r--r--community/pix/APKBUILD4
-rw-r--r--community/plasma-applet-weather-widget/APKBUILD4
-rw-r--r--community/plasma-browser-integration/APKBUILD4
-rw-r--r--community/plasma-desktop/APKBUILD4
-rw-r--r--community/plasma-dialer/APKBUILD4
-rw-r--r--community/plasma-disks/APKBUILD4
-rw-r--r--community/plasma-firewall/APKBUILD4
-rw-r--r--community/plasma-framework/APKBUILD4
-rw-r--r--community/plasma-integration/APKBUILD4
-rw-r--r--community/plasma-nano/APKBUILD4
-rw-r--r--community/plasma-nm/APKBUILD4
-rw-r--r--community/plasma-pa/APKBUILD4
-rw-r--r--community/plasma-pass/APKBUILD4
-rw-r--r--community/plasma-sdk/APKBUILD4
-rw-r--r--community/plasma-settings/APKBUILD4
-rw-r--r--community/plasma-systemmonitor/APKBUILD4
-rw-r--r--community/plasma-thunderbolt/APKBUILD4
-rw-r--r--community/plasma-vault/APKBUILD4
-rw-r--r--community/plasma-videoplayer/APKBUILD4
-rw-r--r--community/plasma-workspace/APKBUILD4
-rw-r--r--community/plasma/APKBUILD2
-rw-r--r--community/pluma/APKBUILD4
-rw-r--r--community/plymouth-kcm/APKBUILD4
-rw-r--r--community/poco/APKBUILD2
-rw-r--r--community/polari/APKBUILD2
-rw-r--r--community/polkit-gnome/APKBUILD4
-rw-r--r--community/polkit-kde-agent-1/APKBUILD4
-rw-r--r--community/polkit-qt-1/APKBUILD4
-rw-r--r--community/polkit/APKBUILD2
-rw-r--r--community/portfolio/APKBUILD2
-rw-r--r--community/poweralertd/APKBUILD2
-rw-r--r--community/powerdevil/APKBUILD4
-rw-r--r--community/prime_server/APKBUILD5
-rw-r--r--community/print-manager/APKBUILD4
-rw-r--r--community/psautohint/APKBUILD2
-rw-r--r--community/pulseaudio/APKBUILD2
-rw-r--r--community/pure-maps/APKBUILD4
-rw-r--r--community/purple-mm-sms/APKBUILD4
-rw-r--r--community/purpose/APKBUILD4
-rw-r--r--community/py3-adblock/APKBUILD2
-rw-r--r--community/py3-beautifulsoup4/APKBUILD4
-rw-r--r--community/py3-boto3/APKBUILD2
-rw-r--r--community/py3-cloudpickle/APKBUILD2
-rw-r--r--community/py3-dnsrobocert/APKBUILD2
-rw-r--r--community/py3-ducc0/APKBUILD2
-rw-r--r--community/py3-ecdsa/APKBUILD5
-rw-r--r--community/py3-greenlet/APKBUILD5
-rw-r--r--community/py3-h2/APKBUILD1
-rw-r--r--community/py3-h5py/APKBUILD3
-rw-r--r--community/py3-hyperopt/APKBUILD2
-rw-r--r--community/py3-inflect/APKBUILD2
-rw-r--r--community/py3-jaraco.itertools/APKBUILD2
-rw-r--r--community/py3-keepass/APKBUILD2
-rw-r--r--community/py3-language-server/APKBUILD3
-rw-r--r--community/py3-lazy-object-proxy/APKBUILD4
-rw-r--r--community/py3-libvirt/APKBUILD4
-rw-r--r--community/py3-loky/APKBUILD2
-rw-r--r--community/py3-matrix-nio/APKBUILD2
-rw-r--r--community/py3-msgpack/APKBUILD2
-rw-r--r--community/py3-networkx/APKBUILD2
-rw-r--r--community/py3-nodeenv/APKBUILD2
-rw-r--r--community/py3-opencl/APKBUILD3
-rw-r--r--community/py3-pandas/APKBUILD2
-rw-r--r--community/py3-py-cpuinfo/APKBUILD3
-rw-r--r--community/py3-pyache/APKBUILD2
-rw-r--r--community/py3-pyclipper/APKBUILD4
-rw-r--r--community/py3-pygit2/APKBUILD2
-rw-r--r--community/py3-pygit2/s390x-patch-context-mark-xfail.patch2
-rw-r--r--community/py3-pyside2/APKBUILD4
-rw-r--r--community/py3-pyside6/APKBUILD3
-rw-r--r--community/py3-pytest-benchmark/APKBUILD2
-rw-r--r--community/py3-pytest-black/APKBUILD2
-rw-r--r--community/py3-pytest-xdist/APKBUILD5
-rw-r--r--community/py3-pytools/APKBUILD3
-rw-r--r--community/py3-pywal/APKBUILD4
-rw-r--r--community/py3-pyzbar/APKBUILD2
-rw-r--r--community/py3-qtwebengine/APKBUILD4
-rw-r--r--community/py3-s3transfer/APKBUILD2
-rw-r--r--community/py3-scipy/APKBUILD2
-rw-r--r--community/py3-setuptools_scm/APKBUILD7
-rw-r--r--community/py3-shapely/APKBUILD2
-rw-r--r--community/py3-skia-pathops/APKBUILD2
-rw-r--r--community/py3-snuggs/APKBUILD2
-rw-r--r--community/py3-speechpy/APKBUILD2
-rw-r--r--community/py3-text2speech/APKBUILD2
-rw-r--r--community/py3-timezonefinder/APKBUILD3
-rw-r--r--community/py3-twine/APKBUILD4
-rw-r--r--community/py3-typed-ast/APKBUILD1
-rw-r--r--community/py3-ufo2ft/APKBUILD2
-rw-r--r--community/py3-vlc/APKBUILD2
-rw-r--r--community/py3-wolframalpha/APKBUILD3
-rw-r--r--community/py3-zict/APKBUILD4
-rw-r--r--community/qqc2-breeze-style/APKBUILD4
-rw-r--r--community/qqc2-desktop-style/APKBUILD4
-rw-r--r--community/qrca/APKBUILD4
-rw-r--r--community/qrupdate/APKBUILD7
-rw-r--r--community/qt5-qtquick3d/APKBUILD4
-rw-r--r--community/qt5-qtwebview/APKBUILD4
-rw-r--r--community/qt6-qtquick3d/APKBUILD4
-rw-r--r--community/quaternion/APKBUILD2
-rw-r--r--community/qutebrowser/APKBUILD4
-rw-r--r--community/radare2/APKBUILD2
-rw-r--r--community/rakudo/APKBUILD2
-rw-r--r--community/rawtherapee/APKBUILD4
-rw-r--r--community/rbspy/APKBUILD2
-rw-r--r--community/rcon/APKBUILD4
-rw-r--r--community/rebuilderd/APKBUILD2
-rw-r--r--community/remmina/APKBUILD2
-rw-r--r--community/restic/APKBUILD3
-rw-r--r--community/retroarch/APKBUILD2
-rw-r--r--community/ripgrep/APKBUILD4
-rw-r--r--community/rkward/APKBUILD2
-rw-r--r--community/rmlmapper/APKBUILD4
-rw-r--r--community/rocs/APKBUILD4
-rw-r--r--community/rofi-wayland/APKBUILD2
-rw-r--r--community/rofi/APKBUILD2
-rw-r--r--community/rsibreak/APKBUILD4
-rw-r--r--community/ruby-ffi/APKBUILD1
-rw-r--r--community/ruby-pg_query/APKBUILD3
-rw-r--r--community/ruby-rmagick/APKBUILD2
-rw-r--r--community/ruqola/APKBUILD4
-rw-r--r--community/rust/APKBUILD4
-rw-r--r--community/rust/alpine-target.patch68
-rw-r--r--community/rust/mips-softfloat.patch10
-rw-r--r--community/s-tui/APKBUILD2
-rw-r--r--community/sddm-kcm/APKBUILD4
-rw-r--r--community/sddm/APKBUILD4
-rw-r--r--community/sdl2/APKBUILD2
-rw-r--r--community/seahorse/APKBUILD2
-rw-r--r--community/shelf/APKBUILD2
-rw-r--r--community/shiboken2/APKBUILD2
-rw-r--r--community/shotwell/APKBUILD2
-rw-r--r--community/shunit2/APKBUILD2
-rw-r--r--community/sierrabreezeenhanced/APKBUILD4
-rw-r--r--community/sigar/0004-make-the-package-compile-on-MIPS.patch39
-rw-r--r--community/sigar/0005-no-m64-mips-arm.patch14
-rw-r--r--community/sigar/APKBUILD8
-rw-r--r--community/signon-ui/APKBUILD4
-rw-r--r--community/simple-scan/APKBUILD2
-rw-r--r--community/sink/APKBUILD2
-rw-r--r--community/skanlite/APKBUILD4
-rw-r--r--community/sn0int/APKBUILD4
-rw-r--r--community/solid/APKBUILD4
-rw-r--r--community/sound-juicer/APKBUILD2
-rw-r--r--community/spectacle/APKBUILD4
-rw-r--r--community/sqlint/APKBUILD4
-rw-r--r--community/squeekboard/APKBUILD2
-rw-r--r--community/ssh-audit/APKBUILD2
-rw-r--r--community/station/APKBUILD4
-rw-r--r--community/stellarium/APKBUILD2
-rw-r--r--community/step/APKBUILD4
-rw-r--r--community/stress-ng/APKBUILD2
-rw-r--r--community/superlu/APKBUILD6
-rw-r--r--community/supertux/APKBUILD2
-rw-r--r--community/sushi/APKBUILD2
-rw-r--r--community/sweeper/APKBUILD4
-rw-r--r--community/sysprof/APKBUILD4
-rw-r--r--community/systemsettings/APKBUILD4
-rw-r--r--community/tailscale/APKBUILD2
-rw-r--r--community/tau/APKBUILD4
-rw-r--r--community/tectonic/APKBUILD4
-rw-r--r--community/telepathy-mission-control/APKBUILD4
-rw-r--r--community/telepathy-ofono/APKBUILD4
-rw-r--r--community/texlive/APKBUILD4
-rw-r--r--community/tint2/APKBUILD4
-rw-r--r--community/tinyssh/APKBUILD2
-rw-r--r--community/tokei/APKBUILD2
-rw-r--r--community/tomcat-native/APKBUILD4
-rw-r--r--community/tootle/APKBUILD2
-rw-r--r--community/tor/APKBUILD2
-rw-r--r--community/totem/APKBUILD2
-rw-r--r--community/tracker-miners/APKBUILD2
-rw-r--r--community/tracker/APKBUILD4
-rw-r--r--community/tumbler/APKBUILD2
-rw-r--r--community/udisks2/APKBUILD8
-rw-r--r--community/uglify-js/APKBUILD4
-rw-r--r--community/uglifycss/APKBUILD4
-rw-r--r--community/umbrello/APKBUILD2
-rw-r--r--community/unison/APKBUILD4
-rw-r--r--community/upower/APKBUILD4
-rw-r--r--community/upx/APKBUILD2
-rw-r--r--community/urfkill/APKBUILD2
-rw-r--r--community/vdr/APKBUILD2
-rw-r--r--community/vips/APKBUILD2
-rw-r--r--community/virt-viewer/APKBUILD2
-rw-r--r--community/vkd3d/APKBUILD2
-rw-r--r--community/vlc/APKBUILD4
-rw-r--r--community/vvave/APKBUILD4
-rw-r--r--community/vvmd/APKBUILD2
-rw-r--r--community/vvmplayer/APKBUILD2
-rw-r--r--community/wacomtablet/APKBUILD4
-rw-r--r--community/weasyprint/APKBUILD4
-rw-r--r--community/websocat/APKBUILD2
-rw-r--r--community/weston/APKBUILD2
-rw-r--r--community/writefreely/APKBUILD4
-rw-r--r--community/wys/APKBUILD4
-rw-r--r--community/x264/APKBUILD3
-rw-r--r--community/x2goserver/APKBUILD4
-rw-r--r--community/xapian-core/APKBUILD1
-rw-r--r--community/xdg-desktop-portal-kde/APKBUILD4
-rw-r--r--community/xfburn/APKBUILD2
-rw-r--r--community/xfce-polkit/APKBUILD2
-rw-r--r--community/xfce4-power-manager/APKBUILD2
-rw-r--r--community/xfce4-pulseaudio-plugin/APKBUILD2
-rw-r--r--community/xfce4-settings/APKBUILD4
-rw-r--r--community/xfce4-stopwatch-plugin/APKBUILD2
-rw-r--r--community/xfce4-weather-plugin/APKBUILD2
-rw-r--r--community/xfce4-whiskermenu-plugin/APKBUILD2
-rw-r--r--community/xfce4-xkb-plugin/APKBUILD4
-rw-r--r--community/xfce4/APKBUILD4
-rw-r--r--community/xpra/APKBUILD3
-rw-r--r--community/yakuake/APKBUILD2
-rw-r--r--community/yarn/APKBUILD2
-rw-r--r--community/zabbix/APKBUILD19
-rw-r--r--community/zanshin/APKBUILD4
-rw-r--r--community/zef/APKBUILD2
-rw-r--r--community/zeroconf-ioslave/APKBUILD4
-rw-r--r--community/zeromq-gsl/APKBUILD4
-rw-r--r--community/zola/APKBUILD2
-rw-r--r--community/zoneminder/APKBUILD2
827 files changed, 1293 insertions, 1761 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index 26d0e75215..2a48368c01 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -6,8 +6,8 @@ pkgver=4.1.2
pkgrel=2
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org/"
-# mips64 and riscv64 blocked by java-jre-headless
-arch="all !mips64 !riscv64"
+# riscv64 blocked by java-jre-headless
+arch="all !riscv64"
license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later"
depends="$pkgname-mathlib"
depends_dev="
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index a880b61345..3b4bc3e32e 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -4,8 +4,8 @@ pkgver=3.0.5
pkgrel=0
pkgdesc="A fully-featured word processor"
url="https://www.abisource.com/"
-# s390x, mips, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev readline-dev libgsf-dev enchant2-dev fribidi-dev wv-dev
diff --git a/community/accerciser/APKBUILD b/community/accerciser/APKBUILD
index 4f35404354..07e6141bfb 100644
--- a/community/accerciser/APKBUILD
+++ b/community/accerciser/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.38.0
pkgrel=2
pkgdesc="Interactive Python accessibility explorer"
url="https://wiki.gnome.org/Apps/Accerciser"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="noarch !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="noarch !s390x !riscv64"
license="BSD-3-Clause"
depends="libwnck3 py3-gobject3 py3-atspi gtk+3.0 librsvg py3-xlib ipython"
makedepends="gtk+3.0-dev py3-gobject3-dev glib-dev at-spi2-core-dev itstool"
diff --git a/community/accountsservice/APKBUILD b/community/accountsservice/APKBUILD
index 6f749dc1fa..a2e5d74527 100644
--- a/community/accountsservice/APKBUILD
+++ b/community/accountsservice/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=2
pkgdesc="D-Bus interface for user account query and manipulation"
options="!check" # No testsuite
url="https://www.freedesktop.org/software/accountsservice/"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
depends_dev="glib-dev gobject-introspection-dev polkit-dev"
makedepends="
diff --git a/community/acf-vlc-daemon/APKBUILD b/community/acf-vlc-daemon/APKBUILD
index af9819f36d..17c9e835b5 100644
--- a/community/acf-vlc-daemon/APKBUILD
+++ b/community/acf-vlc-daemon/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.5.0
pkgrel=4
pkgdesc="Web-based system administration interface for vlc"
url="https://gitlab.alpinelinux.org/acf/acf-vlc-daemon"
-arch="noarch !s390x !mips !mips64 !armhf !riscv64" # limited by vlc
+arch="noarch !s390x !armhf !riscv64" # limited by vlc
license="GPL-2.0-only"
options="!check" # no test suite
depends="acf-core vlc-daemon"
diff --git a/community/acme-redirect/APKBUILD b/community/acme-redirect/APKBUILD
index 09bc31f5fb..b5bc67145b 100644
--- a/community/acme-redirect/APKBUILD
+++ b/community/acme-redirect/APKBUILD
@@ -5,9 +5,9 @@ pkgver=0.5.3
pkgrel=1
pkgdesc="Tiny http daemon that answers acme challenges and redirects everything else to https"
url="https://github.com/kpcyrd/acme-redirect"
-# mips64, s390x and riscv64 blocked by rust/cargo
+# s390x and riscv64 blocked by rust/cargo
# ppc64le blocked by ring crate
-arch="all !mips64 !s390x !ppc64le !riscv64"
+arch="all !s390x !ppc64le !riscv64"
license="GPL-3.0-or-later"
makedepends="
cargo
diff --git a/community/adwaita-icon-theme/APKBUILD b/community/adwaita-icon-theme/APKBUILD
index 19fa184f55..059a39b974 100644
--- a/community/adwaita-icon-theme/APKBUILD
+++ b/community/adwaita-icon-theme/APKBUILD
@@ -6,8 +6,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="Adwaita icon theme"
url="https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="noarch !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="noarch !s390x !riscv64"
options="!check" # Icons only, no binaries.
license="LGPL-3.0-or-later OR CC-BY-SA-3.0"
depends="librsvg"
diff --git a/community/afl/APKBUILD b/community/afl/APKBUILD
index 9d73cdf49c..ee03e5cb7d 100644
--- a/community/afl/APKBUILD
+++ b/community/afl/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.57b
pkgrel=2
pkgdesc="Fuzzer relying on genetic algorithms instead of brute force"
url="https://lcamtuf.coredump.cx/afl/"
-arch="all !x86 !mips !mips64"
+arch="all !x86"
license="Apache-2.0"
options="!check" # no tests provided
depends="clang llvm"
diff --git a/community/aircrack-ng/APKBUILD b/community/aircrack-ng/APKBUILD
index b1a463acd3..3d74113439 100644
--- a/community/aircrack-ng/APKBUILD
+++ b/community/aircrack-ng/APKBUILD
@@ -6,7 +6,7 @@ _pkgver=${pkgver/_/-}
pkgrel=2
pkgdesc="Key cracker for the 802.11 WEP and WPA-PSK protocols"
url="http://www.aircrack-ng.org"
-arch="all !s390x !mips !mips64" # tests fails on big-endian
+arch="all !s390x" # tests fails on big-endian
license="GPL-2.0-or-later"
depends="ethtool wireless-tools iw sqlite grep"
makedepends="autoconf automake libnl3-dev libpcap-dev openssl1.1-compat-dev libtool
diff --git a/community/aisleriot/APKBUILD b/community/aisleriot/APKBUILD
index 4668c538cc..98976629cf 100644
--- a/community/aisleriot/APKBUILD
+++ b/community/aisleriot/APKBUILD
@@ -5,7 +5,7 @@ pkgver=3.22.17
pkgrel=1
pkgdesc="Solitaire and other card games for GNOME"
url="https://wiki.gnome.org/Apps/Aisleriot"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
license="GPL-3.0-or-later"
options="!strip" # guille libraries cannot be stripped
depends="guile"
diff --git a/community/akonadi-calendar-tools/APKBUILD b/community/akonadi-calendar-tools/APKBUILD
index 9d9c3fc183..6a60220c36 100644
--- a/community/akonadi-calendar-tools/APKBUILD
+++ b/community/akonadi-calendar-tools/APKBUILD
@@ -4,8 +4,8 @@ pkgname=akonadi-calendar-tools
pkgver=21.12.1
pkgrel=1
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by akonadi-calendar -> kmailtransport -> libkgapi -> qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by akonadi-calendar -> kmailtransport -> libkgapi -> qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="CLI tools to manage akonadi calendars"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/akonadi-calendar/APKBUILD b/community/akonadi-calendar/APKBUILD
index b6469dd699..3982903881 100644
--- a/community/akonadi-calendar/APKBUILD
+++ b/community/akonadi-calendar/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="Akonadi calendar integration"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by kmailtransport -> libkgapi -> qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by kmailtransport -> libkgapi -> qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/akonadi-contacts/APKBUILD b/community/akonadi-contacts/APKBUILD
index 7f232c91ee..10c423699e 100644
--- a/community/akonadi-contacts/APKBUILD
+++ b/community/akonadi-contacts/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="Libraries and daemons to implement Contact Management in Akonadi"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by akonadi
+# s390x and riscv64 blocked by akonadi
# ppc64le blocked by qt5-qtwebengine -> akonadi
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.0-or-later AND GPL-2.0-or-later AND BSD-3-Clause"
depends_dev="
diff --git a/community/akonadi-import-wizard/APKBUILD b/community/akonadi-import-wizard/APKBUILD
index cb1745cebd..9be7609a09 100644
--- a/community/akonadi-import-wizard/APKBUILD
+++ b/community/akonadi-import-wizard/APKBUILD
@@ -4,8 +4,8 @@ pkgname=akonadi-import-wizard
pkgver=21.12.1
pkgrel=1
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by kmailtransport -> libkgapi -> qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by kmailtransport -> libkgapi -> qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Import data from other mail clients to KMail"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/akonadi-mime/APKBUILD b/community/akonadi-mime/APKBUILD
index f6d7096359..47d874b6d4 100644
--- a/community/akonadi-mime/APKBUILD
+++ b/community/akonadi-mime/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="Libraries and daemons to implement basic email handling"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by akonadi
+# s390x and riscv64 blocked by akonadi
# ppc64le blocked by qt5-qtwebengine -> kaccounts-integration
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/akonadi-search/APKBUILD b/community/akonadi-search/APKBUILD
index a41aec09fa..cebd8fcaa4 100644
--- a/community/akonadi-search/APKBUILD
+++ b/community/akonadi-search/APKBUILD
@@ -5,10 +5,10 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="Libraries and daemons to implement searching in Akonadi"
# armhf blocked by extra-cmake-modules
-# mips64 and riscv64 blocked by akonadi
+# riscv64 blocked by akonadi
# s390x blocked by multiple KDE Frameworks
# ppc64le blocked by qt5-qtwebengine -> akonadi
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://community.kde.org/KDE_PIM"
license="( GPL-2.0-only OR GPL-3.0-only ) AND ( LGPL-2.1-only OR LGPL-3.0-only )"
depends_dev="
diff --git a/community/akonadi/APKBUILD b/community/akonadi/APKBUILD
index 5ad241766a..b1e814e24a 100644
--- a/community/akonadi/APKBUILD
+++ b/community/akonadi/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="A cross-desktop storage service for PIM data and meta data providing concurrent read, write, and query access"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
+# s390x and riscv64 blocked by polkit
# ppc64le blocked by kaccounts-integration
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.0-or-later"
depends="
diff --git a/community/akonadiconsole/APKBUILD b/community/akonadiconsole/APKBUILD
index 4815e1ea8c..22d359c2b2 100644
--- a/community/akonadiconsole/APKBUILD
+++ b/community/akonadiconsole/APKBUILD
@@ -4,9 +4,9 @@ pkgname=akonadiconsole
pkgver=21.12.1
pkgrel=1
# armhf blocked by extra-cmake-modules
-# s390x, ppc64le, mips64 and riscv64 blocked by akonadi
+# s390x, ppc64le and riscv64 blocked by akonadi
# ppc64le blocked by calendarsupport
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Application for debugging Akonadi Resources"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/akregator/APKBUILD b/community/akregator/APKBUILD
index c18779265e..b4426cf5df 100644
--- a/community/akregator/APKBUILD
+++ b/community/akregator/APKBUILD
@@ -4,8 +4,8 @@ pkgname=akregator
pkgver=21.12.1
pkgrel=2
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://apps.kde.org/akregator/"
pkgdesc="RSS Feed Reader"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
diff --git a/community/alkimia/APKBUILD b/community/alkimia/APKBUILD
index 62e4de212b..11747a07de 100644
--- a/community/alkimia/APKBUILD
+++ b/community/alkimia/APKBUILD
@@ -4,9 +4,9 @@ pkgname=alkimia
pkgver=8.1.0
pkgrel=2
# armhf blocked by qt5-qtdeclarative
-# armhf, mips64, ppc64le, riscv64, s390x blocked by qt5-qtwebengine
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !ppc64le !s390x !riscv64"
+# armhf, ppc64le, riscv64, s390x blocked by qt5-qtwebengine
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://community.kde.org/Alkimia/libalkimia"
pkgdesc="A library with common classes and functionality used by finance applications for the KDE SC"
license="GPL-3.0-or-later"
diff --git a/community/amfora/APKBUILD b/community/amfora/APKBUILD
index 0d59759e14..8c89dc2057 100644
--- a/community/amfora/APKBUILD
+++ b/community/amfora/APKBUILD
@@ -12,11 +12,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/makeworld-the-better-one/amf
export GOPATH="$srcdir"
export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-case $CARCH in
- mips|mips64)
- export GOFLAGS="${GOFLAGS/-buildmode=pie}" # buildmode=pie is not supported on mips64
- ;;
-esac
build() {
go build \
diff --git a/community/angelfish/APKBUILD b/community/angelfish/APKBUILD
index 09de0eac52..eff7585203 100644
--- a/community/angelfish/APKBUILD
+++ b/community/angelfish/APKBUILD
@@ -5,9 +5,9 @@ pkgver=22.02
pkgrel=0
pkgdesc="Small Webbrowser for Plasma Mobile"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and mips64 blocked by qt5-qtwebengine
+# ppc64le and s390x blocked by qt5-qtwebengine
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !ppc64le !s390x !armhf !mips64 !riscv64"
+arch="all !ppc64le !s390x !armhf !riscv64"
url="https://phabricator.kde.org/source/plasma-angelfish/"
license="GPL-3.0-or-later"
depends="
diff --git a/community/apache-ant/APKBUILD b/community/apache-ant/APKBUILD
index 5ed590b723..86a331ea8a 100644
--- a/community/apache-ant/APKBUILD
+++ b/community/apache-ant/APKBUILD
@@ -6,8 +6,8 @@ pkgver=1.10.12
pkgrel=0
pkgdesc="A java-based build tool"
url="https://ant.apache.org/"
-# mips64 and riscv64 blocked by java-jdk
-arch="noarch !mips64 !riscv64"
+# riscv64 blocked by java-jdk
+arch="noarch !riscv64"
options="!check" # Needs itself for testing.
license="Apache-2.0"
depends="java-jdk"
diff --git a/community/apparmor/APKBUILD b/community/apparmor/APKBUILD
index 406946aca3..c67f8dd598 100644
--- a/community/apparmor/APKBUILD
+++ b/community/apparmor/APKBUILD
@@ -5,8 +5,7 @@ pkgver=3.0.3
pkgrel=2
pkgdesc="Linux application security framework - mandatory access control for programs"
url="https://gitlab.com/apparmor/apparmor/wikis/home"
-# mips64 blocked by py3-notify2
-arch="all !mips64"
+arch="all"
license="GPL-2.0-only"
depends="bash"
makedepends="sed python3 autoconf automake libtool bison flex perl-dev swig
diff --git a/community/appstream/APKBUILD b/community/appstream/APKBUILD
index f3b2a33719..67475a5152 100644
--- a/community/appstream/APKBUILD
+++ b/community/appstream/APKBUILD
@@ -34,7 +34,7 @@ builddir="$srcdir/AppStream-$pkgver"
# librsvg doesn't exist on these arches
case "$CARCH" in
- s390x|mips*|riscv64) ;;
+ s390x|riscv64) ;;
*)
makedepends="$makedepends cairo-dev fontconfig-dev
gdk-pixbuf-dev librsvg-dev pango-dev"
diff --git a/community/ark/APKBUILD b/community/ark/APKBUILD
index 7a76ede1e6..f7b1d197fb 100644
--- a/community/ark/APKBUILD
+++ b/community/ark/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="Graphical file compression/decompression utility with support for multiple formats"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.ark"
license="GPL-2.0-only"
depends="
diff --git a/community/armadillo/APKBUILD b/community/armadillo/APKBUILD
index 9bf07abd27..bbe5c10793 100644
--- a/community/armadillo/APKBUILD
+++ b/community/armadillo/APKBUILD
@@ -5,7 +5,7 @@ pkgver=10.7.1
pkgrel=3
pkgdesc="C++ library for linear algebra & scientific computing"
url="http://arma.sourceforge.net/"
-arch="all !mips !mips64" # blocked by openblas
+arch="all"
license="Apache-2.0"
options="!check" # Armadillo must be installed before the tests can be compiled
depends_dev="
diff --git a/community/arpack/APKBUILD b/community/arpack/APKBUILD
index 4405cb2ec3..dbe3cfe45c 100644
--- a/community/arpack/APKBUILD
+++ b/community/arpack/APKBUILD
@@ -6,7 +6,7 @@ pkgver=3.7.0
pkgrel=2
pkgdesc="Collection of Fortran77 subroutines designed to solve large scale eigenvalue problems"
url="https://github.com/opencollab/arpack-ng"
-arch="all !mips !mips64"
+arch="all"
license="BSD-3-Clause"
depends_dev="openblas-dev>=0.3.0"
makedepends="$depends_dev autoconf automake gfortran libtool"
diff --git a/community/artikulate/APKBUILD b/community/artikulate/APKBUILD
index e9a9e79fb5..99bb86ce83 100644
--- a/community/artikulate/APKBUILD
+++ b/community/artikulate/APKBUILD
@@ -4,8 +4,8 @@ pkgname=artikulate
pkgver=21.12.1
pkgrel=1
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> knewstuff
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> knewstuff
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/artikulate"
pkgdesc="Improve your pronunciation by listening to native speakers"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
diff --git a/community/assimp/APKBUILD b/community/assimp/APKBUILD
index e1d3116280..9bf709a282 100644
--- a/community/assimp/APKBUILD
+++ b/community/assimp/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.0.1
pkgrel=3
pkgdesc="Open Asset Import Library imports and exports 3D model formats."
url="http://www.assimp.org/"
-arch="all !s390x !mips !mips64" # fails to build on big-endian
+arch="all !s390x" # fails to build on big-endian
license="BSD-3-Clause"
makedepends="
cmake
diff --git a/community/atril/APKBUILD b/community/atril/APKBUILD
index 59f39d5815..90ab35d77c 100644
--- a/community/atril/APKBUILD
+++ b/community/atril/APKBUILD
@@ -5,9 +5,9 @@ pkgver=1.26.0
pkgrel=1
pkgdesc="A document viewer for MATE"
url="https://github.com/mate-desktop/atril"
-# s390x, mips64 and riscv64 blocked by librsvg -> mate-desktop
+# s390x and riscv64 blocked by librsvg -> mate-desktop
# ppc64le blocked by texlive
-arch="all !s390x !mips64 !riscv64 !ppc64le"
+arch="all !s390x !riscv64 !ppc64le"
license="GPL-2.0-or-later"
depends="mate-icon-theme"
# make check is broken: https://github.com/mate-desktop/atril/issues/167
diff --git a/community/audacious/APKBUILD b/community/audacious/APKBUILD
index a401a0a7c1..17e150e46c 100644
--- a/community/audacious/APKBUILD
+++ b/community/audacious/APKBUILD
@@ -13,10 +13,6 @@ makedepends="$depends_dev libxml2-dev"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang"
source="http://distfiles.audacious-media-player.org/audacious-$pkgver.tar.bz2"
-case "$CARCH" in
- mips*) options="!check";;
-esac
-
prepare() {
default_prepare
diff --git a/community/audiocd-kio/APKBUILD b/community/audiocd-kio/APKBUILD
index 6d7852e03f..7d786347f3 100644
--- a/community/audiocd-kio/APKBUILD
+++ b/community/audiocd-kio/APKBUILD
@@ -4,8 +4,8 @@ pkgname=audiocd-kio
pkgver=21.12.1
pkgrel=1
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="Kioslave for accessing audio CDs"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/aura-browser/APKBUILD b/community/aura-browser/APKBUILD
index bfde54007e..3a06c9a7dc 100644
--- a/community/aura-browser/APKBUILD
+++ b/community/aura-browser/APKBUILD
@@ -7,8 +7,8 @@ _commit="e93d8de146384697bf586346488395680a1dd217"
pkgdesc="Browser for a fully immersed Big Screen experience allowing you to navigate the world wide web using just your remote control"
url="https://invent.kde.org/plasma-bigscreen/aura-browser"
# armhf blocked by extra-cmake-modules
-# s390x, ppc64le riscv64 and mips64 blocked by qt5-qtwebengine
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !s390x !ppc64le !riscv64"
license="GPL-2.0-or-later"
depends="
kirigami2
diff --git a/community/awesome/APKBUILD b/community/awesome/APKBUILD
index cf623d9617..806b058cd9 100644
--- a/community/awesome/APKBUILD
+++ b/community/awesome/APKBUILD
@@ -5,7 +5,7 @@ pkgver=4.3
pkgrel=3
pkgdesc="lua-configurable window manager framework"
url="https://awesomewm.org/"
-arch="all !mips64" # fails to build on mips64
+arch="all"
license="GPL-2.0-or-later"
depends="imagemagick lua5.1-lgi cairo-gobject pango"
makedepends="lua lua5.1 lua5.1-dev libxcb-dev pango-dev cairo-dev cmake gperf glib-dev
diff --git a/community/aws-cli/APKBUILD b/community/aws-cli/APKBUILD
index c2b8c9c0d5..888b866b5f 100644
--- a/community/aws-cli/APKBUILD
+++ b/community/aws-cli/APKBUILD
@@ -5,8 +5,7 @@ pkgver=1.19.105
pkgrel=1
pkgdesc="Universal Command Line Interface for Amazon Web Services"
url="https://github.com/aws/aws-cli"
-# mips64: py3-s3transfer missing
-arch="noarch !mips64"
+arch="noarch"
license="Apache-2.0"
depends="python3 groff py3-botocore py3-jmespath py3-s3transfer py3-docutils
py3-colorama py3-yaml py3-rsa"
diff --git a/community/babeltrace/APKBUILD b/community/babeltrace/APKBUILD
index 5a60bc1d5a..d968c03107 100644
--- a/community/babeltrace/APKBUILD
+++ b/community/babeltrace/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.0.4
pkgrel=1
pkgdesc="Trace converter and read/write library"
url="https://www.efficios.com/babeltrace"
-arch="all !mips !mips64" # Test failures
+arch="all"
license="MIT"
depends_dev="glib-dev"
makedepends="$depends_dev python3-dev swig"
diff --git a/community/babl/APKBUILD b/community/babl/APKBUILD
index a18187cb27..b1b1fca226 100644
--- a/community/babl/APKBUILD
+++ b/community/babl/APKBUILD
@@ -10,11 +10,6 @@ makedepends="meson gobject-introspection-dev lcms2-dev vala"
subpackages="$pkgname-dev"
source="https://ftp.gimp.org/pub/babl/${pkgver%.*}/babl-$pkgver.tar.xz"
-case "$CARCH" in
- # tests time out on builder
- mips*) options="!check";;
-esac
-
build() {
abuild-meson . output
meson compile ${JOBS:+-j ${JOBS}} -C output
diff --git a/community/baloo-widgets/APKBUILD b/community/baloo-widgets/APKBUILD
index fb6af5b4be..29dc5d95b0 100644
--- a/community/baloo-widgets/APKBUILD
+++ b/community/baloo-widgets/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="Widgets for Baloo"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Baloo"
license="LGPL-2.0-only AND LGPL-2.1-or-later"
depends_dev="
diff --git a/community/baloo/APKBUILD b/community/baloo/APKBUILD
index 1c82e282a5..1a09eee42e 100644
--- a/community/baloo/APKBUILD
+++ b/community/baloo/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=1
pkgdesc="A framework for searching and managing metadata"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND ( LGPL-2.1-only OR LGPL-3.0-only )"
depends_dev="
diff --git a/community/bandwhich/APKBUILD b/community/bandwhich/APKBUILD
index f9065b81a9..79bffbca15 100644
--- a/community/bandwhich/APKBUILD
+++ b/community/bandwhich/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.20.0
pkgrel=0
pkgdesc="Terminal bandwidth utilization tool"
url="https://github.com/imsnif/bandwhich"
-# s390x, mips64 and riscv64 blocked by cargo/rust
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by cargo/rust
+arch="all !s390x !riscv64"
license="MIT"
makedepends="cargo"
source="$pkgname-$pkgver.tar.gz::https://github.com/imsnif/bandwhich/archive/$pkgver.tar.gz"
diff --git a/community/baobab/APKBUILD b/community/baobab/APKBUILD
index 60f8d23102..cd0fe53bff 100644
--- a/community/baobab/APKBUILD
+++ b/community/baobab/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="A graphical application to analyse disk usage in any Gnome environment"
url="https://wiki.gnome.org/action/show/Apps/DiskUsageAnalyzer"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="meson glib-dev gtk+3.0-dev gettext-dev vala itstool libhandy1-dev"
options="!check" # no tests
diff --git a/community/bareos/APKBUILD b/community/bareos/APKBUILD
index 0cd6621f9f..53271be728 100644
--- a/community/bareos/APKBUILD
+++ b/community/bareos/APKBUILD
@@ -7,7 +7,6 @@ pkgrel=1
pkgdesc="Bareos - Backup Archiving REcovery Open Sourced"
url="http://www.bareos.org"
_php=php8
-# FTBFS on mips
# chromium-chromedriver only present on these arches
arch="x86_64 aarch64"
options="!check"
diff --git a/community/bcc/APKBUILD b/community/bcc/APKBUILD
index 079bca6bb4..f72bc68b0c 100644
--- a/community/bcc/APKBUILD
+++ b/community/bcc/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.23.0
pkgrel=0
pkgdesc="A toolkit for creating efficient kernel tracing and manipulation programs"
url="https://github.com/iovisor/bcc/"
-# s390x and mips64 build fails
-arch="all !s390x !mips64"
+# s390x build fails
+arch="all !s390x"
license="Apache-2.0"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc:_doc $pkgname-tools:_tools py3-$pkgname:_py:noarch"
_llvmver=12
diff --git a/community/biber/APKBUILD b/community/biber/APKBUILD
index 998b661c75..fd01c3fe47 100644
--- a/community/biber/APKBUILD
+++ b/community/biber/APKBUILD
@@ -30,7 +30,7 @@ options="!check" # test failures on latest perl
prepare() {
default_prepare
# Disable long year tests on 32 bit
- case "$CARCH" in arm*|mips|mipsel*|x86)
+ case "$CARCH" in arm*|x86)
sed -i '/17000002/ s+.*+eq_or_diff("dummy", "dummy", "skip 32 bit");+' t/dateformats.t
;;
esac
diff --git a/community/biblatex/APKBUILD b/community/biblatex/APKBUILD
index 86c699b8a6..41780b5321 100644
--- a/community/biblatex/APKBUILD
+++ b/community/biblatex/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.17
pkgrel=0
pkgdesc="Sophisticated Bibliographies in LaTeX"
url="https://www.ctan.org/pkg/biblatex"
-# mips64, s390x and riscv64 blocked by texlive-luatex
-arch="noarch !x86 !ppc64le !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by texlive-luatex
+arch="noarch !x86 !ppc64le !s390x !riscv64"
license="LPPL-1.3"
depends="texlive-luatex"
makedepends="bash perl"
diff --git a/community/bird/APKBUILD b/community/bird/APKBUILD
index 6edd8a1958..8a69b553f8 100644
--- a/community/bird/APKBUILD
+++ b/community/bird/APKBUILD
@@ -21,7 +21,7 @@ source="
# flawed test on big-endian
case "$CARCH" in
- s390x|mips64) options="!check";;
+ s390x) options="!check";;
esac
[ "$CARCH" = "riscv64" ] && options="$options textrels" # Temporarily allow textrels on riscv64
diff --git a/community/bitcoin/APKBUILD b/community/bitcoin/APKBUILD
index 0347bd739b..afcc8cb835 100644
--- a/community/bitcoin/APKBUILD
+++ b/community/bitcoin/APKBUILD
@@ -6,9 +6,8 @@ pkgrel=1
pkgdesc="Decentralized P2P electronic cash system"
url="https://www.bitcoin.org/"
# x86: segfault in check
-# mips64 blocked by boost -> old kernel
# https://gitlab.alpinelinux.org/alpine/aports/-/issues/12327#note_137460
-arch="all !armhf !x86 !mips64"
+arch="all !armhf !x86"
license="MIT"
makedepends="autoconf automake libtool boost-dev miniupnpc-dev
qt5-qtbase-dev qt5-qttools-dev protobuf-dev libqrencode-dev libevent-dev chrpath zeromq-dev"
diff --git a/community/blinken/APKBUILD b/community/blinken/APKBUILD
index 9e5ede13c2..49c39f4bdd 100644
--- a/community/blinken/APKBUILD
+++ b/community/blinken/APKBUILD
@@ -4,8 +4,8 @@ pkgname=blinken
pkgver=21.12.1
pkgrel=1
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x blocked by kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/blinken/"
pkgdesc="Memory Enhancement Game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
index 4a595d8e73..08e641cce7 100644
--- a/community/bluedevil/APKBUILD
+++ b/community/bluedevil/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
# armhf blocked by qt5-qtdeclarative
-# armhf, s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf, s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND ( LGPL-2.1-only OR LGPL-3.0-only )"
depends="
diff --git a/community/bolt/APKBUILD b/community/bolt/APKBUILD
index d3c7d76365..746baec1fc 100644
--- a/community/bolt/APKBUILD
+++ b/community/bolt/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.9.1
pkgrel=0
pkgdesc="Thunderbolt 3 device manager"
url="https://gitlab.freedesktop.org/bolt/bolt"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="LGPL-2.1-or-later"
makedepends="meson eudev-dev glib-dev polkit-dev asciidoc"
checkdepends="dbus py3-gobject3 bash"
diff --git a/community/bovo/APKBUILD b/community/bovo/APKBUILD
index 9cc8f66047..79b222e985 100644
--- a/community/bovo/APKBUILD
+++ b/community/bovo/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=1
pkgdesc="A Gomoku like game for two players"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/org.kde.bovo"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/bpfmon/APKBUILD b/community/bpfmon/APKBUILD
index 365b2dec4d..97effb558d 100644
--- a/community/bpfmon/APKBUILD
+++ b/community/bpfmon/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.50
pkgrel=0
pkgdesc="BPF based visual packet rate monitor"
url="https://github.com/bbonev/bpfmon"
-arch="all !mips64" # limited by yascreen/go-md2man
+arch="all"
license="GPL-2.0-or-later"
makedepends="libpcap-dev yascreen-dev"
options="!check" # no test
diff --git a/community/brasero/APKBUILD b/community/brasero/APKBUILD
index c89317e470..f0b5ecaf05 100644
--- a/community/brasero/APKBUILD
+++ b/community/brasero/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.12.3
pkgrel=0
pkgdesc="Brasero is a GNOME application to burn CD/DVD"
url="https://wiki.gnome.org/Apps/Brasero"
-# s390x, mips64 and riscv64 blocked by librsvg -> nautilus
-arch="all !s390x !mips64 !riscv64" # blocked by nautilus-dev
+# s390x and riscv64 blocked by librsvg -> nautilus
+arch="all !s390x !riscv64" # blocked by nautilus-dev
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev gstreamer-dev libxml2-dev glib-dev libsm-dev libice-dev
libnotify-dev libcanberra-dev nautilus-dev libburn-dev libisofs-dev tracker-dev
diff --git a/community/breeze-gtk/APKBUILD b/community/breeze-gtk/APKBUILD
index 9e1f0a354c..d7e5290315 100644
--- a/community/breeze-gtk/APKBUILD
+++ b/community/breeze-gtk/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="A GTK Theme Built to Match KDE's Breeze"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> breeze
-arch="noarch !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> breeze
+arch="noarch !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-only"
depends="gtk-engines"
diff --git a/community/buho/APKBUILD b/community/buho/APKBUILD
index 1beae4ec2c..e5b20a6be5 100644
--- a/community/buho/APKBUILD
+++ b/community/buho/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=3
pkgdesc="Note taking app based on MauiKit"
# armhf blocked by qt5-qtdeclarative
-# s390x, ppc64le, mips64 and riscv64 blocked by qt5-qtwebview
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebview
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://invent.kde.org/maui/buho"
license="GPL-2.0-or-later"
depends="
diff --git a/community/caerbannog/APKBUILD b/community/caerbannog/APKBUILD
index 4d823b57c6..2918ab3f1b 100644
--- a/community/caerbannog/APKBUILD
+++ b/community/caerbannog/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.3
pkgrel=1
pkgdesc="mobile-friendly Gtk frontend for password-store"
url="https://git.sr.ht/~craftyguy/caerbannog"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
depends="
libhandy1
diff --git a/community/caja-extensions/APKBUILD b/community/caja-extensions/APKBUILD
index 423ff69ed3..9e8d1bd9f6 100644
--- a/community/caja-extensions/APKBUILD
+++ b/community/caja-extensions/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.26.0
pkgrel=1
pkgdesc="Set of extensions for Caja file manager"
url="https://github.com/mate-desktop/caja-extensions"
-arch="all !s390x !mips !mips64 !riscv64" # limited by mate-desktop
+arch="all !s390x !riscv64" # limited by mate-desktop
license="GPL-2.0-or-later"
makedepends="glib-dev gtk+3.0-dev caja-dev dconf-dev
mate-desktop-dev intltool"
diff --git a/community/caja/APKBUILD b/community/caja/APKBUILD
index e052b23b61..bc6db0f07d 100644
--- a/community/caja/APKBUILD
+++ b/community/caja/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=1
pkgdesc="The file manager for the MATE desktop"
url="https://github.com/mate-desktop/caja"
-# s390x, mips64 and riscv64 blocked by librsvg -> mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends="mate-common"
makedepends="$depends_dev intltool libtool dconf-dev gtk+3.0-dev gtk-doc
diff --git a/community/calamares-extensions/APKBUILD b/community/calamares-extensions/APKBUILD
index f090267b2e..520b22b6c3 100644
--- a/community/calamares-extensions/APKBUILD
+++ b/community/calamares-extensions/APKBUILD
@@ -6,8 +6,8 @@ pkgname=calamares-extensions
pkgver=1.2.1
pkgrel=1
# armhf blocked by qt5-qtdeclarative
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> calamares
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine -> calamares
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://github.com/calamares/calamares-extensions"
pkgdesc="Calamares Branding and Module Examples"
license="GPL-3.0-or-later"
diff --git a/community/calindori/APKBUILD b/community/calindori/APKBUILD
index 84194df47b..c368f0dd17 100644
--- a/community/calindori/APKBUILD
+++ b/community/calindori/APKBUILD
@@ -5,8 +5,8 @@ pkgver=22.02
pkgrel=0
pkgdesc="Calendar for Plasma Mobile"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-framework
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> plasma-framework
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/plasma-mobile/calindori"
license="GPL-3.0-or-later AND LGPL-3.0-or-later AND BSD-2-Clause AND CC-BY-SA-4.0 AND CC0-1.0"
depends="
diff --git a/community/calls/APKBUILD b/community/calls/APKBUILD
index 4a517f7a63..bed0e6e4a5 100644
--- a/community/calls/APKBUILD
+++ b/community/calls/APKBUILD
@@ -4,8 +4,8 @@ pkgname=calls
pkgver=41.0
pkgrel=1
pkgdesc="A phone dialer and call handler"
-# s390x, mips64 and riscv64 blocked by polkit -> modemmanager
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> modemmanager
+arch="all !s390x !riscv64"
url="https://gitlab.gnome.org/GNOME/calls"
license="GPL-3.0-or-later"
depends="modemmanager callaudiod"
diff --git a/community/cantor/APKBUILD b/community/cantor/APKBUILD
index 16faed5cd0..0f60b9d34d 100644
--- a/community/cantor/APKBUILD
+++ b/community/cantor/APKBUILD
@@ -4,9 +4,9 @@ pkgname=cantor
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://edu.kde.org/cantor/"
pkgdesc="KDE Frontend to Mathematical Software "
license="GPL-2.0-or-later"
diff --git a/community/capnproto/APKBUILD b/community/capnproto/APKBUILD
index 9395de93dd..54c96d9303 100644
--- a/community/capnproto/APKBUILD
+++ b/community/capnproto/APKBUILD
@@ -15,7 +15,7 @@ source="https://capnproto.org/$pkgname-c++-$pkgver.tar.gz
builddir="$srcdir/$pkgname-c++-$pkgver"
case "$CARCH" in
- mips*|s390x|armhf|armv7) options="!check";; # FAIL: capnp-test
+ s390x|armhf|armv7) options="!check";; # FAIL: capnp-test
esac
build() {
diff --git a/community/cargo-audit/APKBUILD b/community/cargo-audit/APKBUILD
index 3ef6450ea6..31156de98b 100644
--- a/community/cargo-audit/APKBUILD
+++ b/community/cargo-audit/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.16.0
pkgrel=0
pkgdesc="Audit Cargo.lock for crates with security vulnerabilities"
url="https://github.com/RustSec/rustsec"
-# mips64, s390x and riscv64 blocked by cargo
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by cargo
+arch="all !s390x !riscv64"
license="MIT OR Apache-2.0"
makedepends="cargo openssl1.1-compat-dev"
subpackages="$pkgname-doc"
diff --git a/community/cargo-edit/APKBUILD b/community/cargo-edit/APKBUILD
index 4a3bf25fe5..e1989be144 100644
--- a/community/cargo-edit/APKBUILD
+++ b/community/cargo-edit/APKBUILD
@@ -5,9 +5,9 @@ pkgver=0.8.0
pkgrel=2
pkgdesc="Managing cargo dependencies from the command line"
url="https://github.com/killercup/cargo-edit"
-# mips64, s390x and riscv64 blocked by cargo
+# s390x and riscv64 blocked by cargo
# ppc64le blocked by ring crate
-arch="all !mips64 !s390x !ppc64le !riscv64"
+arch="all !s390x !ppc64le !riscv64"
license="MIT OR Apache-2.0"
makedepends="cargo libgit2-dev"
subpackages="$pkgname-doc"
diff --git a/community/cargo-outdated/APKBUILD b/community/cargo-outdated/APKBUILD
index 5b9b881a22..c4ba731c92 100644
--- a/community/cargo-outdated/APKBUILD
+++ b/community/cargo-outdated/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.10.2
pkgrel=1
pkgdesc="A cargo subcommand for displaying when Rust dependencies are out of date"
url="https://github.com/kbknapp/cargo-outdated"
-# mips64, s390x and riscv64 blocked by cargo
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by cargo
+arch="all !s390x !riscv64"
license="MIT"
makedepends="cargo libgit2-dev"
subpackages="$pkgname-doc"
diff --git a/community/cargo-watch/APKBUILD b/community/cargo-watch/APKBUILD
index 0abeecc43c..a74af6bb64 100644
--- a/community/cargo-watch/APKBUILD
+++ b/community/cargo-watch/APKBUILD
@@ -5,8 +5,8 @@ pkgver=8.1.2
pkgrel=1
pkgdesc="Utility for Cargo to compile projects when sources change"
url="https://github.com/watchexec/cargo-watch"
-# mips64, s390x and riscv64 blocked by cargo
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by cargo
+arch="all !s390x !riscv64"
license="CC0-1.0"
makedepends="cargo"
subpackages="$pkgname-doc
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index f4ccca79c5..3a22304ec3 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -10,7 +10,7 @@ pkgusers="ceph"
pkggroups="ceph"
url="https://ceph.io/en/"
# riscv64 missing nodejs
-arch="all !mips !mips64 !riscv64"
+arch="all !riscv64"
# https://github.com/ceph/ceph/blob/master/COPYING
license="LGPL-2.1-only AND LGPL-2.0-or-later AND GPL-2.0-only AND GPL-3.0-only AND CC-BY-SA-1.0 AND BSL-1.0 AND GPL-2.0-or-later WITH Autoconf-exception-2.0 AND BSD-3-Clause AND MIT AND custom"
depends="ceph-osd ceph-mds ceph-mon"
diff --git a/community/cervisia/APKBUILD b/community/cervisia/APKBUILD
index 1e5c322026..aa0f3329a3 100644
--- a/community/cervisia/APKBUILD
+++ b/community/cervisia/APKBUILD
@@ -4,8 +4,8 @@ pkgname=cervisia
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kparts
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kparts
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development/org.kde.cervisia"
pkgdesc="A user friendly version control system front-end"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/chatty/APKBUILD b/community/chatty/APKBUILD
index b9966ab083..393725224a 100644
--- a/community/chatty/APKBUILD
+++ b/community/chatty/APKBUILD
@@ -7,9 +7,9 @@ pkgname=chatty
pkgver=0.6.1
pkgrel=0
pkgdesc="A phone dialer and call handler"
-# s390x, mips64 and riscv64 blocked by purple-mm-sms
+# s390x and riscv64 blocked by purple-mm-sms
# ppc64le lacks the libphonenumber / libphonenumber-dev
-arch="all !s390x !mips64 !riscv64 !ppc64le"
+arch="all !s390x !riscv64 !ppc64le"
url="https://source.puri.sm/Librem5/chatty"
license="GPL-3.0-or-later"
depends="
diff --git a/community/choqok/APKBUILD b/community/choqok/APKBUILD
index 31b751dc06..5153792740 100644
--- a/community/choqok/APKBUILD
+++ b/community/choqok/APKBUILD
@@ -6,9 +6,9 @@ pkgrel=1
pkgdesc="A micro-blogging client"
url="https://choqok.kde.org/"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by kaccounts-integration
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
license="GPL-2.0-only OR GPL-3.0-only"
makedepends="
extra-cmake-modules
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 7b668d298b..032106a079 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -731,7 +731,7 @@ ef43fa90b05e2407b6daa822193121cdeef6ee9068175572f0928f156f186be9c77539dfa06863ad
3646907cdc6dd766eebc5c7a59302e6ae59a27467316e24bcd7632d661be7471ac444d23ffff5b46fdd83dd1f3973d154dcba4d6beba475b3d1da0b14a0321c1 no-mallinfo.patch
aab0cbed5bccf850d28648a9387bf50b751f3f240f4016c7e74a67bbacf41cb275e3cb68afaa6043278c1bd3266ae63d2cc03bfff5a28f1d3b41fdcece18bbb6 resolver.patch
6bf334f462caea4b779b436151bfccc965c93788001ad6c42a226b3f55b6b7ddaa0f11db8dcc1b7d447ff0f10ccb83e11ebf66a6c8bd4f4463004921be5fd94f musl-stat.patch
-c08153afb2d77bd6de62ef71d895be0828cd5eba6aea46c9e6296dadb337780225b10468bb8ce92ed044cd8cf088f2ef0143a7704d51bdd09188afd68e7843d5 chromium-use-alpine-target.patch
+ded02360a36283973b9abb4150de3d964749a58017fbbd9f09fb6cb29ec97a8ac99ccadd953633bbb7eb9ec77a078f4df9de5f624d1580f33446ceba5fd3a3f6 chromium-use-alpine-target.patch
599f5ef338b5797e04436bdc88921c31365d2dea2613d40053be6e774f654e2889efb0c0bd55c2c5044a6805510fbc337da555971169a75d584fac93e18256ac media-base.patch
2e5a83826239849d096aead033eb519338b84e6fbbf58abfcd7cfe40d0b3070b66bcc825ec84406484d73d1a333f1b9d23a8ab44987ab5c8b187076c84cd668b musl-crashpad.patch
556cc2ba28184a75745f13c673605327f5be590be179eb3f941dc0abded854a814e5da1432a28fb8d4dcdcd66ffd4c94ee1a8824d2cd93b632f48e9310dbc3fa musl-v8-monotonic-pthread-cont_timedwait.patch
diff --git a/community/chromium/chromium-use-alpine-target.patch b/community/chromium/chromium-use-alpine-target.patch
index b9f0648009..8282acaa6b 100644
--- a/community/chromium/chromium-use-alpine-target.patch
+++ b/community/chromium/chromium-use-alpine-target.patch
@@ -22,45 +22,3 @@
}
} else if (current_cpu == "mipsel" && !is_nacl) {
ldflags += [ "-Wl,--hash-style=sysv" ]
-@@ -777,8 +777,8 @@
- cflags += [ "--target=mipsel-linux-android" ]
- ldflags += [ "--target=mipsel-linux-android" ]
- } else {
-- cflags += [ "--target=mipsel-linux-gnu" ]
-- ldflags += [ "--target=mipsel-linux-gnu" ]
-+ cflags += [ "--target=mipsel-alpine-linux-musl" ]
-+ ldflags += [ "--target=mipsel-alpine-linux-musl" ]
- }
- } else {
- cflags += [ "-EL" ]
-@@ -794,7 +794,7 @@
- "-march=mipsel",
- "-mcpu=mips32r6",
- ]
-- } else {
-+ } else {
- cflags += [
- "-mips32r6",
- "-Wa,-mips32r6",
-@@ -908,8 +908,8 @@
- cflags += [ "--target=mips64el-linux-android" ]
- ldflags += [ "--target=mips64el-linux-android" ]
- } else {
-- cflags += [ "--target=mips64el-linux-gnuabi64" ]
-- ldflags += [ "--target=mips64el-linux-gnuabi64" ]
-+ cflags += [ "--target=mips64el-alpine-linux-musl" ]
-+ ldflags += [ "--target=mips64el-alpine-linux-musl" ]
- }
- } else {
- cflags += [
-@@ -967,8 +967,8 @@
- ldflags += [ "-Wl,--hash-style=sysv" ]
- if (custom_toolchain == "") {
- if (is_clang) {
-- cflags += [ "--target=mips64-linux-gnuabi64" ]
-- ldflags += [ "--target=mips64-linux-gnuabi64" ]
-+ cflags += [ "--target=mips64-alpine-linux-musl" ]
-+ ldflags += [ "--target=mips64-alpine-linux-musl" ]
- } else {
- cflags += [
- "-EB",
diff --git a/community/cinnamon-desktop/APKBUILD b/community/cinnamon-desktop/APKBUILD
index 65a74e6795..e7f49f5b18 100644
--- a/community/cinnamon-desktop/APKBUILD
+++ b/community/cinnamon-desktop/APKBUILD
@@ -4,8 +4,8 @@ pkgname=cinnamon-desktop
pkgver=5.0.0
pkgrel=1
pkgdesc="Library providing shared API for Cinnamon applications"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
url="https://github.com/linuxmint/cinnamon-desktop"
license="GPL-2.0-only"
makedepends="
diff --git a/community/claws-mail/APKBUILD b/community/claws-mail/APKBUILD
index 3dba4523ca..71cfe5aa12 100644
--- a/community/claws-mail/APKBUILD
+++ b/community/claws-mail/APKBUILD
@@ -40,7 +40,7 @@ makedepends="gtk+3.0-dev startup-notification-dev enchant2-dev
automake autoconf libtool
"
case "$CARCH" in
- mips64|riscv64)
+ riscv64)
_fancy_opt="--disable-fancy-plugin"
;;
*) subpackages="$subpackages $pkgname-plugins-fancy:_plugin"
diff --git a/community/clip/APKBUILD b/community/clip/APKBUILD
index 4da170ce3d..e07681a4c2 100644
--- a/community/clip/APKBUILD
+++ b/community/clip/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="Video player and video collection manager"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/maui/clip"
license="GPL-3.0-or-later"
depends="
diff --git a/community/clojure/APKBUILD b/community/clojure/APKBUILD
index 368fa00bab..aeac8d4278 100755
--- a/community/clojure/APKBUILD
+++ b/community/clojure/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.10.3
pkgrel=1
pkgdesc="The Clojure Programming Language"
url="https://clojure.org"
-arch="all !armv7 !armhf !x86 !mips !mips64 !riscv64" # java
+arch="all !armv7 !armhf !x86 !riscv64" # java
license="EPL-1.0"
makedepends="maven"
source="https://github.com/clojure/clojure/archive/clojure-$pkgver.tar.gz
diff --git a/community/cloud-init/APKBUILD b/community/cloud-init/APKBUILD
index 8233de4f7d..62c37b8a54 100644
--- a/community/cloud-init/APKBUILD
+++ b/community/cloud-init/APKBUILD
@@ -6,9 +6,8 @@ pkgver=21.4
pkgrel=1
pkgdesc="Cloud instance init scripts"
url="https://cloud-init.io"
-# Dependant package "cloud-utils-growpart" is not available for mips,
-# mips64, or s390x so disable these archs for this package too.
-arch="noarch !mips !mips64 !s390x"
+# s390x: blocked by cloud-utils-growpart
+arch="noarch !s390x"
license="Apache-2.0 OR GPL-3.0-only"
depends="
blkid
diff --git a/community/cloud-utils/APKBUILD b/community/cloud-utils/APKBUILD
index ad50622395..9661849855 100755
--- a/community/cloud-utils/APKBUILD
+++ b/community/cloud-utils/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.32
pkgrel=5
pkgdesc="Utilities for interacting with cloud VM images"
url="https://launchpad.net/cloud-utils/"
-arch="noarch !mips !mips64 !s390x" # tests are broken on big-endian
+arch="noarch !s390x" # tests are broken on big-endian
license="GPL-3.0-or-later"
depends="
bash
diff --git a/community/cloudi/APKBUILD b/community/cloudi/APKBUILD
index a22c76fc31..1e10666937 100644
--- a/community/cloudi/APKBUILD
+++ b/community/cloudi/APKBUILD
@@ -93,7 +93,7 @@ case "$CTARGET_ARCH" in
esac
# Disable JavaScript on architectures that lack nodejs
case "$CTARGET_ARCH" in
- mips*|riscv*)
+ riscv*)
_configure_args="$_configure_args --disable-javascript-support"
;;
*)
@@ -102,7 +102,7 @@ case "$CTARGET_ARCH" in
esac
# Enable OCaml on the appropriate architectures
case "$CTARGET_ARCH" in
- mips*|riscv*)
+ riscv*)
;;
*)
makedepends="$makedepends ocaml"
diff --git a/community/collectd/APKBUILD b/community/collectd/APKBUILD
index d0517539e7..f64edbd16b 100644
--- a/community/collectd/APKBUILD
+++ b/community/collectd/APKBUILD
@@ -6,8 +6,8 @@ pkgver=5.12.0
pkgrel=6
pkgdesc="The system statistics collection daemon"
url="https://collectd.org/"
-# mips64, s390x and riscv64 blocked by polkit -> libvirt
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> libvirt
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
pkgusers="collectd"
pkggroups="collectd"
diff --git a/community/colord-gtk/APKBUILD b/community/colord-gtk/APKBUILD
index 2a42ebdf9d..9e13605858 100644
--- a/community/colord-gtk/APKBUILD
+++ b/community/colord-gtk/APKBUILD
@@ -5,8 +5,8 @@ pkgrel=2
pkgdesc="GTK support library for colord"
options="!check" # Requires bus session
url="https://www.freedesktop.org/software/colord/"
-# s390x, mips64 and riscv64 blocked by polkit -> colord
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> colord
+arch="all !s390x !riscv64"
license="LGPL-2.1-or-later"
makedepends="meson intltool glib-dev gtk+3.0-dev colord-dev lcms2-dev"
checkdepends="xvfb-run"
diff --git a/community/commons-daemon/APKBUILD b/community/commons-daemon/APKBUILD
index b2a8b1b795..6a540d22e1 100644
--- a/community/commons-daemon/APKBUILD
+++ b/community/commons-daemon/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.2.4
pkgrel=1
pkgdesc="Tools to allow Java programs to run as UNIX daemons"
url="https://commons.apache.org/daemon/"
-# mips64 and riscv64 blocked by java-jdk
-arch="all !mips64 !riscv64"
+# riscv64 blocked by java-jdk
+arch="all !riscv64"
license="Apache-2.0"
options="!check" # No test suite
depends="java-jre-headless"
diff --git a/community/communicator/APKBUILD b/community/communicator/APKBUILD
index 47c881882b..0644535ab9 100644
--- a/community/communicator/APKBUILD
+++ b/community/communicator/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="Contacts and dialer application"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/maui/communicator"
license="GPL-3.0-or-later"
depends="
diff --git a/community/consolekit2/APKBUILD b/community/consolekit2/APKBUILD
index 98144ec97e..6b7a13a1ab 100644
--- a/community/consolekit2/APKBUILD
+++ b/community/consolekit2/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=1
pkgdesc="Framework for defining and tracking users, login sessions, and seats"
provides="consolekit=$pkgver"
replaces="consolekit"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
url="https://consolekit2.github.io/ConsoleKit2"
license="GPL-2.0-or-later"
depends="
diff --git a/community/consul/APKBUILD b/community/consul/APKBUILD
index c34cc716ff..d6e983ccb2 100644
--- a/community/consul/APKBUILD
+++ b/community/consul/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.11.3
pkgrel=0
pkgdesc="Tool for service discovery, monitoring and configuration"
url="https://www.consul.io"
-# mips64 and riscv64 blocked by dependency boltdb
-arch="all !mips64 !riscv64"
+# riscv64 blocked by dependency boltdb
+arch="all !riscv64"
license="MPL-2.0"
makedepends="bash go"
install="$pkgname.pre-install"
diff --git a/community/containerd/APKBUILD b/community/containerd/APKBUILD
index a1b97140e2..e60c2ad4d1 100644
--- a/community/containerd/APKBUILD
+++ b/community/containerd/APKBUILD
@@ -64,14 +64,9 @@ prepare() {
}
build() {
- case "$CARCH" in
- mips64*) buildmode=exe;;
- *) buildmode=pie;;
- esac
-
export GO111MODULE=on
- make VERSION="v$pkgver" REVISION="$_commit" BUILDMODE="$buildmode" \
+ make VERSION="v$pkgver" REVISION="$_commit" BUILDMODE=pie \
EXTRA_LDFLAGS="-s -w"
make man
}
diff --git a/community/coreaction/APKBUILD b/community/coreaction/APKBUILD
index 12eb497f16..6411cd9bf3 100644
--- a/community/coreaction/APKBUILD
+++ b/community/coreaction/APKBUILD
@@ -4,8 +4,8 @@ pkgname=coreaction
pkgver=4.2.0
pkgrel=1
pkgdesc="A side bar for showing widgets from C-Suite"
-# s390x, mips64 and riscv64 blocked by polkit -> libcsys
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> libcsys
+arch="all !s390x !riscv64"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
makedepends="qt5-qtbase-dev libcprime-dev libcsys-dev qt5-qtsvg-dev cmake ninja"
diff --git a/community/corefm/APKBUILD b/community/corefm/APKBUILD
index 2ffb11afaf..d5f1afbc2f 100644
--- a/community/corefm/APKBUILD
+++ b/community/corefm/APKBUILD
@@ -5,8 +5,8 @@ pkgver=4.2.0
pkgrel=1
pkgdesc="A lightweight file-manager from C-Suite"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
diff --git a/community/coregarage/APKBUILD b/community/coregarage/APKBUILD
index f824110818..7549718ad5 100644
--- a/community/coregarage/APKBUILD
+++ b/community/coregarage/APKBUILD
@@ -4,7 +4,7 @@ pkgname=coregarage
pkgver=4.2.0
pkgrel=0
pkgdesc="A settings manager for C-Suite"
-arch="all !s390x !mips64 !riscv64" # blocked by polkit
+arch="all !s390x !riscv64" # blocked by polkit
url="https://gitlab.com/cubocore/coreapps/coregarage"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
diff --git a/community/corestats/APKBUILD b/community/corestats/APKBUILD
index 26f5edc2a9..4c18bdf219 100644
--- a/community/corestats/APKBUILD
+++ b/community/corestats/APKBUILD
@@ -4,7 +4,7 @@ pkgname=corestats
pkgver=4.2.0
pkgrel=0
pkgdesc="A system resource viewer from C-Suite"
-arch="all !s390x !mips64 !riscv64" # blocked by libcsys
+arch="all !s390x !riscv64" # blocked by libcsys
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
diff --git a/community/corestuff/APKBUILD b/community/corestuff/APKBUILD
index 9bfd0d9c26..7a61c98c95 100644
--- a/community/corestuff/APKBUILD
+++ b/community/corestuff/APKBUILD
@@ -4,8 +4,8 @@ pkgname=corestuff
pkgver=4.2.0
pkgrel=0
pkgdesc="An activity viewer from C-Suite"
-# s390x, mips64 and riscv64 blocked by polkit -> libcsys
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> libcsys
+arch="all !armhf !s390x !riscv64"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
diff --git a/community/coretoppings/APKBUILD b/community/coretoppings/APKBUILD
index 36fa8aa116..742f7efe98 100644
--- a/community/coretoppings/APKBUILD
+++ b/community/coretoppings/APKBUILD
@@ -5,8 +5,8 @@ pkgver=4.2.0
pkgrel=0
pkgdesc="An activity viewer from the CoreApps family"
# armhf blocked by qt5-qtlocation
-# s390x, mips64 and riscv64 blocked by polkit -> libcsys
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> libcsys
+arch="all !armhf !s390x !riscv64"
url="https://gitlab.com/cubocore"
license="GPL-3.0-or-later"
depends="qt5-qtsvg"
diff --git a/community/corrosion/APKBUILD b/community/corrosion/APKBUILD
index b863c18e4f..edf93251ab 100644
--- a/community/corrosion/APKBUILD
+++ b/community/corrosion/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=2
_commit="946c5dd80a6ebdb84c5986e52af460e23e74394d"
pkgdesc="Marrying Rust and CMake - Easy Rust and C/C++ Integration!"
url="https://github.com/AndrewGaspar/corrosion"
-# s390x and mips64 blocked by Rust
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by Rust
+arch="all !s390x !riscv64"
license="MIT"
depends="
cargo
diff --git a/community/cppcheck/APKBUILD b/community/cppcheck/APKBUILD
index 8719146129..ba821645cf 100644
--- a/community/cppcheck/APKBUILD
+++ b/community/cppcheck/APKBUILD
@@ -5,9 +5,8 @@ pkgver=2.7
pkgrel=0
pkgdesc="Static analysis tool for C/C++ code"
url="https://cppcheck.sourceforge.io/"
-# mips64 blocked by z3
# riscv64 broken, "Could not find qmake spec 'default'."
-arch="all !mips64 !riscv64"
+arch="all !riscv64"
license="GPL-3.0-or-later"
makedepends="docbook-xsl pcre-dev python3 qt5-qttools-dev z3-dev tinyxml2-dev qtchooser"
subpackages="$pkgname-doc $pkgname-htmlreport::noarch $pkgname-gui"
diff --git a/community/cpputest/APKBUILD b/community/cpputest/APKBUILD
index 1857e3be3e..7695a01f05 100644
--- a/community/cpputest/APKBUILD
+++ b/community/cpputest/APKBUILD
@@ -5,7 +5,7 @@ pkgver=4.0
pkgrel=0
pkgdesc="A unit testing and mocking framework for C/C++"
url="http://cpputest.github.io/"
-arch="all !mips !mips64" # FTBFS on soft-float (mips)
+arch="all"
license="BSD-3-Clause"
options="!dbg"
makedepends="cmake"
diff --git a/community/cups-pk-helper/APKBUILD b/community/cups-pk-helper/APKBUILD
index ea3e2c0769..c44ee7e85f 100644
--- a/community/cups-pk-helper/APKBUILD
+++ b/community/cups-pk-helper/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.2.6
pkgrel=1
pkgdesc="PolicyKit helper to configure cups with fine-grained privileges"
url="https://www.freedesktop.org/wiki/Software/cups-pk-helper/"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="glib-dev polkit-dev cups-dev intltool"
subpackages="$pkgname-lang"
diff --git a/community/ddrescue/APKBUILD b/community/ddrescue/APKBUILD
index 3841cdf645..4596405a06 100644
--- a/community/ddrescue/APKBUILD
+++ b/community/ddrescue/APKBUILD
@@ -25,7 +25,6 @@ check() {
# XXX: Some tests fail on s390x, but only on builder, so ignore it for now.
case "$CARCH" in
s390x) make check || true;;
- mips*) make check || true;;
*) make check;;
esac
}
diff --git a/community/deja-dup/APKBUILD b/community/deja-dup/APKBUILD
index f11290f9b7..69ffdf0a79 100644
--- a/community/deja-dup/APKBUILD
+++ b/community/deja-dup/APKBUILD
@@ -5,8 +5,8 @@ pkgver=42.8
pkgrel=1
pkgdesc="Simple backup tool for GNOME"
url="https://wiki.gnome.org/Apps/DejaDup"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
depends="dbus:org.freedesktop.Secrets duplicity"
makedepends="meson gtk+3.0-dev json-glib-dev libhandy1-dev
diff --git a/community/dep/APKBUILD b/community/dep/APKBUILD
index feb719b942..18509ea8bb 100644
--- a/community/dep/APKBUILD
+++ b/community/dep/APKBUILD
@@ -5,8 +5,7 @@ pkgver=0.5.4
pkgrel=5
pkgdesc="Go dependency management tool"
url="https://github.com/golang/dep"
-# mips(64): dependency boltdp does not support mips
-arch="all !mips !mips64 !riscv64"
+arch="all !riscv64"
license="BSD-3-Clause"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/golang/dep/archive/v$pkgver.tar.gz"
diff --git a/community/dfrs/APKBUILD b/community/dfrs/APKBUILD
index 093b7b609b..7c034d5281 100644
--- a/community/dfrs/APKBUILD
+++ b/community/dfrs/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.0.7
pkgrel=0
pkgdesc="Display file system space usage using graphs and colors"
url="https://github.com/anthraxx/dfrs"
-# s390x, mips64 and riscv64 blocked by rust/cargo
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust/cargo
+arch="all !s390x !riscv64"
license="MIT"
makedepends="
cargo
diff --git a/community/discover/APKBUILD b/community/discover/APKBUILD
index 7f3b28822a..938c1b0352 100644
--- a/community/discover/APKBUILD
+++ b/community/discover/APKBUILD
@@ -4,8 +4,8 @@ pkgname=discover
pkgver=5.24.0
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://userbase.kde.org/Discover"
pkgdesc="KDE Plasma resources management GUI"
license="LGPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
diff --git a/community/dnsdist/APKBUILD b/community/dnsdist/APKBUILD
index 4ccecaa833..c5047acd05 100644
--- a/community/dnsdist/APKBUILD
+++ b/community/dnsdist/APKBUILD
@@ -4,9 +4,9 @@ pkgver=1.7.0
pkgrel=0
pkgdesc="dnsdist is a highly DNS-, DoS-, and abuse-aware loadbalancer."
url="https://dnsdist.org/"
-# s390x and mips64 blocked by h2o
+# s390x blocked by h2o
# riscv64 blocked by luajit
-arch="all !s390x !mips64 !riscv64"
+arch="all !s390x !riscv64"
license="GPL-2.0-only WITH OpenSSL-Exception"
_lua_version=5.4
depends="$pkgname-common !$pkgname-luajit"
diff --git a/community/docker/APKBUILD b/community/docker/APKBUILD
index 70952c380a..12d56fde81 100644
--- a/community/docker/APKBUILD
+++ b/community/docker/APKBUILD
@@ -67,12 +67,6 @@ _libnetwork_builddir="$srcdir/libnetwork-$_libnetwork_commit"
_buildtags="seccomp"
-case $CARCH in
- mips64)
- export GOFLAGS="${GOFLAGS/-buildmode=pie}" # Docker does not supprt buildmode=pie on mips64
- ;;
-esac
-
export GO111MODULE=off # go1.16 defaults to on
build() {
diff --git a/community/doctl/APKBUILD b/community/doctl/APKBUILD
index 4662554ba7..d784ea98b2 100644
--- a/community/doctl/APKBUILD
+++ b/community/doctl/APKBUILD
@@ -21,14 +21,9 @@ build() {
minor=${maj_min#*.}
patch=${pkgver#*.*.*}
- _buildmode="-buildmode=pie"
- case $CARCH in
- mips*) _buildmode="" ;;
- esac
-
go build \
-trimpath \
- $_buildmode \
+ -buildmode=pie \
-mod=readonly \
-ldflags "-extldflags \"$LDFLAGS\" \
-X github.com/digitalocean/doctl.Major=$major \
diff --git a/community/dolphin-plugins/APKBUILD b/community/dolphin-plugins/APKBUILD
index 11ce9410bd..6a802e677b 100644
--- a/community/dolphin-plugins/APKBUILD
+++ b/community/dolphin-plugins/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
url="https://www.kde.org/applications/system/dolphin/"
pkgdesc="Extra Dolphin plugins"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="
dolphin-dev
diff --git a/community/dolphin/APKBUILD b/community/dolphin/APKBUILD
index 4d1dad79de..02401aab87 100644
--- a/community/dolphin/APKBUILD
+++ b/community/dolphin/APKBUILD
@@ -4,8 +4,8 @@ pkgname=dolphin
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/system/dolphin"
pkgdesc="KDE File Manager"
license="GPL-2.0-only"
diff --git a/community/dpns/APKBUILD b/community/dpns/APKBUILD
index dce396c53d..200f5f92b1 100644
--- a/community/dpns/APKBUILD
+++ b/community/dpns/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.4
pkgrel=0
pkgdesc="docker pull & save"
url="https://github.com/liske/dpns"
-arch="noarch !ppc64le !mips !mips64" # blocked by docker
+arch="noarch !ppc64le" # blocked by docker
license="GPL-2.0-or-later"
depends="bash docker docker-compose"
subpackages="$pkgname-openrc"
diff --git a/community/dragon/APKBUILD b/community/dragon/APKBUILD
index d9143fc2be..47be1fc685 100644
--- a/community/dragon/APKBUILD
+++ b/community/dragon/APKBUILD
@@ -4,8 +4,8 @@ pkgname=dragon
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/multimedia/org.kde.dragonplayer"
pkgdesc="A multimedia player where the focus is on simplicity, instead of features"
license="GPL-2.0-only OR GPL-3.0-only"
diff --git a/community/drawterm/APKBUILD b/community/drawterm/APKBUILD
index b1fb5e7366..682ed220d0 100644
--- a/community/drawterm/APKBUILD
+++ b/community/drawterm/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0_hg20210414
pkgrel=0
pkgdesc="Connect to Plan 9 CPU servers from other operating systems"
url="http://drawterm.9front.org/"
-arch="all !armhf !armv7 !s390x !mips !mips64"
+arch="all !armhf !armv7 !s390x"
license="LPL-1.02"
options="!check" # upstream does not have a test suite
makedepends="linux-headers libx11-dev libxt-dev"
diff --git a/community/drkonqi/APKBUILD b/community/drkonqi/APKBUILD
index c5f55686f6..99ef497ca8 100644
--- a/community/drkonqi/APKBUILD
+++ b/community/drkonqi/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="The KDE crash handler"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
makedepends="
diff --git a/community/dssim/APKBUILD b/community/dssim/APKBUILD
index fa945b7477..4f1fc35496 100644
--- a/community/dssim/APKBUILD
+++ b/community/dssim/APKBUILD
@@ -5,7 +5,7 @@ pkgver=3.1.0
pkgrel=0
pkgdesc="Tool for image similarity comparison, simulating human perception"
url="https://kornel.ski/dssim"
-arch="all !s390x !mips !mips64 !riscv64" # limited by rust/cargo
+arch="all !s390x !riscv64" # limited by rust/cargo
arch="$arch !ppc64le !armv7 !armhf" # Tries to compile mozjpeg-sys with 'with_simd'
license="AGPL-3.0-only"
makedepends="cargo"
diff --git a/community/dune/APKBUILD b/community/dune/APKBUILD
index 4eac120773..ebe528f5d4 100644
--- a/community/dune/APKBUILD
+++ b/community/dune/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.9.3
pkgrel=0
pkgdesc="A composable build system for OCaml (formerly Jbuilder)"
url="https://github.com/ocaml/dune"
-# mips64 and riscv64 blocked by ocaml
-arch="all !mips64 !riscv64"
+# riscv64 blocked by ocaml
+arch="all !riscv64"
license="Apache-2.0"
checkdepends="bash"
makedepends="ocaml ocaml-compiler-libs ocaml-findlib-dev"
diff --git a/community/ebook-tools/APKBUILD b/community/ebook-tools/APKBUILD
index f00d9bd350..d3ec4a372f 100644
--- a/community/ebook-tools/APKBUILD
+++ b/community/ebook-tools/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.2.2
pkgrel=2
pkgdesc="Tools for accessing and converting various ebook file formats."
url="https://sourceforge.net/projects/ebook-tools/"
-# ppc64le, mips64, s390x and riscv64 blocked by texlive
-arch="all !mips64 !s390x !riscv64 !ppc64le"
+# ppc64le, s390x and riscv64 blocked by texlive
+arch="all !s390x !riscv64 !ppc64le"
license="MIT"
depends_dev="
cmake
diff --git a/community/ecl/APKBUILD b/community/ecl/APKBUILD
index 47d6f968a1..8af66f21be 100644
--- a/community/ecl/APKBUILD
+++ b/community/ecl/APKBUILD
@@ -4,8 +4,7 @@ pkgname=ecl
pkgver=21.2.1
pkgrel=1
pkgdesc="Embeddable Common Lisp"
-# not compatible with soft-float archs (like mips)
-arch="all !mips !mips64"
+arch="all"
url="https://common-lisp.net/project/ecl"
options="!check"
license="LGPL-2.1-or-later"
diff --git a/community/eg25-manager/APKBUILD b/community/eg25-manager/APKBUILD
index 21e3f372fb..112d9c78a6 100644
--- a/community/eg25-manager/APKBUILD
+++ b/community/eg25-manager/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.4.2
pkgrel=0
pkgdesc="Daemon for managing the Quectel EG25 modem"
url="https://gitlab.com/mobian1/devices/eg25-manager"
-# s390x, mips64 and riscv64 blocked by polkit -> modemmanager
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> modemmanager
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
makedepends="
curl-dev
diff --git a/community/eigen/APKBUILD b/community/eigen/APKBUILD
index 5bb67fb499..a004d8551b 100644
--- a/community/eigen/APKBUILD
+++ b/community/eigen/APKBUILD
@@ -9,17 +9,12 @@ url="https://eigen.tuxfamily.org/"
arch="noarch"
license="MPL-2.0"
options="!check" # checks take a long time, and tend to fail randomly
-makedepends="cmake suitesparse-dev mpfr-dev fftw-dev boost-dev gmp-dev glu-dev freeglut-dev"
+makedepends="cmake suitesparse-dev mpfr-dev fftw-dev boost-dev gmp-dev glu-dev freeglut-dev openblas-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://gitlab.com/libeigen/eigen/-/archive/$pkgver/eigen-$pkgver.tar.gz
fftw-test-fix.patch
"
-case "$CARCH" in
- mips*) makedepends="$makedepends blas-dev" ;;
- *) makedepends="$makedepends openblas-dev" ;;
-esac
-
build() {
# needs -std so c11 tests are being built
CXXFLAGS="$CXXFLAGS -std=c++11" \
diff --git a/community/elisa/APKBUILD b/community/elisa/APKBUILD
index 3bfbe04f80..f5e63992af 100644
--- a/community/elisa/APKBUILD
+++ b/community/elisa/APKBUILD
@@ -4,8 +4,8 @@ pkgname=elisa
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/multimedia/org.kde.elisa"
pkgdesc="A simple music player aiming to provide a nice experience for its users"
license="LGPL-3.0-or-later"
diff --git a/community/elogind/APKBUILD b/community/elogind/APKBUILD
index 27a2cc8394..b6c4082a60 100644
--- a/community/elogind/APKBUILD
+++ b/community/elogind/APKBUILD
@@ -39,7 +39,6 @@ subpackages="
"
source="https://github.com/elogind/elogind/archive/v$pkgver/elogind-v$pkgver.tar.gz
elogind.initd
- fix-mips-detection.patch
fix-version.patch
remove-polkit-gobject-1-check.patch
"
@@ -47,7 +46,7 @@ source="https://github.com/elogind/elogind/archive/v$pkgver/elogind-v$pkgver.tar
build() {
case "$CARCH" in
# polkit is not available on these arches
- s390x|mips|mips64|riscv64) _polkit=false; export CFLAGS="$CFLAGS -D__IGNORE_pkey_mprotect -DSO_PEERSEC=31" ;;
+ s390x|riscv64) _polkit=false; export CFLAGS="$CFLAGS -D__IGNORE_pkey_mprotect -DSO_PEERSEC=31" ;;
*) _polkit=true ;;
esac
export LDFLAGS="$LDFLAGS -lintl"
@@ -103,7 +102,6 @@ bashcomp() {
sha512sums="
9db0f068ed94ec07bab4d764ccb38840af3d05a4b7c9c539721906f5381b509cb9a3cbfb0453a978210d306136368de6162578c600d522416ef2a7ac1b9f348b elogind-v246.10.tar.gz
e73738488e78af099fdbb7c93a411a3e8d69080a93f89c245cb8c6de5fe4cb7fe724687d19e21eb6be52ccc795ec200d9c6e499efb1afd2b27467f7f541a7dd1 elogind.initd
-0fda4318afc6db9c9d00121ed4f8267286e692cca04acf4c1006fab99267cdd6228e1d176293f99db043384ae6fa192fc8109a365bf221dda7f2c4177d104820 fix-mips-detection.patch
178c33608f0d69fde8558c521aea9981e0a0bd4a6666d2e1b4f0714dbb7038955ceb86cf323ea741ee67f89218a2e7d332aa05507c2a06eb01fd0785dd81716b fix-version.patch
5cf63f50e8623a4a6e403924860ba76b5dcd19220514c382175afb6f07dbbccc97a27f858ae0c7bc6869f7558255fffc3174e3ac468e5d47333d9cf1db9a5ac1 remove-polkit-gobject-1-check.patch
"
diff --git a/community/elogind/fix-mips-detection.patch b/community/elogind/fix-mips-detection.patch
deleted file mode 100644
index 37069471a7..0000000000
--- a/community/elogind/fix-mips-detection.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/basic/missing_syscall.h b/src/basic/missing_syscall.h
-index ccfa657..20ddb08 100644
---- a/src/basic/missing_syscall.h
-+++ b/src/basic/missing_syscall.h
-@@ -11,7 +11,7 @@
- #include <sys/wait.h>
- #include <unistd.h>
-
--#ifdef ARCH_MIPS
-+#ifdef _MIPS_SIM
- #include <asm/sgidefs.h>
- #endif
-
diff --git a/community/emacs/APKBUILD b/community/emacs/APKBUILD
index ae7b58ebe5..0b2fa76f44 100644
--- a/community/emacs/APKBUILD
+++ b/community/emacs/APKBUILD
@@ -15,7 +15,7 @@ source="https://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.xz
no-git-repo.patch"
case $CARCH in
- mips64|riscv64|s390x)
+ riscv64|s390x)
# limited by librsvg (rust)
_docdir="nox"
;;
@@ -85,7 +85,7 @@ build() {
mv ./* nox || true
case "$CARCH" in
- mips64|riscv64|s390x)
+ riscv64|s390x)
# limited by librsvg (rust)
_build_nox
;;
diff --git a/community/engrampa/APKBUILD b/community/engrampa/APKBUILD
index 6ff74dfa36..cff35c3284 100644
--- a/community/engrampa/APKBUILD
+++ b/community/engrampa/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="An archive manager for the MATE"
url="https://github.com/mate-desktop/engrampa"
-# s390x, mips64 and riscv64 blocked by caja
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by caja
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="libxml2-utils"
makedepends="glib-dev gtk+3.0-dev caja-dev itstool libsm-dev intltool"
diff --git a/community/eog/APKBUILD b/community/eog/APKBUILD
index 1465d0db68..ebaa6290d3 100644
--- a/community/eog/APKBUILD
+++ b/community/eog/APKBUILD
@@ -5,7 +5,7 @@ pkgver=41.1
pkgrel=0
pkgdesc="An image viewer for GNOME"
url="https://wiki.gnome.org/Apps/EyeOfGnome"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
license="GPL-2.0-or-later"
depends="gsettings-desktop-schemas"
depends_dev="gvfs-dev libxml2-dev jpeg-dev libexif-dev lcms2-dev
diff --git a/community/eom/APKBUILD b/community/eom/APKBUILD
index d86a9e99e8..23f6eb230c 100644
--- a/community/eom/APKBUILD
+++ b/community/eom/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="A simple graphics viewer for the MATE"
url="https://github.com/mate-desktop/eom"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
license="GPL-2.0"
depends="mate-icon-theme libxml2-utils"
makedepends="glib-dev gtk+3.0-dev itstool mate-desktop-dev
diff --git a/community/epiphany/APKBUILD b/community/epiphany/APKBUILD
index 4cf5c5d4f5..e8c3c42a8a 100644
--- a/community/epiphany/APKBUILD
+++ b/community/epiphany/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.3
pkgrel=0
pkgdesc="A simple, clean, beautiful view of the web"
url="https://wiki.gnome.org/Apps/Web"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
depends="gsettings-desktop-schemas dbus:org.freedesktop.Secrets"
makedepends="meson iso-codes-dev gtk+3.0-dev gsettings-desktop-schemas-dev
diff --git a/community/eventviews/APKBUILD b/community/eventviews/APKBUILD
index 4f0f5ede43..5465759c9d 100644
--- a/community/eventviews/APKBUILD
+++ b/community/eventviews/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Library for creating events"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by polkit -> akonadi
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by polkit -> akonadi
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="GPL-2.0-or-later"
depends_dev="
diff --git a/community/evince/APKBUILD b/community/evince/APKBUILD
index 70e84906c1..6dfffdd083 100644
--- a/community/evince/APKBUILD
+++ b/community/evince/APKBUILD
@@ -6,8 +6,8 @@ pkgver=41.3
pkgrel=0
pkgdesc="simple document viewer for GTK+"
url="https://wiki.gnome.org/Apps/Evince"
-# s390x, mips64 and riscv64 blocked by librsvg -> adwaita-icon-theme
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> adwaita-icon-theme
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="adwaita-icon-theme gsettings-desktop-schemas"
depends_dev="gtk+3.0-dev poppler-dev libsm-dev libevent-dev libxrandr-dev
diff --git a/community/evolution-data-server/APKBUILD b/community/evolution-data-server/APKBUILD
index 58de72b75b..e7d2fff6b9 100644
--- a/community/evolution-data-server/APKBUILD
+++ b/community/evolution-data-server/APKBUILD
@@ -18,10 +18,6 @@ makedepends="$depends_dev gperf flex bison glib-dev gtk+3.0-dev libsecret-dev
subpackages="$pkgname-dev $pkgname-lang"
source="https://download.gnome.org/sources/evolution-data-server/${pkgver%.*}/evolution-data-server-$pkgver.tar.xz"
-case "$CARCH" in
- mips*) options="$options !check" ;;
-esac
-
build() {
CFLAGS="$CFLAGS -I/usr/include/gnu-libiconv" \
cmake -B build -G Ninja \
diff --git a/community/exempi/APKBUILD b/community/exempi/APKBUILD
index ccf3059d79..f7fa76980a 100644
--- a/community/exempi/APKBUILD
+++ b/community/exempi/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.5.2
pkgrel=2
pkgdesc="A library to parse XMP metadata"
url="https://wiki.freedesktop.org/libopenraw/Exempi/"
-arch="all !s390x !mips !mips64"
+arch="all !s390x"
license="BSD-3-Clause"
makedepends="expat-dev zlib-dev boost-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
diff --git a/community/falkon/APKBUILD b/community/falkon/APKBUILD
index aa0919eff2..ff997c67a5 100644
--- a/community/falkon/APKBUILD
+++ b/community/falkon/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="Cross-platform Qt Web Browser"
url="https://github.com/KDE/falkon"
# armhf blocked by qt5-qtdeclarative
-# mips64, ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
license="GPL-3.0-or-later"
depends="qt5-qtbase-sqlite"
makedepends="
diff --git a/community/faudio/APKBUILD b/community/faudio/APKBUILD
index ba142fce6d..29637e2af6 100644
--- a/community/faudio/APKBUILD
+++ b/community/faudio/APKBUILD
@@ -5,7 +5,7 @@ pkgver=21.07
pkgrel=0
pkgdesc="Accuracy-focused XAudio reimplementation for open platforms"
url="https://fna-xna.github.io/"
-arch="all !mips !mips64"
+arch="all"
license="Zlib"
makedepends="cmake sdl2-dev"
subpackages="$pkgname-dev"
diff --git a/community/ffcall/APKBUILD b/community/ffcall/APKBUILD
index 29b25d4b04..e44977c183 100644
--- a/community/ffcall/APKBUILD
+++ b/community/ffcall/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.4
pkgrel=0
pkgdesc="C library for implementing foreign function calls in embedded interpreters"
url="https://www.gnu.org/software/libffcall"
-arch="all !mips !mips64"
+arch="all"
license="GPL-2.0-or-later"
makedepends="$depends_dev"
subpackages="$pkgname-doc"
diff --git a/community/ffmpeg/APKBUILD b/community/ffmpeg/APKBUILD
index 210a6b679c..d255457938 100644
--- a/community/ffmpeg/APKBUILD
+++ b/community/ffmpeg/APKBUILD
@@ -148,7 +148,6 @@ build() {
case "$CARCH" in
x86) _asm="--disable-asm" ;;
- mips*) _asm="--disable-asm --disable-inline-asm --disable-mipsdsp --disable-mipsdspr2 --disable-msa --disable-msa2 --disable-mipsfpu --disable-mips64r6 --disable-mips64r2" ;;
esac
./configure \
diff --git a/community/ffmpegthumbs/APKBUILD b/community/ffmpegthumbs/APKBUILD
index 57c39d8ecf..3f55b45713 100644
--- a/community/ffmpegthumbs/APKBUILD
+++ b/community/ffmpegthumbs/APKBUILD
@@ -4,8 +4,8 @@ pkgname=ffmpegthumbs
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="FFmpeg-based thumbnail creator for video files"
license="GPL-2.0-or-later"
diff --git a/community/fgt/APKBUILD b/community/fgt/APKBUILD
index f61b864a90..354560ef58 100644
--- a/community/fgt/APKBUILD
+++ b/community/fgt/APKBUILD
@@ -13,9 +13,6 @@ source="https://github.com/gadomski/fgt/archive/v$pkgver/fgt-v$pkgver.tar.gz
0001-Stop-forcing-static-builds.patch
"
-# tests time out
-[ "$CARCH" = "mips64" ] && options="!check"
-
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
diff --git a/community/file-roller/APKBUILD b/community/file-roller/APKBUILD
index 936b1d3b9d..05a03fe656 100644
--- a/community/file-roller/APKBUILD
+++ b/community/file-roller/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.40.0
pkgrel=0
pkgdesc="File Roller is an archive manager for the GNOME desktop "
url="https://wiki.gnome.org/Apps/FileRoller"
-# s390x, mips64 and riscv64 blocked by librsvg -> nautilus
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> nautilus
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="cpio"
makedepends="meson glib-dev gtk+3.0-dev json-glib-dev libnotify-dev libarchive-dev
diff --git a/community/filelight/APKBUILD b/community/filelight/APKBUILD
index 444932ed27..de4be2d7df 100644
--- a/community/filelight/APKBUILD
+++ b/community/filelight/APKBUILD
@@ -4,8 +4,8 @@ pkgname=filelight
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/filelight"
pkgdesc="An application to visualize the disk usage on your computer"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
diff --git a/community/firefox/APKBUILD b/community/firefox/APKBUILD
index 3ea5878ed1..4ee4693311 100644
--- a/community/firefox/APKBUILD
+++ b/community/firefox/APKBUILD
@@ -7,7 +7,7 @@ _releasedate=2022-02-08
pkgrel=1
pkgdesc="Firefox web browser"
url="https://www.firefox.com/"
-# s390x, mips64 and riscv64 blocked by rust and cargo
+# s390x and riscv64 blocked by rust and cargo
# armhf: https://bugzilla.mozilla.org/show_bug.cgi?id=1680495
arch="x86_64 armv7 aarch64 x86 ppc64le"
license="GPL-3.0-only AND LGPL-2.1-only AND LGPL-3.0-only AND MPL-2.0"
diff --git a/community/flatbuffers/APKBUILD b/community/flatbuffers/APKBUILD
index 7f0351c125..09d98230cd 100644
--- a/community/flatbuffers/APKBUILD
+++ b/community/flatbuffers/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Memory Efficient Serialization Library"
url="https://google.github.io/flatbuffers/"
# blocked by bus error in tests
-arch="all !armhf !mips64"
+arch="all !armhf"
license="Apache-2.0"
makedepends="cmake"
subpackages="$pkgname-dev"
diff --git a/community/flatpak-builder/APKBUILD b/community/flatpak-builder/APKBUILD
index 67f3f0f789..3fe11288b6 100644
--- a/community/flatpak-builder/APKBUILD
+++ b/community/flatpak-builder/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="Tool to build flatpaks from source"
options="!check" # Testsuite fails on tests that require FUSE
url="https://flatpak.org"
-# s390x, mips64 and riscv64 blocked by polkit -> flatpak
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> flatpak
+arch="all !s390x !riscv64"
license="LGPL-2.1-or-later"
depends="flatpak git elfutils"
makedepends="flatpak-dev glib-dev libsoup-dev json-glib-dev
diff --git a/community/flatseal/APKBUILD b/community/flatseal/APKBUILD
index 474d862b13..c3e7c9a40a 100644
--- a/community/flatseal/APKBUILD
+++ b/community/flatseal/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.7.5
pkgrel=2
pkgdesc="Permission Manager for Flatpak"
url="https://github.com/tchx84/Flatseal"
-# s390x, mips64 and riscv64 blocked by gjs
-arch="noarch !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by gjs
+arch="noarch !s390x !riscv64"
license="GPL-3.0-or-later"
depends="appstream-glib gjs gtk+3.0 libhandy1 webkit2gtk"
makedepends="gettext glib-dev meson"
diff --git a/community/fluidsynth/APKBUILD b/community/fluidsynth/APKBUILD
index 9f02a033a7..aa3c0a880c 100644
--- a/community/fluidsynth/APKBUILD
+++ b/community/fluidsynth/APKBUILD
@@ -26,7 +26,7 @@ subpackages="$pkgname-dev $pkgname-doc"
# tests are broken on s390x
case "$CARCH" in
- s390x|mips64) options="!check"
+ s390x) options="!check"
esac
build() {
diff --git a/community/font-manager/APKBUILD b/community/font-manager/APKBUILD
index 4736f8dae1..05995c8447 100644
--- a/community/font-manager/APKBUILD
+++ b/community/font-manager/APKBUILD
@@ -30,7 +30,7 @@ subpackages="$pkgname-doc
$pkgname-thunar:ext_thunar"
case "$CARCH" in
- s390x|mips64|ppc64le|riscv64)
+ s390x|ppc64le|riscv64)
_enable_nemo=false
_enable_nautilus=false
;;
diff --git a/community/font-noto-emoji/APKBUILD b/community/font-noto-emoji/APKBUILD
index 49f5052a55..3cf20c93e3 100644
--- a/community/font-noto-emoji/APKBUILD
+++ b/community/font-noto-emoji/APKBUILD
@@ -8,7 +8,7 @@ _commit="9a5261d871451f9b5183c93483cbd68ed916b1e9"
pkgrel=0
pkgdesc="Google Noto emoji fonts"
url="https://github.com/googlefonts/noto-emoji"
-arch="noarch !mips !mips64" # fails to build on mips
+arch="noarch"
license="OFL-1.1"
makedepends="
bash
diff --git a/community/frameworkintegration/APKBUILD b/community/frameworkintegration/APKBUILD
index 0c7a874fa5..77a5706654 100644
--- a/community/frameworkintegration/APKBUILD
+++ b/community/frameworkintegration/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=1
pkgdesc="Framework providing components to allow applications to integrate with a KDE Workspace"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> knewstuff
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> knewstuff
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/freeimage/APKBUILD b/community/freeimage/APKBUILD
index 5642935697..e1f583a46c 100644
--- a/community/freeimage/APKBUILD
+++ b/community/freeimage/APKBUILD
@@ -6,7 +6,7 @@ pkgver=3.18.0
pkgrel=2
pkgdesc="Open Source library project for developers who would like to support popular graphics image formats."
url="http://freeimage.sourceforge.net/"
-arch="all !s390x !mips64" # build fails on s390x and mips64
+arch="all !s390x" # build fails on s390x
license="GPL-2.0-or-later FIPL"
makedepends="dos2unix"
subpackages="$pkgname-dev"
diff --git a/community/fs-uae-launcher/APKBUILD b/community/fs-uae-launcher/APKBUILD
index 1a374a71b1..c2b95e1676 100644
--- a/community/fs-uae-launcher/APKBUILD
+++ b/community/fs-uae-launcher/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.0.5
pkgrel=0
pkgdesc="FS-UAE emulator launcher."
url="https://fs-uae.net/launcher"
-arch="noarch !armhf !armv7 !aarch64 !s390x !mips !mips64" # fs-uae not avail
+arch="noarch !armhf !armv7 !aarch64 !s390x" # fs-uae not avail
license="GPL-2.0-only"
depends="fs-uae~$pkgver py3-qt5 py3-sip-pyqt5"
makedepends="py3-setuptools gettext"
diff --git a/community/fs-uae/APKBUILD b/community/fs-uae/APKBUILD
index 4c4ef8f619..957d0daf0c 100644
--- a/community/fs-uae/APKBUILD
+++ b/community/fs-uae/APKBUILD
@@ -6,7 +6,7 @@ pkgver=3.0.5
pkgrel=0
pkgdesc="Amiga emulator."
url="https://fs-uae.net/"
-arch="all !armhf !armv7 !aarch64 !s390x !mips64" # --enable-jit not supported for these arches
+arch="all !armhf !armv7 !aarch64 !s390x" # --enable-jit not supported for these arches
license="GPL-2.0-only"
makedepends="zip sdl2-dev libpng-dev libx11-dev libxi-dev openal-soft-dev linux-headers libmpeg2-dev glib-dev"
subpackages="$pkgname-lang"
diff --git a/community/fwupd-efi/APKBUILD b/community/fwupd-efi/APKBUILD
index b93371f146..b0b250dd05 100644
--- a/community/fwupd-efi/APKBUILD
+++ b/community/fwupd-efi/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.1
pkgrel=1
pkgdesc="EFI application used by uefi-capsule plugin in fwupd"
url="https://github.cm/fwupd/fwupd-efi"
-arch="all !armhf !ppc64le !s390x !mips64" # limited by gnu-efi
+arch="all !armhf !ppc64le !s390x" # limited by gnu-efi
arch="$arch !riscv64" # upstream does not recognize it
license="LGPL-3.0-or-later"
makedepends="meson gnu-efi-dev"
diff --git a/community/gcc-cross-embedded-stage1/APKBUILD b/community/gcc-cross-embedded-stage1/APKBUILD
index 1ed52de6be..9954246fac 100644
--- a/community/gcc-cross-embedded-stage1/APKBUILD
+++ b/community/gcc-cross-embedded-stage1/APKBUILD
@@ -15,7 +15,7 @@ _targets="
"
# or1k-elf fails to build on 32-bit architectures
case "$CARCH" in
- x86_64|aarch64|ppc64le|mips64) _targets="$_targets or1k-elf"
+ x86_64|aarch64|ppc64le) _targets="$_targets or1k-elf"
esac
pkgname=gcc-cross-embedded-stage1
pkgver=11.2.0
diff --git a/community/gcc-cross-embedded/APKBUILD b/community/gcc-cross-embedded/APKBUILD
index 20fefffe5f..15a96a39fe 100644
--- a/community/gcc-cross-embedded/APKBUILD
+++ b/community/gcc-cross-embedded/APKBUILD
@@ -16,7 +16,7 @@ _targets="
"
# or1k-elf fails to build on 32-bit architectures
case "$CARCH" in
- x86_64|aarch64|ppc64le|mips64) _targets="$_targets or1k-elf"
+ x86_64|aarch64|ppc64le) _targets="$_targets or1k-elf"
esac
pkgname=gcc-cross-embedded
pkgver=11.2.0
@@ -25,7 +25,7 @@ pkgdesc="The GNU Compiler Collection for embedded targets"
url="https://gcc.gnu.org/"
depends="gcc"
makedepends="bash linux-headers gmp-dev mpfr-dev mpc1-dev zlib-dev isl-dev"
-arch="all !s390x !mips !mips64 !riscv64" # fails on s390x and mips with error message:
+arch="all !s390x !riscv64" # fails on s390x with error message:
# 'internal compiler error: Segmentation fault'
license="GPL-3.0-or-later"
for target in $_targets; do
diff --git a/community/gcc6/APKBUILD b/community/gcc6/APKBUILD
index 3f9448dc08..d984a4b1ae 100644
--- a/community/gcc6/APKBUILD
+++ b/community/gcc6/APKBUILD
@@ -7,8 +7,7 @@ pkgrel=12 # Update java-gcj-compat _gccpkgrel so it matchs!
pkgdesc="The GNU Compiler Collection"
url="https://gcc.gnu.org/"
# riscv64: Support for RISC-V was added in GCC7
-# mips: FTBFS
-arch="all !mips !mips64 !riscv64"
+arch="all !riscv64"
license="GPL LGPL"
_gccrel=$pkgver-r$pkgrel
depends="binutils isl"
diff --git a/community/gcompat/APKBUILD b/community/gcompat/APKBUILD
index c4dee85f3d..e676e1c990 100644
--- a/community/gcompat/APKBUILD
+++ b/community/gcompat/APKBUILD
@@ -19,7 +19,6 @@ case "$CARCH" in
aarch64) _ld="ld-linux-aarch64.so.1" ;;
x86) _ld="ld-linux.so.2" ;;
x86_64) _ld="ld-linux-x86-64.so.2" ;;
- mips*) _ld="ld.so.1" ;;
s390x) _ld="ld64.so.1" ;;
ppc64le) _ld="ld64.so.2" ;;
esac
@@ -32,8 +31,6 @@ case "$CARCH" in
ppc) ARCH="powerpc" ;;
ppc64*) ARCH="powerpc64" ;;
s390*) ARCH="s390x" ;;
- mips64*) ARCH="mips64" ;;
- mips*) ARCH="mips" ;;
riscv64) ARCH="riscv64" ;;
esac
@@ -56,7 +53,7 @@ package() {
# Required symlink on 64-bit platforms
case "$CARCH" in
- x86_64|ppc64le|mips64|aarch64)
+ x86_64|ppc64le|aarch64)
mkdir "$pkgdir"/lib64
ln -s ../lib/$_ld "$pkgdir"/lib64/$_ld
;;
diff --git a/community/gdm/APKBUILD b/community/gdm/APKBUILD
index c6b14af1e5..902be41c56 100644
--- a/community/gdm/APKBUILD
+++ b/community/gdm/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.3
pkgrel=0
pkgdesc="GNOME display manager"
url="https://wiki.gnome.org/Projects/GDM"
-# s390x, mips64 and riscv64 blocked by polkit -> upower
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> upower
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="dbus
dconf
diff --git a/community/gegl/APKBUILD b/community/gegl/APKBUILD
index 607ca7ae8d..c439a64db2 100644
--- a/community/gegl/APKBUILD
+++ b/community/gegl/APKBUILD
@@ -4,8 +4,8 @@ pkgver=0.4.34
pkgrel=0
pkgdesc="Graph based image processing framework"
url="https://www.gegl.org/"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later AND LGPL-3.0-or-later"
makedepends="babl-dev bash gobject-introspection-dev libpng-dev
libjpeg-turbo-dev gtk+-dev librsvg-dev lua5.1-dev gexiv2-dev
diff --git a/community/geoclue/APKBUILD b/community/geoclue/APKBUILD
index 0fb2162017..1c8803e80d 100644
--- a/community/geoclue/APKBUILD
+++ b/community/geoclue/APKBUILD
@@ -26,7 +26,7 @@ source="
"
case "$CARCH" in
- s390x|mips64|riscv64)
+ s390x|riscv64)
_arch_opts="-D3g-source=false -Dcdma-source=false -Dmodem-gps-source=false"
;;
*)
diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
index 1952127cdf..0079a107dc 100644
--- a/community/geth/APKBUILD
+++ b/community/geth/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.10.13
pkgrel=1
pkgdesc="Official Go implementation of the Ethereum protocol"
url="https://geth.ethereum.org/"
-arch="all !aarch64 !mips64" # build fails
+arch="all !aarch64" # build fails
license="LGPL-3.0-or-later"
makedepends="go linux-headers"
checkdepends="fuse"
diff --git a/community/gimp/APKBUILD b/community/gimp/APKBUILD
index 93aee1ce42..199c2d18ab 100644
--- a/community/gimp/APKBUILD
+++ b/community/gimp/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.10.30
pkgrel=0
pkgdesc="GNU Image Manipulation Program"
url="https://www.gimp.org/"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
license="GPL-3.0-or-later"
depends="dbus"
makedepends="gtk+-dev libxpm-dev libxmu-dev librsvg-dev dbus-glib-dev
diff --git a/community/ginkgo/APKBUILD b/community/ginkgo/APKBUILD
index 106481676e..54774205fa 100644
--- a/community/ginkgo/APKBUILD
+++ b/community/ginkgo/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=1
pkgdesc="BDD-style Go testing framework"
url="https://onsi.github.io/ginkgo/"
license="MIT"
-arch="all !armhf !mips64" # test failures
+arch="all !armhf" # test failures
options="chmod-clean"
makedepends="go"
source="https://github.com/onsi/ginkgo/archive/v$pkgver/ginkgo-$pkgver.tar.gz
diff --git a/community/git-interactive-rebase-tool/APKBUILD b/community/git-interactive-rebase-tool/APKBUILD
index 4d1f8667b4..0907ba306c 100644
--- a/community/git-interactive-rebase-tool/APKBUILD
+++ b/community/git-interactive-rebase-tool/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.1.0
pkgrel=2
pkgdesc="A terminal based sequence editor for interactive rebase"
url="https://gitrebasetool.mitmaro.ca"
-arch="all !s390x !mips64 !riscv64" # limited by rust/cargo
+arch="all !s390x !riscv64" # limited by rust/cargo
license="GPL-3.0-or-later"
makedepends="cargo libgit2-dev zlib-dev"
subpackages="$pkgname-doc"
diff --git a/community/gjs/APKBUILD b/community/gjs/APKBUILD
index 2cb76da5c3..d0d9e7c6f4 100644
--- a/community/gjs/APKBUILD
+++ b/community/gjs/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.70.1
pkgrel=0
pkgdesc="GNOME javascript library"
url="https://wiki.gnome.org/Projects/Gjs"
-# s390x, mips64 and riscv64 blocked by mozjs78
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by mozjs78
+arch="all !s390x !riscv64"
license="MIT AND LGPL-2.0-or-later"
makedepends="dbus gobject-introspection-dev mozjs78-dev mozjs78
gtk+3.0-dev cairo-dev meson libffi>=3.3"
diff --git a/community/gkraken/APKBUILD b/community/gkraken/APKBUILD
index b066b68e64..9d40fb4582 100644
--- a/community/gkraken/APKBUILD
+++ b/community/gkraken/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.14.5
pkgrel=2
pkgdesc="GUI that allows to control cooling of NZXT Kraken X pumps from Linux"
url="https://gitlab.com/leinardi/gkraken"
-arch="noarch !mips !mips64"
+arch="noarch"
license="GPL-3.0-or-later"
depends="python3 libdazzle libnotify py3-gobject3 py3-rx liquidctl py3-injector
py3-matplotlib py3-peewee py3-xdg"
diff --git a/community/glib-networking/APKBUILD b/community/glib-networking/APKBUILD
index a0e51b9988..9c87944226 100644
--- a/community/glib-networking/APKBUILD
+++ b/community/glib-networking/APKBUILD
@@ -20,7 +20,7 @@ source="https://download.gnome.org/sources/glib-networking/${pkgver%.*}/glib-net
# - CVE-2020-13645
case "$CARCH" in
- s390x|mips64) options="!check" # timeout
+ s390x) options="!check" # timeout
;;
esac
diff --git a/community/gnome-applets/APKBUILD b/community/gnome-applets/APKBUILD
index 1178286b12..cc60d65ebb 100644
--- a/community/gnome-applets/APKBUILD
+++ b/community/gnome-applets/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.40.0
pkgrel=0
pkgdesc="Small programs for the panel"
url="https://wiki.gnome.org/Projects/GnomeApplets"
-# s390x, mips64 and riscv64 blocked by polkit -> upower
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> upower
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="adwaita-icon-theme"
makedepends="gtk+3.0-dev glib-dev libgtop-dev libwnck3-dev libnotify-dev upower-dev
diff --git a/community/gnome-authenticator/APKBUILD b/community/gnome-authenticator/APKBUILD
index 1432c4d387..cf10b5d328 100644
--- a/community/gnome-authenticator/APKBUILD
+++ b/community/gnome-authenticator/APKBUILD
@@ -5,9 +5,9 @@ pkgver=4.0.3
pkgrel=1
pkgdesc="Two-Factor Authentication application"
url="https://gitlab.gnome.org/World/Authenticator"
-# s390x, mips64, riscv64 blocked by libadwaita
+# s390x, riscv64 blocked by libadwaita
# x86, ppc64le building dependency ring v0.16.20 fails
-arch="all !s390x !mips64 !riscv64 !x86 !ppc64le"
+arch="all !s390x !riscv64 !x86 !ppc64le"
license="GPL-3.0-only"
makedepends="meson cargo gstreamer-dev gst-plugins-bad-dev gst-plugins-base-dev gtk4.0-dev libadwaita-dev zbar-dev"
checkdepends="appstream-glib desktop-file-utils"
diff --git a/community/gnome-books/APKBUILD b/community/gnome-books/APKBUILD
index 39d08f1d75..b949916488 100644
--- a/community/gnome-books/APKBUILD
+++ b/community/gnome-books/APKBUILD
@@ -5,7 +5,7 @@ pkgver=40.0
pkgrel=0
pkgdesc="GNOME Ebook Manager"
url="https://wiki.gnome.org/Apps/Books"
-arch="all !s390x !mips !mips64 !riscv64" # limited by gjs and librsvg
+arch="all !s390x !riscv64" # limited by gjs and librsvg
license="LGPL-2.0-or-later"
depends="gsettings-desktop-schemas libgepub tracker-miners"
makedepends="meson gjs-dev evince-dev gnome-desktop-dev gtk+3.0-dev glib-dev
diff --git a/community/gnome-calculator/APKBUILD b/community/gnome-calculator/APKBUILD
index f86c8094ba..1b68926ffb 100644
--- a/community/gnome-calculator/APKBUILD
+++ b/community/gnome-calculator/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.1
pkgrel=0
pkgdesc="Calculator for solving mathematical equations"
url="https://wiki.gnome.org/Apps/Calculator"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
makedepends="vala gtksourceview4-dev glib-dev gtk+3.0-dev libsoup-dev
libxml2-dev meson mpc1-dev mpfr-dev itstool libgee-dev libhandy1-dev"
diff --git a/community/gnome-characters/APKBUILD b/community/gnome-characters/APKBUILD
index 6b8e0924ba..5d444b51cf 100644
--- a/community/gnome-characters/APKBUILD
+++ b/community/gnome-characters/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="A simple utility application to find and insert unusual characters"
url="https://wiki.gnome.org/Design/Apps/CharacterMap"
-# s390x, mips64 and riscv64 blocked by gjs
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by gjs
+arch="all !s390x !riscv64"
license="BSD-3-Clause AND GPL-2.0-or-later"
makedepends="meson gjs-dev glib-dev pango-dev gtk+3.0-dev libunistring-dev
libhandy1-dev"
diff --git a/community/gnome-chess/APKBUILD b/community/gnome-chess/APKBUILD
index 340716b486..711c22698e 100644
--- a/community/gnome-chess/APKBUILD
+++ b/community/gnome-chess/APKBUILD
@@ -3,7 +3,7 @@
pkgname=gnome-chess
pkgver=41.1
pkgrel=0
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
url="https://wiki.gnome.org/Apps/Chess"
pkgdesc="Play the classic two-player boardgame of chess"
license="GPL-3.0-or-later"
diff --git a/community/gnome-clocks/APKBUILD b/community/gnome-clocks/APKBUILD
index 2859ea83cb..f7df0b2f63 100644
--- a/community/gnome-clocks/APKBUILD
+++ b/community/gnome-clocks/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="Clock application designed for GNOME 3"
url="https://wiki.gnome.org/Apps/Clocks"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="gsettings-desktop-schemas waked"
makedepends="meson glib-dev gtk+3.0-dev libgweather-dev gsound-dev gnome-desktop-dev
diff --git a/community/gnome-control-center/APKBUILD b/community/gnome-control-center/APKBUILD
index 85b7251bf2..aeadc9db1e 100644
--- a/community/gnome-control-center/APKBUILD
+++ b/community/gnome-control-center/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.2
pkgrel=2
pkgdesc="GNOME control center"
url="https://gitlab.gnome.org/GNOME/gnome-control-center"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="colord cups-pk-helper openrc-settingsd dbus:org.freedesktop.Secrets"
makedepends="
diff --git a/community/gnome-disk-utility/APKBUILD b/community/gnome-disk-utility/APKBUILD
index ff52e344ec..6c2862a941 100644
--- a/community/gnome-disk-utility/APKBUILD
+++ b/community/gnome-disk-utility/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="GNOME libraries and applications for dealing with storage devices"
url="https://wiki.gnome.org/Apps/Disks"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
# Uses udisks_client that calls dbus /org/freedesktop/UDisks2/Manager
depends="gptfdisk parted udisks2"
diff --git a/community/gnome-flashback/APKBUILD b/community/gnome-flashback/APKBUILD
index ff301342c3..e09eca5183 100644
--- a/community/gnome-flashback/APKBUILD
+++ b/community/gnome-flashback/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.40.0
pkgrel=0
pkgdesc="GNOME Flashback is a GNOME session providing a similiar experience to GNOME 2.x"
url="https://wiki.gnome.org/Projects/GnomeFlashback"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="gsettings-desktop-schemas xkeyboard-config"
makedepends="gtk+3.0-dev gnome-desktop-dev gnome-panel-dev libcanberra-dev
diff --git a/community/gnome-font-viewer/APKBUILD b/community/gnome-font-viewer/APKBUILD
index 5d72d9a4c9..291ef24b48 100644
--- a/community/gnome-font-viewer/APKBUILD
+++ b/community/gnome-font-viewer/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="View fonts on your system"
url="https://gitlab.gnome.org/GNOME/gnome-font-viewer"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
makedepends="glib-dev gtk+3.0-dev harfbuzz-dev fontconfig-dev freetype-dev
gnome-desktop-dev meson libhandy1-dev"
diff --git a/community/gnome-games/APKBUILD b/community/gnome-games/APKBUILD
index 49ab37af91..465e183526 100644
--- a/community/gnome-games/APKBUILD
+++ b/community/gnome-games/APKBUILD
@@ -5,8 +5,8 @@ pkgver=40.0
pkgrel=0
pkgdesc="Browse and play your games"
url="https://wiki.gnome.org/Apps/Games"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
makedepends="meson gtk+3.0-dev vala grilo-dev libhandy1-dev librsvg-dev libmanette-dev
libsoup-dev tracker-dev sqlite-dev libxml2-dev libarchive-dev retro-gtk-dev"
diff --git a/community/gnome-maps/APKBUILD b/community/gnome-maps/APKBUILD
index 3f373bf289..09477a26a2 100644
--- a/community/gnome-maps/APKBUILD
+++ b/community/gnome-maps/APKBUILD
@@ -5,7 +5,7 @@ pkgver=41.1
pkgrel=1
pkgdesc="simple map client"
url="https://wiki.gnome.org/Apps/Maps"
-arch="all !s390x !mips !mips64 !riscv64" # limited by gjs
+arch="all !s390x !riscv64" # limited by gjs
license="GPL-2.0-or-later"
depends="gfbgraph gjs geoclue libhandy1"
makedepends="meson glib-dev gjs-dev gtk+3.0-dev gobject-introspection-dev geoclue-dev
diff --git a/community/gnome-mines/APKBUILD b/community/gnome-mines/APKBUILD
index 51f61db84c..c675632b7b 100644
--- a/community/gnome-mines/APKBUILD
+++ b/community/gnome-mines/APKBUILD
@@ -3,7 +3,7 @@
pkgname=gnome-mines
pkgver=40.0
pkgrel=1
-arch="all !s390x !mips !mips64 !riscv64" # librsvg
+arch="all !s390x !riscv64" # librsvg
url="https://wiki.gnome.org/Apps/Mines"
pkgdesc="Clear hidden mines from a minefield"
license="GPL-3.0-or-later"
diff --git a/community/gnome-music/APKBUILD b/community/gnome-music/APKBUILD
index ccf05860e6..f7bbf7d9e7 100644
--- a/community/gnome-music/APKBUILD
+++ b/community/gnome-music/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=1
pkgdesc="Music is the new GNOME music playing application"
url="https://wiki.gnome.org/Apps/Music"
-# s390x, mips64 and riscv64 blocked by polkit -> tracker
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> tracker
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="grilo grilo-plugins gnome-online-accounts libdazzle libsoup py3-gobject3
tracker libmediaart py3-cairo gst-plugins-good tracker-miners"
diff --git a/community/gnome-obfuscate/APKBUILD b/community/gnome-obfuscate/APKBUILD
index b9900af39e..76cb8d9169 100644
--- a/community/gnome-obfuscate/APKBUILD
+++ b/community/gnome-obfuscate/APKBUILD
@@ -5,8 +5,8 @@ pkgver="0.0.2"
pkgrel=1
pkgdesc="Censor private information"
url="https://gitlab.gnome.org/World/obfuscate"
-# s390x, mips64 and riscv64 blocked by cargo/rust
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by cargo/rust
+arch="all !s390x !riscv64"
license="MIT"
makedepends="meson cargo gtk+3.0-dev"
checkdepends="desktop-file-utils appstream-glib"
diff --git a/community/gnome-panel/APKBUILD b/community/gnome-panel/APKBUILD
index 9b979e4b38..461d293f44 100644
--- a/community/gnome-panel/APKBUILD
+++ b/community/gnome-panel/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.40.0
pkgrel=0
pkgdesc="Gnome Panel provides panels and default applets for the gnome-flashback desktop"
url="https://wiki.gnome.org/Projects/GnomePanel"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="gnome-desktop gtk+3.0-dev glib-dev pango-dev libwnck3-dev
gnome-menus-dev evolution-data-server-dev libgweather-dev dconf-dev
diff --git a/community/gnome-passwordsafe/APKBUILD b/community/gnome-passwordsafe/APKBUILD
index 1a3732d3eb..03a51ed0a9 100644
--- a/community/gnome-passwordsafe/APKBUILD
+++ b/community/gnome-passwordsafe/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.0
pkgrel=3
pkgdesc="A password manager for GNOME"
url="https://gitlab.gnome.org/World/secrets"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="noarch !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="noarch !s390x !riscv64"
license="GPL-3.0-only"
depends="python3 py3-keepass>=3.2.1 py3-pycryptodomex libhandy1 py3-libpwquality py3-gobject3"
makedepends="meson gtk+3.0-dev libhandy1-dev libpwquality-dev gobject-introspection-dev"
diff --git a/community/gnome-photos/APKBUILD b/community/gnome-photos/APKBUILD
index 606699837d..493c01bbfa 100644
--- a/community/gnome-photos/APKBUILD
+++ b/community/gnome-photos/APKBUILD
@@ -5,8 +5,8 @@ pkgver=40.0
pkgrel=0
pkgdesc="Access, organize and share your photos on GNOME"
url="https://wiki.gnome.org/Apps/Photos"
-# s390x, mips64 and riscv64 blocked by librsvg -> gegl
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> gegl
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
depends="gsettings-desktop-schemas tracker-miners"
makedepends="meson babl-dev cairo-dev gtk+3.0-dev gexiv2-dev glib-dev
diff --git a/community/gnome-podcasts/APKBUILD b/community/gnome-podcasts/APKBUILD
index bf702433dc..22678ce850 100644
--- a/community/gnome-podcasts/APKBUILD
+++ b/community/gnome-podcasts/APKBUILD
@@ -7,8 +7,8 @@ pkgdesc="Podcast app for GNOME"
url="https://wiki.gnome.org/Apps/Podcasts"
# x86 blocked by crashing Rust
# armv7 blocked by failing test
-# s390x, mips64 and riscv64 blocked by rust/cargo
-arch="all !s390x !mips64 !armv7 !riscv64"
+# s390x and riscv64 blocked by rust/cargo
+arch="all !s390x !armv7 !riscv64"
license="GPL-3.0-or-later"
depends="gst-plugins-good"
makedepends="meson gtk+3.0-dev gstreamer-dev libhandy1-dev sqlite-dev openssl1.1-compat-dev
diff --git a/community/gnome-power-manager/APKBUILD b/community/gnome-power-manager/APKBUILD
index ef4b56ad95..193a233261 100644
--- a/community/gnome-power-manager/APKBUILD
+++ b/community/gnome-power-manager/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.32.0
pkgrel=2
pkgdesc="GNOME power manager"
url="https://gitlab.gnome.org/GNOME/gnome-power-manager"
-# s390x, mips64 and riscv64 blocked by polkit -> upower
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> upower
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="intltool gobject-introspection-dev upower-dev gtk+3.0-dev meson"
subpackages="$pkgname-lang"
diff --git a/community/gnome-remote-desktop/APKBUILD b/community/gnome-remote-desktop/APKBUILD
index 048fe0f796..a3852a8956 100644
--- a/community/gnome-remote-desktop/APKBUILD
+++ b/community/gnome-remote-desktop/APKBUILD
@@ -5,7 +5,7 @@ pkgver=41.0
pkgrel=0
pkgdesc="GNOME Remote Desktop - remove desktop server"
url="https://gitlab.gnome.org/jadahl/gnome-remote-desktop"
-arch="all !s390x !mips64" # blocked by pipewire
+arch="all !s390x" # blocked by pipewire
license="GPL-2.0-or-later"
makedepends="meson glib-dev pipewire-dev elogind-dev libsecret-dev libnotify-dev
libvncserver-dev freerdp-dev cairo-dev fuse3-dev libxkbcommon-dev"
diff --git a/community/gnome-screenshot/APKBUILD b/community/gnome-screenshot/APKBUILD
index 0fdb75a8dc..aa233d24d2 100644
--- a/community/gnome-screenshot/APKBUILD
+++ b/community/gnome-screenshot/APKBUILD
@@ -5,8 +5,8 @@ pkgver=40.0
pkgrel=0
pkgdesc="Screenshot capture utility for GNOME"
url="https://gitlab.gnome.org/GNOME/gnome-screenshot"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy1
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy1
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="desktop-file-utils"
makedepends="meson libcanberra-dev glib-dev itstool appstream-glib-dev
diff --git a/community/gnome-session/APKBUILD b/community/gnome-session/APKBUILD
index 626a77d4de..4ed79a6c2c 100644
--- a/community/gnome-session/APKBUILD
+++ b/community/gnome-session/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.3
pkgrel=0
pkgdesc="GNOME session manager"
url="https://gitlab.gnome.org/GNOME/gnome-session"
-# s390x, mips64 and riscv64 blocked by polkit -> upower
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> upower
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="alsa-plugins-pulse
bash
diff --git a/community/gnome-settings-daemon/APKBUILD b/community/gnome-settings-daemon/APKBUILD
index a532927c09..fa37f8873e 100644
--- a/community/gnome-settings-daemon/APKBUILD
+++ b/community/gnome-settings-daemon/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=1
pkgdesc="GNOME settings daemon"
url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
-# s390x, mips64 and riscv64 blocked by polkit -> upower
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> upower
+arch="all !s390x !riscv64"
options="!check" # needs unpackaged py-dbusmock
license="GPL-2.0-only AND LGPL-2.1-only"
depends_dev="gnome-desktop-dev libnotify-dev
diff --git a/community/gnome-shell-extensions/APKBUILD b/community/gnome-shell-extensions/APKBUILD
index ed83747ffe..426070bc3e 100644
--- a/community/gnome-shell-extensions/APKBUILD
+++ b/community/gnome-shell-extensions/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="collection of extensions for GNOME Shell"
url="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
-# s390x, mips64 and riscv64 blocked by mozjs78
-arch="noarch !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by mozjs78
+arch="noarch !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="meson sassc mozjs78-dev gettext-dev"
subpackages="$pkgname-lang"
diff --git a/community/gnome-shortwave/APKBUILD b/community/gnome-shortwave/APKBUILD
index a92849749f..d32e68bac0 100644
--- a/community/gnome-shortwave/APKBUILD
+++ b/community/gnome-shortwave/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.1.1
pkgrel=2
pkgdesc="Listen to internet radio"
url="https://gitlab.gnome.org/World/Shortwave"
-# s390x, mips64 and riscv64 blocked by rust/cargo
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust/cargo
+arch="all !s390x !riscv64"
license="GPL-3.0-only"
depends="gst-libav gst-plugins-bad gst-plugins-good"
makedepends="meson gettext cargo glib-dev gtk+3.0-dev libhandy-dev gstreamer-dev
diff --git a/community/gnome-software/APKBUILD b/community/gnome-software/APKBUILD
index e65518b22a..4768a3da84 100644
--- a/community/gnome-software/APKBUILD
+++ b/community/gnome-software/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.3
pkgrel=0
pkgdesc="Software lets you install and update applications and system extensions"
url="https://wiki.gnome.org/Apps/Software"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="gnome-software-plugin-apk"
makedepends="meson appstream-dev gdk-pixbuf-dev libxmlb-dev glib-dev gtk+3.0-dev
diff --git a/community/gnome-sound-recorder/APKBUILD b/community/gnome-sound-recorder/APKBUILD
index 752bc37e68..549684c8c1 100644
--- a/community/gnome-sound-recorder/APKBUILD
+++ b/community/gnome-sound-recorder/APKBUILD
@@ -5,7 +5,7 @@ pkgver=40.0
pkgrel=1
pkgdesc="simple and modern sound recorder"
url="https://wiki.gnome.org/Apps/SoundRecorder"
-arch="noarch !s390x !mips !mips64 !riscv64" # limited by gjs
+arch="noarch !s390x !riscv64" # limited by gjs
license="GPL-2.0-or-later"
makedepends="gjs-dev glib-dev gtk+3.0-dev gobject-introspection-dev meson
gst-plugins-bad-dev libhandy1-dev"
diff --git a/community/gnome-system-monitor/APKBUILD b/community/gnome-system-monitor/APKBUILD
index 83b8336a15..5b48817bee 100644
--- a/community/gnome-system-monitor/APKBUILD
+++ b/community/gnome-system-monitor/APKBUILD
@@ -5,7 +5,7 @@ pkgver=41.0
pkgrel=0
pkgdesc="GNOME system monitor"
url="https://www.gnome.org/"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
license="GPL-2.0-or-later"
makedepends="gnome-desktop-dev libgtop-dev gtkmm3-dev
libxml2-dev librsvg-dev itstool libxml2-utils libxslt
diff --git a/community/gnome-taquin/APKBUILD b/community/gnome-taquin/APKBUILD
index 53654d3a4f..eba5c74bb3 100644
--- a/community/gnome-taquin/APKBUILD
+++ b/community/gnome-taquin/APKBUILD
@@ -3,7 +3,7 @@
pkgname=gnome-taquin
pkgver=3.38.1
pkgrel=1
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
url="https://wiki.gnome.org/Apps/Taquin"
pkgdesc="Move tiles so that they reach their places"
license="GPL-3.0-or-later AND CC-BY-SA-3.0"
diff --git a/community/gnome-terminal/APKBUILD b/community/gnome-terminal/APKBUILD
index 09d6938b6d..3d88baaed1 100644
--- a/community/gnome-terminal/APKBUILD
+++ b/community/gnome-terminal/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.42.0
pkgrel=0
pkgdesc="GNOME terminal emulator application"
url="https://wiki.gnome.org/Apps/Terminal"
-# s390x, mips64 and riscv64 blocked by polkit -> gnome-shell
-arch="all !s390x !armhf !ppc64le !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> gnome-shell
+arch="all !s390x !armhf !ppc64le !riscv64"
license="GPL-2.0-or-later AND GFDL-1.3-only"
depends="dbus desktop-file-utils gsettings-desktop-schemas ncurses-terminfo-base"
makedepends="meson dconf-dev gnome-shell gsettings-desktop-schemas-dev nautilus-dev vte3-dev
diff --git a/community/gnome-themes-extra/APKBUILD b/community/gnome-themes-extra/APKBUILD
index e23f009ba9..c4db4e8edd 100644
--- a/community/gnome-themes-extra/APKBUILD
+++ b/community/gnome-themes-extra/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.28
pkgrel=3
pkgdesc="Misc themes and theme-y tidbits"
url="https://gitlab.gnome.org/GNOME/gnome-themes-extra"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="noarch !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="noarch !s390x !riscv64"
license="LGPL-2.1-only"
depends="ttf-cantarell librsvg"
makedepends="intltool gtk+3.0-dev librsvg-dev gnome-common automake autoconf
diff --git a/community/gnome-tour/APKBUILD b/community/gnome-tour/APKBUILD
index 5331c5d263..7795e68f5d 100644
--- a/community/gnome-tour/APKBUILD
+++ b/community/gnome-tour/APKBUILD
@@ -5,8 +5,8 @@ pkgver=40.0
pkgrel=0
pkgdesc="GNOME Tour & Greeter"
url="https://gitlab.gnome.org/GNOME/gnome-tour"
-# s390x, mips64 and riscv64 blocked by cargo
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by cargo
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
makedepends="meson cargo glib-dev gtk+3.0-dev libhandy1-dev"
checkdepends="appstream-glib desktop-file-utils"
diff --git a/community/gnome-tweaks/APKBUILD b/community/gnome-tweaks/APKBUILD
index 6e52052ca0..a9a30d289d 100644
--- a/community/gnome-tweaks/APKBUILD
+++ b/community/gnome-tweaks/APKBUILD
@@ -5,9 +5,9 @@ pkgver=40.0
pkgrel=2
pkgdesc="GNOME3 tool to customize advanced options"
url="https://wiki.gnome.org/Apps/Tweaks"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy
+# s390x and riscv64 blocked by rust -> libhandy
# armv7 blocked by mutter
-arch="noarch !s390x !armv7 !mips64 !riscv64"
+arch="noarch !s390x !armv7 !riscv64"
license="GPL-3.0-or-later CC0-1.0"
depends="gtk+3.0 dconf gnome-settings-daemon mutter-schemas libnotify py3-gobject3
libhandy1"
diff --git a/community/gnome-usage/APKBUILD b/community/gnome-usage/APKBUILD
index 973d1fa8b6..bdbe38c23a 100644
--- a/community/gnome-usage/APKBUILD
+++ b/community/gnome-usage/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.38.1
pkgrel=0
pkgdesc="System resources status"
url="https://wiki.gnome.org/Apps/Usage"
-# s390x, mips64 and riscv64 blocked by polkit -> tracker
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> tracker
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later"
makedepends="meson glib-dev gtk+3.0-dev libdazzle-dev libgtop-dev vala
libhandy1-dev tracker-dev"
diff --git a/community/gnome-weather/APKBUILD b/community/gnome-weather/APKBUILD
index c3b29faf6b..c7bd669d1a 100644
--- a/community/gnome-weather/APKBUILD
+++ b/community/gnome-weather/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=0
pkgdesc="GNOME Weather application"
url="https://wiki.gnome.org/Apps/Weather"
-# s390x, mips64 and riscv64 blocked by gjs
-arch="noarch !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by gjs
+arch="noarch !s390x !riscv64"
license="GPL-2.0-only"
makedepends="meson glib-dev gobject-introspection-dev gtk+3.0-dev gjs-dev
geoclue-dev libgweather-dev libhandy1-dev"
diff --git a/community/gnome/APKBUILD b/community/gnome/APKBUILD
index 01c35b4f31..2c71c81ad7 100644
--- a/community/gnome/APKBUILD
+++ b/community/gnome/APKBUILD
@@ -5,7 +5,7 @@ pkgver=41
pkgrel=2
pkgdesc="GNOME (Base) meta package"
url="https://www.gnome.org/"
-arch="all !mips64 !s390x !riscv64" # GNOME isn't available on all arches yet
+arch="all !s390x !riscv64" # GNOME isn't available on all arches yet
options="!check" # No tests for a metapkg
license="GPL-3.0-or-later"
depends="
diff --git a/community/gnumeric/APKBUILD b/community/gnumeric/APKBUILD
index 2369454402..ce13eac7d9 100644
--- a/community/gnumeric/APKBUILD
+++ b/community/gnumeric/APKBUILD
@@ -4,8 +4,8 @@ pkgver=1.12.50
pkgrel=1
pkgdesc="GNOME Spreadsheet Program"
url="https://www.gnome.org/projects/gnumeric"
-# s390x, mips64 and riscv64 blocked by librsvg -> goffice
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> goffice
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later OR GPL-3.0-or-later"
makedepends="
autoconf
diff --git a/community/go-bindata-assetfs/APKBUILD b/community/go-bindata-assetfs/APKBUILD
index 23dd18f501..d66f682de4 100644
--- a/community/go-bindata-assetfs/APKBUILD
+++ b/community/go-bindata-assetfs/APKBUILD
@@ -15,11 +15,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/elazarl/go-bindata-assetfs/a
build() {
export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
- case $CARCH in
- mips*)
- export GOFLAGS="${GOFLAGS/-buildmode=pie}" # Not supported on mips(64)
- ;;
- esac
export GOPATH="$srcdir"
go build -ldflags="-s -w" -v -o bin/"$pkgname" ./"$pkgname"/main.go
}
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 58f0031209..e048731888 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -105,10 +105,6 @@ x86) export GOARCH="386" ;;
x86_64) export GOARCH="amd64" ;;
ppc64) export GOARCH="ppc64" ;;
ppc64le) export GOARCH="ppc64le" ;;
-mips) export GOARCH="mips" GOMIPS=softfloat ;;
-mips64) export GOARCH="mips64" GOMIPS64=softfloat ;;
-mips64el) export GOARCH="mips64le" GOMIPS64=softfloat ;;
-mipsel) export GOARCH="mipsle" GOMIPS=softfloat ;;
riscv64) export GOARCH="riscv64" ;;
*) export GOARCH="unsupported";;
esac
diff --git a/community/gocryptfs/APKBUILD b/community/gocryptfs/APKBUILD
index 16d0aead25..71b46f9f13 100644
--- a/community/gocryptfs/APKBUILD
+++ b/community/gocryptfs/APKBUILD
@@ -5,9 +5,8 @@ pkgver=2.2.1
pkgrel=1
pkgdesc="Encrypted overlay filesystem written in Go"
url="https://github.com/rfjakob/gocryptfs"
-# mips64 FTBFS
# riscv64 fails to build https://gitlab.alpinelinux.org/alpine/aports/-/issues/12793
-arch="all !mips64 !riscv64"
+arch="all !riscv64"
license="MIT"
makedepends="go bash openssl1.1-compat-dev"
depends="fuse"
diff --git a/community/goffice/APKBUILD b/community/goffice/APKBUILD
index a3ddf06a57..587cf1404a 100644
--- a/community/goffice/APKBUILD
+++ b/community/goffice/APKBUILD
@@ -7,8 +7,8 @@ _min=${pkgver#$_maj.}
_min=${_min%%.*}
pkgdesc="Library of document-centric objects and utilities built on top of GLib and Gtk+"
url="https://www.gnome.org/"
-# s390x, mips64, riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x, riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later OR GPL-3.0-or-later"
makedepends="librsvg-dev intltool autoconf automake libtool gtk-doc
libxslt-dev gobject-introspection-dev glib-dev libgsf-dev cairo-dev
diff --git a/community/gomuks/APKBUILD b/community/gomuks/APKBUILD
index 537fd75f98..ed631f76ae 100644
--- a/community/gomuks/APKBUILD
+++ b/community/gomuks/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.2.4
pkgrel=1
pkgdesc="terminal-based Matrix client written in Go"
url="https://github.com/tulir/gomuks"
-arch="all !mips64"
+arch="all"
license="AGPL-3.0-or-later"
depends="ncurses"
makedepends="go olm-dev"
diff --git a/community/gparted/APKBUILD b/community/gparted/APKBUILD
index 5b867f0247..32ff009774 100644
--- a/community/gparted/APKBUILD
+++ b/community/gparted/APKBUILD
@@ -5,8 +5,8 @@ pkgrel=0
pkgdesc="graphical partition editor for creating, reorganizing, and deleting disk partitions"
options="!check" # Requires eudev
url="http://gparted.sourceforge.net/"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="e2fsprogs ntfs-3g-progs exfatprogs"
makedepends="gtkmm3-dev parted-dev util-linux-dev intltool polkit-dev"
diff --git a/community/gpaste/APKBUILD b/community/gpaste/APKBUILD
index fdd2095e28..f170a6c74b 100644
--- a/community/gpaste/APKBUILD
+++ b/community/gpaste/APKBUILD
@@ -5,7 +5,7 @@ pkgver=3.42.2
pkgrel=0
pkgdesc="Clipboard managment system"
url="https://github.com/Keruspe/GPaste"
-arch="all !armhf !s390x !ppc64le !mips !mips64 !riscv64" # limited by gnome-control-center
+arch="all !armhf !s390x !ppc64le !riscv64" # limited by gnome-control-center
license="BSD-2-Clause"
makedepends="meson gtk+3.0-dev gnome-control-center-dev dbus-dev mutter-dev
gjs-dev appstream-glib-dev vala"
diff --git a/community/gpodder-adaptive/APKBUILD b/community/gpodder-adaptive/APKBUILD
index 6115f42b9f..dd01ddc980 100644
--- a/community/gpodder-adaptive/APKBUILD
+++ b/community/gpodder-adaptive/APKBUILD
@@ -6,7 +6,7 @@ _plusver=1
pkgrel=1
pkgdesc="Podcast aggregator (adaptive version)"
url="https://github.com/gpodder/gpodder/tree/adaptive"
-arch="all !s390x !mips !mips64 !riscv64" # blocked by adwaita-icon-theme
+arch="all !s390x !riscv64" # blocked by adwaita-icon-theme
license="GPL-3.0-or-later"
depends="
adwaita-icon-theme
diff --git a/community/gpodder/APKBUILD b/community/gpodder/APKBUILD
index 9222d5e65d..0a90bdd370 100644
--- a/community/gpodder/APKBUILD
+++ b/community/gpodder/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.10.21
pkgrel=1
pkgdesc="Podcast aggregator"
url="https://gpodder.org"
-arch="noarch !s390x !mips !mips64 !riscv64" # blocked by adwaita-icon-theme
+arch="noarch !s390x !riscv64" # blocked by adwaita-icon-theme
license="GPL-3.0-or-later"
depends="
adwaita-icon-theme
diff --git a/community/gradle/APKBUILD b/community/gradle/APKBUILD
index b417793425..afc2eaad4e 100644
--- a/community/gradle/APKBUILD
+++ b/community/gradle/APKBUILD
@@ -5,8 +5,8 @@ pkgver=7.4
pkgrel=0
pkgdesc="Build tool with a focus on build automation and support for multi-language development"
url="https://gradle.org/"
-# mips64 and riscv64 blocked by openjdk8/java-jdk
-arch="noarch !mips64 !riscv64"
+# riscv64 blocked by openjdk8/java-jdk
+arch="noarch !riscv64"
options="!check"
license="Apache-2.0"
depends="java-jdk"
diff --git a/community/grafana/APKBUILD b/community/grafana/APKBUILD
index ede512d47f..143ac3708a 100644
--- a/community/grafana/APKBUILD
+++ b/community/grafana/APKBUILD
@@ -10,7 +10,7 @@ _commit=67423f42a5 # git rev-parse --short HEAD
_stamp=1644426944 # git --no-pager show -s --format=%ct
pkgdesc="Open source, feature rich metrics dashboard and graph editor"
url="https://grafana.com"
-arch="all !s390x !mips64" # tests fail https://github.com/grafana/grafana/issues/26390
+arch="all !s390x" # tests fail https://github.com/grafana/grafana/issues/26390
license="AGPL-3.0-only"
depends="grafana-frontend=$pkgver-r$pkgrel"
makedepends="go"
diff --git a/community/granatier/APKBUILD b/community/granatier/APKBUILD
index 090b4cd784..8a6c6ea34e 100644
--- a/community/granatier/APKBUILD
+++ b/community/granatier/APKBUILD
@@ -4,8 +4,8 @@ pkgname=granatier
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/org.kde.granatier"
pkgdesc="A clone of the classic Bomberman game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/grantlee-editor/APKBUILD b/community/grantlee-editor/APKBUILD
index 77d455c5df..40eb407029 100644
--- a/community/grantlee-editor/APKBUILD
+++ b/community/grantlee-editor/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Utilities and tools to manage themes in KDE PIM applications "
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/grantleetheme/APKBUILD b/community/grantleetheme/APKBUILD
index b41ef8b421..66483db381 100644
--- a/community/grantleetheme/APKBUILD
+++ b/community/grantleetheme/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM mail related libraries"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by knewstuff
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by knewstuff
+arch="all !armhf !s390x !riscv64"
url="https://kontact.kde.org/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
makedepends="
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
index 0f9c188a33..225c6cae69 100644
--- a/community/greenbone-security-assistant/APKBUILD
+++ b/community/greenbone-security-assistant/APKBUILD
@@ -6,8 +6,8 @@ pkgver=21.4.3
pkgrel=1
pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
url="https://www.openvas.org/"
-# no nodejs on riscv64, mips
-arch="all !mips !mips64 !riscv64"
+# no nodejs on riscv64
+arch="all !riscv64"
license="GPL-2.0-or-later"
depends="wget"
makedepends="cmake doxygen xmltoman graphviz gvm-libs-dev
diff --git a/community/grilo-plugins/APKBUILD b/community/grilo-plugins/APKBUILD
index dc7e266c82..ded6ba0150 100644
--- a/community/grilo-plugins/APKBUILD
+++ b/community/grilo-plugins/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.3.14
pkgrel=0
pkgdesc="GNOME media discovery framework plugins"
url="https://wiki.gnome.org/Projects/Grilo"
-# s390x, mips64 and riscv64 blocked by polkit -> tracker-miners
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> tracker-miners
+arch="all !s390x !riscv64"
license="LGPL-2.1-or-later"
depends="tracker-miners"
makedepends="glib-dev grilo-dev avahi-dev meson gstreamer-dev json-glib-dev
diff --git a/community/grpc-java/APKBUILD b/community/grpc-java/APKBUILD
index e316f004f3..8397adb006 100644
--- a/community/grpc-java/APKBUILD
+++ b/community/grpc-java/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="The Java gRPC implementation. HTTP/2 based RPC"
url="https://github.com/grpc/grpc-java"
# armhf and aarch64 are blocked by build failures
-# mips64 and riscv64 blocked by java
-arch="all !aarch64 !armhf !armv7 !s390x !mips64 !riscv64"
+# riscv64 blocked by java
+arch="all !aarch64 !armhf !armv7 !s390x !riscv64"
license="Apache-2.0"
depends="java-jre-headless"
makedepends="java-jdk protobuf-dev nss"
diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
index ba5c3b236d..01ca9d95c6 100644
--- a/community/gst-plugins-bad/APKBUILD
+++ b/community/gst-plugins-bad/APKBUILD
@@ -22,7 +22,7 @@ makedepends="alsa-lib-dev aom-dev bluez-dev bzip2-dev curl-dev directfb-dev faac
"
case "$CARCH" in
- s390x|mips64|riscv64) ;;
+ s390x|riscv64) ;;
*) makedepends="$makedepends librsvg-dev libexif-dev" ;;
esac
diff --git a/community/gtk4.0/APKBUILD b/community/gtk4.0/APKBUILD
index 361f477fef..70b726a724 100644
--- a/community/gtk4.0/APKBUILD
+++ b/community/gtk4.0/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="The GTK Toolkit (v4)"
url="https://www.gtk.org/"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
-arch="all !mips !mips64 !s390x !riscv64" # blocked by polkit -> colord
+arch="all !s390x !riscv64" # blocked by polkit -> colord
options="!check" # Test suite is known to fail upstream
license="LGPL-2.1-or-later"
subpackages="$pkgname-demo $pkgname-dev $pkgname-doc $pkgname-lang $pkgname-dbg"
diff --git a/community/gtkmm4/APKBUILD b/community/gtkmm4/APKBUILD
index 7d54fa979f..6687bc617e 100644
--- a/community/gtkmm4/APKBUILD
+++ b/community/gtkmm4/APKBUILD
@@ -5,8 +5,8 @@ pkgver=4.4.0
pkgrel=0
pkgdesc="C++ wrappers for GTK 4"
url="https://www.gtkmm.org/"
-# s390x, mips64 and riscv64 blocked by polkit -> gtk4.0
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> gtk4.0
+arch="all !s390x !riscv64"
license="LGPL-2.1-or-later"
makedepends="
atkmm2.36-dev
diff --git a/community/gtksourceview5/APKBUILD b/community/gtksourceview5/APKBUILD
index 56fa017b9f..01bb97e473 100644
--- a/community/gtksourceview5/APKBUILD
+++ b/community/gtksourceview5/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.2.0
pkgrel=0
pkgdesc="A text widget adding syntax highlighting and more to GNOME"
url="https://wiki.gnome.org/Projects/GtkSourceView"
-# s390x, mips64 and riscv64 blocked by librsvg -> glade
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> glade
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends_dev="gtk4.0-dev libxml2-dev"
makedepends="$depends_dev gobject-introspection-dev vala libxslt meson glade-dev
diff --git a/community/gvfs/APKBUILD b/community/gvfs/APKBUILD
index a2ad1c7e8a..1bbf9484c0 100644
--- a/community/gvfs/APKBUILD
+++ b/community/gvfs/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.48.1
pkgrel=0
pkgdesc="Backends for the gio framework in GLib"
url="https://wiki.gnome.org/Projects/gvfs"
-# s390x, mips64 and riscv64 blocked by polkit -> udisks2
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> udisks2
+arch="all !s390x !riscv64"
license="LGPL-2.0-or-later"
depends="gsettings-desktop-schemas dbus:org.freedesktop.Secrets"
makedepends="fuse3-dev libgudev-dev expat-dev samba-dev libxml2-dev
diff --git a/community/gvmd/APKBUILD b/community/gvmd/APKBUILD
index 38f2a4c115..14085a4bd9 100644
--- a/community/gvmd/APKBUILD
+++ b/community/gvmd/APKBUILD
@@ -30,7 +30,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/gvmd/archive/v$pkg
case "$CARCH" in
# cppcheck is not available
- s390x|aarch64|mips|mips64) options="$options !check"
+ s390x|aarch64) options="$options !check"
esac
prepare() {
diff --git a/community/gwenview/APKBUILD b/community/gwenview/APKBUILD
index 871ca841f1..c54d60bfe2 100644
--- a/community/gwenview/APKBUILD
+++ b/community/gwenview/APKBUILD
@@ -4,9 +4,9 @@ pkgname=gwenview
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> purpose
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://kde.org/applications/graphics/org.kde.gwenview"
pkgdesc="Fast and easy to use image viewer by KDE"
license="GPL-2.0-only"
@@ -35,9 +35,6 @@ makedepends="
"
checkdepends="xvfb-run kinit dbus"
source="https://download.kde.org/stable/release-service/$pkgver/src/gwenview-$pkgver.tar.xz"
-case "$CARCH" in
- mips64) options="!check" # test failures
-esac
subpackages="$pkgname-doc $pkgname-lang"
build() {
diff --git a/community/h2o/APKBUILD b/community/h2o/APKBUILD
index 1c9792b400..89dbfcbd1c 100644
--- a/community/h2o/APKBUILD
+++ b/community/h2o/APKBUILD
@@ -6,7 +6,7 @@ pkgver=2.2.6
pkgrel=8
pkgdesc="An optimized HTTP/1, HTTP/2 server written in C"
url="https://h2o.examp1e.net"
-arch="all !s390x !mips64 !mips64el"
+arch="all !s390x"
depends="perl openssl"
license="MIT"
checkdepends="
diff --git a/community/haxe/APKBUILD b/community/haxe/APKBUILD
index 48731a9e17..1b89c33197 100644
--- a/community/haxe/APKBUILD
+++ b/community/haxe/APKBUILD
@@ -6,7 +6,7 @@ _versuffix=
pkgrel=2
pkgdesc="Cross-platform toolkit and programming language"
url="https://haxe.org"
-#arch="all !x86 !armhf !armv7 !mips !mips64"
+#arch="all !x86 !armhf !armv7"
license="GPL MIT LGPL" # http://haxe.org/foundation/open-source.html
makedepends="ocaml-camlp4-dev ocaml neko-dev zlib-dev pcre-dev"
options="!strip"
diff --git a/community/hdf5/APKBUILD b/community/hdf5/APKBUILD
index 831b92de4e..77c2f71ad2 100644
--- a/community/hdf5/APKBUILD
+++ b/community/hdf5/APKBUILD
@@ -22,11 +22,11 @@ makedepends="cmake $depends_dev gfortran libaec-dev perl"
subpackages="$pkgname-fortran $pkgname-static $pkgname-doc $pkgname-dev"
source="https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-${pkgver%.*}/hdf5-$pkgver/src/hdf5-$pkgver.tar.bz2"
-# Optional dependency java-jdk is not available on mips and riscv64
+# Optional dependency java-jdk is not available on riscv64
_with_java=""
_enable_java=""
case "$CARCH" in
- mips*|riscv64) ;;
+ riscv64) ;;
*)
makedepends="$makedepends java-jdk"
subpackages="$subpackages java-$pkgname:java"
diff --git a/community/heirloom-doctools/APKBUILD b/community/heirloom-doctools/APKBUILD
index 17591ed834..9d06db9105 100644
--- a/community/heirloom-doctools/APKBUILD
+++ b/community/heirloom-doctools/APKBUILD
@@ -5,7 +5,7 @@ pkgver=191015
pkgrel=2
pkgdesc="The Heirloom Documentation Tools"
url="http://n-t-roff.github.io/heirloom/doctools.html"
-arch="all !mips !mips64" # FTBFS on mips due to missing yyval()
+arch="all"
license="CDDL"
depends="!coreutils !util-linux !mandoc-soelim"
# TODO: Switch to bison <https://github.com/n-t-roff/heirloom-doctools/issues/85>
diff --git a/community/hexyl/APKBUILD b/community/hexyl/APKBUILD
index 7dd9332351..fb723948f7 100644
--- a/community/hexyl/APKBUILD
+++ b/community/hexyl/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Command-line hex viewer with colored output"
url="https://github.com/sharkdp/hexyl"
license="Apache-2.0 OR MIT"
-arch="all !s390x !mips64 !riscv64" # blocked by rust/cargo
+arch="all !s390x !riscv64" # blocked by rust/cargo
makedepends="cargo"
source="https://github.com/sharkdp/hexyl/archive/v$pkgver/hexyl-$pkgver.tar.gz"
diff --git a/community/hfsprogs/APKBUILD b/community/hfsprogs/APKBUILD
index ba87fc9761..610365637f 100644
--- a/community/hfsprogs/APKBUILD
+++ b/community/hfsprogs/APKBUILD
@@ -8,7 +8,7 @@ pkgrel=4
pkgdesc="Tools to create/check Apple HFS+ filesystems"
# We use modified version provided by Fedora's dev, not directly from Apple.
url="https://src.fedoraproject.org/rpms/hfsplus-tools"
-arch="all !mips !mips64" # broken on soft-float
+arch="all" # broken on soft-float
license="APSL-2.0"
makedepends="clang libbsd-dev openssl-dev linux-headers util-linux-dev"
provides="$_pkgname=$pkgver-r$pkgrel"
diff --git a/community/hivemind-ptt/APKBUILD b/community/hivemind-ptt/APKBUILD
index 63a80ad4ce..b1cdc9d882 100644
--- a/community/hivemind-ptt/APKBUILD
+++ b/community/hivemind-ptt/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.1.6
pkgrel=2
pkgdesc="Mycroft Push to Talk Satellite"
url="https://github.com/JarbasHiveMind/HiveMind-PTT"
-arch="noarch !mips64" # blocked by py3-text2speech
+arch="noarch" # blocked by py3-text2speech
license="Apache-2.0"
depends="
py3-jarbas-hive-mind
diff --git a/community/hugo/APKBUILD b/community/hugo/APKBUILD
index 22480420f3..e9a95895bd 100644
--- a/community/hugo/APKBUILD
+++ b/community/hugo/APKBUILD
@@ -19,7 +19,6 @@ subpackages="
source="https://github.com/gohugoio/hugo/archive/v$pkgver/hugo-$pkgver.tar.gz
skip-git-tests.patch
skip-para-test.patch
- increase-timeout-pagebundler-test.patch
skip-image-test.patch
"
@@ -57,6 +56,5 @@ sha512sums="
4a4c8ab730c1cc839e3e15a29b1200fa969402efa40774022a70fae11d98819173f6002ed3ee4a84ce1148c0744c82ce16ee0fec409935a903130ae71d62ba24 hugo-0.92.2.tar.gz
f07d458b5df72d0b10e0fd9ec6120502b62af1ee347f0ec83eda99147c525327c0098150db80450da48c5bc03d825279e35f0940dae5d909203757abb6bd1a20 skip-git-tests.patch
6ba192d8cb67f115f7ce596c297a55fc64713a4cdb0077cfbb7e45051c7560f5b668da88f513d4f34d8e0eeb4a9d991c5312d62e454c85e95960d8a33f0f8f69 skip-para-test.patch
-0eafc165979d869ef401fec050678ba025431ac66b79a9761879024da8326e2dd5e9d14d90e32c3071d83dbac6973c2b4f954217e789944524b660a09131b298 increase-timeout-pagebundler-test.patch
0feb0495f03315c9224b301ea955061fcbbf9ae8f871640fbb4b5c0792785a714f3a030f702a1f1f6a8048d60f07a133df4ced2a989df0b9c851b8503b59d26d skip-image-test.patch
"
diff --git a/community/hugo/increase-timeout-pagebundler-test.patch b/community/hugo/increase-timeout-pagebundler-test.patch
deleted file mode 100644
index cace72afaa..0000000000
--- a/community/hugo/increase-timeout-pagebundler-test.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: This takes longer on mips64, so increasee the timeout to make sure
-it has time to finish on mips64
-Upstream: no
-
-diff --git a/hugolib/pagebundler_test.go b/hugolib/pagebundler_test.go
-index fa420a0..34d928a 100644
---- a/hugolib/pagebundler_test.go
-+++ b/hugolib/pagebundler_test.go
-@@ -90,6 +90,7 @@ func TestPageBundlerSiteRegular(t *testing.T) {
- })
-
- cfg.Set("uglyURLs", ugly)
-+ cfg.Set("timeout", 120000)
-
- b := newTestSitesBuilderFromDepsCfg(c, deps.DepsCfg{Logger: loggers.NewErrorLogger(), Fs: fs, Cfg: cfg}).WithNothingAdded()
-
-
diff --git a/community/hydroxide/APKBUILD b/community/hydroxide/APKBUILD
index 04723196c2..aee4235aea 100644
--- a/community/hydroxide/APKBUILD
+++ b/community/hydroxide/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=1
pkgdesc="Third-party, open-source ProtonMail CardDAV, IMAP and SMTP bridge"
url="https://github.com/emersion/hydroxide"
license="MIT"
-arch="all !mips !mips64 !riscv64" # failure to build github.com/boltdb/bolt
+arch="all !riscv64" # failure to build github.com/boltdb/bolt
makedepends="go"
options="net !check" # no tests
source="https://github.com/emersion/hydroxide/releases/download/v$pkgver/hydroxide-$pkgver.tar.gz"
diff --git a/community/icinga-php-library/APKBUILD b/community/icinga-php-library/APKBUILD
index b82fe6914b..c4bfaa8cbd 100644
--- a/community/icinga-php-library/APKBUILD
+++ b/community/icinga-php-library/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.7.0
pkgrel=0
pkgdesc="Bundle for all Icinga PHP libraries"
url="https://github.com/Icinga/icinga-php-library"
-arch="noarch !armhf !armv7 !s390x !mips !mips64 !x86"
+arch="noarch !armhf !armv7 !s390x !x86"
license="MIT"
options="!check"
subpackages="$pkgname-doc"
diff --git a/community/icinga-php-thirdparty/APKBUILD b/community/icinga-php-thirdparty/APKBUILD
index 821af87608..de382f81ae 100644
--- a/community/icinga-php-thirdparty/APKBUILD
+++ b/community/icinga-php-thirdparty/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.10.0
pkgrel=0
pkgdesc="Bundle for all 3rd party PHP libraries used by Icinga Web products"
url="https://github.com/Icinga/icinga-php-thirdparty"
-arch="noarch !armhf !armv7 !s390x !mips !mips64 !x86"
+arch="noarch !armhf !armv7 !s390x !x86"
license="MIT"
options="!check"
subpackages="$pkgname-doc"
diff --git a/community/icinga2/APKBUILD b/community/icinga2/APKBUILD
index 7db9f26587..ca9f58a0c5 100644
--- a/community/icinga2/APKBUILD
+++ b/community/icinga2/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.13.1
pkgrel=3
pkgdesc="An open source host, service and network monitoring program"
url="http://www.icinga.org"
-arch="all !armhf !armv7 !s390x !mips !mips64"
+arch="all !armhf !armv7 !s390x"
license="GPL-2.0-only"
depends="monitoring-plugins"
makedepends="$depends_dev cmake bison flex boost-dev yajl-dev
diff --git a/community/icingaweb2-module-director/APKBUILD b/community/icingaweb2-module-director/APKBUILD
index b43efb6297..60a9375ab5 100644
--- a/community/icingaweb2-module-director/APKBUILD
+++ b/community/icingaweb2-module-director/APKBUILD
@@ -7,7 +7,7 @@ pkgver=1.8.1
pkgrel=3
pkgdesc="Configuration frontend for Icinga 2, integrated automation"
url="http://www.icinga.org"
-arch="noarch !armhf !armv7 !s390x !mips !mips64 !x86"
+arch="noarch !armhf !armv7 !s390x !x86"
license="GPL-2.0-or-later"
_php=php8
depends="icingaweb2 $_php-curl $_php-pcntl icingaweb2-module-incubator"
diff --git a/community/icingaweb2-module-incubator/APKBUILD b/community/icingaweb2-module-incubator/APKBUILD
index 66750df155..ac837acc8a 100644
--- a/community/icingaweb2-module-incubator/APKBUILD
+++ b/community/icingaweb2-module-incubator/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.12.0
pkgrel=0
pkgdesc="Bleeding edge libraries useful for Icinga Web 2 modules"
url="https://www.icinga.org"
-arch="noarch !armhf !armv7 !s390x !mips !mips64 !x86"
+arch="noarch !armhf !armv7 !s390x !x86"
license="MIT"
options="!check"
_php=php8
diff --git a/community/icingaweb2/APKBUILD b/community/icingaweb2/APKBUILD
index 4145682c3a..2182da539a 100644
--- a/community/icingaweb2/APKBUILD
+++ b/community/icingaweb2/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=2
pkgdesc="Web Interface for Icinga2"
url="http://www.icinga.org"
# x86: php6-pecl-imagick missing
-arch="noarch !armhf !armv7 !s390x !mips !mips64 !x86"
+arch="noarch !armhf !armv7 !s390x !x86"
license="GPL-2.0"
_php=php8
depends="$_php ${_php}-ldap ${_php}-intl ${_php}-dom
diff --git a/community/ikona/APKBUILD b/community/ikona/APKBUILD
index f53f470d56..98cda4743a 100644
--- a/community/ikona/APKBUILD
+++ b/community/ikona/APKBUILD
@@ -8,7 +8,7 @@ url="https://invent.kde.org/kde/ikona/"
# ppc64le and s390x blocked by qt5-qtwebengine-dev
# armhf blocked by qt5-qtdeclarative-dev
# riscv64 blocked by qt5-qtwebengine and rust/cargo
-arch="all !ppc64le !s390x !armhf !mips64 !riscv64"
+arch="all !ppc64le !s390x !armhf !riscv64"
license="GPL-2.0-or-later"
makedepends="
cargo
diff --git a/community/imagemagick/APKBUILD b/community/imagemagick/APKBUILD
index dc0e2e31d6..b1f8b0884a 100644
--- a/community/imagemagick/APKBUILD
+++ b/community/imagemagick/APKBUILD
@@ -34,7 +34,6 @@ makedepends="
case "$CARCH" in
s390x|riscv64) ;;
- mips64) options="$options !check" ;;
*) makedepends="$makedepends librsvg-dev" ;;
esac
diff --git a/community/imagemagick6/APKBUILD b/community/imagemagick6/APKBUILD
index c0e514c66b..841ddd373a 100644
--- a/community/imagemagick6/APKBUILD
+++ b/community/imagemagick6/APKBUILD
@@ -19,7 +19,6 @@ makedepends="fontconfig-dev freetype-dev ghostscript-dev lcms2-dev
case "$CARCH" in
s390x|riscv64) ;;
- mips64) options="!check" ;;
*) makedepends="$makedepends librsvg-dev" ;;
esac
diff --git a/community/imv/APKBUILD b/community/imv/APKBUILD
index 8f99565346..84bbe962a4 100644
--- a/community/imv/APKBUILD
+++ b/community/imv/APKBUILD
@@ -31,7 +31,7 @@ source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~exec64/imv/archive/v$pkgver.
builddir="$srcdir/$pkgname-v$pkgver"
case $CARCH in
- s390x|mips64|riscv64)
+ s390x|riscv64)
_rsvg=""
;;
*)
diff --git a/community/incidenceeditor/APKBUILD b/community/incidenceeditor/APKBUILD
index f358d9cfc2..6d0d1a8de6 100644
--- a/community/incidenceeditor/APKBUILD
+++ b/community/incidenceeditor/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="KDE PIM incidence editor"
# armhf blocked by extra-cmake-modules
# ppc64le blocked by kmailtransport -> qt5-qtwebengine
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
depends_dev="
diff --git a/community/index/APKBUILD b/community/index/APKBUILD
index 2932ce5020..9cb898533b 100644
--- a/community/index/APKBUILD
+++ b/community/index/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="Index file manager based on MauiKit"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by mauikit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/kde/index-fm"
license="GPL-2.0-or-later"
depends="
diff --git a/community/influxdb/APKBUILD b/community/influxdb/APKBUILD
index a9f4391fbd..ff0405e2e4 100644
--- a/community/influxdb/APKBUILD
+++ b/community/influxdb/APKBUILD
@@ -7,8 +7,8 @@ _commit=688e697c51 # git rev-parse --short HEAD
_branch=${pkgver%.*}
pkgdesc="Scalable datastore for metrics, events, and real-time analytics"
url="https://www.influxdata.com/products/influxdb-overview/"
-# mips64 and riscv64 blocked by boltdb dependency
-arch="all !mips64 !riscv64"
+# riscv64 blocked by boltdb dependency
+arch="all !riscv64"
license="MIT"
makedepends="go asciidoc xmlto"
install="$pkgname.pre-install"
diff --git a/community/ion-shell/APKBUILD b/community/ion-shell/APKBUILD
index cd6423944e..1917466738 100644
--- a/community/ion-shell/APKBUILD
+++ b/community/ion-shell/APKBUILD
@@ -7,7 +7,7 @@ _commit=df993477678248a62745c9c0a56c880dfd06b515
pkgdesc="modern system shell with simple, yet powerful, syntax"
url="https://doc.redox-os.org/ion-manual/html/"
# ppc64le: Rust SIGSEGVs when compiling
-arch="all !s390x !mips !mips64 !riscv64" # limited by cargo
+arch="all !s390x !riscv64" # limited by cargo
license="MIT"
makedepends="cargo"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
diff --git a/community/ipynb2html/APKBUILD b/community/ipynb2html/APKBUILD
index 4c869081c3..0c50a8f585 100644
--- a/community/ipynb2html/APKBUILD
+++ b/community/ipynb2html/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Convert Jupyter Notebook to static HTML"
url="https://github.com/jirutka/ipynb2html"
# riscv64 missing nodejs
-arch="noarch !mips !mips64 !riscv64"
+arch="noarch !riscv64"
license="MIT BSD-3-Clause"
depends="nodejs"
makedepends="yarn"
diff --git a/community/isoimagewriter/APKBUILD b/community/isoimagewriter/APKBUILD
index b0f5c8c67e..3e076691e2 100644
--- a/community/isoimagewriter/APKBUILD
+++ b/community/isoimagewriter/APKBUILD
@@ -4,8 +4,8 @@ pkgname=isoimagewriter
pkgver=0.8
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kauth
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kauth
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/ISOImageWriter"
pkgdesc="A program to write hybrid ISO files onto a USB disk"
license="GPL-3.0-only"
diff --git a/community/itinerary/APKBUILD b/community/itinerary/APKBUILD
index 0525f51f50..bd52412e55 100644
--- a/community/itinerary/APKBUILD
+++ b/community/itinerary/APKBUILD
@@ -6,7 +6,6 @@ pkgrel=0
# armhf blocked by qt5-qtdeclarative
# ppc64le blocked by kitinerary
# s390x blocked by qt5-qtdeclarative
-# mips64 blocked by qt5-qtdeclarative
arch="aarch64 armv7 x86_64 x86"
url="https://invent.kde.org/pim/itinerary"
pkgdesc="Itinerary and boarding pass management application"
diff --git a/community/iwd/APKBUILD b/community/iwd/APKBUILD
index 2ad5a7369b..12d02417b4 100644
--- a/community/iwd/APKBUILD
+++ b/community/iwd/APKBUILD
@@ -26,10 +26,6 @@ source="https://mirrors.edge.kernel.org/pub/linux/network/wireless/iwd-$pkgver.t
main.conf
"
-case "$CARCH" in
-mips*) options="!check";;
-esac
-
build() {
./configure \
--build=$CBUILD \
diff --git a/community/janet/APKBUILD b/community/janet/APKBUILD
index b0951a9f55..e57e0a8bd4 100644
--- a/community/janet/APKBUILD
+++ b/community/janet/APKBUILD
@@ -8,9 +8,7 @@ url="https://janet-lang.org/"
license="MIT"
arch="all !riscv64" # FTBS riscv64
subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/janet-lang/janet/archive/v$pkgver.tar.gz
- mips-64-bit.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://github.com/janet-lang/janet/archive/v$pkgver.tar.gz"
prepare() {
default_prepare
@@ -56,5 +54,4 @@ package() {
sha512sums="
4181f15ad61bfba46ce87acd148166bd0ab3c5dd5fb608d8d8722b912ecfa435baa7d881d4a8163aabb1b06bca2983b108dfb7256efa854c12c136e4f24c1ef2 janet-1.19.2.tar.gz
-c983e178650193c4b471f82cb2c77ffc10796d192365019c078c9ece0a63799fb46fc7898f1e11d911f964cf65810c3750d1266461305179d23c49f8fa622fa2 mips-64-bit.patch
"
diff --git a/community/janet/mips-64-bit.patch b/community/janet/mips-64-bit.patch
deleted file mode 100644
index b91bcfdbec..0000000000
--- a/community/janet/mips-64-bit.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Description: mips64 is not properly detected as 64-bits
-Upstream: no
-diff --git a/src/include/janet.h b/src/include/janet.h
-index 4448a90..dc73001 100644
---- a/src/include/janet.h
-+++ b/src/include/janet.h
-@@ -96,7 +96,8 @@ extern "C" {
- || (defined(__sparc__) && defined(__arch64__) || defined (__sparcv9)) /* BE */ \
- || defined(__s390x__) /* S390 64-bit (BE) */ \
- || (defined(__ppc64__) || defined(__PPC64__)) \
-- || defined(__aarch64__) /* ARM 64-bit */
-+ || defined(__aarch64__) /* ARM 64-bit */ \
-+ || defined(__mips64) /* MIPS 64-bit */
- #define JANET_64 1
- #else
- #define JANET_32 1
diff --git a/community/java-gcj-compat/APKBUILD b/community/java-gcj-compat/APKBUILD
index bfd949b3af..3f589d4b98 100644
--- a/community/java-gcj-compat/APKBUILD
+++ b/community/java-gcj-compat/APKBUILD
@@ -11,7 +11,7 @@ pkgrel=$(( $_mypkgrel + $_gccpkgrel ))
pkgdesc="JDK like environment using GCJ"
url="https://git.alpinelinux.org/aports.git"
# riscv64 blocked by gcc6
-arch="all !mips64 !riscv64"
+arch="all !riscv64"
license="GPL-2.0-or-later"
depends="fastjar gcc6-java=$_gccver-r$_gccpkgrel java-common"
makedepends="gcc6-java=$_gccver-r$_gccpkgrel zlib-dev"
diff --git a/community/java-jansi-native/APKBUILD b/community/java-jansi-native/APKBUILD
index 9f2a520df0..2a1914858b 100644
--- a/community/java-jansi-native/APKBUILD
+++ b/community/java-jansi-native/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.5
pkgrel=0
pkgdesc="Native JNI libraries used by the Jansi project."
url="https://github.com/fusesource/jansi-native"
-arch="all !mips !mips64 !riscv64" # missing openjdk8
+arch="all !riscv64" # missing openjdk8
license="Apache-2.0"
depends="openjdk8-jre-base"
makedepends="autoconf automake libtool maven openjdk8"
diff --git a/community/java-jffi/APKBUILD b/community/java-jffi/APKBUILD
index 50f8fe739f..61e8bd1fe3 100644
--- a/community/java-jffi/APKBUILD
+++ b/community/java-jffi/APKBUILD
@@ -8,8 +8,8 @@ pkgrel=0
pkgdesc="Java Foreign Function Interface"
url="https://github.com/jnr/jffi"
# ppc64le blocked by build failure
-# mips64 and riscv64 blocked by openjdk8
-arch="all !ppc64le !mips64 !riscv64"
+# riscv64 blocked by openjdk8
+arch="all !ppc64le !riscv64"
license="Apache-2.0"
depends="$pkgname-native=$pkgver-r$pkgrel java-jre-headless"
makedepends="apache-ant file linux-headers openjdk8 texinfo"
diff --git a/community/java-jna/APKBUILD b/community/java-jna/APKBUILD
index 884fb058f3..be6f8e0e00 100644
--- a/community/java-jna/APKBUILD
+++ b/community/java-jna/APKBUILD
@@ -6,8 +6,8 @@ pkgver=5.6.0
pkgrel=2
pkgdesc="JNA provides Java programs easy access to native shared libraries."
url="https://github.com/java-native-access/jna"
-# mips64, aarch64 and riscv64 blocked by java-jre-headless
-arch="all !mips64 !aarch64 !riscv64"
+# aarch64 and riscv64 blocked by java-jre-headless
+arch="all !aarch64 !riscv64"
license="Apache-2.0 LGPL-2.1"
depends="java-jre-headless"
makedepends="apache-ant autoconf automake libffi-dev>=3.2 libtool"
diff --git a/community/java-lz4/APKBUILD b/community/java-lz4/APKBUILD
index 71a9fb6eb2..9f4340748c 100644
--- a/community/java-lz4/APKBUILD
+++ b/community/java-lz4/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="LZ4 compression for Java"
url="https://github.com/jpountz/lz4-java"
# aarch64, ppc64le: hangs during build
-# mips64 and riscv64 blocked by java-jre-headless
-arch="all !mips64 !riscv64 !aarch64 !ppc64le"
+# riscv64 blocked by java-jre-headless
+arch="all !riscv64 !aarch64 !ppc64le"
license="Apache-2.0"
depends="java-jre-headless $pkgname-native lz4-dev xxhash-dev"
makedepends="apache-ant"
diff --git a/community/java-postgresql-jdbc/APKBUILD b/community/java-postgresql-jdbc/APKBUILD
index a08a0658c9..b839d17135 100644
--- a/community/java-postgresql-jdbc/APKBUILD
+++ b/community/java-postgresql-jdbc/APKBUILD
@@ -6,8 +6,8 @@ pkgver=42.2.10
pkgrel=1
pkgdesc="Java JDBC 4.2 (JRE 8+) driver for PostgreSQL database"
url="https://jdbc.postgresql.org"
-# mips64 and riscv64 blocked by java-jdk
-arch="noarch !mips64 !riscv64"
+# riscv64 blocked by java-jdk
+arch="noarch !riscv64"
license="BSD-3-Clause"
makedepends="java-jdk maven"
source="$pkgname-$pkgver.tar.gz::https://github.com/pgjdbc/pgjdbc/archive/REL$pkgver.tar.gz"
diff --git a/community/java-sigar/APKBUILD b/community/java-sigar/APKBUILD
index 6fc5fe551c..f9781201f9 100644
--- a/community/java-sigar/APKBUILD
+++ b/community/java-sigar/APKBUILD
@@ -6,7 +6,7 @@ pkgver=1.6.4
pkgrel=1
pkgdesc="System Information Gatherer And Reporter"
url="https://github.com/hyperic/sigar/"
-arch="all !aarch64 !mips !mips64 !riscv64" # missing openjdk8
+arch="all !aarch64 !riscv64" # missing openjdk8
license="Apache-2.0"
depends="$pkgname-native=$pkgver-r$pkgrel"
subpackages="$pkgname-native"
diff --git a/community/java-snappy/APKBUILD b/community/java-snappy/APKBUILD
index 3ac88fe4f2..ee01fd0137 100644
--- a/community/java-snappy/APKBUILD
+++ b/community/java-snappy/APKBUILD
@@ -7,9 +7,9 @@ _libver=${pkgver%.*}
pkgrel=0
pkgdesc="Snappy compressor/decompressor for Java"
url="https://github.com/xerial/snappy-java"
-# mips64, x86 and riscv64 blocked by openjdk8
+# x86 and riscv64 blocked by openjdk8
# aarch64 fails to build https://gitlab.alpinelinux.org/alpine/aports/-/issues/12925
-arch="all !mips !mips64 !x86 !riscv64"
+arch="all !x86 !riscv64"
license="Apache-2.0"
options="!check" # Tests does not work correctly
depends="java-jre-headless"
diff --git a/community/jenkins/APKBUILD b/community/jenkins/APKBUILD
index 3a7d9ea29e..dd082eb666 100644
--- a/community/jenkins/APKBUILD
+++ b/community/jenkins/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.319.3
pkgrel=0
pkgdesc="Extendable continuous integration server (LTS version)"
url="https://jenkins.io"
-# mips64 and riscv64 blocked by openjdk8
-arch="noarch !mips64 !riscv64"
+# riscv64 blocked by openjdk8
+arch="noarch !riscv64"
license="MIT"
depends="java-jre-headless freetype ttf-dejavu xvfb fontconfig"
install="$pkgname.pre-install"
diff --git a/community/jetty-runner/APKBUILD b/community/jetty-runner/APKBUILD
index 4570141c25..103fb75e66 100644
--- a/community/jetty-runner/APKBUILD
+++ b/community/jetty-runner/APKBUILD
@@ -6,8 +6,8 @@ _pkgver="${pkgver%.*}.v${pkgver##*.}"
pkgrel=0
pkgdesc="Fast and easy way to run Java web application from the command line."
url="https://www.eclipse.org/jetty"
-# mips64 and riscv64 blocked by java-jre-headless
-arch="noarch !mips64 !riscv64"
+# riscv64 blocked by java-jre-headless
+arch="noarch !riscv64"
license="Apache-2.0"
depends="java-jre-headless"
subpackages="$pkgname-openrc"
diff --git a/community/jgmenu/APKBUILD b/community/jgmenu/APKBUILD
index 7d81154f7b..a8d86ef580 100644
--- a/community/jgmenu/APKBUILD
+++ b/community/jgmenu/APKBUILD
@@ -5,8 +5,8 @@ pkgver=4.4.0
pkgrel=0
pkgdesc="Simple, independent X11 menu"
url="https://github.com/johanmalm/jgmenu"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="GPL-2.0-only"
depends="
bash
diff --git a/community/jool-modules-lts/APKBUILD b/community/jool-modules-lts/APKBUILD
index 03f673b5ab..f7868fdc63 100644
--- a/community/jool-modules-lts/APKBUILD
+++ b/community/jool-modules-lts/APKBUILD
@@ -30,7 +30,7 @@ pkgver=$_kver
pkgrel=$(( $_krel + $_rel ))
pkgdesc="SIIT and NAT64 for Linux (kernel modules for linux-$_flavor)"
url="https://jool.mx"
-arch="all !armhf !mips64 !riscv64"
+arch="all !armhf !riscv64"
license="GPL-2.0-or-later"
depends="$_kpkg=$_kpkgver"
makedepends="$_kpkg-dev=$_kpkgver linux-headers"
diff --git a/community/jruby/APKBUILD b/community/jruby/APKBUILD
index 5f5e474fd8..4827cf0449 100644
--- a/community/jruby/APKBUILD
+++ b/community/jruby/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="An implementation of Ruby on the JVM"
url="https://www.jruby.org/"
# all arches blocked by java-jffi
-arch="noarch !armhf !armv7 !mips !mips64 !ppc64le !x86 !s390x !riscv64"
+arch="noarch !armhf !armv7 !ppc64le !x86 !s390x !riscv64"
license="EPL-2.0 OR GPL-2.0-or-later OR LGPL-2.1-or-later AND Ruby"
# libc6-compat: https://github.com/jnr/jnr-posix/issues/73
depends="$pkgname-libs=$pkgver-r$pkgrel
diff --git a/community/juk/APKBUILD b/community/juk/APKBUILD
index dd3d2f53c5..76f3192508 100644
--- a/community/juk/APKBUILD
+++ b/community/juk/APKBUILD
@@ -4,8 +4,8 @@ pkgname=juk
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://juk.kde.org/"
pkgdesc="A jukebox, tagger and music collection manager"
license="GPL-2.0-or-later"
diff --git a/community/jwm/APKBUILD b/community/jwm/APKBUILD
index 4e83fc52f5..fb1e956512 100644
--- a/community/jwm/APKBUILD
+++ b/community/jwm/APKBUILD
@@ -7,8 +7,8 @@ pkgrel=1
pkgdesc="A lightweight window manager for the X11 Window System"
options="!check" # No testsuite
url="http://joewing.net/projects/jwm/"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="MIT"
makedepends="libx11-dev libxext-dev libxft-dev libxmu-dev libxinerama-dev
libxpm-dev libxrender-dev libjpeg-turbo-dev libpng-dev librsvg-dev"
diff --git a/community/k9s/APKBUILD b/community/k9s/APKBUILD
index 3c225e6b18..805a4d3103 100644
--- a/community/k9s/APKBUILD
+++ b/community/k9s/APKBUILD
@@ -9,7 +9,7 @@ _date=2021-12-28T17:08:34UTC # git show -s --format=%ci | date -u +%FT%T%Z
pkgdesc="Kubernetes TUI"
url="https://k9scli.io"
# riscv64 FTBS
-arch="all !x86 !armhf !mips64 !riscv64 !aarch64" # tests fail
+arch="all !x86 !armhf !riscv64 !aarch64" # tests fail
license="Apache-2.0"
makedepends="go"
options="net chmod-clean"
diff --git a/community/kaccounts-integration/APKBUILD b/community/kaccounts-integration/APKBUILD
index e59acc923c..ecd0f3462b 100644
--- a/community/kaccounts-integration/APKBUILD
+++ b/community/kaccounts-integration/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kaccounts-integration
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64, ppc64le and riscv64 blocked by signon-ui and kdeclarative
-arch="all !armhf !s390x !mips64 !ppc64le !riscv64"
+# s390x, ppc64le and riscv64 blocked by signon-ui and kdeclarative
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://kde.org/applications/internet/"
pkgdesc="Small system to administer web accounts for the sites and services across the KDE desktop"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
diff --git a/community/kaccounts-providers/APKBUILD b/community/kaccounts-providers/APKBUILD
index 046135f457..826d9c8cf7 100644
--- a/community/kaccounts-providers/APKBUILD
+++ b/community/kaccounts-providers/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kaccounts-providers
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, ppc64le, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/internet/"
pkgdesc="Small system to administer web accounts for the sites and services across the KDE desktop"
license="GPL-2.0-or-later"
diff --git a/community/kactivitymanagerd/APKBUILD b/community/kactivitymanagerd/APKBUILD
index 1a1f4c08f7..4841991e09 100644
--- a/community/kactivitymanagerd/APKBUILD
+++ b/community/kactivitymanagerd/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="System service to manage user's activities and track the usage patterns"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-only OR GPL-3.0-only"
depends="qt5-qtbase-sqlite"
diff --git a/community/kaddressbook/APKBUILD b/community/kaddressbook/APKBUILD
index 24551dad45..335c1fdf2f 100644
--- a/community/kaddressbook/APKBUILD
+++ b/community/kaddressbook/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kaddressbook
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/components/kaddressbook.html"
pkgdesc="Address Book application to manage your contacts"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
diff --git a/community/kajongg/APKBUILD b/community/kajongg/APKBUILD
index 286472c171..021d42346a 100644
--- a/community/kajongg/APKBUILD
+++ b/community/kajongg/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kajongg
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kconfigwidgets
-arch="noarch !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kconfigwidgets
+arch="noarch !armhf !s390x !riscv64"
url="https://kde.org/applications/games/org.kde.kajongg"
pkgdesc="Mah Jongg - the ancient Chinese board game for 4 players"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kalarm/APKBUILD b/community/kalarm/APKBUILD
index 916c6c30a0..b54643e54d 100644
--- a/community/kalarm/APKBUILD
+++ b/community/kalarm/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kalarm
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Personal alarm scheduler"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kalarmcal/APKBUILD b/community/kalarmcal/APKBUILD
index 7dd8872f53..ff64c80c9b 100644
--- a/community/kalarmcal/APKBUILD
+++ b/community/kalarmcal/APKBUILD
@@ -4,9 +4,9 @@ pkgname=kalarmcal
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kcalutils
+# s390x and riscv64 blocked by polkit -> kcalutils
# ppc64le blocked by qt5-qtwebengine -> akonadi
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://kontact.kde.org/"
pkgdesc="The KAlarm client library"
license="LGPL-2.0-or-later"
diff --git a/community/kalgebra/APKBUILD b/community/kalgebra/APKBUILD
index c738183182..41b3941045 100644
--- a/community/kalgebra/APKBUILD
+++ b/community/kalgebra/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kalgebra
pkgver=21.12.1
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kalgebra/"
pkgdesc="2D and 3D Graph Calculator"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kalzium/APKBUILD b/community/kalzium/APKBUILD
index 9f5f8973dd..727288cda7 100644
--- a/community/kalzium/APKBUILD
+++ b/community/kalzium/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kalzium
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> khtml
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> khtml
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kalzium/"
pkgdesc="Periodic Table of Elements"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kamera/APKBUILD b/community/kamera/APKBUILD
index 835d2fccc3..e85c296abb 100644
--- a/community/kamera/APKBUILD
+++ b/community/kamera/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
# s390x blocked by exif
-# mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/graphics"
pkgdesc="KDE integration for gphoto2 cameras"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kamoso/APKBUILD b/community/kamoso/APKBUILD
index 128640a09c..db847783ae 100644
--- a/community/kamoso/APKBUILD
+++ b/community/kamoso/APKBUILD
@@ -4,9 +4,9 @@ pkgname=kamoso
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> purpose
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://kde.org/applications/multimedia/org.kde.kamoso"
pkgdesc="An application to take pictures and videos out of your webcam"
license="GPL-2.0-or-later AND LGPL-2.1-only"
diff --git a/community/kanagram/APKBUILD b/community/kanagram/APKBUILD
index a430fd5548..b34307a67e 100644
--- a/community/kanagram/APKBUILD
+++ b/community/kanagram/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kanagram
pkgver=21.12.1
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kanagram/"
pkgdesc="Letter Order Game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kapman/APKBUILD b/community/kapman/APKBUILD
index 91e44a7d7d..002242277d 100644
--- a/community/kapman/APKBUILD
+++ b/community/kapman/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kapman
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/org.kde.kapman"
pkgdesc="A clone of the well known game Pac-Man"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kapptemplate/APKBUILD b/community/kapptemplate/APKBUILD
index b3b7b1b7a2..d964f22751 100644
--- a/community/kapptemplate/APKBUILD
+++ b/community/kapptemplate/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kapptemplate
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development/org.kde.kapptemplate"
pkgdesc="Factory for the easy creation of KDE/Qt components and programs"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kate/APKBUILD b/community/kate/APKBUILD
index d8e3f70123..56089cb6bb 100644
--- a/community/kate/APKBUILD
+++ b/community/kate/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kate
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kate"
pkgdesc="A multi-document, multi-view text editor"
license="LGPL-2.0-only AND LGPL-2.0-or-later"
diff --git a/community/katomic/APKBUILD b/community/katomic/APKBUILD
index e509f4c416..bacf4a33e2 100644
--- a/community/katomic/APKBUILD
+++ b/community/katomic/APKBUILD
@@ -4,8 +4,8 @@ pkgname=katomic
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/org.kde.katomic"
pkgdesc="A fun and educational game built around molecular geometry"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
index cee244e6e7..87c444e234 100644
--- a/community/kauth/APKBUILD
+++ b/community/kauth/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Abstraction to system policy and authentication features"
# armhf blocked by extra-cmake-modules
-# mips, mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kbackup/APKBUILD b/community/kbackup/APKBUILD
index 53b5ce7a8f..57012797e3 100644
--- a/community/kbackup/APKBUILD
+++ b/community/kbackup/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kbackup
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kbackup"
pkgdesc="An application which lets you back up your data in a simple, user friendly way"
license="GPL-2.0-only"
diff --git a/community/kblackbox/APKBUILD b/community/kblackbox/APKBUILD
index c4ca20c050..383759698d 100644
--- a/community/kblackbox/APKBUILD
+++ b/community/kblackbox/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kblackbox
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/org.kde.kblackbox"
pkgdesc="A game of hide and seek played on a grid of boxes"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kblocks/APKBUILD b/community/kblocks/APKBUILD
index 45f59e45c2..a2e8c26c9e 100644
--- a/community/kblocks/APKBUILD
+++ b/community/kblocks/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kblocks
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kblocks/"
pkgdesc="The classic falling blocks game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kbookmarks/APKBUILD b/community/kbookmarks/APKBUILD
index ad0a693a96..1889efbb86 100644
--- a/community/kbookmarks/APKBUILD
+++ b/community/kbookmarks/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Support for bookmarks and the XBEL format"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kbounce/APKBUILD b/community/kbounce/APKBUILD
index 2833b8448f..123d17e355 100644
--- a/community/kbounce/APKBUILD
+++ b/community/kbounce/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kbounce
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kbounce/"
pkgdesc="A single player arcade game with the elements of puzzle"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kbreakout/APKBUILD b/community/kbreakout/APKBUILD
index 9bb841febc..6b9bf51db6 100644
--- a/community/kbreakout/APKBUILD
+++ b/community/kbreakout/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kbreakout
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kbreakout/"
pkgdesc="A Breakout-like game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kbruch/APKBUILD b/community/kbruch/APKBUILD
index cebd9adb23..49d1646917 100644
--- a/community/kbruch/APKBUILD
+++ b/community/kbruch/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kbruch
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kbruch/"
pkgdesc="Practice Fractions"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kcachegrind/APKBUILD b/community/kcachegrind/APKBUILD
index cb0ec7d956..e0b7822e4d 100644
--- a/community/kcachegrind/APKBUILD
+++ b/community/kcachegrind/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kcachegrind
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and risc64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and risc64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development/org.kde.kcachegrind"
pkgdesc="A profile data visualization tool, used to determine the most time consuming parts in the execution of a program"
license="GPL-2.0-only AND GFDL-1.2-only"
diff --git a/community/kcalc/APKBUILD b/community/kcalc/APKBUILD
index 9f8415d95e..2662dbeaee 100644
--- a/community/kcalc/APKBUILD
+++ b/community/kcalc/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kcalc
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kcalc"
pkgdesc="Scientific Calculator"
license="GPL-2.0-or-later"
diff --git a/community/kcalutils/APKBUILD b/community/kcalutils/APKBUILD
index e496585fb2..9fda4aeb9d 100644
--- a/community/kcalutils/APKBUILD
+++ b/community/kcalutils/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="The KDE calendar utility library"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kconfigwidgets
+arch="all !armhf !s390x !riscv64"
url="https://api.kde.org/kdepim/kcalutils/html"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/kcharselect/APKBUILD b/community/kcharselect/APKBUILD
index 059cb97163..dc7c0ea872 100644
--- a/community/kcharselect/APKBUILD
+++ b/community/kcharselect/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kcharselect
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kcharselect"
pkgdesc="A tool to select special characters from all installed fonts and copy them into the clipboard"
license="GPL-2.0-or-later"
diff --git a/community/kclock/APKBUILD b/community/kclock/APKBUILD
index 6fb07ed239..c49db13748 100644
--- a/community/kclock/APKBUILD
+++ b/community/kclock/APKBUILD
@@ -6,9 +6,9 @@ pkgrel=0
pkgdesc="Clock app for Plasma Mobile"
url="https://invent.kde.org/plasma-mobile/kclock"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-framework
+# s390x and riscv64 blocked by polkit -> plasma-framework
# x86 broken
-arch="all !armhf !s390x !x86 !mips64 !riscv64"
+arch="all !armhf !s390x !x86 !riscv64"
license="LicenseRef-KDE-Accepted-GPL"
depends="
kirigami-addons
diff --git a/community/kcmutils/APKBUILD b/community/kcmutils/APKBUILD
index 2427d97d13..916a035fb4 100644
--- a/community/kcmutils/APKBUILD
+++ b/community/kcmutils/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Utilities for interacting with KCModules"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kcolorchooser/APKBUILD b/community/kcolorchooser/APKBUILD
index b2522c49d5..9592182bfc 100644
--- a/community/kcolorchooser/APKBUILD
+++ b/community/kcolorchooser/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kcolorchooser
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/graphics/org.kde.kcolorchooser"
pkgdesc="A color palette tool, used to mix colors and create custom color palettes"
license="MIT"
diff --git a/community/kconfigwidgets/APKBUILD b/community/kconfigwidgets/APKBUILD
index 336b8d0cf3..eb47607ced 100644
--- a/community/kconfigwidgets/APKBUILD
+++ b/community/kconfigwidgets/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Widgets for KConfig"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kcron/APKBUILD b/community/kcron/APKBUILD
index e4536acdcd..790436f7ea 100644
--- a/community/kcron/APKBUILD
+++ b/community/kcron/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kcron
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/system/"
pkgdesc="Configure and schedule tasks"
license="GPL-2.0-or-later"
diff --git a/community/kdav/APKBUILD b/community/kdav/APKBUILD
index ac788ce403..69ae3c22b5 100644
--- a/community/kdav/APKBUILD
+++ b/community/kdav/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="A DAV protocol implementation with KJobs"
url="https://community.kde.org/Frameworks"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
license="LGPL-2.0-or-later"
depends_dev="
kcoreaddons-dev
diff --git a/community/kde-applications/APKBUILD b/community/kde-applications/APKBUILD
index 62447254e4..a6167ac062 100644
--- a/community/kde-applications/APKBUILD
+++ b/community/kde-applications/APKBUILD
@@ -3,7 +3,7 @@
pkgname=kde-applications
pkgver=21.12.1
pkgrel=0
-arch="noarch !mips64 !ppc64le !s390x" # Limited by edu, network, umbrello and pim
+arch="noarch !ppc64le !s390x" # Limited by edu, network, umbrello and pim
url="https://kde.org/applications/"
pkgdesc="KDE Applications meta package"
license="GPL-3.0-or-later"
diff --git a/community/kde-cli-tools/APKBUILD b/community/kde-cli-tools/APKBUILD
index 80992d9d82..f8725ca945 100644
--- a/community/kde-cli-tools/APKBUILD
+++ b/community/kde-cli-tools/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Tools based on KDE Frameworks 5 to better interact with the system"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/plasma/kde-cli-tools"
license="(GPL-2.0-only OR GPL-3.0-only) AND GPL-2.0-or-later AND GPL-2.0-only AND LGPL-2.1-only"
makedepends="
diff --git a/community/kde-dev-utils/APKBUILD b/community/kde-dev-utils/APKBUILD
index 180b8a7fba..627115c852 100644
--- a/community/kde-dev-utils/APKBUILD
+++ b/community/kde-dev-utils/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kde-dev-utils
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kparts-dev
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kparts-dev
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development/"
pkgdesc="Small utilities for developers using KDE/Qt libs/frameworks"
license="(LGPL-2.0-only OR LGPL-3.0-only) AND GPL-2.0-or-later"
diff --git a/community/kde-gtk-config/APKBUILD b/community/kde-gtk-config/APKBUILD
index c0414a1681..c0d1a41392 100644
--- a/community/kde-gtk-config/APKBUILD
+++ b/community/kde-gtk-config/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="GTK2 and GTK3 Configurator for KDE"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64, riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x, riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/plasma/kde-gtk-config"
license="GPL-2.0 AND LGPL-2.1-only OR LGPL-3.0-only"
depends="gsettings-desktop-schemas"
diff --git a/community/kdeclarative/APKBUILD b/community/kdeclarative/APKBUILD
index 465a7cc76e..7b6f08645a 100644
--- a/community/kdeclarative/APKBUILD
+++ b/community/kdeclarative/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Provides integration of QML and KDE Frameworks"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kdeconnect/APKBUILD b/community/kdeconnect/APKBUILD
index 5db3b373c9..fd7060bde9 100644
--- a/community/kdeconnect/APKBUILD
+++ b/community/kdeconnect/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="Adds communication between KDE and your smartphone"
url="https://community.kde.org/KDEConnect"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
license="GPL-2.0-only OR GPL-3.0-only"
depends="
kirigami2
diff --git a/community/kdegraphics-mobipocket/APKBUILD b/community/kdegraphics-mobipocket/APKBUILD
index d3f655382e..40a3f6fe21 100644
--- a/community/kdegraphics-mobipocket/APKBUILD
+++ b/community/kdegraphics-mobipocket/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A collection of plugins to handle mobipocket files"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/graphics/"
license="GPL-2.0-or-later"
depends_dev="
diff --git a/community/kdegraphics-thumbnailers/APKBUILD b/community/kdegraphics-thumbnailers/APKBUILD
index 1df70936f8..9ef3990ffb 100644
--- a/community/kdegraphics-thumbnailers/APKBUILD
+++ b/community/kdegraphics-thumbnailers/APKBUILD
@@ -5,7 +5,7 @@ pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
# s390x and riscv64 blocked by kio -> polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
pkgdesc="Thumbnailers for various graphics file formats"
url="https://www.kde.org/applications/graphics/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
diff --git a/community/kdelibs4support/APKBUILD b/community/kdelibs4support/APKBUILD
index f59b15f8de..e00cc221d4 100644
--- a/community/kdelibs4support/APKBUILD
+++ b/community/kdelibs4support/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Porting aid from KDELibs4"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-only AND (LGPL-2.1-only OR LGPL-3.0-only) AND (LGPL-2.0-only OR LGPL-3.0-only)"
depends_dev="
diff --git a/community/kdenetwork-filesharing/APKBUILD b/community/kdenetwork-filesharing/APKBUILD
index 6b960b142a..e4ce6764a6 100644
--- a/community/kdenetwork-filesharing/APKBUILD
+++ b/community/kdenetwork-filesharing/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kdenetwork-filesharing
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# armhf, s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf, s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/internet/"
pkgdesc="Properties dialog plugin to share a directory with the local network"
license="GPL-2.0-only OR GPL-3.0-only"
diff --git a/community/kdenlive/APKBUILD b/community/kdenlive/APKBUILD
index 395e71b977..bf3e3722ff 100644
--- a/community/kdenlive/APKBUILD
+++ b/community/kdenlive/APKBUILD
@@ -3,9 +3,9 @@
pkgname=kdenlive
pkgver=21.12.1
pkgrel=0
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
+# s390x and riscv64 blocked by polkit -> kxmlgui
# ppc64le mlt uses 64bit long double while libgcc uses 128bit long double
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://kdenlive.org"
pkgdesc="An intuitive and powerful multi-track video editor, including most recent video technologies"
license="GPL-2.0-or-later"
diff --git a/community/kdepim-addons/APKBUILD b/community/kdepim-addons/APKBUILD
index b471864c3a..0e6d6cbd4d 100644
--- a/community/kdepim-addons/APKBUILD
+++ b/community/kdepim-addons/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kdepim-addons
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Addons for KDE PIM applications"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
diff --git a/community/kdepim-runtime/APKBUILD b/community/kdepim-runtime/APKBUILD
index 1a3b57b778..06b45a6255 100644
--- a/community/kdepim-runtime/APKBUILD
+++ b/community/kdepim-runtime/APKBUILD
@@ -7,8 +7,8 @@ pkgdesc="Extends the functionality of kdepim"
url="https://kontact.kde.org/"
# armhf blocked by extra-cmake-modules
# ppc64le blocked by qt5-qtwebengine -> libkgapi
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !ppc64le !s390x !riscv64"
license="LGPL-2.0-or-later"
makedepends="
akonadi-calendar-dev
diff --git a/community/kdeplasma-addons/APKBUILD b/community/kdeplasma-addons/APKBUILD
index 0d06a5c033..22384ce222 100644
--- a/community/kdeplasma-addons/APKBUILD
+++ b/community/kdeplasma-addons/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="All kind of addons to improve your Plasma experience"
# armhf blocked by qt5-qtdeclarative
-# mips, ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.0-only AND GPL-2.0-or-later"
depends="purpose"
diff --git a/community/kdeplasma-applets-xrdesktop/APKBUILD b/community/kdeplasma-applets-xrdesktop/APKBUILD
index 4fa5d3b00a..1477c25bd3 100644
--- a/community/kdeplasma-applets-xrdesktop/APKBUILD
+++ b/community/kdeplasma-applets-xrdesktop/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="xrdesktop applet for KDE Plasma"
url="https://gitlab.freedesktop.org/xrdesktop/kdeplasma-applets-xrdesktop"
# armhf blocked by extra-cmake-modules
-# mips64, s390x, ppc64le and riscv64 blocked by polkit -> kwin-effect-xrdesktop
-arch="noarch !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by polkit -> kwin-effect-xrdesktop
+arch="noarch !armhf !s390x !ppc64le !riscv64"
license="MIT"
depends="
kwin-effect-xrdesktop
diff --git a/community/kdesdk-kioslaves/APKBUILD b/community/kdesdk-kioslaves/APKBUILD
index b1067ecb76..c999ce5b91 100644
--- a/community/kdesdk-kioslaves/APKBUILD
+++ b/community/kdesdk-kioslaves/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kdesdk-kioslaves
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development"
pkgdesc="KIO-Slaves"
license="GPL-2.0-or-later"
diff --git a/community/kdesdk-thumbnailers/APKBUILD b/community/kdesdk-thumbnailers/APKBUILD
index 521fa51234..4377605a60 100644
--- a/community/kdesdk-thumbnailers/APKBUILD
+++ b/community/kdesdk-thumbnailers/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kdesdk-thumbnailers
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/development/"
pkgdesc="Plugins for the thumbnailing system"
license="GPL-2.0-only OR GPL-3.0-only"
diff --git a/community/kdesignerplugin/APKBUILD b/community/kdesignerplugin/APKBUILD
index 3757042ac6..9e14ce2f7c 100644
--- a/community/kdesignerplugin/APKBUILD
+++ b/community/kdesignerplugin/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Integration of Frameworks widgets in Qt Designer/Creator"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
depends_dev="
diff --git a/community/kdevelop/APKBUILD b/community/kdevelop/APKBUILD
index ab5b894f08..0e775e93d1 100644
--- a/community/kdevelop/APKBUILD
+++ b/community/kdevelop/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kdevelop
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://www.kdevelop.org/"
pkgdesc="A featureful, plugin-extensible IDE for C/C++ and other programming languages"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kdf/APKBUILD b/community/kdf/APKBUILD
index 3848bdf229..30b93fd16b 100644
--- a/community/kdf/APKBUILD
+++ b/community/kdf/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kdf
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/system/org.kde.kdf"
pkgdesc="View disk usage"
license="GPL-2.0-or-later"
diff --git a/community/kdialog/APKBUILD b/community/kdialog/APKBUILD
index 042b958d55..c9977001a1 100644
--- a/community/kdialog/APKBUILD
+++ b/community/kdialog/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kdialog
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/"
pkgdesc="A utility for displaying dialog boxes from shell scripts"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kdiamond/APKBUILD b/community/kdiamond/APKBUILD
index c2a172498c..0bd90ac97e 100644
--- a/community/kdiamond/APKBUILD
+++ b/community/kdiamond/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A single player puzzle game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kdiamond/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/keditbookmarks/APKBUILD b/community/keditbookmarks/APKBUILD
index 74e71a5be4..b631435607 100644
--- a/community/keditbookmarks/APKBUILD
+++ b/community/keditbookmarks/APKBUILD
@@ -4,8 +4,8 @@ pkgname=keditbookmarks
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and mips64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/"
pkgdesc="Bookmark Organizer and Editor"
license="GPL-2.0-only AND GFDL-1.2-only"
diff --git a/community/kfind/APKBUILD b/community/kfind/APKBUILD
index ecc9edf3fa..ff76d949de 100644
--- a/community/kfind/APKBUILD
+++ b/community/kfind/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kfind
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/utilities/kfind"
pkgdesc="Find Files/Folders"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kfloppy/APKBUILD b/community/kfloppy/APKBUILD
index 211cf9b269..d59c428458 100644
--- a/community/kfloppy/APKBUILD
+++ b/community/kfloppy/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kfloppy
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kfloppy"
pkgdesc="A utility that provides a straightforward graphical means to format 3.5\" and 5.25\" floppy disks"
license="GPL-2.0-or-later"
diff --git a/community/kfourinline/APKBUILD b/community/kfourinline/APKBUILD
index c3d98f9c78..5032505032 100644
--- a/community/kfourinline/APKBUILD
+++ b/community/kfourinline/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A four-in-a-row game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kfourinline/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kgamma5/APKBUILD b/community/kgamma5/APKBUILD
index abdb243896..05bcee3c6f 100644
--- a/community/kgamma5/APKBUILD
+++ b/community/kgamma5/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Adjust your monitor's gamma settings"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kconfigwidgets
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
makedepends="
diff --git a/community/kgeography/APKBUILD b/community/kgeography/APKBUILD
index 7b20da3109..0628893d84 100644
--- a/community/kgeography/APKBUILD
+++ b/community/kgeography/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kgeography
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kgeography"
pkgdesc="Geography Trainer"
license="GPL-2.0-or-later"
diff --git a/community/kget/APKBUILD b/community/kget/APKBUILD
index 9e912a20a8..947d90d381 100644
--- a/community/kget/APKBUILD
+++ b/community/kget/APKBUILD
@@ -5,8 +5,7 @@ pkgver=21.12.1
pkgrel=0
# ppc64le, s390x and riscv64 blocked by polkit -> kio
# armhf blocked by extra-cmake-modules
-# mips64 blocked by libktorrent
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/internet/org.kde.kget"
pkgdesc="A versatile and user-friendly download manager"
license="GPL-2.0-or-later AND LGPL-2.0-only AND GFDL-1.2-only"
diff --git a/community/kgoldrunner/APKBUILD b/community/kgoldrunner/APKBUILD
index c23bca1be1..490d4cc3a6 100644
--- a/community/kgoldrunner/APKBUILD
+++ b/community/kgoldrunner/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kgoldrunner
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kgoldrunner/"
pkgdesc="A game of action and puzzle solving"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kgpg/APKBUILD b/community/kgpg/APKBUILD
index 9e2750b9bd..9a050cfa5c 100644
--- a/community/kgpg/APKBUILD
+++ b/community/kgpg/APKBUILD
@@ -4,9 +4,9 @@ pkgname=kgpg
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> kaccounts-integration
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://kde.org/applications/utilities/org.kde.kgpg"
pkgdesc="A simple interface for GnuPG, a powerful encryption utility"
license="GPL-2.0-or-later"
diff --git a/community/kgx/APKBUILD b/community/kgx/APKBUILD
index 7c911ecf1b..5f6053f2b5 100644
--- a/community/kgx/APKBUILD
+++ b/community/kgx/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.4.0
pkgrel=1
pkgdesc="A minimal terminal for GNOME"
url="https://gitlab.gnome.org/ZanderBrown/kgx"
-# s390x, mips64 and riscv64 blocked by rust -> libhandy
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by rust -> libhandy
+arch="all !s390x !riscv64"
license="GPL-3.0-only"
depends="
dbus
diff --git a/community/khangman/APKBUILD b/community/khangman/APKBUILD
index 973e84d844..6864d64625 100644
--- a/community/khangman/APKBUILD
+++ b/community/khangman/APKBUILD
@@ -4,8 +4,8 @@ pkgname=khangman
pkgver=21.12.1
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/khangman"
pkgdesc="Hangman game"
license="GPL-2.0-or-later"
diff --git a/community/khelpcenter/APKBUILD b/community/khelpcenter/APKBUILD
index 4fb4e2fcc9..cf32f143c4 100644
--- a/community/khelpcenter/APKBUILD
+++ b/community/khelpcenter/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Application to show KDE Applications' documentation"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> khtml
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> khtml
+arch="all !armhf !s390x !riscv64"
url="https://userbase.kde.org/KHelpCenter"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/khotkeys/APKBUILD b/community/khotkeys/APKBUILD
index 69571289d4..6800d31c97 100644
--- a/community/khotkeys/APKBUILD
+++ b/community/khotkeys/APKBUILD
@@ -4,8 +4,8 @@ pkgname=khotkeys
pkgver=5.24.0
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by libksysguard
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by libksysguard
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
pkgdesc="Key Accelerator Application"
license="GPL-2.0-only AND LGPL-2.0-or-later"
diff --git a/community/khtml/APKBUILD b/community/khtml/APKBUILD
index b6fb01658f..ff92e2c45e 100644
--- a/community/khtml/APKBUILD
+++ b/community/khtml/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="The KDE HTML library, ancestor of WebKit"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND LGPL-2.1-only"
depends_dev="
diff --git a/community/kiconthemes/APKBUILD b/community/kiconthemes/APKBUILD
index dd6b8cc08d..c096e387f9 100644
--- a/community/kiconthemes/APKBUILD
+++ b/community/kiconthemes/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Support for icon themes"
# armhf blocked by extra-cmake-module
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only"
depends_dev="
diff --git a/community/kidentitymanagement/APKBUILD b/community/kidentitymanagement/APKBUILD
index bde9e98359..d99aa4c0c9 100644
--- a/community/kidentitymanagement/APKBUILD
+++ b/community/kidentitymanagement/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM libraries"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kontact.kde.org"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/kig/APKBUILD b/community/kig/APKBUILD
index 6139e3da26..168bf1a54b 100644
--- a/community/kig/APKBUILD
+++ b/community/kig/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kig
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kig"
pkgdesc="Interactive Geometry"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kigo/APKBUILD b/community/kigo/APKBUILD
index 52c90741db..d52a909e12 100644
--- a/community/kigo/APKBUILD
+++ b/community/kigo/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="An open-source implementation of the popular Go game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kigo/"
license="LicenseRef-KDE-Accepted-GPL AND GFDL-1.2-only"
makedepends="
diff --git a/community/kile/APKBUILD b/community/kile/APKBUILD
index 30371c2800..51e61d633c 100644
--- a/community/kile/APKBUILD
+++ b/community/kile/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kile
pkgver=2.9.93
pkgrel=1
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by texlive
-arch="all !armhf !ppc64le !mips64 !s390x !riscv64"
+# ppc64le, s390x and riscv64 blocked by texlive
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/office/org.kde.kile"
pkgdesc="A user-friendly TeX/LaTeX editor"
license="GPL-2.0-or-later"
diff --git a/community/killbots/APKBUILD b/community/killbots/APKBUILD
index f4f17bcebe..32d5cefd73 100644
--- a/community/killbots/APKBUILD
+++ b/community/killbots/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A simple game of evading killer robots"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/killbots/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kimageformats/APKBUILD b/community/kimageformats/APKBUILD
index 14be4c58ba..3df8678885 100644
--- a/community/kimageformats/APKBUILD
+++ b/community/kimageformats/APKBUILD
@@ -5,8 +5,7 @@ pkgver=5.90.0
pkgrel=1
pkgdesc="Image format plugins for Qt5"
# armhf blocked by extra-cmake-modules
-# mips64 blocked by openexr
-arch="all !armhf !mips64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
makedepends="
diff --git a/community/kimagemapeditor/APKBUILD b/community/kimagemapeditor/APKBUILD
index 41ed3fcb01..fd437c6ecf 100644
--- a/community/kimagemapeditor/APKBUILD
+++ b/community/kimagemapeditor/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kimagemapeditor
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/development/org.kde.kimagemapeditor"
pkgdesc="An editor of image maps embedded inside HTML files, based on the <map> tag"
license="GPL-2.0-or-later"
diff --git a/community/kimap/APKBUILD b/community/kimap/APKBUILD
index d0fa776589..ee17eea1be 100644
--- a/community/kimap/APKBUILD
+++ b/community/kimap/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Job-based API for interacting with IMAP servers"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio-dev
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kio-dev
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/kinfocenter/APKBUILD b/community/kinfocenter/APKBUILD
index 1ff2746152..3bb47ccb16 100644
--- a/community/kinfocenter/APKBUILD
+++ b/community/kinfocenter/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="A utility that provides information about a computer system"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="
diff --git a/community/kinit/APKBUILD b/community/kinit/APKBUILD
index fcb6f35f6c..316de51073 100644
--- a/community/kinit/APKBUILD
+++ b/community/kinit/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Process launcher to speed up launching KDE applications"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
diff --git a/community/kio-extras/APKBUILD b/community/kio-extras/APKBUILD
index ee9140c5b3..6382917bdb 100644
--- a/community/kio-extras/APKBUILD
+++ b/community/kio-extras/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kio-extras
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/internet/"
pkgdesc="Additional components to increase the functionality of KIO"
license="GPL-2.0-or-later (LGPL-2.1-only OR LGPL-3.0-only)"
diff --git a/community/kio-fuse/APKBUILD b/community/kio-fuse/APKBUILD
index 067c782978..c14d6ee27e 100644
--- a/community/kio-fuse/APKBUILD
+++ b/community/kio-fuse/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kio-fuse
pkgver=5.0.1
pkgrel=1
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/"
pkgdesc="FUSE interface for KIO"
license="GPL-3.0-only"
diff --git a/community/kio-gdrive/APKBUILD b/community/kio-gdrive/APKBUILD
index dd4e227cd2..03001a670a 100644
--- a/community/kio-gdrive/APKBUILD
+++ b/community/kio-gdrive/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kio-gdrive
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> libkgapi
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine -> libkgapi
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://community.kde.org/KIO_GDrive"
pkgdesc="KIO Slave to access Google Drive"
license="GPL-2.0-or-later"
diff --git a/community/kio/APKBUILD b/community/kio/APKBUILD
index a0cca56b35..e17b7fb1e5 100644
--- a/community/kio/APKBUILD
+++ b/community/kio/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Resource and network access abstraction"
# armhf blocked by extra-cmake-modules
- # mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+ # s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="
diff --git a/community/kipi-plugins/APKBUILD b/community/kipi-plugins/APKBUILD
index e54a3ef824..9b09898fb8 100644
--- a/community/kipi-plugins/APKBUILD
+++ b/community/kipi-plugins/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A collection of plugins extending the KDE graphics and image applications"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://userbase.kde.org/KIPI"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kiriki/APKBUILD b/community/kiriki/APKBUILD
index 76a13c2dd2..4bd87567c7 100644
--- a/community/kiriki/APKBUILD
+++ b/community/kiriki/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="An addictive and fun dice game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kiriki/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kiten/APKBUILD b/community/kiten/APKBUILD
index d18dab2207..319fdc8120 100644
--- a/community/kiten/APKBUILD
+++ b/community/kiten/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kiten
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kconfigwidgets
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kiten/"
pkgdesc="Japanese Reference/Study Tool"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kitty/APKBUILD b/community/kitty/APKBUILD
index 425802d5bd..acc19bb665 100644
--- a/community/kitty/APKBUILD
+++ b/community/kitty/APKBUILD
@@ -6,7 +6,7 @@ pkgver=0.24.1
pkgrel=0
pkgdesc="Modern, hackable, featureful, OpenGL based terminal emulator"
url="https://sw.kovidgoyal.net/kitty/"
-arch="all !mips !mips64" # fails to build on mips
+arch="all"
license="GPL-3.0-only"
depends="less ncurses ncurses-terminfo-base py3-pygments"
checkdepends="ttf-dejavu"
diff --git a/community/kiwiirc/APKBUILD b/community/kiwiirc/APKBUILD
index 176693d7a7..855ab28b55 100644
--- a/community/kiwiirc/APKBUILD
+++ b/community/kiwiirc/APKBUILD
@@ -6,8 +6,8 @@ pkgver=0.9.4
pkgrel=2
pkgdesc="A hand-crafted webirc client"
url="https://www.kiwiirc.com/"
-# mips64 and riscv64 blocked by nodejs
-arch="noarch !mips64 !riscv64"
+# riscv64 blocked by nodejs
+arch="noarch !riscv64"
license="AGPL-3.0"
depends="nodejs>=0.10.0"
makedepends="nodejs npm"
diff --git a/community/kjumpingcube/APKBUILD b/community/kjumpingcube/APKBUILD
index 71b574b3fe..aafdc2936c 100644
--- a/community/kjumpingcube/APKBUILD
+++ b/community/kjumpingcube/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A simple tactical game"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kjumpingcube/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kldap/APKBUILD b/community/kldap/APKBUILD
index 436a67dfee..72e5751afd 100644
--- a/community/kldap/APKBUILD
+++ b/community/kldap/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="LDAP access API for KDE"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://github.com/kde/kldap"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/kleopatra/APKBUILD b/community/kleopatra/APKBUILD
index 79b3db0695..3810e77442 100644
--- a/community/kleopatra/APKBUILD
+++ b/community/kleopatra/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kleopatra
pkgver=21.12.1
pkgrel=0
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/utilities/kleopatra/"
pkgdesc="Certificate Manager and Unified Crypto GUI"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/klettres/APKBUILD b/community/klettres/APKBUILD
index 54181e3f50..c7b381bf4d 100644
--- a/community/klettres/APKBUILD
+++ b/community/klettres/APKBUILD
@@ -4,8 +4,8 @@ pkgname=klettres
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> knewstuff
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> knewstuff
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/klettres"
pkgdesc="Learn the Alphabet"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/klickety/APKBUILD b/community/klickety/APKBUILD
index 313f5d36a2..6fafd69299 100644
--- a/community/klickety/APKBUILD
+++ b/community/klickety/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="An adaptation of the Clickomania game"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/klickety/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/klines/APKBUILD b/community/klines/APKBUILD
index 58ed4c95e5..975d11a27d 100644
--- a/community/klines/APKBUILD
+++ b/community/klines/APKBUILD
@@ -4,8 +4,8 @@ pkgname=klines
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/klines/"
pkgdesc="A simple but highly addictive one player game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kmag/APKBUILD b/community/kmag/APKBUILD
index 073274bde5..96832acaa5 100644
--- a/community/kmag/APKBUILD
+++ b/community/kmag/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kmag
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kmag"
pkgdesc="A screen magnifier"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kmail-account-wizard/APKBUILD b/community/kmail-account-wizard/APKBUILD
index cd4a729599..e458d9850a 100644
--- a/community/kmail-account-wizard/APKBUILD
+++ b/community/kmail-account-wizard/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kmail-account-wizard
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> kmailtransport
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine -> kmailtransport
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="KMail account wizard"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kmail/APKBUILD b/community/kmail/APKBUILD
index 233832cfd6..b1cfb0518f 100644
--- a/community/kmail/APKBUILD
+++ b/community/kmail/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kmail
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/components/kmail.html"
pkgdesc="Email client, supporting POP3 and IMAP mailboxes"
license="GPL-2.0-or-later"
diff --git a/community/kmailtransport/APKBUILD b/community/kmailtransport/APKBUILD
index c8f281573b..983645a282 100644
--- a/community/kmailtransport/APKBUILD
+++ b/community/kmailtransport/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Manage mail transport"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x and mips64 blocked by libkgapi
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le and s390x blocked by libkgapi
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/kmbox/APKBUILD b/community/kmbox/APKBUILD
index 32950dbfc8..d16e49a1dd 100644
--- a/community/kmbox/APKBUILD
+++ b/community/kmbox/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Library for accessing mail storages in MBox format"
# armhf blocked by extra-cmake-modules
-# mips, mips64 and s390x blocked by kmime
-arch="all !armhf !mips !mips64 !s390x"
+# s390x blocked by kmime
+arch="all !armhf !s390x"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later"
depends_dev="kmime-dev"
diff --git a/community/kmediaplayer/APKBUILD b/community/kmediaplayer/APKBUILD
index 11100b8437..ac97c13013 100644
--- a/community/kmediaplayer/APKBUILD
+++ b/community/kmediaplayer/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Media player framework for KDE 5"
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !mips64 !s390x !riscv64" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
+arch="all !armhf !s390x !riscv64" # armhf blocked by extra-cmake-modules and s390x blocked by polkit
url="https://community.kde.org/Frameworks"
license="X11 AND LGPL-2.1-or-later"
depends_dev="qt5-qtbase-dev kparts-dev kxmlgui-dev"
diff --git a/community/kmenuedit/APKBUILD b/community/kmenuedit/APKBUILD
index 9a3c60d2a2..42b37757a2 100644
--- a/community/kmenuedit/APKBUILD
+++ b/community/kmenuedit/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="KDE menu editor"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
makedepends="
diff --git a/community/kmix/APKBUILD b/community/kmix/APKBUILD
index 4f9c485e96..256477c15a 100644
--- a/community/kmix/APKBUILD
+++ b/community/kmix/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kmix
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/multimedia/org.kde.kmix"
pkgdesc="A sound channel mixer and volume control"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kmousetool/APKBUILD b/community/kmousetool/APKBUILD
index 5196033a22..c1d34f1abb 100644
--- a/community/kmousetool/APKBUILD
+++ b/community/kmousetool/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kmousetool
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kmousetool"
pkgdesc="A program that clicks the mouse for you"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kmouth/APKBUILD b/community/kmouth/APKBUILD
index 8414faaf2f..3df9b9f10e 100644
--- a/community/kmouth/APKBUILD
+++ b/community/kmouth/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kmouth
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kmouth"
pkgdesc="Speech Synthesizer Frontend"
license="GPL-2.0-or-later"
diff --git a/community/kmplot/APKBUILD b/community/kmplot/APKBUILD
index 2da5f0feef..1290c3a29a 100644
--- a/community/kmplot/APKBUILD
+++ b/community/kmplot/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kmplot
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kparts
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kparts
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kmplot"
pkgdesc="Mathematical Function Plotter"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kmymoney/APKBUILD b/community/kmymoney/APKBUILD
index 74a0491a57..2cff0cba88 100644
--- a/community/kmymoney/APKBUILD
+++ b/community/kmymoney/APKBUILD
@@ -4,9 +4,9 @@ pkgname=kmymoney
pkgver=5.1.2
pkgrel=2
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-# armhf, mips, mips64, ppc64le, s390x, riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !mips !mips64 !ppc64le !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+# armhf, ppc64le, s390x, riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kmymoney.org/"
pkgdesc="Personal finance manager for KDE which operates similarly to MS-Money or Quicken"
license="GPL-2.0-or-later"
diff --git a/community/knavalbattle/APKBUILD b/community/knavalbattle/APKBUILD
index 12efaac9b6..f640e2798b 100644
--- a/community/knavalbattle/APKBUILD
+++ b/community/knavalbattle/APKBUILD
@@ -4,8 +4,8 @@ pkgname=knavalbattle
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/knavalbattle/"
pkgdesc="A ship sinking game"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/knetwalk/APKBUILD b/community/knetwalk/APKBUILD
index 7775c17c30..523df9749a 100644
--- a/community/knetwalk/APKBUILD
+++ b/community/knetwalk/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Connect all the terminals to the server, in as few turns as possible"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
+# s390x and riscv64 blocked by polkit -> kxmlgui
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/knetwalk/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/knewstuff/APKBUILD b/community/knewstuff/APKBUILD
index 525c49e4fc..1be1c64797 100644
--- a/community/knewstuff/APKBUILD
+++ b/community/knewstuff/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Framework for downloading and sharing additional application data"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends="kirigami2"
diff --git a/community/knights/APKBUILD b/community/knights/APKBUILD
index 6f98d32c51..dec5bc2f75 100644
--- a/community/knights/APKBUILD
+++ b/community/knights/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Chess board by KDE with XBoard protocol support"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/games/knights/"
license="GPL-2.0-or-later"
makedepends="
diff --git a/community/knotes/APKBUILD b/community/knotes/APKBUILD
index e8fd44a2b0..e2af809912 100644
--- a/community/knotes/APKBUILD
+++ b/community/knotes/APKBUILD
@@ -4,9 +4,9 @@ pkgname=knotes
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips, ppc64le and s390x blocked by kdepim-runtime
+# ppc64le and s390x blocked by kdepim-runtime
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !ppc64le !s390x !mips !mips64 !riscv64"
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Popup notes"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/knotifyconfig/APKBUILD b/community/knotifyconfig/APKBUILD
index c2f70f87f4..39579ea93d 100644
--- a/community/knotifyconfig/APKBUILD
+++ b/community/knotifyconfig/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Configuration system for KNotify"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-only"
depends_dev="
diff --git a/community/koko/APKBUILD b/community/koko/APKBUILD
index ff685298c0..8401e4a63f 100644
--- a/community/koko/APKBUILD
+++ b/community/koko/APKBUILD
@@ -7,9 +7,9 @@ _geonames_pkgver=2020.06.25
pkgdesc="Image gallery application for Plasma Mobile"
url="https://invent.kde.org/graphics/koko"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> purpose
-arch="all !armhf !s390x !mips64 !ppc64le !riscv64"
+arch="all !armhf !s390x !ppc64le !riscv64"
license="LGPL-2.0-or-later AND LGPL-2.1-only AND LGPL-3.0-only AND LicenseRef-KDE-Accepted-GPL"
depends="
kdeclarative
diff --git a/community/kolf/APKBUILD b/community/kolf/APKBUILD
index e2e605b0d8..3845853477 100644
--- a/community/kolf/APKBUILD
+++ b/community/kolf/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A miniature golf game with 2d top-down view"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kolf/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kollision/APKBUILD b/community/kollision/APKBUILD
index 444d0c9988..589ccc39ab 100644
--- a/community/kollision/APKBUILD
+++ b/community/kollision/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A simple ball dodging game"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kollision/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kolourpaint/APKBUILD b/community/kolourpaint/APKBUILD
index d3f256fea1..8c3131395c 100644
--- a/community/kolourpaint/APKBUILD
+++ b/community/kolourpaint/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kolourpaint
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="http://www.kolourpaint.org/"
pkgdesc="An easy-to-use paint program"
license="BSD-2-Clause AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kompare/APKBUILD b/community/kompare/APKBUILD
index 51e359089d..75c4711c49 100644
--- a/community/kompare/APKBUILD
+++ b/community/kompare/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kompare
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kiconthemes
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kiconthemes
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development/org.kde.kompare"
pkgdesc="Graphical File Differences Tool"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/konqueror/APKBUILD b/community/konqueror/APKBUILD
index ea70f2eab5..051edbadc4 100644
--- a/community/konqueror/APKBUILD
+++ b/community/konqueror/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE File Manager & Web Browser"
# armhf blocked by extra-cmake-modules
-# s390x, ppc64le, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://konqueror.org/"
license="GPL-2.0-or-later AND GFDL-1.2-only AND LicenseRef-KDE-Accepted-LGPL"
makedepends="
diff --git a/community/konsole/APKBUILD b/community/konsole/APKBUILD
index b6ab8ecbea..a9ce6839d1 100644
--- a/community/konsole/APKBUILD
+++ b/community/konsole/APKBUILD
@@ -4,8 +4,8 @@ pkgname=konsole
pkgver=21.12.1
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/system/konsole"
pkgdesc="KDE's terminal emulator"
license="GPL-2.0-only AND LGPL-2.1-or-later AND Unicode-DFS-2016"
diff --git a/community/kontact/APKBUILD b/community/kontact/APKBUILD
index 86b0be747d..2b27e97f45 100644
--- a/community/kontact/APKBUILD
+++ b/community/kontact/APKBUILD
@@ -4,9 +4,9 @@ pkgname=kontact
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Container application to unify several major PIM applications within one application"
license="GPL-2.0-or-later"
diff --git a/community/kontactinterface/APKBUILD b/community/kontactinterface/APKBUILD
index 6d6795a444..f5870eb92c 100644
--- a/community/kontactinterface/APKBUILD
+++ b/community/kontactinterface/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kontactinterface
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kparts
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kparts
+arch="all !armhf !s390x !riscv64"
url="https://kontact.kde.org/"
pkgdesc="Kontact Plugin Interface Library"
license="LGPL-2.0-only OR LGPL-3.0-only"
diff --git a/community/kontrast/APKBUILD b/community/kontrast/APKBUILD
index bea1b7f209..f8cb5b41fd 100644
--- a/community/kontrast/APKBUILD
+++ b/community/kontrast/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Tool to check contrast for colors that allows verifying that your colors are correctly accessible"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kdeclarative
+# s390x and riscv64 blocked by polkit -> kdeclarative
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/accessibility/kontrast"
license="GPL-3.0-or-later AND CC0-1.0"
depends="kirigami2"
diff --git a/community/konversation/APKBUILD b/community/konversation/APKBUILD
index 37883251c6..3fc29c0411 100644
--- a/community/konversation/APKBUILD
+++ b/community/konversation/APKBUILD
@@ -4,8 +4,8 @@ pkgname=konversation
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://konversation.kde.org/"
pkgdesc="A user-friendly and fully-featured IRC client"
license="GPL-2.0-or-later"
diff --git a/community/kopete/APKBUILD b/community/kopete/APKBUILD
index c62c134d94..c2fb709412 100644
--- a/community/kopete/APKBUILD
+++ b/community/kopete/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kopete
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kcmutils
+arch="all !armhf !s390x !riscv64"
url="https://userbase.kde.org/Kopete"
pkgdesc="An instant messenger supporting AIM, ICQ, Jabber, Gadu-Gadu, Novell GroupWise Messenger, and more"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/korganizer/APKBUILD b/community/korganizer/APKBUILD
index e9c5ec2138..2caea8c52c 100644
--- a/community/korganizer/APKBUILD
+++ b/community/korganizer/APKBUILD
@@ -4,8 +4,8 @@ pkgname=korganizer
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> kmailtransport
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine -> kmailtransport
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/components/korganizer.html"
pkgdesc="The calendar and scheduling component of Kontact"
license="GPL-2.0-or-later"
diff --git a/community/kparts/APKBUILD b/community/kparts/APKBUILD
index 9ad632de61..3789b66b69 100644
--- a/community/kparts/APKBUILD
+++ b/community/kparts/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Document centric plugin system"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends_dev="
diff --git a/community/kpat/APKBUILD b/community/kpat/APKBUILD
index 9a8445011b..67d914561c 100644
--- a/community/kpat/APKBUILD
+++ b/community/kpat/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KPatience offers a selection of solitaire card games"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games/kpat/"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
diff --git a/community/kpeoplesink/APKBUILD b/community/kpeoplesink/APKBUILD
index 9c64ceef6a..11479d7602 100644
--- a/community/kpeoplesink/APKBUILD
+++ b/community/kpeoplesink/APKBUILD
@@ -7,9 +7,9 @@ _commit="6f382e619e22f9f34b0760fc19a23eb1863bf45b"
pkgdesc="Expose Sink contacts to KPeople"
url="https://invent.kde.org/pim/kpeoplesink"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by signon-ui -> kaccounts-integration
+# s390x and riscv64 blocked by signon-ui -> kaccounts-integration
# ppc64le blocked by kaccounts-integration
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
license="LGPL-2.1-or-later"
makedepends="
extra-cmake-modules
diff --git a/community/kphotoalbum/APKBUILD b/community/kphotoalbum/APKBUILD
index 781c1f6861..02ee550af0 100644
--- a/community/kphotoalbum/APKBUILD
+++ b/community/kphotoalbum/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="KDE Photo Album, picture collection manager"
url="https://kphotoalbum.org"
# armhf blocked my extra-cmake-modules
-# mips64, ppc64le, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !ppc64le !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="
exiv2-dev
diff --git a/community/kpimtextedit/APKBUILD b/community/kpimtextedit/APKBUILD
index 6073edd47c..d7034f700b 100644
--- a/community/kpimtextedit/APKBUILD
+++ b/community/kpimtextedit/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Advanced text editor which provide advanced html feature"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://api.kde.org/kdepim/kpimtextedit/html"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
depends_dev="
diff --git a/community/kpmcore/APKBUILD b/community/kpmcore/APKBUILD
index fbf480b69e..6cd3a6a2d5 100644
--- a/community/kpmcore/APKBUILD
+++ b/community/kpmcore/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kpmcore
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kauth
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kauth
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/system/org.kde.partitionmanager"
pkgdesc="Library for managing partitions"
license="GPL-3.0-or-later"
diff --git a/community/krapslog/APKBUILD b/community/krapslog/APKBUILD
index 3732357343..fad655a015 100644
--- a/community/krapslog/APKBUILD
+++ b/community/krapslog/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.3.2
pkgrel=0
pkgdesc="Tool for visualizing log file volume as sparklines in your terminal"
url="https://github.com/acj/krapslog-rs"
-arch="all !s390x !mips !mips64 !riscv64" # limited by rust/cargo
+arch="all !s390x !riscv64" # limited by rust/cargo
license="MIT"
makedepends="cargo"
source="$pkgname-rs-$pkgver.tar.gz::https://github.com/acj/krapslog-rs/archive/$pkgver.tar.gz"
diff --git a/community/krdc/APKBUILD b/community/krdc/APKBUILD
index a83ac32851..f0422d2e55 100644
--- a/community/krdc/APKBUILD
+++ b/community/krdc/APKBUILD
@@ -4,8 +4,8 @@ pkgname=krdc
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/internet/krdc/"
pkgdesc="Remote Desktop Client"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/krename/APKBUILD b/community/krename/APKBUILD
index df460accc5..8e563ef256 100644
--- a/community/krename/APKBUILD
+++ b/community/krename/APKBUILD
@@ -4,8 +4,8 @@ pkgname=krename
pkgver=5.0.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://apps.kde.org/en/krename"
pkgdesc="Utility to handle specialized file renames"
license="GPL-2.0-or-later"
diff --git a/community/krfb/APKBUILD b/community/krfb/APKBUILD
index c4790cbad8..90db7baba6 100644
--- a/community/krfb/APKBUILD
+++ b/community/krfb/APKBUILD
@@ -3,8 +3,8 @@
pkgname=krfb
pkgver=21.12.1
pkgrel=0
-# armhf, s390x, mips64 and riscv64 blocked by kwallet-dev and kxmlgui-dev
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf, s390x and riscv64 blocked by kwallet-dev and kxmlgui-dev
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/internet/org.kde.krfb"
pkgdesc="Desktop sharing"
license="GPL-3.0-or-later AND GFDL-1.2-only"
diff --git a/community/kross/APKBUILD b/community/kross/APKBUILD
index 2231254d75..f158c4b449 100644
--- a/community/kross/APKBUILD
+++ b/community/kross/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Framework for scripting KDE applications"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kruler/APKBUILD b/community/kruler/APKBUILD
index 7d7c141773..c68355d7fc 100644
--- a/community/kruler/APKBUILD
+++ b/community/kruler/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kruler
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/graphics/org.kde.kruler"
pkgdesc="An on-screen ruler for measuring pixels"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/krunner/APKBUILD b/community/krunner/APKBUILD
index 72fe40fe35..ea3bebd793 100644
--- a/community/krunner/APKBUILD
+++ b/community/krunner/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Framework for providing different actions given a string query"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kscreen/APKBUILD b/community/kscreen/APKBUILD
index 1a9f785c7f..93ffbf7ab6 100644
--- a/community/kscreen/APKBUILD
+++ b/community/kscreen/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="KDE's screen management software"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kconfigwidgets
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="hicolor-icon-theme"
diff --git a/community/kscreenlocker/APKBUILD b/community/kscreenlocker/APKBUILD
index e2df260f6f..ad56a5875d 100644
--- a/community/kscreenlocker/APKBUILD
+++ b/community/kscreenlocker/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Library and components for secure lock screen architecture"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kdeclarative-dev, kcmutils-dev, ktextwidgets-dev, kxmlgui-dev
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kdeclarative-dev, kcmutils-dev, ktextwidgets-dev, kxmlgui-dev
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only)"
depends="
diff --git a/community/ksmtp/APKBUILD b/community/ksmtp/APKBUILD
index d950935f11..88d71fd52c 100644
--- a/community/ksmtp/APKBUILD
+++ b/community/ksmtp/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Job-based library to send email through an SMTP server"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kio
+arch="all !armhf !s390x !riscv64"
url="https://kontact.kde.org"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/ksshaskpass/APKBUILD b/community/ksshaskpass/APKBUILD
index 0d8129c440..926cfe5cc8 100644
--- a/community/ksshaskpass/APKBUILD
+++ b/community/ksshaskpass/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="ssh-add helper that uses kwallet and kpassworddialog"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kwallet
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kwallet
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
makedepends="
diff --git a/community/ksysguard/APKBUILD b/community/ksysguard/APKBUILD
index a99eb5f814..d123426b42 100644
--- a/community/ksysguard/APKBUILD
+++ b/community/ksysguard/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.22.0
pkgrel=0
pkgdesc="Track and control the processes running in your system"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://userbase.kde.org/KSysGuard"
license="GPL-2.0-only"
makedepends="
diff --git a/community/kteatime/APKBUILD b/community/kteatime/APKBUILD
index f555a0bd58..1382fbdcac 100644
--- a/community/kteatime/APKBUILD
+++ b/community/kteatime/APKBUILD
@@ -4,7 +4,7 @@ pkgname=kteatime
pkgver=21.12.1
pkgrel=0
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !mips !mips64 !s390x !riscv64"
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.kteatime"
pkgdesc="A handy timer for steeping tea"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/ktexteditor/APKBUILD b/community/ktexteditor/APKBUILD
index f7122f8fd2..36cfc3cfd1 100644
--- a/community/ktexteditor/APKBUILD
+++ b/community/ktexteditor/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Advanced embeddable text editor"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND (LGPL-2.0-only OR LGPL-3.0-only)"
depends_dev="
diff --git a/community/ktextwidgets/APKBUILD b/community/ktextwidgets/APKBUILD
index 5fac05017b..1d43ea8384 100644
--- a/community/ktextwidgets/APKBUILD
+++ b/community/ktextwidgets/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Advanced text editing widgets"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
diff --git a/community/ktimer/APKBUILD b/community/ktimer/APKBUILD
index 9c23dac7d5..0b1482dc56 100644
--- a/community/ktimer/APKBUILD
+++ b/community/ktimer/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A little tool to execute programs after some time"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.ktimer"
license="GPL-2.0-or-later"
makedepends="
diff --git a/community/ktimetracker/APKBUILD b/community/ktimetracker/APKBUILD
index 8425610b7a..789cbdb5e0 100644
--- a/community/ktimetracker/APKBUILD
+++ b/community/ktimetracker/APKBUILD
@@ -4,8 +4,8 @@ pkgname=ktimetracker
pkgver=5.0.1
pkgrel=3
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://apps.kde.org/ktimetracker/"
pkgdesc="Todo management and time tracker"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/ktnef/APKBUILD b/community/ktnef/APKBUILD
index 13f699b615..aaee43c5a5 100644
--- a/community/ktnef/APKBUILD
+++ b/community/ktnef/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="API for handling TNEF data"
# armhf blocked by extra-cmake-modules
# s390x blocked by kcalendarcore
-# mips64 and riscv64 blocked by polkit -> kcalutils
-arch="all !armhf !s390x !mips64 !riscv64"
+# riscv64 blocked by polkit -> kcalutils
+arch="all !armhf !s390x !riscv64"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/ktorrent/APKBUILD b/community/ktorrent/APKBUILD
index 63e1876809..018f7ab0ae 100644
--- a/community/ktorrent/APKBUILD
+++ b/community/ktorrent/APKBUILD
@@ -5,8 +5,7 @@ pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
# ppc64le, s390x and riscv64 blocked by polkit -> plasma-workspace
-# mips64 blocked by libktorrent
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
license="GPL-2.0-or-later"
diff --git a/community/ktouch/APKBUILD b/community/ktouch/APKBUILD
index a45c6f7af2..e07e07c5bd 100644
--- a/community/ktouch/APKBUILD
+++ b/community/ktouch/APKBUILD
@@ -4,7 +4,7 @@ pkgname=ktouch
pkgver=21.12.1
pkgrel=0
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !mips !mips64 !s390x !riscv64" # armhf blocked by qt5-qtdeclarative, everything else by rust
+arch="all !armhf !s390x !riscv64" # armhf blocked by qt5-qtdeclarative, everything else by rust
url="https://edu.kde.org/ktouch/"
pkgdesc="Touch Typing Tutor"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/ktp-common-internals/APKBUILD b/community/ktp-common-internals/APKBUILD
index e84a25be88..3a11a21032 100644
--- a/community/ktp-common-internals/APKBUILD
+++ b/community/ktp-common-internals/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="Library for KTp"
url="https://github.com/kde/ktp-common-internals"
# armhf blocked by extra-cmake-modules
-# s390x. mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
license="LGPL-2.1-only AND GPL-2.0-only"
depends_dev="
kcmutils-dev
diff --git a/community/ktrip/APKBUILD b/community/ktrip/APKBUILD
index ff6677bdaa..a4f89eb7df 100644
--- a/community/ktrip/APKBUILD
+++ b/community/ktrip/APKBUILD
@@ -4,8 +4,8 @@ pkgver=22.02
pkgrel=0
pkgdesc="A public transport assistant"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by qqc2-desktop-style
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by qqc2-desktop-style
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/utilities/ktrip"
license="GPL-2.0-only OR GPL-3.0-only"
depends="
diff --git a/community/kturtle/APKBUILD b/community/kturtle/APKBUILD
index 901be9c7d3..cfe02f88ab 100644
--- a/community/kturtle/APKBUILD
+++ b/community/kturtle/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kturtle
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kturtle"
pkgdesc="Educational Programming Environment"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kup/APKBUILD b/community/kup/APKBUILD
index 62e9aebe20..19e21db65b 100644
--- a/community/kup/APKBUILD
+++ b/community/kup/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.9.1
pkgrel=1
pkgdesc="A KDE bup backup software for helping people to keep up-to-date backups"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://store.kde.org/p/1127689"
license="GPL-2.0-only"
depends="rsync"
diff --git a/community/kwallet-pam/APKBUILD b/community/kwallet-pam/APKBUILD
index d0a56289fa..13788da8de 100644
--- a/community/kwallet-pam/APKBUILD
+++ b/community/kwallet-pam/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="KWallet PAM integration"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kwallet
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kwallet
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
depends="socat"
diff --git a/community/kwallet/APKBUILD b/community/kwallet/APKBUILD
index 252e70b93b..91542f87c4 100644
--- a/community/kwallet/APKBUILD
+++ b/community/kwallet/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Secure and unified container for user passwords"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
@@ -35,10 +35,6 @@ provides="dbus:org.freedesktop.Secrets"
# 2nd highst priority after gnome-keyring, mainly for KDE
provider_priority=10
-case "$CARCH" in
- mips*) options="!check";;
-esac
-
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
diff --git a/community/kwalletmanager/APKBUILD b/community/kwalletmanager/APKBUILD
index d731f3d8d1..8037c38a6f 100644
--- a/community/kwalletmanager/APKBUILD
+++ b/community/kwalletmanager/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kwalletmanager
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/system/org.kde.kwalletmanager5"
pkgdesc="A tool to manage the passwords on your KDE system"
license="GPL-2.0-or-later"
diff --git a/community/kwave/APKBUILD b/community/kwave/APKBUILD
index 137473a0de..8fd6daa4da 100644
--- a/community/kwave/APKBUILD
+++ b/community/kwave/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kwave
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="http://kwave.sourceforge.net/"
pkgdesc="A sound editor for KDE"
license="GPL-2.0-or-later"
diff --git a/community/kweather/APKBUILD b/community/kweather/APKBUILD
index 0b1f63e787..274b170799 100644
--- a/community/kweather/APKBUILD
+++ b/community/kweather/APKBUILD
@@ -8,7 +8,7 @@ url="https://invent.kde.org/plasma-mobile/kweather"
# armhf blocked by qt5-qtdeclarative
# s390x blocked by plasma-framework
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
license="GPL-2.0-or-later AND CC-BY-4.0"
depends="
kirigami2
diff --git a/community/kwin-effect-xrdesktop/APKBUILD b/community/kwin-effect-xrdesktop/APKBUILD
index 0839cc033f..b48db8afa9 100644
--- a/community/kwin-effect-xrdesktop/APKBUILD
+++ b/community/kwin-effect-xrdesktop/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=1
pkgdesc="xrdesktop effect for KWin"
url="https://gitlab.freedesktop.org/xrdesktop/kwin-effect-xrdesktop"
# armhf blocked by extra-cmake-modules
-# mips64, s390x, ppc64le and riscv64 blocked by polkit -> kxmlgui
-arch="all !s390x !ppc64le !mips64 !armhf !riscv64"
+# s390x, ppc64le and riscv64 blocked by polkit -> kxmlgui
+arch="all !s390x !ppc64le !armhf !riscv64"
license="MIT"
makedepends="
extra-cmake-modules
diff --git a/community/kwin/APKBUILD b/community/kwin/APKBUILD
index 8e25cb9cbc..df479de915 100644
--- a/community/kwin/APKBUILD
+++ b/community/kwin/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=1
pkgdesc="An easy to use, but flexible, composited Window Manager"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by kscreenlocker
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kscreenlocker
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
depends="
diff --git a/community/kwordquiz/APKBUILD b/community/kwordquiz/APKBUILD
index 726661f00f..cbaca8d90d 100644
--- a/community/kwordquiz/APKBUILD
+++ b/community/kwordquiz/APKBUILD
@@ -4,8 +4,8 @@ pkgname=kwordquiz
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org/kwordquiz"
pkgdesc="Flash Card Trainer"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/kxmlgui/APKBUILD b/community/kxmlgui/APKBUILD
index 642ab7a0a9..4e676997a2 100644
--- a/community/kxmlgui/APKBUILD
+++ b/community/kxmlgui/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="User configurable main windows"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="
diff --git a/community/kxmlrpcclient/APKBUILD b/community/kxmlrpcclient/APKBUILD
index d9d9fe6178..e0ba335c67 100644
--- a/community/kxmlrpcclient/APKBUILD
+++ b/community/kxmlrpcclient/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="XML-RPC client library for KDE"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://projects.kde.org/projects/kde/pim/kxmlrpcclient"
license="BSD-2-Clause"
depends_dev="
diff --git a/community/lavalauncher/APKBUILD b/community/lavalauncher/APKBUILD
index 00ecd5318c..4b271da35c 100644
--- a/community/lavalauncher/APKBUILD
+++ b/community/lavalauncher/APKBUILD
@@ -23,7 +23,7 @@ builddir="$srcdir/$pkgname-v$pkgver"
# enable SVG image support where possible
case "$CARCH" in
- s390x|mips64|riscv64) ;;
+ s390x|riscv64) ;;
*) makedepends="$makedepends librsvg-dev" ;;
esac
diff --git a/community/laz-perf/APKBUILD b/community/laz-perf/APKBUILD
index 1a3d3f40d5..b1ebc58261 100644
--- a/community/laz-perf/APKBUILD
+++ b/community/laz-perf/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="Alternative LAZ implementation for C++ and JavaScript"
url="https://github.com/hobu/laz-perf"
# armhf, armv7: io_test segfaults
-# mips, mips64, s390x: broken on big endian
-arch="all !armhf !armv7 !s390x !mips !mips64"
+# s390x: broken on big endian
+arch="all !armhf !armv7 !s390x"
license="LGPL-2.0-or-later"
depends_dev="$pkgname"
makedepends="
diff --git a/community/leiningen/APKBUILD b/community/leiningen/APKBUILD
index 23cf6741e7..da3d05d18c 100644
--- a/community/leiningen/APKBUILD
+++ b/community/leiningen/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Automate Clojure Projects"
options="!check" #No Checks
url="https://leiningen.org/"
-arch="noarch !mips !mips64 !riscv64" # blocked by java-jdk
+arch="noarch !riscv64" # blocked by java-jdk
license="EPL-1.0"
depends="bash java-jdk"
subpackages="$pkgname-doc
diff --git a/community/lfs/APKBUILD b/community/lfs/APKBUILD
index e3ada633c6..99aba3cf70 100644
--- a/community/lfs/APKBUILD
+++ b/community/lfs/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Get information on your mounted disks"
url="https://github.com/Canop/lfs"
license="MIT"
-arch="all !s390x !mips64 !riscv64" # blocked by rust/cargo
+arch="all !s390x !riscv64" # blocked by rust/cargo
makedepends="cargo"
source="https://github.com/Canop/lfs/archive/v$pkgver/lfs-$pkgver.tar.gz"
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
index 43b8d29fb1..95b2285b91 100644
--- a/community/libfm/APKBUILD
+++ b/community/libfm/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.3.2
pkgrel=2
pkgdesc="Library for file management"
url="https://wiki.lxde.org/en/PCManFM"
-arch="all !s390x !mips64"
+arch="all !s390x"
license="GPL-2.0-or-later"
makedepends="
autoconf
diff --git a/community/libgravatar/APKBUILD b/community/libgravatar/APKBUILD
index 3f559756fc..931774b5e6 100644
--- a/community/libgravatar/APKBUILD
+++ b/community/libgravatar/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM library providing Gravatar support"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> akonadi
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://kontact.kde.org/"
license="LGPL-2.0-or-later"
depends_dev="
diff --git a/community/libjxl/APKBUILD b/community/libjxl/APKBUILD
index 7239e7e83c..f8fa266247 100644
--- a/community/libjxl/APKBUILD
+++ b/community/libjxl/APKBUILD
@@ -30,7 +30,7 @@ source="libjxl-$pkgver.tar.gz::https://github.com/libjxl/libjxl/archive/refs/tag
# gimp-dev not available
case "$CARCH" in
- s390x|mips|mips64|riscv64) ;;
+ s390x|riscv64) ;;
*) makedepends="$makedepends gimp-dev"
esac
diff --git a/community/libkcddb/APKBUILD b/community/libkcddb/APKBUILD
index fe2c6c335c..daf9062bf6 100644
--- a/community/libkcddb/APKBUILD
+++ b/community/libkcddb/APKBUILD
@@ -4,8 +4,8 @@ pkgname=libkcddb
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="KDE CDDB library"
license="LGPL-2.0-or-later AND GPL-2.0-or-later"
diff --git a/community/libkcompactdisc/APKBUILD b/community/libkcompactdisc/APKBUILD
index a0e3a186f5..8543203f29 100644
--- a/community/libkcompactdisc/APKBUILD
+++ b/community/libkcompactdisc/APKBUILD
@@ -4,8 +4,8 @@ pkgname=libkcompactdisc
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> solid
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> solid
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="Library for interfacing with CDs"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
diff --git a/community/libkdegames/APKBUILD b/community/libkdegames/APKBUILD
index 314ec07aff..d40c79725b 100644
--- a/community/libkdegames/APKBUILD
+++ b/community/libkdegames/APKBUILD
@@ -4,8 +4,8 @@ pkgname=libkdegames
pkgver=21.12.1
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games"
pkgdesc="Common code and data for many KDE games"
license="LGPL-2.0-only AND GFDL-1.2-only"
diff --git a/community/libkdepim/APKBUILD b/community/libkdepim/APKBUILD
index c69d587d8f..2f2bb2f190 100644
--- a/community/libkdepim/APKBUILD
+++ b/community/libkdepim/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Lib for common KDEPim apps"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> akonadi
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://community.kde.org/KDE_PIM"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends_dev="
diff --git a/community/libkeduvocdocument/APKBUILD b/community/libkeduvocdocument/APKBUILD
index 8d153aeac6..a94e9aee02 100644
--- a/community/libkeduvocdocument/APKBUILD
+++ b/community/libkeduvocdocument/APKBUILD
@@ -3,8 +3,8 @@
pkgname=libkeduvocdocument
pkgver=21.12.1
pkgrel=0
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://edu.kde.org"
pkgdesc="Library to parse, convert, and manipulate KVTML files"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/libkgapi/APKBUILD b/community/libkgapi/APKBUILD
index f6a081fd07..e35e1b54cf 100644
--- a/community/libkgapi/APKBUILD
+++ b/community/libkgapi/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="LibKGAPI is a KDE-based library for accessing various Google services via their public API"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
diff --git a/community/libkipi/APKBUILD b/community/libkipi/APKBUILD
index 01d5f1e1e5..d46146a1d4 100644
--- a/community/libkipi/APKBUILD
+++ b/community/libkipi/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE Image Plugin Interface library"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kxmlgui
+arch="all !armhf !s390x !riscv64"
url="https://www.digikam.org/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends_dev="
diff --git a/community/libkleo/APKBUILD b/community/libkleo/APKBUILD
index ed29cb0f54..3eaa98e7e9 100644
--- a/community/libkleo/APKBUILD
+++ b/community/libkleo/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM cryptographic library"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kpimtextedit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kpimtextedit
+arch="all !armhf !s390x !riscv64"
url="https://kontact.kde.org"
license="GPL-2.0-or-later"
# TODO: Maybe replace gnupg with specific gnupg subpackages.
diff --git a/community/libkmahjongg/APKBUILD b/community/libkmahjongg/APKBUILD
index d06cc6e9c1..82c581f8a1 100644
--- a/community/libkmahjongg/APKBUILD
+++ b/community/libkmahjongg/APKBUILD
@@ -4,8 +4,8 @@ pkgname=libkmahjongg
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked polkit -> kconfigwidgets
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked polkit -> kconfigwidgets
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/games"
pkgdesc="Common code, backgrounds and tile sets for games using Mahjongg tiles"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/libkomparediff2/APKBUILD b/community/libkomparediff2/APKBUILD
index 8015c6fceb..6480dafd50 100644
--- a/community/libkomparediff2/APKBUILD
+++ b/community/libkomparediff2/APKBUILD
@@ -4,8 +4,8 @@ pkgname=libkomparediff2
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development"
pkgdesc="Library to compare files and strings"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
diff --git a/community/libksane/APKBUILD b/community/libksane/APKBUILD
index fa3b5256de..9906276a14 100644
--- a/community/libksane/APKBUILD
+++ b/community/libksane/APKBUILD
@@ -5,7 +5,7 @@ pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
# s390x blocked by ktextwidgest, kwallet
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/graphics/"
pkgdesc="An image scanning library"
license="LGPL-2.1-only OR LGPL-3.0-only"
diff --git a/community/libksieve/APKBUILD b/community/libksieve/APKBUILD
index 5735af210b..0f19efebd9 100644
--- a/community/libksieve/APKBUILD
+++ b/community/libksieve/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM library for managing sieves"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="GPL-2.0-only"
depends_dev="
diff --git a/community/libksysguard/APKBUILD b/community/libksysguard/APKBUILD
index c175f187e9..c0b78b2745 100644
--- a/community/libksysguard/APKBUILD
+++ b/community/libksysguard/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="KDE system monitor library"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kauth
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kauth
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later AND (GPL-2.0-only OR GPL-3.0-only)"
depends_dev="
diff --git a/community/libktorrent/APKBUILD b/community/libktorrent/APKBUILD
index ffba975b9d..f052ebd23e 100644
--- a/community/libktorrent/APKBUILD
+++ b/community/libktorrent/APKBUILD
@@ -4,8 +4,8 @@ pkgname=libktorrent
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/internet/org.kde.ktorrent"
pkgdesc="A powerful BitTorrent client for KDE"
license="GPL-2.0-or-later"
diff --git a/community/libldac/APKBUILD b/community/libldac/APKBUILD
index 68f3677571..df2ed33a50 100644
--- a/community/libldac/APKBUILD
+++ b/community/libldac/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Lossy audio codec for Bluetooth connections"
url="https://github.com/EHfive/ldacBT"
license="Apache-2.0"
-arch="all !s390x !mips64" # no support for big-endian
+arch="all !s390x" # no support for big-endian
makedepends="cmake"
subpackages="$pkgname-dev"
source="https://github.com/EHfive/ldacBT/releases/download/v$pkgver/ldacBT-$pkgver.tar.gz"
diff --git a/community/libmad/APKBUILD b/community/libmad/APKBUILD
index df80e6a945..462fc277a4 100644
--- a/community/libmad/APKBUILD
+++ b/community/libmad/APKBUILD
@@ -37,12 +37,10 @@ prepare() {
}
build() {
- case "$CARCH" in mips*) _enable_fpm_64bit="--enable-fpm=64bit";; esac
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- $_enable_fpm_64bit \
--enable-accuracy
make -j1
diff --git a/community/libmarisa/APKBUILD b/community/libmarisa/APKBUILD
index a58d5eb394..057ef7a7d0 100644
--- a/community/libmarisa/APKBUILD
+++ b/community/libmarisa/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.2.6
pkgrel=0
pkgdesc="MARISA: Matching Algorithm with Recursively Implemented StorAge"
url="https://github.com/s-yata/marisa-trie"
-arch="all !mips64" # test 'base-test' fails
+arch="all" # test 'base-test' fails
license="BSD-2-Clause OR LGPL-2.1-or-later"
makedepends="autoconf automake libtool"
subpackages="$pkgname-dev"
diff --git a/community/libnma/APKBUILD b/community/libnma/APKBUILD
index 1f256e5329..e7c32f2ce6 100644
--- a/community/libnma/APKBUILD
+++ b/community/libnma/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.8.32
pkgrel=0
pkgdesc="NetworkManager GUI client library"
url="https://wiki.gnome.org/Projects/NetworkManager/"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="LGPL-2.1-or-later"
depends="mobile-broadband-provider-info"
makedepends="iso-codes-dev networkmanager-dev glib-dev gtk+3.0-dev gcr-dev
diff --git a/community/libnymphcast/APKBUILD b/community/libnymphcast/APKBUILD
index f93f42d356..de9fab96d0 100644
--- a/community/libnymphcast/APKBUILD
+++ b/community/libnymphcast/APKBUILD
@@ -3,7 +3,7 @@
pkgname=libnymphcast
pkgver=0.1_beta0
pkgrel=1
-arch="all !mips64"
+arch="all"
url="https://github.com/MayaPosch/libnymphcast"
pkgdesc="NymphCast Client Library"
license="BSD-3-Clause"
diff --git a/community/libpinyin/APKBUILD b/community/libpinyin/APKBUILD
index 68cbfdde26..481f2ec735 100644
--- a/community/libpinyin/APKBUILD
+++ b/community/libpinyin/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="Library to deal with pinyin"
url="https://github.com/libpinyin/libpinyin"
# armhf blocked by kyotocabinet
-# s390x and mips64 blocked due to failing tests
-arch="all !armhf !s390x !mips64"
+# s390x blocked due to failing tests
+arch="all !armhf !s390x"
license="GPL-3.0-or-later"
depends_dev="kyotocabinet-dev"
makedepends="$depends_dev
diff --git a/community/libpostal/APKBUILD b/community/libpostal/APKBUILD
index e30977063e..935c292f45 100644
--- a/community/libpostal/APKBUILD
+++ b/community/libpostal/APKBUILD
@@ -22,9 +22,9 @@ case "$CARCH" in
*) _sse2="--disable-sse2" ;;
esac
-# s390x and mips64 have a test failure but we're unable to see the log
+# s390x has a test failure but we're unable to see the log
case "$CARCH" in
- s390x|mips64) options="!check" ;;
+ s390x) options="!check" ;;
arm*) _scanner_flags="--with-cflags-scanner-extra=-marm" ;;
esac
diff --git a/community/libquotient/APKBUILD b/community/libquotient/APKBUILD
index 7dfccca48e..955beb8d41 100644
--- a/community/libquotient/APKBUILD
+++ b/community/libquotient/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.6.11
pkgrel=0
pkgdesc="Qt5 library for cross-platform clients for Matrix"
url="https://github.com/quotient-im/libQuotient"
-arch="all !armhf !mips64" # blocked by qt5-qtmultimedia, mips blocked by qtolm
+arch="all !armhf" # blocked by qt5-qtmultimedia
license="LGPL-2.1-or-later"
depends_dev="
qt5-qtbase-dev
diff --git a/community/libreoffice/APKBUILD b/community/libreoffice/APKBUILD
index 6f46d9dae7..097922a522 100644
--- a/community/libreoffice/APKBUILD
+++ b/community/libreoffice/APKBUILD
@@ -9,7 +9,7 @@ url="https://www.libreoffice.org/"
# missing openjdk11 on riscv64
# armhf disabled due to requiring armv6k as minimum arm architecture
# ppc64le build failure, https://gitlab.alpinelinux.org/alpine/aports/-/merge_requests/11136#note_184208
-arch="all !s390x !mips64 !riscv64 !armhf !ppc64le"
+arch="all !s390x !riscv64 !armhf !ppc64le"
license="MPL-2.0"
makedepends="
apache-ant
diff --git a/community/libretro-beetle-psx/APKBUILD b/community/libretro-beetle-psx/APKBUILD
index 2d72424ce6..743a7511e5 100644
--- a/community/libretro-beetle-psx/APKBUILD
+++ b/community/libretro-beetle-psx/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libretro-beetle-psx
pkgver=0_git20200623
pkgrel=0
_commit="89a74ee2d0e2295408a23796c42ae6dbcf6a165f"
-arch="all !s390x !mips !mips64"
+arch="all !s390x"
url="https://github.com/libretro/beetle-psx-libretro"
pkgdesc="Standalone port/fork of Mednafen PSX to the Libretro API"
license="GPL-2.0-or-later"
diff --git a/community/libretro-melonds/APKBUILD b/community/libretro-melonds/APKBUILD
index f43a3b0dfd..34ea631b3f 100644
--- a/community/libretro-melonds/APKBUILD
+++ b/community/libretro-melonds/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
_commit="657c729e7473e9b2c09ddf2eef9dcf4ba5b247ec"
pkgdesc="Nintendo DS emulator for libretro"
url="https://github.com/libretro/melonDS"
-arch="all !mips !mips64"
+arch="all"
license="GPL-3.0-only"
makedepends="mesa-dev"
source="$pkgname-$_commit.tar.gz::https://github.com/libretro/melonDS/archive/$_commit.tar.gz"
diff --git a/community/librsvg/APKBUILD b/community/librsvg/APKBUILD
index c37181e5ea..1efd9bf668 100644
--- a/community/librsvg/APKBUILD
+++ b/community/librsvg/APKBUILD
@@ -6,7 +6,7 @@ pkgver=2.50.7
pkgrel=1
pkgdesc="SAX-based renderer for SVG files into a GdkPixbuf"
url="https://wiki.gnome.org/Projects/LibRsvg"
-arch="all !s390x !mips !mips64 !riscv64" # rust
+arch="all !s390x !riscv64" # rust
license="LGPL-2.1-or-later"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc $pkgname-lang"
makedepends="$depends_dev bzip2-dev cairo-dev glib-dev cargo rust vala
diff --git a/community/libvirt-glib/APKBUILD b/community/libvirt-glib/APKBUILD
index bd3f369da2..6affa4603d 100644
--- a/community/libvirt-glib/APKBUILD
+++ b/community/libvirt-glib/APKBUILD
@@ -5,8 +5,8 @@ pkgver=4.0.0
pkgrel=0
pkgdesc="libvirt glib integration for events"
url="https://libvirt.org/"
-# s390x, mips64 and riscv64 blocked by polkit -> libvirt
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> libvirt
+arch="all !s390x !riscv64"
license="LGPL-2.0-or-later"
depends_dev="libvirt-dev"
makedepends="$depends_dev gobject-introspection-dev libxml2-dev vala meson"
diff --git a/community/libvirt/APKBUILD b/community/libvirt/APKBUILD
index acb5404715..81016b0e15 100644
--- a/community/libvirt/APKBUILD
+++ b/community/libvirt/APKBUILD
@@ -5,8 +5,8 @@ _ver="${pkgver/_rc/-rc}"
pkgrel=1
pkgdesc="A virtualization API for several hypervisor and container systems"
url="https://libvirt.org/"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
options="!check"
license="LGPL-2.1-or-later"
_daemon_deps="bridge-utils dmidecode dnsmasq ip6tables iptables"
diff --git a/community/libxml++-2.6/APKBUILD b/community/libxml++-2.6/APKBUILD
index af6c8908b5..b2e85c0d35 100644
--- a/community/libxml++-2.6/APKBUILD
+++ b/community/libxml++-2.6/APKBUILD
@@ -6,7 +6,7 @@ pkgver=2.42.0
pkgrel=0
pkgdesc="libxml++ is a C++ wrapper for the libxml XML parser library."
url="https://libxmlplusplus.github.io/libxmlplusplus/"
-arch="all !s390x !mips64" # broken on big-endian
+arch="all !s390x" # broken on big-endian
license="LGPL-2.1-only"
makedepends="meson libxml2-dev glibmm-dev"
subpackages="$pkgname-dev"
diff --git a/community/lightdm-gtk-greeter/APKBUILD b/community/lightdm-gtk-greeter/APKBUILD
index 3735f6a5c7..880d63fe8d 100644
--- a/community/lightdm-gtk-greeter/APKBUILD
+++ b/community/lightdm-gtk-greeter/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.0.8
pkgrel=1
pkgdesc="Gtk based greeter for lightdm."
url="https://launchpad.net/lightdm-gtk-greeter"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
license="GPL-3.0-or-later"
makedepends="gtk+3.0-dev lightdm-dev exo exo-dev xfce4-dev-tools"
subpackages="$pkgname-lang $pkgname-doc"
diff --git a/community/lightdm/APKBUILD b/community/lightdm/APKBUILD
index 39a1b899d2..4057d651fb 100644
--- a/community/lightdm/APKBUILD
+++ b/community/lightdm/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=5
pkgdesc="cross-desktop display manager"
url="https://www.freedesktop.org/wiki/Software/LightDM"
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !mips !mips64 !riscv64" # gnome-themes-standard missing due to librsvg
+arch="all !s390x !riscv64" # gnome-themes-standard missing due to librsvg
license="GPL-3.0-or-later"
depends="dbus xinit accountsservice gnome-themes-standard
adwaita-icon-theme"
diff --git a/community/lightsoff/APKBUILD b/community/lightsoff/APKBUILD
index c48fa796a6..87ca915f49 100644
--- a/community/lightsoff/APKBUILD
+++ b/community/lightsoff/APKBUILD
@@ -3,8 +3,8 @@
pkgname=lightsoff
pkgver=40.0.1
pkgrel=0
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
url="https://wiki.gnome.org/Apps/Lightsoff"
pkgdesc="Turn off all the lights"
license="GPL-2.0-or-later"
diff --git a/community/lokalize/APKBUILD b/community/lokalize/APKBUILD
index 086e49662a..5e921a9bbd 100644
--- a/community/lokalize/APKBUILD
+++ b/community/lokalize/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
pkgdesc="Computer-Aided Translation System"
url="https://apps.kde.org/lokalize/"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by kio
+arch="all !armhf !s390x !riscv64"
license="(GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
diff --git a/community/lollypop/APKBUILD b/community/lollypop/APKBUILD
index 871fa76a96..04eee2d371 100644
--- a/community/lollypop/APKBUILD
+++ b/community/lollypop/APKBUILD
@@ -8,7 +8,7 @@ pkgrel=0
pkgdesc="Music player for GNOME"
url="https://gitlab.gnome.org/World/Lollypop"
# riscv64 disabled due to missing rust in recursive dependency
-arch="noarch !mips !mips64 !s390x !riscv64" # libhandy missing
+arch="noarch !s390x !riscv64" # libhandy missing
license="GPL-3.0-only"
depends="
gst-plugins-good
diff --git a/community/love/APKBUILD b/community/love/APKBUILD
index 07b0cff548..49e316f243 100755
--- a/community/love/APKBUILD
+++ b/community/love/APKBUILD
@@ -5,9 +5,9 @@ pkgver=11.3
pkgrel=1
pkgdesc="A Lua 2D Graphics Library"
url="https://love2d.org"
-# s390x, mips64: build failures on big endian
+# s390x: build failures on big endian
# riscv64 missing luajit
-arch="all !s390x !mips64 !riscv64"
+arch="all !s390x !riscv64"
license="Zlib"
makedepends="libtool autoconf automake sdl2-dev zlib-dev openal-soft-dev
freetype-dev libmodplug-dev mpg123-dev libvorbis-dev libtheora-dev luajit-dev
diff --git a/community/lttng-tools/APKBUILD b/community/lttng-tools/APKBUILD
index f518de94e8..52b17519c1 100644
--- a/community/lttng-tools/APKBUILD
+++ b/community/lttng-tools/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.13.2
pkgrel=0
pkgdesc="LTTng 2.0 control and utility programs"
url="https://lttng.org"
-arch="all !mips !mips64" # Due to babeltrace
+arch="all" # Due to babeltrace
license="GPL-2.0-only LGPL-2.1-only"
depends="babeltrace"
depends_dev="kmod-dev libxml2-dev lttng-ust-dev popt-dev userspace-rcu-dev
diff --git a/community/lua-http/APKBUILD b/community/lua-http/APKBUILD
index 166a843805..b87be0e820 100644
--- a/community/lua-http/APKBUILD
+++ b/community/lua-http/APKBUILD
@@ -15,7 +15,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/daurnimator/lua-http/archive
case "$CARCH" in
# FIXME: Some tests fail with "Address not available".
# and ppc64le hangs
- aarch64|arm*|ppc64le|mips*) options="!check";;
+ aarch64|arm*|ppc64le) options="!check";;
esac
_luaversions="5.1 5.2 5.3"
diff --git a/community/lxdm/APKBUILD b/community/lxdm/APKBUILD
index 0e33c9282e..9e8fb95848 100644
--- a/community/lxdm/APKBUILD
+++ b/community/lxdm/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.5.3
pkgrel=4
pkgdesc="LXDE desktop login manager"
url="https://wiki.lxde.org/en/LXDM"
-arch="all !mips !mips64 !s390x !riscv64" # blocked by consolekit2 -> polkit
+arch="all !s390x !riscv64" # blocked by consolekit2 -> polkit
license="GPL-3.0-or-later"
depends="bash"
makedepends="gtk+3.0-dev consolekit2-dev autoconf automake libtool intltool
diff --git a/community/lxpolkit/APKBUILD b/community/lxpolkit/APKBUILD
index 7365ebc44e..23543d503a 100644
--- a/community/lxpolkit/APKBUILD
+++ b/community/lxpolkit/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.1.0
pkgrel=3
pkgdesc="Simple PolicyKit authentication agent"
url="https://lxde.org/"
-arch="all !mips !mips64 !s390x !riscv64" # limited by polkit
+arch="all !s390x !riscv64" # limited by polkit
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev polkit-dev intltool"
subpackages="$pkgname-lang"
diff --git a/community/lxsession/APKBUILD b/community/lxsession/APKBUILD
index f61664a39e..3c2e23ea8a 100644
--- a/community/lxsession/APKBUILD
+++ b/community/lxsession/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.5.5
pkgrel=0
pkgdesc="Lightweight X11 session manager"
url="https://wiki.lxde.org/en/LXSession"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="gtk+-dev dbus-glib-dev polkit-dev"
subpackages="$pkgname-doc $pkgname-lang"
diff --git a/community/mailcommon/APKBUILD b/community/mailcommon/APKBUILD
index e3ae183e8f..c1cd35dd1f 100644
--- a/community/mailcommon/APKBUILD
+++ b/community/mailcommon/APKBUILD
@@ -5,7 +5,7 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM library providing support for mail applications"
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64" # Limited by messagelib -> qt5-qtwebengine
+arch="all !ppc64le !s390x !armhf !riscv64" # Limited by messagelib -> qt5-qtwebengine
url="https://kontact.kde.org/"
license="GPL-2.0-or-later"
# TODO: Consider replacing gnupg with specific gnupg subpackages that mailcommon really needs.
diff --git a/community/mailimporter/APKBUILD b/community/mailimporter/APKBUILD
index 71fa3ca8d2..d5f79308d2 100644
--- a/community/mailimporter/APKBUILD
+++ b/community/mailimporter/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM library providing support for mail applications"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> pimcommon
+# s390x and riscv64 blocked by polkit -> pimcommon
# ppc64le blocked by qt5-qtwebengine -> akonadi
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://kontact.kde.org/"
license="GPL-2.0-or-later"
depends_dev="
diff --git a/community/maliit-keyboard/APKBUILD b/community/maliit-keyboard/APKBUILD
index a6f5f2fe10..17b8d5e1dd 100644
--- a/community/maliit-keyboard/APKBUILD
+++ b/community/maliit-keyboard/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.2.0
pkgrel=0
pkgdesc="Maliit Keyboard 2"
# armhf blocked by qt5-qtdeclarative
-# s390x and mips64 blocked by libpinyin
-arch="all !armhf !s390x !mips64"
+# s390x blocked by libpinyin
+arch="all !armhf !s390x"
url="https://github.com/maliit/keyboard"
license="LGPL-3.0-only AND BSD-3-Clause AND CC-BY-SA-3.0"
depends="dconf"
diff --git a/community/marble/APKBUILD b/community/marble/APKBUILD
index 20dfb25ee7..e15b02a296 100644
--- a/community/marble/APKBUILD
+++ b/community/marble/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="A Virtual Globe and World Atlas that you can use to learn more about Earth"
# armhf blocked by extra-cmake-modules
-# mips64, ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url='https://marble.kde.org'
license="LGPL-2.1-or-later AND GPL-3.0-or-later"
depends_dev="
diff --git a/community/marco/APKBUILD b/community/marco/APKBUILD
index f0209fdab3..d2f5061932 100644
--- a/community/marco/APKBUILD
+++ b/community/marco/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="MATE window manager"
url="https://github.com/mate-desktop/marco"
-# s390x, mips64 and riscv64 are blocked by librsvg -> mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 are blocked by librsvg -> mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="mate-common yelp-tools libxml2-utils mate-desktop"
makedepends="libtool itstool zenity intltool glib-dev gtk+3.0-dev
diff --git a/community/massif-visualizer/APKBUILD b/community/massif-visualizer/APKBUILD
index 6802c99364..2accf58c58 100644
--- a/community/massif-visualizer/APKBUILD
+++ b/community/massif-visualizer/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.7.0
pkgrel=0
pkgdesc="Visualizer for Valgrind Massif data files"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/development/org.kde.massif-visualizer"
license="GPL-2.0-or-later"
makedepends="
diff --git a/community/mate-applets/APKBUILD b/community/mate-applets/APKBUILD
index d14fb07fef..4ecfe716e9 100644
--- a/community/mate-applets/APKBUILD
+++ b/community/mate-applets/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="Applets for use with the MATE panel"
url="https://github.com/mate-desktop/mate-applets"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="mate-icon-theme"
makedepends="intltool gtk+3.0-dev mate-panel-dev libwnck3-dev
diff --git a/community/mate-control-center/APKBUILD b/community/mate-control-center/APKBUILD
index 5609ef225c..9b0de4f32f 100644
--- a/community/mate-control-center/APKBUILD
+++ b/community/mate-control-center/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=1
pkgdesc="MATE's main interface for configuration of various aspects of your desktop"
url="https://github.com/mate-desktop/mate-control-center"
-# s390x, mips64 and riscv64 blocked by polkit
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="mate-common mate-menus mate-icon-theme desktop-file-utils"
makedepends="dbus-glib-dev libtool intltool itstool gtk+3.0-dev polkit-dev
diff --git a/community/mate-desktop-environment/APKBUILD b/community/mate-desktop-environment/APKBUILD
index 6af0d38800..ff3724cb2b 100644
--- a/community/mate-desktop-environment/APKBUILD
+++ b/community/mate-desktop-environment/APKBUILD
@@ -5,7 +5,7 @@ pkgrel=0
pkgdesc="Metapackage for MATE desktop environment"
url="https://mate-desktop.org/"
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !mips !mips64 !riscv64"
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later LGPL-2.0-or-later"
depends="caja
caja-extensions>=$pkgver
diff --git a/community/mate-desktop/APKBUILD b/community/mate-desktop/APKBUILD
index 33881bbf2f..e3d6a7300d 100644
--- a/community/mate-desktop/APKBUILD
+++ b/community/mate-desktop/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=1
pkgdesc="The MATE Desktop Environment"
url="https://mate-desktop.org/"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends="mate-common yelp-tools"
makedepends="startup-notification itstool intltool dconf-dev gtk+3.0-dev
diff --git a/community/mate-indicator-applet/APKBUILD b/community/mate-indicator-applet/APKBUILD
index d9262d643c..843626494c 100644
--- a/community/mate-indicator-applet/APKBUILD
+++ b/community/mate-indicator-applet/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="A small applet to display information from various applications consistently in the panel"
url="https://github.com/mate-desktop/mate-indicator-applet"
-# s390x, mips64 and riscv64 blocked by librsvg -> mate-panel
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> mate-panel
+arch="all !s390x !riscv64"
license="GPL-3.0-or-later AND LGPL-2.1-or-later"
makedepends="autoconf automake libtool mate-common glib-dev
gtk+3.0-dev mate-panel-dev intltool libindicator-dev
diff --git a/community/mate-media/APKBUILD b/community/mate-media/APKBUILD
index 368ccc36d4..f318c92220 100644
--- a/community/mate-media/APKBUILD
+++ b/community/mate-media/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="Media tools for MATE"
url="https://github.com/mate-desktop/mate-media"
-# s390x, mips64 and riscv64 blocked by librsvg -> mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="intltool gobject-introspection-dev gtk+3.0-dev
libcanberra-dev libmatemixer-dev mate-desktop-dev
diff --git a/community/mate-notification-daemon/APKBUILD b/community/mate-notification-daemon/APKBUILD
index c7c28c7044..0094cc0412 100644
--- a/community/mate-notification-daemon/APKBUILD
+++ b/community/mate-notification-daemon/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="Small, passive popup dialogs that notify the user of particular events"
url="https://github.com/mate-desktop/mate-notification-daemon"
-# s390x, mips64 and riscv64 blocked by mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="mate-common"
makedepends="libwnck3-dev libnotify-dev libtool intltool dbus-glib-dev
diff --git a/community/mate-panel/APKBUILD b/community/mate-panel/APKBUILD
index 08cc47f37e..2670f1153c 100644
--- a/community/mate-panel/APKBUILD
+++ b/community/mate-panel/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=1
pkgdesc="The MATE panel is the area on your desktop from which you can run applications"
url="https://github.com/mate-desktop/mate-panel"
-# s390x, mips64 and riscv64 blocked by mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
depends="mate-common"
makedepends="librsvg-dev libmateweather-dev libtool intltool itstool
diff --git a/community/mate-polkit/APKBUILD b/community/mate-polkit/APKBUILD
index 8da5b1bcff..32db748822 100644
--- a/community/mate-polkit/APKBUILD
+++ b/community/mate-polkit/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="MATE Authentication Agent for PolicyKit"
url="https://github.com/mate-desktop/mate-polkit"
-arch="all !mips !mips64 !s390x !riscv64" # blocked by polkit
+arch="all !s390x !riscv64" # blocked by polkit
license="GPL-2.0-or-later"
depends="mate-common"
makedepends="polkit-dev libtool intltool gtk+3.0-dev
diff --git a/community/mate-power-manager/APKBUILD b/community/mate-power-manager/APKBUILD
index 10c1d93d53..df9ccb1289 100644
--- a/community/mate-power-manager/APKBUILD
+++ b/community/mate-power-manager/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="A Power Manager for MATE"
url="https://github.com/mate-desktop/mate-power-manager"
-arch="all !s390x !mips !mips64 !riscv64" # blocked by mate-desktop and polkit
+arch="all !s390x !riscv64" # blocked by mate-desktop and polkit
license="GPL-2.0-or-later"
makedepends="$depends_dev intltool gettext-dev itstool glib-dev libcanberra-dev
dbus-glib-dev mate-desktop-dev dconf-dev libnotify-dev
diff --git a/community/mate-screensaver/APKBUILD b/community/mate-screensaver/APKBUILD
index 6affd3e6bc..356777a91a 100644
--- a/community/mate-screensaver/APKBUILD
+++ b/community/mate-screensaver/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="A screen saver and locker for MATE"
url="https://github.com/mate-desktop/mate-screensaver"
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !mips !mips64 !riscv64" # mate-desktop
+arch="all !s390x !riscv64" # mate-desktop
license="GPL-2.0-or-later"
makedepends="intltool glib-dev libxscrnsaver-dev gtk+3.0-dev
mate-desktop-dev dbus-glib-dev mate-menus-dev dconf-dev
diff --git a/community/mate-sensors-applet/APKBUILD b/community/mate-sensors-applet/APKBUILD
index f8a2423252..be03a3a677 100644
--- a/community/mate-sensors-applet/APKBUILD
+++ b/community/mate-sensors-applet/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="Applet for the MATE Panel to display readings from hardware sensors"
url="https://github.com/mate-desktop/mate-sensors-applet"
-# #s390x, mips64 and riscv64 blocked by librsvg -> mate-panel
-arch="all !s390x !mips64 !riscv64"
+# #s390x and riscv64 blocked by librsvg -> mate-panel
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="perl-xml-parser"
makedepends="intltool glib-dev gtk+3.0-dev mate-panel-dev libxslt-dev
diff --git a/community/mate-session-manager/APKBUILD b/community/mate-session-manager/APKBUILD
index 9480b2d849..0a66ff2eb7 100644
--- a/community/mate-session-manager/APKBUILD
+++ b/community/mate-session-manager/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="The MATE session manager"
url="https://github.com/mate-desktop/mate-session-manager"
-# s390x, mips64 and riscv64 blocked by mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="mate-common mate-desktop"
makedepends="intltool libtool dconf-dev dbus-glib-dev gtk+3.0-dev
diff --git a/community/mate-settings-daemon/APKBUILD b/community/mate-settings-daemon/APKBUILD
index 4148ee83c2..a5c1b579d5 100644
--- a/community/mate-settings-daemon/APKBUILD
+++ b/community/mate-settings-daemon/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=1
pkgdesc="MATE Settings daemon"
url="https://github.com/mate-desktop/mate-settings-daemon"
-# s390x. mips64 and riscv64 blocked by polkit -> mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later LGPL-2.1-or-later"
depends="mate-common"
makedepends="libtool intltool libmatekbd-dev freeglut-dev
diff --git a/community/mate-system-monitor/APKBUILD b/community/mate-system-monitor/APKBUILD
index 5463231263..176961d372 100644
--- a/community/mate-system-monitor/APKBUILD
+++ b/community/mate-system-monitor/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="A system monitor for MATE"
url="https://github.com/mate-desktop/mate-system-monitor"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all !s390x !riscv64" # limited by librsvg -> rust
license="GPL-2.0-or-later"
depends="mate-icon-theme"
makedepends="gtk+3.0-dev libwnck3-dev gtkmm3-dev libgtop-dev
diff --git a/community/mate-terminal/APKBUILD b/community/mate-terminal/APKBUILD
index 86fa055dc4..8946692d90 100644
--- a/community/mate-terminal/APKBUILD
+++ b/community/mate-terminal/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="MATE terminal emulator"
url="https://github.com/mate-desktop/mate-terminal"
-# s390x, mips64 and riscv64 blocked by librsvg -> mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="mate-common yelp-tools mate-desktop"
makedepends="libtool intltool dconf-dev libsm-dev itstool vte3-dev
diff --git a/community/mate-utils/APKBUILD b/community/mate-utils/APKBUILD
index b60562b869..5d38c554d6 100644
--- a/community/mate-utils/APKBUILD
+++ b/community/mate-utils/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="Utilities for the MATE Desktop"
url="https://github.com/mate-desktop/mate-utils"
-# s390x, mips64 and riscv64 blocked by librsvg -> mate-panel
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> mate-panel
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
makedepends="intltool glib-dev gtk+3.0-dev mate-panel-dev udisks2-dev
libgtop-dev libcanberra-dev inkscape itstool libsm-dev libxml2-utils"
diff --git a/community/mauikit-accounts/APKBUILD b/community/mauikit-accounts/APKBUILD
index 83283f476b..1e3e238376 100644
--- a/community/mauikit-accounts/APKBUILD
+++ b/community/mauikit-accounts/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="MauiKit Utilities to handle User Accounts"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://mauikit.org/"
license="GPL-2.0-or-later"
depends="
diff --git a/community/mauikit-filebrowsing/APKBUILD b/community/mauikit-filebrowsing/APKBUILD
index 84335874f1..ea70fa0ef1 100644
--- a/community/mauikit-filebrowsing/APKBUILD
+++ b/community/mauikit-filebrowsing/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="MauiKit File Browsing utilities and controls"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://mauikit.org/"
license="GPL-2.0-or-later"
depends="
diff --git a/community/mauikit-imagetools/APKBUILD b/community/mauikit-imagetools/APKBUILD
index fb4f3b4241..53ff24a728 100644
--- a/community/mauikit-imagetools/APKBUILD
+++ b/community/mauikit-imagetools/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="MauiKit Image Tools Components"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://mauikit.org/"
license="GPL-2.0-or-later"
depends="
diff --git a/community/mauikit-texteditor/APKBUILD b/community/mauikit-texteditor/APKBUILD
index 9c321f6fb9..0ab8c7007c 100644
--- a/community/mauikit-texteditor/APKBUILD
+++ b/community/mauikit-texteditor/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="MauiKit Text Editor components"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by mauikit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://mauikit.org/"
license="GPL-2.0-or-later"
depends="kirigami2"
diff --git a/community/mauikit/APKBUILD b/community/mauikit/APKBUILD
index d409be084b..2b9a90e54a 100644
--- a/community/mauikit/APKBUILD
+++ b/community/mauikit/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=0
pkgdesc="Kit for developing MAUI Apps"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by plasma-framework
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by plasma-framework
+arch="all !armhf !s390x !riscv64"
url="https://mauikit.org/"
license="GPL-2.0-or-later"
depends="kirigami2"
diff --git a/community/maven/APKBUILD b/community/maven/APKBUILD
index 1e158eccd6..55a0bb66eb 100644
--- a/community/maven/APKBUILD
+++ b/community/maven/APKBUILD
@@ -7,8 +7,8 @@ _pkgname="$pkgname-${pkgver%%.*}"
pkgrel=0
pkgdesc="A Java project management and project comprehension tool."
url="http://maven.apache.org"
-# mips64 and riscv64 blocked by java-jdk
-arch="noarch !mips64 !riscv64"
+# riscv64 blocked by java-jdk
+arch="noarch !riscv64"
license="Apache-2.0"
options="!check" # repackaged release without a test suite
depends="java-jdk"
diff --git a/community/mellowplayer/APKBUILD b/community/mellowplayer/APKBUILD
index 0e0de82f59..cd88a59aed 100644
--- a/community/mellowplayer/APKBUILD
+++ b/community/mellowplayer/APKBUILD
@@ -7,8 +7,8 @@ pkgdesc="QT based cloud music integration for your desktop"
url="https://colinduquesnoy.gitlab.io/MellowPlayer/"
# armhf blocked by qt5-qtdeclarative
# aarch64 tests fail with segfault
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64 !aarch64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64 !aarch64"
license="GPL-2.0-or-later"
depends="qt5-qtgraphicaleffects qt5-qtquickcontrols qt5-qtsvg qt5-qtwayland"
makedepends="cmake qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev qt5-qtbase-mysql
diff --git a/community/mercurial/APKBUILD b/community/mercurial/APKBUILD
index a6f9337cb4..fe496fcb94 100644
--- a/community/mercurial/APKBUILD
+++ b/community/mercurial/APKBUILD
@@ -20,7 +20,7 @@ source="https://www.mercurial-scm.org/release/mercurial-$pkgver.tar.gz
blacklist.txt
"
case "$CARCH" in
- ppc64le|mips64|aarch64|armv7|armhf) options="$options !check" ;; # around 400 of 919 tests time out
+ ppc64le|aarch64|armv7|armhf) options="$options !check" ;; # around 400 of 919 tests time out
esac
case "$CARCH" in
# Oxidation, limited by Rust
diff --git a/community/mercury/APKBUILD b/community/mercury/APKBUILD
index af45c8942b..54e75011aa 100644
--- a/community/mercury/APKBUILD
+++ b/community/mercury/APKBUILD
@@ -5,7 +5,7 @@ pkgver=20.06.1
pkgrel=1
pkgdesc="Compiler for the Mercury language"
url="http://www.mercurylang.org"
-arch="all !mips64 !riscv64" # hangs on configure tests
+arch="all !riscv64" # hangs on configure tests
license="GPL-2.0-only"
makedepends="autoconf automake bison flex"
depends="$pkgname-libs"
diff --git a/community/messagelib/APKBUILD b/community/messagelib/APKBUILD
index bdaa739e27..e7008c635a 100644
--- a/community/messagelib/APKBUILD
+++ b/community/messagelib/APKBUILD
@@ -5,8 +5,8 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="KDE PIM messaging library"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kontact.kde.org/"
license="LGPL-2.0-only OR LGPL-3.0-only AND GPL-2.0-or-later"
depends_dev="
diff --git a/community/midori/APKBUILD b/community/midori/APKBUILD
index 2a80c15238..60d6ea6608 100644
--- a/community/midori/APKBUILD
+++ b/community/midori/APKBUILD
@@ -4,8 +4,8 @@ pkgver=9.0
pkgrel=5
pkgdesc="lightweight web browser based on Gtk WebKit"
url="https://www.midori-browser.org"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="LGPL-2.1-or-later"
makedepends="cmake librsvg-dev python3 vala gtk+3.0-dev gcr-dev
libarchive-dev json-glib-dev webkit2gtk-dev libpeas-dev ninja
diff --git a/community/milou/APKBUILD b/community/milou/APKBUILD
index fe4cdc8328..6b246a560f 100644
--- a/community/milou/APKBUILD
+++ b/community/milou/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="A dedicated search application built on top of Baloo"
# armhf blocked by qt5-qtdeclarative
# s390x blocked by polkit -> kdeclarative
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
makedepends="
diff --git a/community/mimic1/APKBUILD b/community/mimic1/APKBUILD
index f1e0ea3790..73bc482079 100644
--- a/community/mimic1/APKBUILD
+++ b/community/mimic1/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.3.0.1
pkgrel=0
pkgdesc="Mycroft's TTS engine, based on CMU's Flite (Festival Lite)"
url="https://mimic.mycroft.ai/"
-# mips, mips64 and s390x are unsupported architectures
-arch="all !mips !mips64 !s390x"
+# s390x is an unsupported architecture
+arch="all !s390x"
license="MIT AND BSD-2-Clause AND BSD-3-Clause AND BSD-4-Clause AND Apache-2.0 AND CDLA-Permissive-1.0"
makedepends="automake autoconf libtool pcre2-dev pulseaudio-dev alsa-lib-dev"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/community/mkvtoolnix/APKBUILD b/community/mkvtoolnix/APKBUILD
index 9f6695b028..eff7f1e616 100644
--- a/community/mkvtoolnix/APKBUILD
+++ b/community/mkvtoolnix/APKBUILD
@@ -7,10 +7,8 @@ pkgrel=0
pkgdesc="Set of tools to create, edit and inspect Matroska files"
url="https://mkvtoolnix.download/index.html"
# armhf blocked by qtmultimedia -> qtdeclarative
-# mips64 blocked by boost -> old kernel
-# https://gitlab.alpinelinux.org/alpine/aports/-/issues/12327#note_137460
# riscv64 blocked by fatal error: boost/core/use_default.hpp: No such file or directory
-arch="all !armhf !mips64 !riscv64"
+arch="all !armhf !riscv64"
license="GPL-2.0-only"
makedepends="boost-dev docbook-xsl file-dev flac-dev gtest-dev pcre2-dev
libmatroska-dev libogg-dev libvorbis-dev ruby ruby-rake zlib-dev
diff --git a/community/mmsd-tng/APKBUILD b/community/mmsd-tng/APKBUILD
index b7261a3eff..29a14110b9 100644
--- a/community/mmsd-tng/APKBUILD
+++ b/community/mmsd-tng/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.8
pkgrel=0
pkgdesc="daemon for receiving and managing GSM MMS messages"
url="https://gitlab.com/kop316/mmsd"
-# mips64, s390x and riscv64 blocked by polkit -> modemmanager
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> modemmanager
+arch="all !s390x !riscv64"
license="GPL-2.0-only"
# upstream was renamed mmsd-->mmsd-tng
provides="mmsd=$pkgver-r$pkgrel"
diff --git a/community/modemmanager-qt/APKBUILD b/community/modemmanager-qt/APKBUILD
index 1e6a3e8baf..230ce65c2d 100644
--- a/community/modemmanager-qt/APKBUILD
+++ b/community/modemmanager-qt/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Qt wrapper for ModemManager DBus API"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> modemmanager
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> modemmanager
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="
diff --git a/community/modemmanager/APKBUILD b/community/modemmanager/APKBUILD
index 7045ca3b79..3b37b4d75e 100644
--- a/community/modemmanager/APKBUILD
+++ b/community/modemmanager/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.18.6
pkgrel=0
pkgdesc="ModemManager library"
url="http://www.freedesktop.org/wiki/Software/ModemManager"
-arch="all !mips !mips64 !s390x !riscv64" # limited by polkit
+arch="all !s390x !riscv64" # limited by polkit
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="dbus polkit libmm-glib=$pkgver-r$pkgrel"
depends_dev="libmm-glib=$pkgver-r$pkgrel"
diff --git a/community/moment/APKBUILD b/community/moment/APKBUILD
index 91f76ec841..24907b8286 100644
--- a/community/moment/APKBUILD
+++ b/community/moment/APKBUILD
@@ -6,9 +6,8 @@ pkgrel=0
pkgdesc="Qt/QML Matrix client"
url="https://mx-moment.xyz"
# armhf: blocked by py3-pyotherside, qt5-qtquickcontrols2
-# mips64: ???
# s390x: blocked by py3-watchgod
-arch="all !armhf !mips64 !s390x"
+arch="all !armhf !s390x"
license="LGPL-3.0-or-later"
replaces=mirage
provides="mirage=$pkgver-r$pkgrel"
diff --git a/community/mongodb-tools/APKBUILD b/community/mongodb-tools/APKBUILD
index 69ad8cf843..5cf5170075 100644
--- a/community/mongodb-tools/APKBUILD
+++ b/community/mongodb-tools/APKBUILD
@@ -11,7 +11,6 @@ makedepends="$depends_dev go cyrus-sasl-dev openssl1.1-compat-dev libpcap-dev ba
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/mongodb/mongo-tools/archive/r$pkgver.tar.gz
fix-build.patch
- remove-buildflags.patch
"
builddir="$srcdir/src/github.com/mongodb/mongo-tools"
@@ -36,6 +35,7 @@ package() {
"$bindir"
}
-sha512sums="ddddf8340788635d5be60457460830f4f8be47f7e90b61e0a498a95f46d0e1671b4e1482049d761c5d5f36c63d01277753d74f6a51446340a3dd2e2e3e0de546 mongodb-tools-4.2.14.tar.gz
+sha512sums="
+ddddf8340788635d5be60457460830f4f8be47f7e90b61e0a498a95f46d0e1671b4e1482049d761c5d5f36c63d01277753d74f6a51446340a3dd2e2e3e0de546 mongodb-tools-4.2.14.tar.gz
74e432b354fd75209b87461e54f79a173ba0d647a2e45a48d520ee9342236b6a50ef1c634312f4804402578b8534d59ebf10973ce90cae2bbe76407102f2b404 fix-build.patch
-52d1fe25cd0c44331fac7320d3d77d8a72dee18ccace4f301a01ce9f6fda8e6daa0334a4b62fc8c9c8bc791717fd25fe2e3a4550d9d4f66367b63937d2bdc8ac remove-buildflags.patch"
+"
diff --git a/community/mongodb-tools/remove-buildflags.patch b/community/mongodb-tools/remove-buildflags.patch
deleted file mode 100644
index 46ac171597..0000000000
--- a/community/mongodb-tools/remove-buildflags.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Description: buildflags only set -buildmode=pie on linux, which we control with
-GOFLAGS. -buildmode=pie is not supported on mips.
-diff --git a/build.sh b/build.sh
-index 519f9c8..c96ed9c 100755
---- a/build.sh
-+++ b/build.sh
-@@ -29,7 +29,7 @@ mkdir -p bin
- ec=0
- for i in bsondump mongostat mongofiles mongoexport mongoimport mongorestore mongodump mongotop mongoreplay; do
- echo "Building ${i}..."
-- go build -o "bin/$i$BINARY_EXT" $(buildflags) -ldflags "$(print_ldflags)" -tags "$(print_tags $tags)" "$i/main/$i.go" || { echo "Error building $i"; ec=1; break; }
-+ go build -o "bin/$i$BINARY_EXT" -ldflags "$(print_ldflags)" -tags "$(print_tags $tags)" "$i/main/$i.go" || { echo "Error building $i"; ec=1; break; }
- ./bin/${i}${BINARY_EXT} --version | head -1
- done
-
diff --git a/community/mousepad/APKBUILD b/community/mousepad/APKBUILD
index d3d2f3d5e5..c7f23dd7a5 100644
--- a/community/mousepad/APKBUILD
+++ b/community/mousepad/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.5.8
pkgrel=0
pkgdesc="Simple Text Editor for Xfce4"
url="https://git.xfce.org/apps/mousepad/"
-arch="all !s390x !mips !mips64" # Limited by gtksourceview
+arch="all !s390x" # Limited by gtksourceview
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev gtksourceview-dev intltool xfconf-dev"
depends="desktop-file-utils"
diff --git a/community/msitools/APKBUILD b/community/msitools/APKBUILD
index 789d451009..550c32e479 100644
--- a/community/msitools/APKBUILD
+++ b/community/msitools/APKBUILD
@@ -4,8 +4,7 @@ pkgver=0.101
pkgrel=1
pkgdesc="Set of programs to inspect and build Windows Installer (.MSI) files"
url="https://wiki.gnome.org/msitools"
-# mips(64): test failures
-arch="all !mips !mips64"
+arch="all"
license="GPL-2.0-or-later LGPL-2.1-or-later"
makedepends="meson libgsf-dev libgcab-dev bison vala perl
gobject-introspection-dev"
diff --git a/community/musescore/APKBUILD b/community/musescore/APKBUILD
index a91646f9ce..a37fdf0163 100644
--- a/community/musescore/APKBUILD
+++ b/community/musescore/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=3
pkgdesc="Create, play and print beautiful sheet music"
url="https://musescore.org/"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by luatex -> texlive
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by luatex -> texlive
+arch="all !armhf !s390x !riscv64"
license="GPL-2.0-or-later"
depends="
qt5-qtgraphicaleffects
diff --git a/community/mutter/APKBUILD b/community/mutter/APKBUILD
index 013dd2b865..1e70f6836f 100644
--- a/community/mutter/APKBUILD
+++ b/community/mutter/APKBUILD
@@ -5,7 +5,7 @@ pkgver=41.3
pkgrel=1
pkgdesc="clutter-based window manager and compositor"
url="https://wiki.gnome.org/Projects/Mutter/"
-arch="all !mips64 !s390x !riscv64" # limited by gnome-settings-daemon -> rust
+arch="all !s390x !riscv64" # limited by gnome-settings-daemon -> rust
license="GPL-2.0-or-later"
depends="
gnome-settings-daemon
diff --git a/community/mycroft-gui/APKBUILD b/community/mycroft-gui/APKBUILD
index a1fd5e8f64..3ece54f115 100644
--- a/community/mycroft-gui/APKBUILD
+++ b/community/mycroft-gui/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=1
pkgdesc="The Graphical User Interface used by the Mycroft Mark II and more"
url="https://mycroft.ai"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine -> qt5-qtwebview
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine -> qt5-qtwebview
+arch="all !armhf !ppc64le !s390x !riscv64"
license="Apache-2.0"
depends="kirigami2"
makedepends="
diff --git a/community/mycroft-plasmoid/APKBUILD b/community/mycroft-plasmoid/APKBUILD
index 7aaeec3246..776a98c002 100644
--- a/community/mycroft-plasmoid/APKBUILD
+++ b/community/mycroft-plasmoid/APKBUILD
@@ -6,9 +6,9 @@ pkgrel=0
_commit="70f84636da63b00d114747e440e4a15aa7d5b019"
pkgdesc="Plasma integration of different Mycroft AI services"
url="https://invent.kde.org/utilities/mycroft-plasmoid"
-# ppc64le, s390x, armhf, mips and mips64 blocked by mycroft-gui
+# ppc64le, s390x, armhf blocked by mycroft-gui
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !ppc64le !s390x !armhf !mips !mips64 !riscv64"
+arch="all !ppc64le !s390x !armhf !riscv64"
license="Apache-2.0 AND LGPL-2.0-or-later AND LicenseRef-KDE-Accepted-GPL"
depends="mycroft-gui"
makedepends="
diff --git a/community/mygnuhealth/APKBUILD b/community/mygnuhealth/APKBUILD
index f31a003248..878170c992 100644
--- a/community/mygnuhealth/APKBUILD
+++ b/community/mygnuhealth/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.0.5
pkgrel=1
pkgdesc="The GNU Health Personal Health Record (PHR)"
url="https://invent.kde.org/pim/mygnuhealth"
-# armhf, mips64 and riscv64 blocked by py3-pyside2
-arch="noarch !armhf !mips64 !riscv64"
+# armhf and riscv64 blocked by py3-pyside2
+arch="noarch !armhf !riscv64"
license="GPL-3.0-or-later"
depends="
kirigami2
diff --git a/community/namecoin/APKBUILD b/community/namecoin/APKBUILD
index 916053839f..e75e0bf4c1 100644
--- a/community/namecoin/APKBUILD
+++ b/community/namecoin/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=2
pkgdesc="Namecoin is a peer to peer DNS based on bitcoin"
url="https://www.namecoin.org/"
#x86: Test failures
-#s390x,mips: Missing packages
-arch="all !s390x !mips !mips64 !x86"
+#s390x: Missing packages
+arch="all !s390x !x86"
license="MIT"
makedepends="$depends_dev autoconf automake libtool boost-dev openssl1.1-compat-dev
miniupnpc-dev qt5-qtbase-dev qt5-qttools-dev protobuf-dev
diff --git a/community/nautilus/APKBUILD b/community/nautilus/APKBUILD
index 1e545ff671..3f297cb2fc 100644
--- a/community/nautilus/APKBUILD
+++ b/community/nautilus/APKBUILD
@@ -5,8 +5,8 @@ pkgver=41.0
pkgrel=1
pkgdesc="GNOME file manager"
url="https://wiki.gnome.org/Apps/Nautilus"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="tracker-miners gsettings-desktop-schemas"
depends_dev="gnome-desktop-dev gnome-autoar-dev"
diff --git a/community/nemo/APKBUILD b/community/nemo/APKBUILD
index 6d795adaad..04d634b42b 100644
--- a/community/nemo/APKBUILD
+++ b/community/nemo/APKBUILD
@@ -4,9 +4,9 @@ pkgname=nemo
pkgver=4.8.6
pkgrel=0
pkgdesc="File manager for the Cinnamon desktop environment"
-# s390x, mips64 and ppc64le blocked by exempi
+# s390x and ppc64le blocked by exempi
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !mips64 !ppc64le !riscv64" # exempi, libexif-dev not available for all archs
+arch="all !s390x !ppc64le !riscv64" # exempi, libexif-dev not available for all archs
url="https://github.com/linuxmint/nemo"
license="GPL-2.0-only"
makedepends="
diff --git a/community/neochat/APKBUILD b/community/neochat/APKBUILD
index 825dc3d0af..7f014b217a 100644
--- a/community/neochat/APKBUILD
+++ b/community/neochat/APKBUILD
@@ -6,9 +6,8 @@ pkgrel=0
pkgdesc="A client for Matrix, the decentralized communication protocol"
url="https://invent.kde.org/network/neochat/"
# armhf blocked by extra-cmake-modules
-# mips64 blocked by libquotient-dev
# riscv64 and s390x blocked by qqc2-desktop-style
-arch="all !armhf !mips64 !s390x !riscv64"
+arch="all !armhf !s390x !riscv64"
license="GPL-2.0-or-later AND GPL-3.0-only AND GPL-3.0-or-later AND BSD-2-Clause"
depends="
kirigami2
diff --git a/community/netcdf/APKBUILD b/community/netcdf/APKBUILD
index c948e266a4..4c7bec947d 100644
--- a/community/netcdf/APKBUILD
+++ b/community/netcdf/APKBUILD
@@ -5,9 +5,8 @@ pkgver=4.8.1
pkgrel=2
pkgdesc="Libraries for the Unidata network Common Data Format"
url="https://www.unidata.ucar.edu/software/netcdf/"
-# disabled on mips as tests fail
# disabled on s390x because of https://github.com/Unidata/netcdf-c/issues/1987
-arch="all !mips !mips64 !s390x"
+arch="all !s390x"
license="BSD-3-Clause"
options="net" # tests need network access
makedepends="
diff --git a/community/network-manager-applet/APKBUILD b/community/network-manager-applet/APKBUILD
index ffcb4ec294..30a331cb12 100644
--- a/community/network-manager-applet/APKBUILD
+++ b/community/network-manager-applet/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.24.0
pkgrel=0
pkgdesc="GTK network manager applet"
url="https://wiki.gnome.org/Projects/NetworkManager"
-# mips64, s390x and riscv64 blocked by networkmanager and polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by networkmanager and polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="dbus:org.freedesktop.Secrets"
makedepends="
diff --git a/community/networkmanager-elogind/APKBUILD b/community/networkmanager-elogind/APKBUILD
index fbf586172c..4bf66a665a 100644
--- a/community/networkmanager-elogind/APKBUILD
+++ b/community/networkmanager-elogind/APKBUILD
@@ -6,8 +6,8 @@ pkgver=1.32.12
pkgrel=0
pkgdesc="Network Management daemon (with elogind hibernation support)"
url="https://wiki.gnome.org/Projects/NetworkManager"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="iptables dbus mobile-broadband-provider-info openresolv"
install="$pkgname.pre-install $pkgname.pre-upgrade"
diff --git a/community/networkmanager-l2tp/APKBUILD b/community/networkmanager-l2tp/APKBUILD
index fcb76bf46d..8a49508ca8 100644
--- a/community/networkmanager-l2tp/APKBUILD
+++ b/community/networkmanager-l2tp/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=3
pkgdesc="L2TP support for NetworkManager"
url="https://github.com/nm-l2tp/NetworkManager-l2tp"
license="GPL-2.0-only"
-# s390x, mips64 and riscv64 blocked by networkmanager
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by networkmanager
+arch="all !s390x !riscv64"
makedepends="intltool python3 libnma-dev libtool automake autoconf gettext-dev
glib-dev ppp-dev nss-dev gtk+3.0-dev libsecret-dev openssl1.1-compat-dev"
depends="ppp xl2tpd strongswan"
diff --git a/community/networkmanager-openvpn/APKBUILD b/community/networkmanager-openvpn/APKBUILD
index 159baf1003..d033adab95 100644
--- a/community/networkmanager-openvpn/APKBUILD
+++ b/community/networkmanager-openvpn/APKBUILD
@@ -5,9 +5,9 @@ pkgver=1.8.16
pkgrel=0
pkgdesc="NetworkManager VPN plugin for OpenVPN"
url="https://wiki.gnome.org/Projects/NetworkManager/VPN"
-# s390x and mips64 blocked by network-manager-applet-dev -> networkmanager-dev
+# s390x blocked by network-manager-applet-dev -> networkmanager-dev
# riscv64 blocked by polkit -> libnma
-arch="all !s390x !mips64 !riscv64"
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="
dbus:org.freedesktop.Secrets
diff --git a/community/networkmanager-qt/APKBUILD b/community/networkmanager-qt/APKBUILD
index 987646c5d4..a77311dc78 100644
--- a/community/networkmanager-qt/APKBUILD
+++ b/community/networkmanager-qt/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Qt wrapper for NetworkManager API"
# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> networkmanager
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit -> networkmanager
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends="networkmanager"
diff --git a/community/networkmanager/APKBUILD b/community/networkmanager/APKBUILD
index 2df998aae4..ca4b497797 100644
--- a/community/networkmanager/APKBUILD
+++ b/community/networkmanager/APKBUILD
@@ -6,8 +6,8 @@ pkgver=1.32.12
pkgrel=1
pkgdesc="Network Management daemon"
url="https://wiki.gnome.org/Projects/NetworkManager"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="iptables dbus mobile-broadband-provider-info"
install="$pkgname.pre-install $pkgname.pre-upgrade"
diff --git a/community/newlib-stage1/APKBUILD b/community/newlib-stage1/APKBUILD
index 37a990a62f..b7a1f4cfe4 100644
--- a/community/newlib-stage1/APKBUILD
+++ b/community/newlib-stage1/APKBUILD
@@ -9,7 +9,7 @@ _targets="
"
# or1k-elf fails to build on 32-bit architectures
case "$CARCH" in
- x86_64|aarch64|ppc64le|mips64) _targets="$_targets or1k-elf"
+ x86_64|aarch64|ppc64le) _targets="$_targets or1k-elf"
esac
pkgname=newlib-stage1
pkgver=4.1.0
diff --git a/community/newlib/APKBUILD b/community/newlib/APKBUILD
index 69ba1437e8..f95ade5e2d 100644
--- a/community/newlib/APKBUILD
+++ b/community/newlib/APKBUILD
@@ -9,7 +9,7 @@ _targets="
"
# or1k-elf fails to build on 32-bit architectures
case "$CARCH" in
- x86_64|aarch64|ppc64le|mips64) _targets="$_targets or1k-elf"
+ x86_64|aarch64|ppc64le) _targets="$_targets or1k-elf"
esac
pkgname=newlib
pkgver=4.1.0
@@ -17,8 +17,8 @@ pkgrel=3
pkgdesc="C standard library implementation intended for use on embedded systems"
url="https://www.sourceware.org/newlib/"
makedepends="texinfo"
-# s390x, mips64 and riscv64 blocked by gcc-cross-embedded
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by gcc-cross-embedded
+arch="all !s390x !riscv64"
license="GPL-2.0-only AND LGPL-2.1-only AND 0BSD AND BSD-3-Clause AND GPL-3.0-only AND LGPL-3.0-only"
source="
https://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz
diff --git a/community/newsflash/APKBUILD b/community/newsflash/APKBUILD
index ecbc6d7b82..b480602404 100644
--- a/community/newsflash/APKBUILD
+++ b/community/newsflash/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.5.1
pkgrel=0
pkgdesc="An rss feed reader that supports various web based services"
url="https://gitlab.com/news-flash/news_flash_gtk/"
-arch="all !s390x !mips64 !riscv64" # cargo, rust, libhandy not found
+arch="all !s390x !riscv64" # cargo, rust, libhandy not found
license="GPL-3.0-only"
makedepends="meson bash rust cargo webkit2gtk-dev libhandy1-dev sqlite-dev gettext-dev openssl1.1-compat-dev"
source="news_flash_gtk-v.$pkgver.tar.gz::https://gitlab.com/news-flash/news_flash_gtk/-/archive/$pkgver/news_flash_gtk-$pkgver.tar.gz"
diff --git a/community/nextcloud-client/APKBUILD b/community/nextcloud-client/APKBUILD
index 345a4dc939..08a4667b88 100644
--- a/community/nextcloud-client/APKBUILD
+++ b/community/nextcloud-client/APKBUILD
@@ -5,9 +5,9 @@ pkgver=3.3.5
pkgrel=0
pkgdesc="Nextcloud Desktop Client"
url="https://github.com/nextcloud/desktop"
-# mips, s390x, ppc64le and riscv64 blocked by qt5-qtwebengine
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebengine
# armhf blocked by extra-cmake-modules
-arch="all !s390x !ppc64le !armhf !mips64 !riscv64"
+arch="all !s390x !ppc64le !armhf !riscv64"
license="GPL-2.0-only"
depends="dbus:org.freedesktop.Secrets"
makedepends="$depends_dev cmake doxygen qt5-qttools-dev qt5-qtkeychain-dev
diff --git a/community/nim/APKBUILD b/community/nim/APKBUILD
index 4929697aca..da70ebb71c 100644
--- a/community/nim/APKBUILD
+++ b/community/nim/APKBUILD
@@ -21,10 +21,10 @@ source="https://nim-lang.org/download/nim-$pkgver.tar.xz
"
# Don't run tests on armhf and ppc64le, it'd take eternity...
-# Can't run tests on mips and riscv64, no nodejs...
+# Can't run tests on riscv64, no nodejs...
# Temporarily allow textrels on riscv64
case "$CARCH" in
- armhf | ppc64le | mips*) options="!check";;
+ armhf | ppc64le ) options="!check";;
riscv64) options="!check textrels";;
esac
diff --git a/community/nodejs-clean-css/APKBUILD b/community/nodejs-clean-css/APKBUILD
index 431cb5be08..cd5a35500b 100644
--- a/community/nodejs-clean-css/APKBUILD
+++ b/community/nodejs-clean-css/APKBUILD
@@ -5,7 +5,7 @@ pkgver=5.1.2
pkgrel=0
pkgdesc="A fast, efficient, and well tested CSS minifier for nodejs"
url="https://github.com/jakubpawlowicz/clean-css"
-arch="noarch !mips !mips64 !riscv64" # blocked by nodejs
+arch="noarch !riscv64" # blocked by nodejs
license="MIT"
depends="nodejs"
makedepends="npm"
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index d37b67d228..f01b9753b8 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -57,7 +57,7 @@ pkgver=17.5.0
pkgrel=1
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
-arch="all !mips64 !mips64el !riscv64"
+arch="all !riscv64"
license="MIT"
depends="ca-certificates"
depends_dev="libuv"
@@ -78,7 +78,6 @@ provides="nodejs"
replaces="nodejs nodejs-lts" # nodejs-lts for backward compatibility
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz
dont-run-gyp-files-for-bundled-deps.patch
- link-with-libatomic-on-mips32.patch
elf.patch
unbundle-uv.patch
39739.patch
@@ -112,7 +111,6 @@ build() {
export CPPFLAGS="${CPPFLAGS/-Os/} $common_flags"
case "$CARCH" in
- mips*) _carchflags="--with-mips-arch-variant=r1 --with-mips-float-abi=soft";;
riscv64) _carchflags="--dest-cpu=riscv64";
esac
@@ -148,7 +146,6 @@ package() {
sha512sums="
c07b59b837e7e01636d1502f9f23e0e6b4d89d868fd66cb7a5c53f5df42952557e36b257cabe69d5e3a0b632c31030348e78d305319db65349d2536a18a94a5f node-v17.5.0.tar.gz
940cc90aaa77a531cde13e31918a9978f9478936c3851038bcdf2869e64de03ce84dec5a46519469a90a8ba2853226825452d23d9347752abdbe04e944c083eb dont-run-gyp-files-for-bundled-deps.patch
-65df7eeadbdfc015185260c0e24f3206714e4d2aacceef742d078a4f8bae386b2867e0f7f3b8c2eac47180cb10a8e14b71a36a23bb74ed6a95eecbaf76897e0c link-with-libatomic-on-mips32.patch
e6f2907bdf2082097841f44ac9380d5b1bc65eca39be7153da081266940c6a10d2932e16a2e15bdcf12fec61c45549d009d1a07e5e1633603172968b5f6fdb77 elf.patch
d8f1092a92f7a168755020b3e40fe72b743f9150de6d18f7664074dadaef866ecb4fa8252fa891fd7cf34b3dc183455af8d5570d7b3f1883464c2b6e3a9f2789 unbundle-uv.patch
080ede859262f5507a913b1f9995092ed075777e94c73c23ee74d74c739e9b2e6b4cc3afad189a333692f10485e7e3e12a15662286df2c946f73bdd6083baee8 39739.patch
diff --git a/community/nodejs-current/link-with-libatomic-on-mips32.patch b/community/nodejs-current/link-with-libatomic-on-mips32.patch
deleted file mode 100644
index b082c4139a..0000000000
--- a/community/nodejs-current/link-with-libatomic-on-mips32.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/tools/v8_gypfiles/v8.gyp
-+++ b/tools/v8_gypfiles/v8.gyp
-@@ -1201,6 +1201,11 @@
- ['want_separate_host_toolset', {
- 'toolsets': ['host', 'target'],
- }],
-+ [ 'host_arch=="mips" or host_arch=="mipsel"', {
-+ 'link_settings': {
-+ 'libraries': [ '-latomic' ],
-+ },
-+ }],
- ['component=="shared_library"', {
- 'direct_dependent_settings': {
- 'defines': ['USING_V8_PLATFORM_SHARED'],
---- a/node.gyp
-+++ b/node.gyp
-@@ -376,6 +376,11 @@
- 'msvs_disabled_warnings!': [4244],
-
- 'conditions': [
-+ [ 'host_arch=="mips" or host_arch=="mipsel"', {
-+ 'link_settings': {
-+ 'libraries': [ '-latomic' ],
-+ },
-+ }],
- [ 'error_on_warn=="true"', {
- 'cflags': ['-Werror'],
- }],
diff --git a/community/nodejs-less-plugin-clean-css/APKBUILD b/community/nodejs-less-plugin-clean-css/APKBUILD
index bf764f1165..a5fab04bb4 100644
--- a/community/nodejs-less-plugin-clean-css/APKBUILD
+++ b/community/nodejs-less-plugin-clean-css/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.5.1
pkgrel=1
pkgdesc="Post-process and compress CSS using clean-css"
url="https://github.com/less/less-plugin-clean-css"
-arch="noarch !mips !mips64 !riscv64" # blocked by nodejs
+arch="noarch !riscv64" # blocked by nodejs
license="MIT"
depends="nodejs"
makedepends="npm nodejs-less nodejs-clean-css"
diff --git a/community/nodejs-less/APKBUILD b/community/nodejs-less/APKBUILD
index c50892b734..9bd4fdd899 100644
--- a/community/nodejs-less/APKBUILD
+++ b/community/nodejs-less/APKBUILD
@@ -5,7 +5,7 @@ pkgver=4.1.1
pkgrel=0
pkgdesc="A standalone compiler for the LESS CSS language"
url="https://lesscss.org"
-arch="noarch !mips64 !riscv64" # blocked by nodejs
+arch="noarch !riscv64" # blocked by nodejs
license="AGPL-3.0-or-later"
depends="nodejs"
makedepends="npm"
diff --git a/community/nomad/APKBUILD b/community/nomad/APKBUILD
index 3bd97b6361..a36dbdcb6f 100644
--- a/community/nomad/APKBUILD
+++ b/community/nomad/APKBUILD
@@ -6,8 +6,8 @@ pkgver=1.1.1 # remember to update GIT_COMMIT below
pkgrel=3
pkgdesc="easy-to-use, flexible, and performant workload orchestrator"
url="https://www.nomadproject.io/"
-arch="all !mips64 !riscv64 !x86"
-# x86 run out of memory, mips64 & riscv64 limited by yarn/npm
+arch="all !riscv64 !x86"
+# x86 run out of memory, riscv64 limited by yarn/npm
license="MPL-2.0"
depends="cni-plugins"
makedepends="linux-headers bash make go yarn npm go-bindata-assetfs"
diff --git a/community/nota/APKBUILD b/community/nota/APKBUILD
index a00ea47b97..5ab12d1e5f 100644
--- a/community/nota/APKBUILD
+++ b/community/nota/APKBUILD
@@ -5,8 +5,8 @@ pkgver=2.1.0
pkgrel=1
pkgdesc="Nota is a simple and convergent text editor"
# armhf blocked by qt5-qtdeclarative
-# s390x, ppc64le, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !s390x !ppc64le !riscv64"
url="https://invent.kde.org/maui/nota"
license="GPL-2.0-or-later"
depends="
diff --git a/community/numberstation/APKBUILD b/community/numberstation/APKBUILD
index c6510f24fb..ad3610ad0e 100644
--- a/community/numberstation/APKBUILD
+++ b/community/numberstation/APKBUILD
@@ -4,8 +4,8 @@ pkgver=1.1.0
pkgrel=0
pkgdesc="TOTP Authentication application for mobile"
url="https://git.sr.ht/~martijnbraam/numberstation"
-# riscv64, s390x and mips64 blocked by libhandy1, ppc64le blocked by py3-keyring
-arch="noarch !s390x !mips64 !ppc64le !riscv64"
+# riscv64, s390x blocked by libhandy1, ppc64le blocked by py3-keyring
+arch="noarch !s390x !ppc64le !riscv64"
license="GPL-3.0-or-later"
depends="python3 py3-gobject3 py3-otp py3-keyring gtk+3.0 libhandy1"
makedepends="py3-setuptools glib-dev libhandy1-dev meson ninja"
diff --git a/community/nx-libs/APKBUILD b/community/nx-libs/APKBUILD
index 1f73d9ef3a..28f5d51f05 100644
--- a/community/nx-libs/APKBUILD
+++ b/community/nx-libs/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.5.99.26
pkgrel=0
pkgdesc="NoMachine libraries (redistributed by x2go)"
url="http://x2go.org"
-# mips64 and riscv64 are not supported
-arch="all !mips64 !riscv64"
+# riscv64 is not supported
+arch="all !riscv64"
license="GPL-2.0-or-later"
depends="font-cursor-misc font-misc-misc"
makedepends="libx11-dev zlib-dev libjpeg-turbo-dev
diff --git a/community/nymphcast/APKBUILD b/community/nymphcast/APKBUILD
index ee11b520a1..3c3180cb93 100644
--- a/community/nymphcast/APKBUILD
+++ b/community/nymphcast/APKBUILD
@@ -3,9 +3,8 @@
pkgname=nymphcast
pkgver=0.1_rc0
pkgrel=0
-# mips64 blocked by poco -> nymphrpc
# armhf, s390x and riscv64 blocked by vlc
-arch="all !mips64 !armhf !s390x !riscv64"
+arch="all !armhf !s390x !riscv64"
url="http://nyanko.ws/product_nymphcast.php"
pkgdesc="Audio and video casting system with support for custom applications"
license="BSD-3-Clause"
diff --git a/community/nymphrpc/APKBUILD b/community/nymphrpc/APKBUILD
index c88883f05f..3ab71e23a6 100644
--- a/community/nymphrpc/APKBUILD
+++ b/community/nymphrpc/APKBUILD
@@ -3,8 +3,7 @@
pkgname=nymphrpc
pkgver=0.1_alpha1
pkgrel=0
-# mips64 blocked by poco
-arch="all !mips64"
+arch="all"
url="https://github.com/MayaPosch/NymphRPC"
pkgdesc="Versatile and fast remote procedure call library"
license="BSD-3-Clause"
diff --git a/community/obs-studio/APKBUILD b/community/obs-studio/APKBUILD
index fe40c2598e..4b5dcc98ef 100644
--- a/community/obs-studio/APKBUILD
+++ b/community/obs-studio/APKBUILD
@@ -17,9 +17,9 @@ makedepends="cmake ffmpeg-dev libxinerama-dev
subpackages="$pkgname-dev"
source="https://github.com/obsproject/obs-studio/archive/$pkgver/obs-studio-$pkgver.tar.gz"
-# mips64, armhf, s390x and riscv64 blocked by librsvg -> vlc
+# armhf, s390x and riscv64 blocked by librsvg -> vlc
case $CARCH in
- mips64|armhf|s390x|riscv64)
+ armhf|s390x|riscv64)
;;
*)
makedepends="$makedepends vlc-dev"
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index 6f82ef8b63..c6337e0960 100644
--- a/community/ocaml-camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -11,8 +11,8 @@ _ocamlver=${pkgver%.*}
pkgrel=0
pkgdesc="Caml preprocessor and pretty-printer"
url="https://github.com/ocaml/camlp4/releases"
-# mips64 and riscv64 blocked by ocaml
-arch="all !mips64 !riscv64"
+# riscv64 blocked by ocaml
+arch="all !riscv64"
license="LGPL-2.0-or-later-WITH-linking-exception"
depends="ocaml-runtime=~$_ocamlver ocaml-ocamlbuild"
depends_dev="$pkgname=$pkgver-r$pkgrel"
diff --git a/community/ocaml-findlib/APKBUILD b/community/ocaml-findlib/APKBUILD
index 3a70fd9199..1b5fb25ab8 100644
--- a/community/ocaml-findlib/APKBUILD
+++ b/community/ocaml-findlib/APKBUILD
@@ -6,8 +6,8 @@ pkgver=1.9.1
pkgrel=2
pkgdesc="OCaml package manager"
url="http://projects.camlcity.org/projects/findlib.html"
-# mips64 and riscv64 blocked by ocaml
-arch="all !mips64 !riscv64"
+# riscv64 blocked by ocaml
+arch="all !riscv64"
license="MIT"
depends="ocaml ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel"
diff --git a/community/ocaml/APKBUILD b/community/ocaml/APKBUILD
index bb829493c6..78ce7cd5eb 100644
--- a/community/ocaml/APKBUILD
+++ b/community/ocaml/APKBUILD
@@ -7,8 +7,7 @@ pkgrel=0
pkgdesc="Main implementation of the Caml programming language"
url="https://ocaml.org/"
# riscv64: make[4]: *** [Makefile:181: dynlink_compilerlibs/binutils.cmo] Segmentation fault
-# mips64: "native-code compiler is not supported"
-arch="all !mips64 !riscv64"
+arch="all !riscv64"
license="LGPL-2.1-or-later-WITH-linking-exception"
depends="$pkgname-runtime=$pkgver-r$pkgrel gcc"
makedepends="gdbm-dev libc-dev ncurses-dev zlib-dev binutils-dev"
@@ -24,7 +23,7 @@ source="https://caml.inria.fr/pub/distrib/ocaml-${pkgver%.*}/ocaml-$pkgver.tar.g
# 32bit archs
case "$CARCH" in
-armv7|armhf|mips|x86) options="$options textrels" ;;
+armv7|armhf|x86) options="$options textrels" ;;
esac
build() {
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index ed8800242f..c5b9da098c 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -8,8 +8,8 @@ pkgrel=5
pkgdesc="Generic build tool with built-in rules for building OCaml library and programs"
options="!check"
url="https://github.com/ocaml/ocamlbuild"
-# mips64 and riscv64 blocked by ocaml
-arch="all !mips64 !riscv64"
+# riscv64 blocked by ocaml
+arch="all !riscv64"
license="LGPL-2.0-or-later-WITH-linking-exception"
checkdepends="ocaml-compiler-libs ocaml-findlib"
depends="ocaml-$pkgname=$pkgver-r$pkgrel cmd:tput"
diff --git a/community/octave/APKBUILD b/community/octave/APKBUILD
index aa1e153ded..4981a3d131 100644
--- a/community/octave/APKBUILD
+++ b/community/octave/APKBUILD
@@ -7,8 +7,8 @@ pkgrel=1
pkgdesc="A high-level language, primarily intended for numerical computations"
url="https://www.gnu.org/software/octave/"
# ppc64le, s390x missing texlive
-# missing openjdk8 on riscv64 and mips64
-arch="all !s390x !riscv64 !mips64 !ppc64le"
+# missing openjdk8 on riscv64
+arch="all !s390x !riscv64 !ppc64le"
license="GPL-3.0-or-later"
subpackages="$pkgname-dev $pkgname-doc"
diff --git a/community/okteta/APKBUILD b/community/okteta/APKBUILD
index 131a839d6b..e4e11d65a8 100644
--- a/community/okteta/APKBUILD
+++ b/community/okteta/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.26.6
pkgrel=0
pkgdesc="KDE hex editor for viewing and editing the raw data of files"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/utilities/org.kde.okteta"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND (GPL-2.0-only OR GPL-3.0-only) AND GFDL-1.2-only"
makedepends="
diff --git a/community/okular/APKBUILD b/community/okular/APKBUILD
index 5628b9e1ba..57a3ebb635 100644
--- a/community/okular/APKBUILD
+++ b/community/okular/APKBUILD
@@ -4,9 +4,9 @@ pkgname=okular
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> purpose
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://kde.org/applications/office/org.kde.okular"
pkgdesc="A universal document viewer"
license="GPL-2.0-or-later AND LGPL-2.0-or-later"
diff --git a/community/olm/APKBUILD b/community/olm/APKBUILD
index 5795249988..06912ca290 100644
--- a/community/olm/APKBUILD
+++ b/community/olm/APKBUILD
@@ -15,6 +15,7 @@ makedepends="
"
checkdepends="
py3-pytest
+ py3-pytest-benchmark
py3-pytest-cov
py3-future
py3-aspectlib
@@ -22,15 +23,6 @@ checkdepends="
source="https://gitlab.matrix.org/matrix-org/olm/-/archive/$pkgver/olm-$pkgver.tar.gz"
subpackages="$pkgname-dev py3-olm:py3"
-case "$CARCH" in
- mips*)
- _disable_tests="
- --deselect tests/group_session_test.py::TestClass::test_encrypt \
- --deselect tests/group_session_test.py::TestClass::test_decrypt"
- ;;
- *) checkdepends="$checkdepends py3-pytest-benchmark" ;;
-esac
-
build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
@@ -49,7 +41,7 @@ check() {
cd "$builddir"/python
local _pyarch
case "$CARCH" in
- x86_64|aarch64|ppc64le|mips*) _pyarch="$CARCH" ;;
+ x86_64|aarch64|ppc64le) _pyarch="$CARCH" ;;
x86) _pyarch=i686 ;;
armhf|armv7) _pyarch=armv8l ;;
s390x) _pyarch=s390x;;
diff --git a/community/onboard/APKBUILD b/community/onboard/APKBUILD
index f0e20e3ad2..a86a380416 100644
--- a/community/onboard/APKBUILD
+++ b/community/onboard/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=6
pkgdesc="On-screen keyboard useful on tablet PCs or for mobility impaired users"
url="https://launchpad.net/onboard"
license="GPL-3.0-only"
-arch="all !s390x !mips64 !riscv64" # blocked by librsvg
+arch="all !s390x !riscv64" # blocked by librsvg
depends="python3 hunspell iso-codes py3-cairo py3-dbus py3-gobject3 dbus-x11
ncurses gsettings-desktop-schemas librsvg"
makedepends="python3-dev py3-setuptools py3-distutils-extra
diff --git a/community/openbox/APKBUILD b/community/openbox/APKBUILD
index 68c03cbd2d..b1424f132e 100644
--- a/community/openbox/APKBUILD
+++ b/community/openbox/APKBUILD
@@ -5,8 +5,8 @@ pkgver=3.6.1
pkgrel=2
pkgdesc="A highly configurable and standards-compliant X11 window manager"
url="http://openbox.org"
-# s390x, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends_dev="libxcursor-dev libxrandr-dev libxinerama-dev startup-notification-dev"
makedepends="$depends_dev pango-dev libxml2-dev imlib2-dev librsvg-dev
diff --git a/community/openjdk10/APKBUILD b/community/openjdk10/APKBUILD
index b626596ab6..99e4f6ad96 100644
--- a/community/openjdk10/APKBUILD
+++ b/community/openjdk10/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Oracle OpenJDK 10"
provider_priority=10
url="https://hg.openjdk.java.net/jdk-updates/jdk10u"
# oracle dropped support for 32 bit
-# mips64 and riscv64 blocked by openjdk9
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+# riscv64 blocked by openjdk9
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk11/APKBUILD b/community/openjdk11/APKBUILD
index 2983492f94..40f6f22361 100644
--- a/community/openjdk11/APKBUILD
+++ b/community/openjdk11/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Oracle OpenJDK 11"
provider_priority=11
url="https://github.com/openjdk/jdk11u"
# oracle dropped support for 32 bit
-# mips64 and riscv64 blocked by openjdk10
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+# riscv64 blocked by openjdk10
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk12/APKBUILD b/community/openjdk12/APKBUILD
index 4e6f225940..0f1b0791fb 100644
--- a/community/openjdk12/APKBUILD
+++ b/community/openjdk12/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Oracle OpenJDK 12"
provider_priority=12
url="https://hg.openjdk.java.net/jdk-updates/jdk12u"
# x86, armhf and armv7 are not supported by Oracle due to being 32-bit
-# mips64 and riscv64 blocked by openjdk11
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+# riscv64 blocked by openjdk11
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk13/APKBUILD b/community/openjdk13/APKBUILD
index 7fd65145f9..51ae9ebf99 100644
--- a/community/openjdk13/APKBUILD
+++ b/community/openjdk13/APKBUILD
@@ -7,9 +7,9 @@ pkgrel=0
pkgdesc="Oracle OpenJDK 13"
provider_priority=13
url="https://github.com/openjdk/jdk13u"
-# mips64 and riscv64 blocked by openjdk12
+# riscv64 blocked by openjdk12
# x86, armhf and armv7 blocked by dropped 32-bit support upstream
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk14/APKBUILD b/community/openjdk14/APKBUILD
index dd7da37716..ab3b7a59af 100644
--- a/community/openjdk14/APKBUILD
+++ b/community/openjdk14/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Oracle OpenJDK 14"
provider_priority=14
url="https://hg.openjdk.java.net/jdk-updates/jdk14u"
# x86, armhf and armv7 are not supported by Oracle due to being 32-bit
-# mips64 and riscv64 blocked by openjdk13
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+# riscv64 blocked by openjdk13
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk15/APKBUILD b/community/openjdk15/APKBUILD
index 040db8ca28..d9366afb83 100644
--- a/community/openjdk15/APKBUILD
+++ b/community/openjdk15/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Oracle OpenJDK 15"
provider_priority=15
url="https://github.com/openjdk/jdk15u"
# x86, armhf and armv7 are not supported by Oracle due to being 32-bit
-# mips64 and riscv64 blocked by openjdk14
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+# riscv64 blocked by openjdk14
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk16/APKBUILD b/community/openjdk16/APKBUILD
index 013f2c6c51..2e8a39410c 100644
--- a/community/openjdk16/APKBUILD
+++ b/community/openjdk16/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Oracle OpenJDK 16"
provider_priority=16
url="https://github.com/openjdk/jdk16u"
# x86, armhf and armv7 are not supported by Oracle due to being 32-bit
-# mips64 and riscv64 blocked by openjdk15
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+# riscv64 blocked by openjdk15
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk17/APKBUILD b/community/openjdk17/APKBUILD
index c34cbb0c6a..6461abb21d 100644
--- a/community/openjdk17/APKBUILD
+++ b/community/openjdk17/APKBUILD
@@ -7,7 +7,7 @@ pkgrel=1
pkgdesc="Oracle OpenJDK 17"
provider_priority=17
url="https://github.com/openjdk/jdk17u"
-arch="all !x86 !armhf !armv7 !mips !mips64 !riscv64" # oracle dropped support for 32 bit
+arch="all !x86 !armhf !armv7 !riscv64" # oracle dropped support for 32 bit
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index add4dd98ca..969d95f785 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -11,9 +11,8 @@ pkgrel=0
pkgdesc="OpenJDK 7 via IcedTea"
provider_priority=7
url="https://icedtea.classpath.org/"
-# no bootstrap JDK on mips
# riscv64 blocked by java-gcj-compat
-arch="all !mips64 !riscv64"
+arch="all !riscv64"
license="GPL-2.0 with Classpath"
depends="$pkgname-jre java-cacerts"
options="sover-namecheck"
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index 15e7dc05e4..277d45b507 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -10,8 +10,8 @@ pkgrel=0
pkgdesc="OpenJDK 8 provided by IcedTea"
provider_priority=8
url="https://icedtea.classpath.org/"
-# mips64 and riscv64 blocked by openjdk7
-arch="all !mips64 !riscv64"
+# riscv64 blocked by openjdk7
+arch="all !riscv64"
license="custom"
depends="$pkgname-jre java-cacerts nss"
options="sover-namecheck"
diff --git a/community/openjdk9/APKBUILD b/community/openjdk9/APKBUILD
index e832afebd0..c0b2aecf4f 100644
--- a/community/openjdk9/APKBUILD
+++ b/community/openjdk9/APKBUILD
@@ -8,8 +8,8 @@ pkgdesc="Oracle OpenJDK 9"
provider_priority=9
url="https://hg.openjdk.java.net/jdk-updates/jdk9u"
# oracle dropped support for 32 bit
-# mips64 and riscv64 blocked by openjdk8
-arch="all !x86 !armhf !armv7 !mips64 !riscv64"
+# riscv64 blocked by openjdk8
+arch="all !x86 !armhf !armv7 !riscv64"
license="GPL-2.0-with-classpath-exception"
makedepends="autoconf
bash
diff --git a/community/openlibm/APKBUILD b/community/openlibm/APKBUILD
index fcea370399..9526aef24b 100644
--- a/community/openlibm/APKBUILD
+++ b/community/openlibm/APKBUILD
@@ -5,9 +5,8 @@ pkgver=0.8.1
pkgrel=0
pkgdesc="High quality system independent, portable, open source libm implementation"
url="https://openlibm.org/"
-# mips fails due to softfloat
# riscv64 is not supported upstream
-arch="all !s390x !mips64 !riscv64"
+arch="all !s390x !riscv64"
license="MIT AND BSD-2-Clause AND ISC AND LGPL-2.1-or-later"
subpackages="$pkgname-dev"
source="openlibm-$pkgver.tar.gz::https://github.com/JuliaLang/openlibm/archive/v$pkgver.tar.gz
diff --git a/community/openrc-settingsd/APKBUILD b/community/openrc-settingsd/APKBUILD
index b2661b18d5..4719c8cbd4 100644
--- a/community/openrc-settingsd/APKBUILD
+++ b/community/openrc-settingsd/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.1.0
pkgrel=0
pkgdesc="System settings D-Bus service for OpenRC"
url="https://gitlab.com/postmarketOS/openrc-settingsd"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
depends="tzdata"
makedepends="glib-dev dbus-dev openrc-dev polkit-dev libdaemon-dev automake autoconf
diff --git a/community/openrct2/APKBUILD b/community/openrct2/APKBUILD
index 982b094149..133cf3bed1 100644
--- a/community/openrct2/APKBUILD
+++ b/community/openrct2/APKBUILD
@@ -7,7 +7,7 @@ _pkgver_title_sequences=0.1.2c
_pkgver_replays=0.0.57
pkgrel=1
pkgdesc="Open-source re-implementation of Roller Coaster Tycoon 2"
-arch="all !s390x !mips !mips64" # Build fails on s390x
+arch="all !s390x" # Build fails on s390x
url="https://openrct2.io"
license="GPL-3.0-only"
depends="$pkgname-data"
diff --git a/community/openspecfun/APKBUILD b/community/openspecfun/APKBUILD
index 92825e6bc8..b08f8fe36a 100644
--- a/community/openspecfun/APKBUILD
+++ b/community/openspecfun/APKBUILD
@@ -5,8 +5,8 @@ pkgver=0.5.5
pkgrel=1
pkgdesc="A collection of special mathematical functions."
url="https://github.com/JuliaLang/openspecfun"
-# s390x, mips64 and riscv64 blocked by openlibm
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by openlibm
+arch="all !s390x !riscv64"
license="MIT Public-Domain"
makedepends="openlibm-dev gfortran"
options="!check" # no tests
diff --git a/community/osmscout-server/APKBUILD b/community/osmscout-server/APKBUILD
index 68cfccff76..5d4df5a3a4 100644
--- a/community/osmscout-server/APKBUILD
+++ b/community/osmscout-server/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=2
pkgdesc="Maps server providing tiles, geocoder, and router"
url="https://rinigus.github.io/osmscout-server"
# armhf blocked by kirigami2
-# s390x, mips64 and riscv64 blocked by luajit -> valhalla
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by luajit -> valhalla
+arch="all !armhf !s390x !riscv64"
license="GPL-3.0-or-later"
depends="
kirigami2
diff --git a/community/oxygen/APKBUILD b/community/oxygen/APKBUILD
index a9d2c2596f..57160d105e 100644
--- a/community/oxygen/APKBUILD
+++ b/community/oxygen/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Artwork, styles and assets for the Oxygen visual style for the Plasma Desktop"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kcmutils
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
makedepends="
diff --git a/community/par2cmdline/APKBUILD b/community/par2cmdline/APKBUILD
index 96994574db..827a8ba6ee 100644
--- a/community/par2cmdline/APKBUILD
+++ b/community/par2cmdline/APKBUILD
@@ -4,7 +4,7 @@ pkgver=0.8.1
pkgrel=0
pkgdesc="PAR 2.0 compatible file verification and repair tool"
url="https://github.com/Parchive/par2cmdline#par2cmdline"
-arch="all !s390x !mips64" # tests/unit_tests fails on big endian
+arch="all !s390x" # tests/unit_tests fails on big endian
license="GPL-2.0-or-later"
subpackages="$pkgname-doc"
source="https://github.com/Parchive/par2cmdline/releases/download/v$pkgver/par2cmdline-$pkgver.tar.bz2"
diff --git a/community/parley/APKBUILD b/community/parley/APKBUILD
index f2b656940b..aaa8453643 100644
--- a/community/parley/APKBUILD
+++ b/community/parley/APKBUILD
@@ -4,8 +4,8 @@ pkgname=parley
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x and riscv64 blocked by qt5-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64"
url="https://kde.org/applications/education/org.kde.parley"
pkgdesc="Vocabulary Trainer"
license="GPL-2.0-or-later AND GFDL-1.2-only"
diff --git a/community/partclone/APKBUILD b/community/partclone/APKBUILD
index 01ee3d9a00..2fda1f1141 100644
--- a/community/partclone/APKBUILD
+++ b/community/partclone/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.3.18
pkgrel=1
pkgdesc="utilities to save and restore used blocks on a partition"
url="https://partclone.org"
-arch="all !mips64" # missing hfsprogs on mips64
+arch="all"
license="GPL-2.0-only"
makedepends="e2fsprogs-dev btrfs-progs-dev ntfs-3g-dev f2fs-tools-dev hfsprogs
ncurses-dev automake autoconf libxslt-dev docbook-xml libtool
diff --git a/community/partitionmanager/APKBUILD b/community/partitionmanager/APKBUILD
index 93a699f4fb..24c0717bce 100644
--- a/community/partitionmanager/APKBUILD
+++ b/community/partitionmanager/APKBUILD
@@ -4,8 +4,8 @@ pkgname=partitionmanager
pkgver=21.12.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/applications/system/org.kde.partitionmanager"
pkgdesc="A KDE utility that allows you to manage disks, partitions, and file systems"
license="GPL-3.0-or-later"
diff --git a/community/pcmanfm/APKBUILD b/community/pcmanfm/APKBUILD
index 4d03c426cb..7112128e23 100644
--- a/community/pcmanfm/APKBUILD
+++ b/community/pcmanfm/APKBUILD
@@ -4,7 +4,7 @@ pkgname=pcmanfm
pkgver=1.3.2
pkgrel=0
pkgdesc="Extremely fast and lightweight file manager"
-arch="all !s390x !mips64"
+arch="all !s390x"
url="https://wiki.lxde.org/en/PCManFM"
license="GPL-2.0-or-later"
makedepends="gtk+3.0-dev libfm-dev libfm-extra-dev intltool"
diff --git a/community/pdal/APKBUILD b/community/pdal/APKBUILD
index 5dba90cc59..bc6197932a 100644
--- a/community/pdal/APKBUILD
+++ b/community/pdal/APKBUILD
@@ -35,7 +35,7 @@ builddir="$srcdir/PDAL-$pkgver-src"
_with_lazperf="OFF"
case "$CARCH" in
- arm*|mips*) ;;
+ arm*) ;;
s390x)
# 95% tests passed, 6 tests failed out of 110
options="!check"
diff --git a/community/pdns-recursor/APKBUILD b/community/pdns-recursor/APKBUILD
index db6f109982..3c66c6083a 100644
--- a/community/pdns-recursor/APKBUILD
+++ b/community/pdns-recursor/APKBUILD
@@ -5,7 +5,7 @@ pkgver=4.6.0
pkgrel=0
pkgdesc="PowerDNS Recursive Server"
url="https://www.powerdns.com/"
-arch="all !s390x !mips64" # broken context
+arch="all !s390x" # broken context
license="GPL-2.0-only WITH OpenSSL-Exception"
makedepends="autoconf automake libtool boost-dev openssl1.1-compat-dev libsodium-dev lua5.3-dev
net-snmp-dev curl curl-dev"
diff --git a/community/perl-crypt-random/APKBUILD b/community/perl-crypt-random/APKBUILD
index 2902359cb7..5c9c483fc5 100644
--- a/community/perl-crypt-random/APKBUILD
+++ b/community/perl-crypt-random/APKBUILD
@@ -8,7 +8,7 @@ pkgver=1.54
pkgrel=0
pkgdesc="Perl module for Crypt-Random"
url="https://metacpan.org/release/Crypt-Random/"
-arch="all !s390x !mips !mips64"
+arch="all !s390x"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl perl-math-pari perl-statistics-chisquare perl-class-loader"
subpackages="$pkgname-doc"
diff --git a/community/perl-math-pari/APKBUILD b/community/perl-math-pari/APKBUILD
index 80e815812e..7a48cde34b 100644
--- a/community/perl-math-pari/APKBUILD
+++ b/community/perl-math-pari/APKBUILD
@@ -7,7 +7,7 @@ pkgver=2.030518
pkgrel=2
pkgdesc="Perl interface to PARI."
url="https://metacpan.org/release/Math-Pari/"
-arch="all !s390x !mips !mips64" #Tests do not work on S390
+arch="all !s390x" #Tests do not work on S390
license="GPL-2.0-or-later OR Artistic-1.0-Perl"
makedepends="perl-dev"
subpackages="$pkgname-doc"
diff --git a/community/peruse/APKBUILD b/community/peruse/APKBUILD
index a7494ff5c5..b06e314e6a 100644
--- a/community/peruse/APKBUILD
+++ b/community/peruse/APKBUILD
@@ -5,10 +5,10 @@ pkgver=1.80
pkgrel=0
pkgdesc="A comic book viewer based on Frameworks 5, for use on multiple form factors"
# armhf blocked by extra-cmake-modules
-# s390x and mips64 blocked by kdeclarative
+# s390x blocked by kdeclarative
# riscv64 disabled due to missing rust in recursive dependency
# ppc64le blocked by okular
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://invent.kde.org/graphics/peruse"
license="LGPL-2.1-or-later AND LicenseRef-KDE-Accepted-LGPL"
depends="
diff --git a/community/pev/APKBUILD b/community/pev/APKBUILD
index daa94421d8..a0ef626712 100644
--- a/community/pev/APKBUILD
+++ b/community/pev/APKBUILD
@@ -13,9 +13,8 @@ subpackages="$pkgname-doc"
source="https://sourceforge.net/projects/pev/files/pev-$pkgver/pev-$pkgver.tar.gz"
case "$CARCH" in
- s390x | mips64)
- # s390x - Testing pepack /usr/lib/python3.8/distutils/command/wininst-10.0-amd64.exe... ERROR [-18]: not a PE file ((null))
- # mips64 - R [-18]: not a PE file ((null))
+ s390x)
+ # Testing pepack /usr/lib/python3.8/distutils/command/wininst-10.0-amd64.exe... ERROR [-18]: not a PE file ((null))
options="!check" ;;
esac
diff --git a/community/phosh/APKBUILD b/community/phosh/APKBUILD
index 97648b8011..6601c11911 100644
--- a/community/phosh/APKBUILD
+++ b/community/phosh/APKBUILD
@@ -8,10 +8,10 @@ pkgrel=1
_commit_gvc="ae1a34aafce7026b8c0f65a43c9192d756fe1057"
_commit_libcall_ui="1044c9c18d777b766523d0d7228f85a2160037b5"
pkgdesc="Shell PoC for the Librem5"
-# Blocked on mips and s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
+# Blocked on s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
# Blocked on ppc64le by gnome-session
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !s390x !ppc64le !mips !mips64 !riscv64"
+arch="all !s390x !ppc64le !riscv64"
url="https://gitlab.gnome.org/World/Phosh/phosh"
license="GPL-3.0-only"
depends="phoc gnome-session bash dbus-x11 gnome-settings-daemon
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 4e27bbf00c..16ce1ced77 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -424,7 +424,7 @@ check() {
# Ignore it for now and continue build even on test failures.
local allow_fail='no'
case "$CARCH" in
- x86 | s390x | mips*) allow_fail='yes'
+ x86 | s390x) allow_fail='yes'
esac
TESTS="${TESTS:- --show-diff}" NO_INTERACTION=1 REPORT_EXIT_STATUS=1 \
diff --git a/community/php8/APKBUILD b/community/php8/APKBUILD
index 040307157e..3c05457cba 100644
--- a/community/php8/APKBUILD
+++ b/community/php8/APKBUILD
@@ -355,7 +355,7 @@ check() {
# Ignore it for now and continue build even on test failures.
local allow_fail='no'
case "$CARCH" in
- x86 | s390x | mips*) allow_fail='yes'
+ x86 | s390x ) allow_fail='yes'
esac
TESTS="${TESTS:- --show-diff}" NO_INTERACTION=1 REPORT_EXIT_STATUS=1 \
diff --git a/community/pimcommon/APKBUILD b/community/pimcommon/APKBUILD
index 6ca552bbdb..f188bb876a 100644
--- a/community/pimcommon/APKBUILD
+++ b/community/pimcommon/APKBUILD
@@ -5,9 +5,9 @@ pkgver=21.12.1
pkgrel=0
pkgdesc="Common lib for KDEPim"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by qt5-qtwebengine -> akonadi
-arch="all !armhf !mips64 !s390x !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url='https://community.kde.org/KDE_PIM'
license="GPL-2.0-or-later"
depends_dev="
diff --git a/community/pix/APKBUILD b/community/pix/APKBUILD
index de7aed3153..b3f4045177 100644
--- a/community/pix/APKBUILD
+++ b/community/pix/APKBUILD
@@ -6,8 +6,8 @@ pkgrel=0
_geonames_pkgver=2020.06.25
pkgdesc="Image gallery manager built with MauiKit"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by mauikit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by mauikit
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/maui/pix"
license="GPL-3.0-or-later"
depends="
diff --git a/community/plasma-applet-weather-widget/APKBUILD b/community/plasma-applet-weather-widget/APKBUILD
index 3ef2a23e3b..232d67aa84 100644
--- a/community/plasma-applet-weather-widget/APKBUILD
+++ b/community/plasma-applet-weather-widget/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.6.10
pkgrel=4
pkgdesc="Plasmoid for showing weather information from yr.no and Open Weather Map servers"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-framework
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> plasma-framework
+arch="all !armhf !s390x !riscv64"
url="https://www.linux-apps.com/content/show.php/Weather+Widget?content=169572"
license="GPL-2.0-only"
depends="
diff --git a/community/plasma-browser-integration/APKBUILD b/community/plasma-browser-integration/APKBUILD
index c778141467..2217d79b30 100644
--- a/community/plasma-browser-integration/APKBUILD
+++ b/community/plasma-browser-integration/APKBUILD
@@ -5,9 +5,9 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Components necessary to integrate browsers into the Plasma Desktop"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
+# s390x and riscv64 blocked by polkit -> kio
# ppc64le blocked by kaccounts-integration
-arch="all !armhf !s390x !mips64 !riscv64 !ppc64le"
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://community.kde.org/Plasma/Browser_Integration"
license="GPL-3.0-or-later"
makedepends="
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index 9e8478ccb5..270023b86f 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -5,10 +5,10 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="KDE Plasma Desktop"
# armhf blocked by qt5-qtdeclarative
-# s390x and mips64 blocked by ibus
+# s390x blocked by ibus
# ppc64le blocked by kaccounts-integration
# riscv64 blocked by polkit -> kwin
-arch="all !armhf !s390x !mips64 !ppc64le !riscv64"
+arch="all !armhf !s390x !ppc64le !riscv64"
url='https://kde.org/plasma-desktop/'
license="GPL-2.0-only AND LGPL-2.1-only"
depends="
diff --git a/community/plasma-dialer/APKBUILD b/community/plasma-dialer/APKBUILD
index 71f704f3ff..de093e117f 100644
--- a/community/plasma-dialer/APKBUILD
+++ b/community/plasma-dialer/APKBUILD
@@ -5,9 +5,9 @@ pkgver=22.02
pkgrel=0
pkgdesc="A dialer for Plasma Mobile"
# armhf blocked by extra-cmake-modules
-# s390x and mips64 blocked by oxygen-sounds
+# s390x blocked by oxygen-sounds
# riscv64 disabled due to missing rust in recursive dependency
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/plasma-mobile/plasma-dialer"
license="GPL-2.0-or-later"
depends="
diff --git a/community/plasma-disks/APKBUILD b/community/plasma-disks/APKBUILD
index 1a3e26fbb3..cd7c307fa7 100644
--- a/community/plasma-disks/APKBUILD
+++ b/community/plasma-disks/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Monitors S.M.A.R.T. capable devices for imminent failure"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
depends="
diff --git a/community/plasma-firewall/APKBUILD b/community/plasma-firewall/APKBUILD
index f72f6c4c98..5b8b06171a 100644
--- a/community/plasma-firewall/APKBUILD
+++ b/community/plasma-firewall/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Control Panel for your system firewall"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kcmutils
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kcmutils
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
depends="
diff --git a/community/plasma-framework/APKBUILD b/community/plasma-framework/APKBUILD
index ad4d43f9f6..0f48d45343 100644
--- a/community/plasma-framework/APKBUILD
+++ b/community/plasma-framework/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.90.0
pkgrel=0
pkgdesc="Plasma library and runtime components based upon KF5 and Qt5"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later AND GPL-2.0-or-later"
depends_dev="
diff --git a/community/plasma-integration/APKBUILD b/community/plasma-integration/APKBUILD
index c48c50d092..365dedae60 100644
--- a/community/plasma-integration/APKBUILD
+++ b/community/plasma-integration/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.1-only AND ((LGPL-2.1-only WITH Nokia-Qt-exception-1.1) OR (GPL-3.0-only WITH Nokia-Qt-exception-1.1))"
depends="
diff --git a/community/plasma-nano/APKBUILD b/community/plasma-nano/APKBUILD
index f46949a88c..33bc05a3d6 100644
--- a/community/plasma-nano/APKBUILD
+++ b/community/plasma-nano/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="A minimal Plasma shell package intended for embedded devices"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-framework
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> plasma-framework
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/kde/plasma-nano"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="qt5-qtvirtualkeyboard"
diff --git a/community/plasma-nm/APKBUILD b/community/plasma-nm/APKBUILD
index 506021fafe..3c56813b6a 100644
--- a/community/plasma-nm/APKBUILD
+++ b/community/plasma-nm/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Plasma applet written in QML for managing network connections"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-framework
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> plasma-framework
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-or-later"
depends="
diff --git a/community/plasma-pa/APKBUILD b/community/plasma-pa/APKBUILD
index 0fd12ded22..67c0cff243 100644
--- a/community/plasma-pa/APKBUILD
+++ b/community/plasma-pa/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Plasma applet for audio volume management using PulseAudio"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-workspace
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> plasma-workspace
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
depends="pulseaudio kirigami2"
diff --git a/community/plasma-pass/APKBUILD b/community/plasma-pass/APKBUILD
index ec407faadc..6eb5572978 100644
--- a/community/plasma-pass/APKBUILD
+++ b/community/plasma-pass/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.2.0
pkgrel=0
pkgdesc="Plasma applet for the Pass password manager"
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> plasma-framework
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> plasma-framework
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LGPL-2.1-or-later"
makedepends="
diff --git a/community/plasma-sdk/APKBUILD b/community/plasma-sdk/APKBUILD
index 83679180d1..06ede41123 100644
--- a/community/plasma-sdk/APKBUILD
+++ b/community/plasma-sdk/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Applications useful for Plasma Development"
# armhf blocked by qt5-qtdeclarative
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
depends="
diff --git a/community/plasma-settings/APKBUILD b/community/plasma-settings/APKBUILD
index 1ff661f76d..a5eb98154f 100644
--- a/community/plasma-settings/APKBUILD
+++ b/community/plasma-settings/APKBUILD
@@ -5,8 +5,8 @@ pkgver=22.02
pkgrel=0
pkgdesc="Settings application for Plasma Mobile"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://community.kde.org/Plasma/Mobile"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
depends="
diff --git a/community/plasma-systemmonitor/APKBUILD b/community/plasma-systemmonitor/APKBUILD
index 163c2fddcc..3dafca2561 100644
--- a/community/plasma-systemmonitor/APKBUILD
+++ b/community/plasma-systemmonitor/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="An application for monitoring system resources"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="LicenseRef-KDE-Accepted-GPL AND LicenseRef-KDE-Accepted-LGPL AND CC0-1.0"
depends="kirigami2"
diff --git a/community/plasma-thunderbolt/APKBUILD b/community/plasma-thunderbolt/APKBUILD
index 6c662563f6..334e83426c 100644
--- a/community/plasma-thunderbolt/APKBUILD
+++ b/community/plasma-thunderbolt/APKBUILD
@@ -4,8 +4,8 @@ pkgname=plasma-thunderbolt
pkgver=5.24.0
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by bolt -> polkit
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by bolt -> polkit
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
pkgdesc="Plasma integration for controlling Thunderbolt devices"
license="GPL-2.0-only OR GPL-3.0-only"
diff --git a/community/plasma-vault/APKBUILD b/community/plasma-vault/APKBUILD
index 6d024656a3..b6ae53eb42 100644
--- a/community/plasma-vault/APKBUILD
+++ b/community/plasma-vault/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Plasma applet and services for creating encrypted vaults"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only AND LGPL-3.0-only)"
makedepends="
diff --git a/community/plasma-videoplayer/APKBUILD b/community/plasma-videoplayer/APKBUILD
index 1d9fe114dc..3208cd2127 100644
--- a/community/plasma-videoplayer/APKBUILD
+++ b/community/plasma-videoplayer/APKBUILD
@@ -6,8 +6,8 @@ _commit="5418bde23b89960ebdaa7f86e0830960a1efe1e4"
pkgdesc="Video Player for Plasma Mobile"
url="https://invent.kde.org/jbbgameich/videoplayer"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kdeclarative
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kdeclarative
+arch="all !armhf !s390x !riscv64"
license="LGPL-2.1-or-later"
depends="
kirigami2
diff --git a/community/plasma-workspace/APKBUILD b/community/plasma-workspace/APKBUILD
index 4ffb0b2e51..45827d01d4 100644
--- a/community/plasma-workspace/APKBUILD
+++ b/community/plasma-workspace/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="KDE Plasma Workspace"
# armhf blocked by kirigami2
-# s390x, mips64 and riscv64 blocked by polkit -> kio-extras
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio-extras
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later AND GPL-2.0-or-later AND MIT AND LGPL-2.1-only AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.0-only"
depends="
diff --git a/community/plasma/APKBUILD b/community/plasma/APKBUILD
index 2f41e5d013..8c4112960b 100644
--- a/community/plasma/APKBUILD
+++ b/community/plasma/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc="Plasma (Base) meta package"
url="https://kde.org/plasma-desktop"
# riscv64 disabled due to missing rust in recursive dependency
-arch="noarch !s390x !ppc64le !armhf !mips !mips64 !riscv64" # Limited by kdeplasma-addons -> qt5-qtwebengine armhf: qtdeclarative
+arch="noarch !s390x !ppc64le !armhf !riscv64" # Limited by kdeplasma-addons -> qt5-qtwebengine armhf: qtdeclarative
options="!check" # No tests for a metapkg
license="GPL-3.0-or-later"
depends="
diff --git a/community/pluma/APKBUILD b/community/pluma/APKBUILD
index 977520d314..bd3de52216 100644
--- a/community/pluma/APKBUILD
+++ b/community/pluma/APKBUILD
@@ -5,8 +5,8 @@ pkgver=1.26.0
pkgrel=0
pkgdesc="A small and lightweight UTF-8 text editor for the MATE"
url="https://github.com/mate-desktop/pluma"
-# s390x, mips64 and riscv64 blocked by librsvg -> mate-desktop
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by librsvg -> mate-desktop
+arch="all !s390x !riscv64"
license="GPL-2.0-or-later"
# check fails as tracked in https://github.com/mate-desktop/pluma/issues/33
options="!check"
diff --git a/community/plymouth-kcm/APKBUILD b/community/plymouth-kcm/APKBUILD
index 09ac9627f4..1db1b2eab8 100644
--- a/community/plymouth-kcm/APKBUILD
+++ b/community/plymouth-kcm/APKBUILD
@@ -4,8 +4,8 @@ pkgname=plymouth-kcm
pkgver=5.24.0
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://invent.kde.org/plasma/plymouth-kcm"
pkgdesc="KCM to manage the Plymouth (Boot) theme"
license="GPL-2.0-or-later"
diff --git a/community/poco/APKBUILD b/community/poco/APKBUILD
index bde7d420a3..746c20af6e 100644
--- a/community/poco/APKBUILD
+++ b/community/poco/APKBUILD
@@ -5,7 +5,7 @@ pkgver=1.11.1
pkgrel=0
pkgdesc="C++ class libraries for building network- and internet-based applications"
url="https://pocoproject.org/"
-arch="all !mips !mips64" # fails to build on soft-float
+arch="all" # fails to build on soft-float
license="BSL-1.0"
makedepends="cmake chrpath openssl1.1-compat-dev linux-headers zlib-dev pcre-dev expat-dev sqlite-dev mariadb-connector-c-dev unixodbc-dev libpq-dev"
source="https://pocoproject.org/releases/poco-$pkgver/poco-$pkgver-all.tar.gz
diff --git a/community/polari/APKBUILD b/community/polari/APKBUILD
index 17f2d1e544..e043319f1f 100644
--- a/community/polari/APKBUILD
+++ b/community/polari/APKBUILD
@@ -5,7 +5,7 @@ pkgver=40.1
pkgrel=0
pkgdesc="Polari is a simple IRC Client that is designed to integrate seamlessly with GNOME 3"
url="https://wiki.gnome.org/Apps/Polari"
-arch="all !s390x !mips !mips64 !riscv64" # limited by gjs
+arch="all !s390x !riscv64" # limited by gjs
license="GPL-2.0-or-later"
depends="telepathy-logger telepathy-idle telepathy-mission-control gspell"
makedepends="meson gobject-introspection-dev gtk+3.0-dev telepathy-glib-dev
diff --git a/community/polkit-gnome/APKBUILD b/community/polkit-gnome/APKBUILD
index d5140dcf7b..c3d89fa20e 100644
--- a/community/polkit-gnome/APKBUILD
+++ b/community/polkit-gnome/APKBUILD
@@ -4,8 +4,8 @@ pkgver=0.105
pkgrel=1
pkgdesc="PolicyKit integration for the GNOME desktop"
url="http://www.freedesktop.org/wiki/Software/PolicyKit"
-# mips64, s390x and riscv64 blocked by polkit
-arch="all !mips64 !s390x !riscv64"
+# s390x and riscv64 blocked by polkit
+arch="all !s390x !riscv64"
license="LGPL-2.0-or-later"
makedepends="$depends_dev gtk+3.0-dev polkit-dev intltool"
subpackages="$pkgname-lang"
diff --git a/community/polkit-kde-agent-1/APKBUILD b/community/polkit-kde-agent-1/APKBUILD
index e887ccafee..088269bc8a 100644
--- a/community/polkit-kde-agent-1/APKBUILD
+++ b/community/polkit-kde-agent-1/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Daemon providing a polkit authentication UI for KDE"
# armhf blocked by extra-cmake-modules
-# mips64, s390x, and riscv64 blocked by polkit -> polkit-qt-1
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x, and riscv64 blocked by polkit -> polkit-qt-1
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later"
depends="polkit-elogind"
diff --git a/community/polkit-qt-1/APKBUILD b/community/polkit-qt-1/APKBUILD
index dbaa65f91d..2f73d6c89f 100644
--- a/community/polkit-qt-1/APKBUILD
+++ b/community/polkit-qt-1/APKBUILD
@@ -4,8 +4,8 @@ pkgname=polkit-qt-1
pkgver=0.114.0
pkgrel=0
pkgdesc="Qt wrapper around polkit-1 client libraries"
-# s390x, mips64 and riscv64 blocked by polkit-elogind
-arch="all !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit-elogind
+arch="all !s390x !riscv64"
url="https://www.kde.org"
license="LGPL-2.1-only"
depends_dev="polkit-elogind-dev"
diff --git a/community/polkit/APKBUILD b/community/polkit/APKBUILD
index 22f0e1511b..b7e3b80b4c 100644
--- a/community/polkit/APKBUILD
+++ b/community/polkit/APKBUILD
@@ -7,7 +7,7 @@ pkgver=0.120
pkgrel=2
pkgdesc="Application development toolkit for controlling system-wide privileges"
url="https://www.freedesktop.org/wiki/Software/polkit/"
-arch="all !mips !mips64 !s390x !riscv64" # Rust
+arch="all !s390x !riscv64" # Rust
license="GPL-2.0-or-later"
options="suid !check" # Needs a functioning dbus daemon
depends="$pkgname-common=$pkgver-r$pkgrel $pkgname-libs=$pkgver-r$pkgrel"
diff --git a/community/portfolio/APKBUILD b/community/portfolio/APKBUILD
index eae3c5b251..d3730f156a 100644
--- a/community/portfolio/APKBUILD
+++ b/community/portfolio/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=2
pkgdesc="Minimalist file manager for those who want to use Linux mobile devices"
url="https://github.com/tchx84/Portfolio"
# riscv64 disabled due to missing rust in recursive dependency
-arch="noarch !s390x !mips64 !riscv64" # no libhandy1 on s390x and mips64
+arch="noarch !s390x !riscv64" # no libhandy1 on s390x
license="GPL-3.0-or-later"
depends="
gtk+3.0
diff --git a/community/poweralertd/APKBUILD b/community/poweralertd/APKBUILD
index 73e047809d..58e6a40805 100644
--- a/community/poweralertd/APKBUILD
+++ b/community/poweralertd/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=2
pkgdesc="UPower-powered power alerter"
url="https://git.sr.ht/~kennylevinsen/poweralertd"
license="GPL-3.0"
-arch="all !mips64 !s390x !riscv64" # limited by upower
+arch="all !s390x !riscv64" # limited by upower
depends="upower"
makedepends="basu-dev meson scdoc"
subpackages="$pkgname-doc"
diff --git a/community/powerdevil/APKBUILD b/community/powerdevil/APKBUILD
index 0d761ee777..e3b79c9c5d 100644
--- a/community/powerdevil/APKBUILD
+++ b/community/powerdevil/APKBUILD
@@ -5,8 +5,8 @@ pkgver=5.24.0
pkgrel=0
pkgdesc="Manages the power consumption settings of a Plasma Shell"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
depends="upower"
diff --git a/community/prime_server/APKBUILD b/community/prime_server/APKBUILD
index fc30275e9e..1781792dc9 100644
--- a/community/prime_server/APKBUILD
+++ b/community/prime_server/APKBUILD
@@ -43,10 +43,7 @@ build() {
check() {
cd build
- case "$CARCH" in
- mips64) _skip_tests="interrupt"
- esac
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "$_skip_tests"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
diff --git a/community/print-manager/APKBUILD b/community/print-manager/APKBUILD
index 4edb82a874..34e5f9bef0 100644
--- a/community/print-manager/APKBUILD
+++ b/community/print-manager/APKBUILD
@@ -4,8 +4,8 @@ pkgname=print-manager
pkgver=21.12.1
pkgrel=0
# armhf blocked by qt5-qtdeclarative
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# s390x and riscv64 blocked by polkit -> kio
+arch="all !armhf !s390x !riscv64"
url="https://www.kde.org/applications/utilities/"
pkgdesc="A tool for managing print jobs and printers"
license="GPL-2.0-or-later"
diff --git a/community/psautohint/APKBUILD b/community/psautohint/APKBUILD
index a5b256f9aa..c4c95c13e3 100644
--- a/community/psautohint/APKBUILD
+++ b/community/psautohint/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.3.1
pkgrel=1
pkgdesc="standalone version of AFDKO's autohinter"
url="https://github.com/adobe-type-tools/psautohint"
-arch="all !s390x !mips !mips64" # ufo2ft
+arch="all !s390x" # ufo2ft
license="Apache-2.0"
depends="python3 py3-fonttools py3-lxml py3-statmake py3-ufo2ft py3-setuptools"
makedepends="py3-setuptools_scm python3-dev"
diff --git a/community/pulseaudio/APKBUILD b/community/pulseaudio/APKBUILD
index a352911a50..505eff87a5 100644
--- a/community/pulseaudio/APKBUILD
+++ b/community/pulseaudio/APKBUILD
@@ -74,7 +74,7 @@ case "$CARCH" in
aarch64|armv7|armhf|x86|ppc64le)
options="$options !check" # once-test fails, all others pass
;;
- s390x|mips*)