aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/flatpak/APKBUILD8
-rw-r--r--testing/flatpak/musl-fixes.patch43
2 files changed, 4 insertions, 47 deletions
diff --git a/testing/flatpak/APKBUILD b/testing/flatpak/APKBUILD
index 236aeb1af08..a1e6544fc70 100644
--- a/testing/flatpak/APKBUILD
+++ b/testing/flatpak/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=flatpak
-pkgver=0.8.4
-pkgrel=1
+pkgver=0.9.1
+pkgrel=0
pkgdesc="Application deployment framework for desktop apps"
url="http://flatpak.org"
arch="all !aarch64"
@@ -45,5 +45,5 @@ package() {
install -D -m644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="6981c8edcd387ecab5d2c2f6008a6463a3be51186c6c36d9f0fc437795334c51d96af99f54e776261c2220a6473295a98b44e0507a7077ea7381924fcb4561a4 flatpak-0.8.4.tar.xz
-7c37149149c902dcb64eae616e7a5dde188aa2ea3d614c5c79ba5d3c61de1dc5d8ff9112ce7618b9405816b5e5795b4007d6cb095076ef59bf0df536db846e9f musl-fixes.patch"
+sha512sums="8048fccb69fc269eed677b8f17c4724d1a77e419fe320aa412eefa550e50d0a6025a41bf3df20ae422b038bbba9b05dfc2a547ccc6bada14874f73a97b2c0348 flatpak-0.9.1.tar.xz
+9287ed146bf71665aa436a2c2110cc5edc829a7b4a3e3190947580850fe9ecfd2bb6adb015c692af022d425fb5259390fcdcbd402e8b0d12ee5d2c1a1071ed4f musl-fixes.patch"
diff --git a/testing/flatpak/musl-fixes.patch b/testing/flatpak/musl-fixes.patch
index 0a84cf374ec..406a06d8340 100644
--- a/testing/flatpak/musl-fixes.patch
+++ b/testing/flatpak/musl-fixes.patch
@@ -1,13 +1,3 @@
---- a/common/flatpak-utils.c
-+++ b/common/flatpak-utils.c
-@@ -36,6 +36,7 @@
- #include <fcntl.h>
- #include <string.h>
- #include <sys/stat.h>
-+#include <sys/file.h>
- #include <sys/types.h>
- #include <sys/utsname.h>
-
--- a/config.h.in
+++ b/config.h.in
@@ -140,3 +140,14 @@
@@ -25,36 +15,3 @@
+ __result; }))
+#endif
+
---- a/builder/builder-module.c
-+++ b/builder/builder-module.c
-@@ -771,7 +771,7 @@
- g_ptr_array_add (args, g_strdup ("flatpak"));
- g_ptr_array_add (args, g_strdup ("build"));
-
-- source_dir_path_canonical = canonicalize_file_name (source_dir_path);
-+ source_dir_path_canonical = realpath (source_dir_path, NULL);
-
- if (builder_context_get_build_runtime (context))
- builddir = "/run/build-runtime/";
---- a/builder/builder-source-shell.c
-+++ b/builder/builder-source-shell.c
-@@ -130,7 +130,7 @@
- g_ptr_array_add (args, g_strdup ("flatpak"));
- g_ptr_array_add (args, g_strdup ("build"));
-
-- source_dir_path_canonical = canonicalize_file_name (source_dir_path);
-+ source_dir_path_canonical = realpath (source_dir_path, NULL);
-
- g_ptr_array_add (args, g_strdup ("--nofilesystem=host"));
- g_ptr_array_add (args, g_strdup_printf ("--filesystem=%s", source_dir_path_canonical));
---- a/common/flatpak-dir.c
-+++ b/common/flatpak-dir.c
-@@ -2862,7 +2862,7 @@
- somewhere the bind mount will be on the target of that, not
- at that exact path. */
- g_autofree char *basedir_orig = g_file_get_path (self->basedir);
-- g_autofree char *basedir = canonicalize_file_name (basedir_orig);
-+ g_autofree char *basedir = realpath (basedir_orig, NULL);
-
- g_debug ("running trigger %s", name);
-