aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-pyroute2/001-ipset-content.patch11
-rw-r--r--community/py3-pyroute2/APKBUILD11
2 files changed, 19 insertions, 3 deletions
diff --git a/community/py3-pyroute2/001-ipset-content.patch b/community/py3-pyroute2/001-ipset-content.patch
new file mode 100644
index 00000000000..b74ad3f988c
--- /dev/null
+++ b/community/py3-pyroute2/001-ipset-content.patch
@@ -0,0 +1,11 @@
+--- a/pyroute2/wiset.py.orig 2021-05-12 23:14:00.000000000 +0200
++++ b/pyroute2/wiset.py 2021-08-13 19:12:57.590768736 +0200
+@@ -251,6 +251,8 @@
+ proto = IP_PROTOCOLS.get(proto, str(proto)).lower()
+ key += '{proto}:'.format(proto=proto)
+ key += str(entry.get_attr("IPSET_ATTR_PORT_FROM"))
++ elif parse_type == "mac":
++ key += entry.get_attr("IPSET_ATTR_ETHER")
+ key += ","
+
+ key = key.strip(",")
diff --git a/community/py3-pyroute2/APKBUILD b/community/py3-pyroute2/APKBUILD
index 5064ffc1dce..0a55da2f746 100644
--- a/community/py3-pyroute2/APKBUILD
+++ b/community/py3-pyroute2/APKBUILD
@@ -2,13 +2,15 @@
pkgname=py3-pyroute2
_pkgname=pyroute2
pkgver=0.5.19
-pkgrel=0
+pkgrel=1
pkgdesc="Python Netlink library"
url="https://github.com/svinota/pyroute2"
arch="noarch"
license="GPL-2.0-or-later OR Apache-2.0"
makedepends="py3-setuptools py3-pytest"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ 001-ipset-content.patch
+ "
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -26,4 +28,7 @@ package() {
rm -rf "${pkgdir:?}/usr/bin"
}
-sha512sums="bd60e2adf59b8438ff4f6abf2d41cf18eb60dcef3072577648488db45ffe89bd9c7207c4eccc38eb9256533ea2950e7f20b82ae4940b1207ba71d0f261e83f6d pyroute2-0.5.19.tar.gz"
+sha512sums="
+bd60e2adf59b8438ff4f6abf2d41cf18eb60dcef3072577648488db45ffe89bd9c7207c4eccc38eb9256533ea2950e7f20b82ae4940b1207ba71d0f261e83f6d pyroute2-0.5.19.tar.gz
+1e38436bf3e2670dd8fd47128d739b4c83d4fc087ba3fb75fac0205754a1c7ae8a5c2996cecfccf80111581ea6656ffefa02e053835dd2e33737748532365be8 001-ipset-content.patch
+"