aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/breezy/APKBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/community/breezy/APKBUILD b/community/breezy/APKBUILD
index f3ea81fe10c..2648775a6df 100644
--- a/community/breezy/APKBUILD
+++ b/community/breezy/APKBUILD
@@ -1,22 +1,33 @@
# Maintainer: Pedro Filipe <xpecex@outlook.com>
pkgname=breezy
pkgver=3.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Decentralized revision control system"
url="https://www.breezy-vcs.org/"
arch="all"
license="GPL-2.0-or-later"
-depends="py3-configobj py3-six"
-makedepends="python3-dev py3-dulwich py3-fastimport py3-gpgme py3-paramiko
- py3-setuptools gettext"
+depends="py3-configobj py3-six py3-dulwich py3-patiencediff"
+makedepends="python3-dev py3-fastimport py3-gpgme py3-inotify py3-paramiko
+ py3-setuptools cython gettext"
+checkdepends="py3-subunit py3-testtools"
+options="!check" # Requires unittest2
subpackages="$pkgname-doc"
-options="!check" # Suit test not work
source="https://launchpad.net/brz/${pkgver%.*}/$pkgver/+download/breezy-$pkgver.tar.gz"
+prepare() {
+ default_prepare
+ # Requires launchpadlib
+ rm -rf breezy/plugins/launchpad/
+}
+
build() {
python3 setup.py build
}
+check() {
+ python3 setup.py test
+}
+
package() {
python3 setup.py install --root="$pkgdir"
ln -s brz "$pkgdir"/usr/bin/bzr # backwards compatibility