aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/erlang/APKBUILD24
-rw-r--r--community/erlang/libressl-2.7.patch15
2 files changed, 4 insertions, 35 deletions
diff --git a/community/erlang/APKBUILD b/community/erlang/APKBUILD
index 212a3633077..5370ca2c7ad 100644
--- a/community/erlang/APKBUILD
+++ b/community/erlang/APKBUILD
@@ -3,9 +3,9 @@
# Contributor: Marlus Saraiva <marlus.saraiva@gmail.com>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=erlang
-pkgver=20.3.4
+pkgver=21.1
_srcver=$pkgver
-pkgrel=2
+pkgrel=0
pkgdesc="General-purpose programming language and runtime environment"
url="http://www.erlang.org/"
license="Apache-2.0"
@@ -17,13 +17,6 @@ subpackages="$pkgname-dev
$pkgname-asn1:asn
$pkgname-common-test:common_test
$pkgname-compiler:compiler
- $pkgname-cosevent:cos_event
- $pkgname-coseventdomain:cos_event_domain
- $pkgname-cosfiletransfer:cos_file_transfer
- $pkgname-cosnotification:cos_notification
- $pkgname-cosproperty:cos_property
- $pkgname-costime:cos_time
- $pkgname-costransaction:cos_transactions
$pkgname-crypto:crypto
$pkgname-debugger:debugger
$pkgname-dialyzer:dialyzer
@@ -64,7 +57,6 @@ options="!check"
source="https://github.com/erlang/otp/archive/OTP-$_srcver.tar.gz
0005-Do-not-install-nteventlog-and-related-doc-files-on-n.patch
0010-fix-nteventlog-remove.patch
- libressl-2.7.patch
"
builddir="$srcdir/otp-OTP-$_srcver"
@@ -114,13 +106,6 @@ _mv_erlang_lib() {
asn() { _mv_erlang_lib asn1; depends="$depends erlang-crypto"; }
common_test() { _mv_erlang_lib common_test; depends="$depends erlang-xmerl"; }
compiler() { _mv_erlang_lib compiler; depends="$depends erlang-syntax-tools erlang-parsetools erlang-erl-interface"; }
-cos_event() { _mv_erlang_lib cosEvent; }
-cos_event_domain() { _mv_erlang_lib cosEventDomain; }
-cos_file_transfer() { _mv_erlang_lib cosFileTransfer; }
-cos_notification() { _mv_erlang_lib cosNotification; }
-cos_property() { _mv_erlang_lib cosProperty; }
-cos_time() { _mv_erlang_lib cosTime; }
-cos_transactions() { _mv_erlang_lib cosTransactions; }
crypto() { _mv_erlang_lib crypto; }
debugger() { _mv_erlang_lib debugger; }
dialyzer() { _mv_erlang_lib dialyzer; }
@@ -194,7 +179,6 @@ dev() {
}
-sha512sums="fafc3d7b3e88a242b1237f769a0163fdf1409d77ea6a875377f3e1ec8df99fde8c2017094107358020ec1cebe918cd5616e14ac26ced36c76438102e8e585605 OTP-20.3.4.tar.gz
+sha512sums="9e118e902c33b8dd71266efb4cc4aeb0db0d8be8adb64ac85595a6507dc847b84e5444a9b5c5cbf46b560c885db9f4cd934c74de4aa2e1574785295ea0865348 OTP-21.1.tar.gz
5d377faccd73382bc86c5aa3182767bc5d1639220c78c2f624135f597f3c823a6871ff13f6f8a109baa8a9ae5d215233b40193e5cfe07af275aa53f327e956de 0005-Do-not-install-nteventlog-and-related-doc-files-on-n.patch
-bb4346dabe17115bc310837c5f0aeb367a745d8ba2159495084e599d0419fc57648d144c811306914ac48d0e087d6150a356f38640ba070642b4578acc5fe573 0010-fix-nteventlog-remove.patch
-1e624ba30c8b501bfe652143ccefab5bc4dec54a61b49fd496482f57202b95cdbaae76182e67f04ae3fd025b3e59aa2b34d5de503850203ea100a65af5dff605 libressl-2.7.patch"
+bb4346dabe17115bc310837c5f0aeb367a745d8ba2159495084e599d0419fc57648d144c811306914ac48d0e087d6150a356f38640ba070642b4578acc5fe573 0010-fix-nteventlog-remove.patch"
diff --git a/community/erlang/libressl-2.7.patch b/community/erlang/libressl-2.7.patch
deleted file mode 100644
index 5deaaa6a4b0..00000000000
--- a/community/erlang/libressl-2.7.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/lib/crypto/c_src/crypto.c b/lib/crypto/c_src/crypto.c
-index 9a3ea07..d972f79 100644
---- a/lib/crypto/c_src/crypto.c
-+++ b/lib/crypto/c_src/crypto.c
-@@ -103,7 +103,9 @@
- # endif
-
- /* LibreSSL wants the 1.0.1 API */
--# define NEED_EVP_COMPATIBILITY_FUNCTIONS
-+# if LIBRESSL_VERSION_NUMBER < 0x2070000fL
-+# define NEED_EVP_COMPATIBILITY_FUNCTIONS
-+# endif
- #endif
-
-