aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/php7/APKBUILD17
-rw-r--r--community/php7/disabled-tests.list78
-rw-r--r--community/php7/musl-time64.patch27
3 files changed, 49 insertions, 73 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 818289f1a4e..05927e0ef1a 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -25,8 +25,8 @@
pkgname=php7
_pkgreal=php
-pkgver=7.4.10
-pkgrel=2
+pkgver=7.4.11
+pkgrel=0
_apiver=20190902
_suffix=${pkgname#php}
# Is this package the default (latest) PHP version?
@@ -100,7 +100,6 @@ source="https://php.net/distributions/$_pkgreal-$pkgver.tar.xz
php7-fpm-version-suffix.patch
fix-tests-devserver.patch
enchant-2.patch
- musl-time64.patch
"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -175,6 +174,9 @@ done
subpackages="$subpackages $pkgname-common::noarch"
# secfixes:
+# 7.4.11-r0:
+# - CVE-2020-7069
+# - CVE-2020-7070
# 7.3.18-r0:
# - CVE-2019-11048
# 7.3.17-r0:
@@ -411,7 +413,7 @@ check() {
x86 | s390x | mips*) allow_fail='yes'
esac
- NO_INTERACTION=1 REPORT_EXIT_STATUS=1 \
+ TESTS="${TESTS:- --show-diff}" NO_INTERACTION=1 REPORT_EXIT_STATUS=1 \
SKIP_SLOW_TESTS=1 SKIP_ONLINE_TESTS=1 TEST_TIMEOUT=10 \
TZ='' LANG='' LC_ALL='' \
TRAVIS=true SKIP_IO_CAPTURE_TESTS=1 \
@@ -671,15 +673,14 @@ _mv() {
mv "$@"
}
-sha512sums="c7beb2d821f4e28b0444c8653c360d210a924e0638cc4b4ebc71bf2c22ef83caedfc880275329c3ffa644adc5858ccff59d35bf36255d57218774089d3376a21 php-7.4.10.tar.xz
+sha512sums="9bdd29a4a6c1ac55ed75d8fb2203ae5ef41992c518cb7e3b84cf74db62b03cfbe0ef4ea5614a684a37fcd2ae727376022ce49ed3ff32fc3a728e2f1e2474fb92 php-7.4.11.tar.xz
1c708de82d1086f272f484faf6cf6d087af7c31750cc2550b0b94ed723961b363f28a947b015b2dfc0765caea185a75f5d2c2f2b099c948b65c290924f606e4f php7-fpm.initd
cacce7bf789467ff40647b7319e3760c6c587218720538516e8d400baa75651f72165c4e28056cd0c1dc89efecb4d00d0d7823bed80b29136262c825ce816691 php7-fpm.logrotate
274bd7b0b2b7002fa84c779640af37b59258bb37b05cb7dd5c89452977d71807f628d91b523b5039608376d1f760f3425d165242ca75ee5129b2730e71c4e198 php7-module.conf
-9cac4cecf93a27b37487c726eb606a22469259fc7982f38ada9c1e0604e0ad2e3c483f02a20965348f384a161a8f70265237aea5515a9a17990d6390805ef46c disabled-tests.list
+4ca6ee559f2df8c49339365d2b4cee09e47d6c47a42e2bfc6b3517a1272ce912d33b743025441724700a9442af797acdc3367fecd386aedf406bd7cc1f80a7a8 disabled-tests.list
a4130d29c7fee2b8cb561b116baf603bdc3a7b5b4985ec3c9918f253d1851197539dfad72c6b36d9f7008f85982904731184c79e4cee4415c1a1b88016639225 install-pear.patch
ebf571c5e595221b9944d7e840807ebb68c1be38bf117186e19a3bd1070310ece5918bcaa5f941679f3371a2108ad57bf179c3f90e612a5a2b982db941172859 includedir.patch
965b52893affb666af64e00d09e0208dcd41b17ce2864cf05616c6d05a05c0121694c0b209d403b8c0c55d18e6f1528c4aba1a4fcdce7b282a13304d12cd0f9d sharedir.patch
16399fbf6a966f9beffe00f659f9551ef8e52285bca116da5bd5b15ec99a2b0bd5fa03be0faa6c893802aa44c100d634083343a9ac0cd2467812865df66dd572 php7-fpm-version-suffix.patch
3bfeea79f9acfaa7be5bab85cd3d02713abb569e54024a22bb2c747c06d97f83ac2c63dcd75c7c409426ac03f8bc2ccc01bcd66bc39a767930d32542349123f9 fix-tests-devserver.patch
-7c8c3cac9efce81d525cb5a70e1402e393881b83ef4c7b5d39d3565803d21cd283daf3d74e9a8b059ecac66cf339756acc63608ffcb83d960dba86583bd45108 enchant-2.patch
-1bdb4e692bd554dc3afd89ad8fd2532787a0ab099796fb938a5307bf9a12193f7758e574ccf585709c37c7d34f7b21137d794a32f843fbd94ace36437a83c77e musl-time64.patch"
+7c8c3cac9efce81d525cb5a70e1402e393881b83ef4c7b5d39d3565803d21cd283daf3d74e9a8b059ecac66cf339756acc63608ffcb83d960dba86583bd45108 enchant-2.patch"
diff --git a/community/php7/disabled-tests.list b/community/php7/disabled-tests.list
index 600672e3d4f..88b0daec511 100644
--- a/community/php7/disabled-tests.list
+++ b/community/php7/disabled-tests.list
@@ -27,7 +27,44 @@ ext/pgsql/tests/*
# Too many tests fail! Some of them bogus, some not.
# THIS SHOULD BE REALLY FIXED!
-ext/openssl/tests/*
+ext/openssl/tests/bug46127.phpt
+ext/openssl/tests/bug48182.phpt
+ext/openssl/tests/bug54992.phpt
+ext/openssl/tests/bug65538_001.phpt
+ext/openssl/tests/bug65538_003.phpt
+ext/openssl/tests/bug65729.phpt
+ext/openssl/tests/bug68265.phpt
+ext/openssl/tests/bug68879.phpt
+ext/openssl/tests/bug68920.phpt
+ext/openssl/tests/bug69215.phpt
+ext/openssl/tests/bug72333.phpt
+ext/openssl/tests/bug74159.phpt
+ext/openssl/tests/bug76705.phpt
+ext/openssl/tests/bug77390.phpt
+ext/openssl/tests/capture_peer_cert_001.phpt
+ext/openssl/tests/openssl_peer_fingerprint_basic.phpt
+ext/openssl/tests/peer_verification.phpt
+ext/openssl/tests/san_peer_matching.phpt
+ext/openssl/tests/session_meta_capture.phpt
+ext/openssl/tests/session_meta_capture_tlsv13.phpt
+ext/openssl/tests/sni_server.phpt
+ext/openssl/tests/sni_server_key_cert.phpt
+ext/openssl/tests/stream_crypto_flags_001.phpt
+ext/openssl/tests/stream_crypto_flags_002.phpt
+ext/openssl/tests/stream_crypto_flags_003.phpt
+ext/openssl/tests/stream_crypto_flags_004.phpt
+ext/openssl/tests/stream_security_level.phpt
+ext/openssl/tests/stream_verify_peer_name_001.phpt
+ext/openssl/tests/stream_verify_peer_name_002.phpt
+ext/openssl/tests/stream_verify_peer_name_003.phpt
+ext/openssl/tests/streams_crypto_method.phpt
+ext/openssl/tests/tls_min_v1.0_max_v1.1_wrapper.phpt
+ext/openssl/tests/tls_wrapper.phpt
+ext/openssl/tests/tls_wrapper_with_tls_v1.3.phpt
+ext/openssl/tests/tlsv1.0_wrapper.phpt
+ext/openssl/tests/tlsv1.1_wrapper.phpt
+ext/openssl/tests/tlsv1.2_wrapper.phpt
+ext/openssl/tests/tlsv1.3_wrapper.phpt
# Broken tests, missing config.
sapi/fpm/tests/socket-ipv4-fallback.phpt
@@ -67,7 +104,7 @@ ext/iconv/tests/bug48147.phpt
# stream_filter_append(): unable to create or locate filter "convert.iconv.ucs-2/utf-8//IGNORE"
ext/iconv/tests/bug76249.phpt
-# Incorrect results.
+# for ICU <= 57.1
ext/intl/tests/spoofchecker_001.phpt
ext/intl/tests/timezone_IDforWindowsID_basic.phpt
ext/intl/tests/timezone_windowsID_basic.phpt
@@ -90,12 +127,6 @@ ext/soap/tests/bug73037.phpt
# Incorrect results.
ext/soap/tests/server009.phpt
-# Fails on ppc64le.
-ext/sockets/tests/mcast_ipv6_send.phpt
-
-# Depends on something from ext/openssl/tests
-ext/standard/tests/streams/stream_context_tcp_nodelay_server.phpt
-
# Incorrect results.
ext/standard/tests/crypt/bcrypt_invalid_algorithm.phpt
ext/standard/tests/crypt/bcrypt_invalid_cost.phpt
@@ -103,13 +134,10 @@ ext/standard/tests/crypt/des_fallback_invalid_salt.phpt
ext/standard/tests/strings/crypt_blowfish.phpt
ext/standard/tests/strings/crypt_blowfish_variation1.phpt
ext/standard/tests/strings/crypt_blowfish_variation2.phpt
-ext/standard/tests/strings/crypt_des_error.phpt
# Incorrect results.
ext/standard/tests/strings/bug51059.phpt
-
-# Fails in chroot (on Travis).
-ext/standard/tests/general_functions/proc_nice_basic.phpt
+ext/standard/tests/strings/bug79986.phpt
# Failing tests related to locale and/or iconv.
ext/date/tests/009.phpt
@@ -144,9 +172,6 @@ ext/fileinfo/tests/bug74170.phpt
# no xml header displayed
ext/tidy/tests/020.phpt
-# randomly fails because of output
-ext/zip/tests/bug53885.phpt
-
#
# Tests that fail for known reason and/or we don't need to worry about them
#
@@ -157,15 +182,9 @@ ext/iconv/tests/iconv_mime_encode.phpt
ext/standard/tests/strings/htmlentities04.phpt
ext/standard/tests/strings/htmlentities15.phpt
-# Segfaults, it tests JIT stacklimit exhaustion.
-ext/pcre/tests/preg_match_error3.phpt
-
# Requires running SNMP server.
ext/snmp/tests/*
-# Operation not permitted.
-ext/sockets/tests/socket_set_option_bindtodevice.phpt
-
# Different wording of socket error messages (due to different libc).
ext/sockets/tests/socket_strerror.phpt
@@ -175,22 +194,5 @@ ext/standard/tests/file/006_error.phpt
# Fails probably due to differencies in musl.
ext/standard/tests/file/popen_pclose_error.phpt
-# WTF?! getservername(true, "tcp") and similar non-senses...
-ext/standard/tests/general_functions/getservbyport_variation1.phpt
-ext/standard/tests/general_functions/getservbyname_variation2.phpt
-ext/standard/tests/general_functions/getservbyname_variation5.phpt
-
-# Needs GNU cut utility.
-ext/standard/tests/mail/mail_basic2.phpt
-ext/standard/tests/mail/mail_variation2.phpt
-
# Fails probably due to differencies in musl.
ext/sockets/tests/socket_create_pair-wrongparams.phpt
-
-# returns extra key - ai_canonname
-ext/sockets/tests/socket_addrinfo_explain.phpt
-# does not pass
-ext/sockets/tests/socket_sendrecvmsg_multi_msg.phpt
-
-# Error message does not match due to some extra info.
-ext/standard/tests/strings/007.phpt
diff --git a/community/php7/musl-time64.patch b/community/php7/musl-time64.patch
deleted file mode 100644
index bba7323bbe4..00000000000
--- a/community/php7/musl-time64.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/ext/calendar/cal_unix.c b/ext/calendar/cal_unix.c
-index e24ac56..e1b203a 100644
---- a/ext/calendar/cal_unix.c
-+++ b/ext/calendar/cal_unix.c
-@@ -28,16 +28,19 @@
- PHP_FUNCTION(unixtojd)
- {
- time_t ts = 0;
-+ zend_long tl = 0;
- struct tm *ta, tmbuf;
-
-- if (zend_parse_parameters(ZEND_NUM_ARGS(), "|l", &ts) == FAILURE) {
-+ if (zend_parse_parameters(ZEND_NUM_ARGS(), "|l", &tl) == FAILURE) {
- return;
- }
-
-- if (!ts) {
-+ if (!tl) {
- ts = time(NULL);
-- } else if (ts < 0) {
-+ } else if (tl < 0) {
- RETURN_FALSE;
-+ } else {
-+ ts = (time_t)tl;
- }
-
- if (!(ta = php_localtime_r(&ts, &tmbuf))) {