aboutsummaryrefslogtreecommitdiffstats
path: root/community/R/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/R/APKBUILD')
-rw-r--r--community/R/APKBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/community/R/APKBUILD b/community/R/APKBUILD
index bec0bf7b3ad..d7db46fbf20 100644
--- a/community/R/APKBUILD
+++ b/community/R/APKBUILD
@@ -2,13 +2,13 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=R
-pkgver=4.2.0
+pkgver=4.3.3
pkgrel=0
pkgdesc="Language and environment for statistical computing"
url="https://www.r-project.org/"
-# riscv64 blocked by java-jre-headless
+# riscv64: blocked by java-jre-headless
arch="all !riscv64"
-license="(GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-or-later"
+license="( GPL-2.0-only OR GPL-3.0-only ) AND LGPL-2.1-or-later"
depends="$pkgname-mathlib"
depends_dev="
bzip2-dev
@@ -29,7 +29,7 @@ depends_dev="
makedepends="
$depends_dev
cairo-dev
- openjdk8-jre-base
+ java-jdk
libxmu-dev
pango-dev
perl
@@ -55,6 +55,7 @@ build() {
# htps://github.com/RcppCore/Rcpp/issues/448
export CXXFLAGS="$CXXFLAGS -D__MUSL__"
+ r_cv_have_curl728=y \
./configure \
--prefix=/usr \
--sysconfdir=/etc/R \
@@ -79,8 +80,8 @@ build() {
--with-tcltk \
--with-x
- make -j1
- make -j1 -C src/nmath/standalone
+ make
+ make -C src/nmath/standalone
}
# TODO: Run provided test suite.
@@ -116,12 +117,6 @@ package() {
mv "$f" "$pkgdir"/etc/R/ && ln -sf /etc/R/$f $f
done
cd -
-
- # Fix #8918
- # R expects iconv -l to return whitespace-separated list of
- # locales, our returns ', ' separated so it adds a , for every
- # locale
- sed -i 's/,//g' "$pkgdir"/usr/lib/R/library/utils/iconvlist
}
mathlib() {
@@ -137,5 +132,5 @@ _dev() {
}
sha512sums="
-99e71dad00b63e44bfcb8dc9539ff1951809112882d9ee7e06a4e99bce2e6ceac24e8348fd598c21e6d5ab0e0629a85170cde208bfa8145af91c398ac4ef7bcd R-4.2.0.tar.gz
+26291590d935ea5678771cdcaea013a6c030897eb762b0204e42b34b0f1d33aac1ec933f36caa18d2a31a057a4456bf629222e4f5679f24bc48a7a764b1aedbe R-4.3.3.tar.gz
"