aboutsummaryrefslogtreecommitdiffstats
path: root/community/abiword/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/abiword/APKBUILD')
-rw-r--r--community/abiword/APKBUILD40
1 files changed, 32 insertions, 8 deletions
diff --git a/community/abiword/APKBUILD b/community/abiword/APKBUILD
index a880b613456..6aa9d51cb6b 100644
--- a/community/abiword/APKBUILD
+++ b/community/abiword/APKBUILD
@@ -1,16 +1,32 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=3.0.5
-pkgrel=0
+pkgrel=10
pkgdesc="A fully-featured word processor"
url="https://www.abisource.com/"
-# s390x, mips, mips64 and riscv64 blocked by librsvg
-arch="all !s390x !mips !mips64 !riscv64"
+arch="all"
options="!check" # Test suite requires valgrind, etc
license="GPL-2.0-or-later"
-makedepends="gtk+3.0-dev readline-dev libgsf-dev enchant2-dev fribidi-dev wv-dev
- popt-dev libjpeg-turbo-dev librsvg-dev bzip2-dev goffice-dev pcre-dev
- libxslt-dev perl automake autoconf libtool autoconf-archive"
+makedepends="
+ autoconf
+ autoconf-archive
+ automake
+ bzip2-dev
+ enchant2-dev
+ fribidi-dev
+ goffice-dev
+ gtk+3.0-dev
+ libgsf-dev
+ libjpeg-turbo-dev
+ librsvg-dev
+ libtool
+ libxslt-dev
+ pcre-dev
+ perl
+ popt-dev
+ readline-dev
+ wv-dev
+ "
# openxml plugin
makedepends="$makedepends boost-dev"
@@ -30,8 +46,11 @@ for _i in $_plugins; do
subpackages="$subpackages $pkgname-plugin-$_i:_plugin"
done
-source="https://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz
- enchant.patch"
+#source="https://www.abisource.com/downloads/abiword/$pkgver/source/abiword-$pkgver.tar.gz
+source="https://dev.alpinelinux.org/archive/abiword/abiword-$pkgver.tar.gz
+ enchant.patch
+ musl-1.2.3.patch
+ "
prepare() {
default_prepare
@@ -58,6 +77,10 @@ check() {
package() {
make DESTDIR="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/share/metainfo
+ mv "$pkgdir"/usr/share/appdata/*.xml "$pkgdir"/usr/share/metainfo
+ rmdir "$pkgdir"/usr/share/appdata
}
_plugin() {
@@ -80,4 +103,5 @@ plugins() {
sha512sums="
a2484268901ff47307c9d1f1928622e364f1006f22ce38257c585144df9411dfe3c2dea28c1f1f50a6e545e8cc579cce34117a89dfa771e20312e3ea1a9989d6 abiword-3.0.5.tar.gz
16f28eafdd1c1444dec5b3f8cbdd00f12c6178ba8db5bb94196064653cdada4cb8e4b2ac78ee9a7093c7968c0ddeb9f50a4e6209a5d5836a24b1b2f1941fb576 enchant.patch
+a4ee1de8df01a6570eb4d069a1b1abd38c39181020f862ce632ab5b863650a58fcaeadc4c988e7fcae3aade5841399d3d5d482d280d44a48286c24e3701e7969 musl-1.2.3.patch
"