aboutsummaryrefslogtreecommitdiffstats
path: root/community/accountsservice/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/accountsservice/APKBUILD')
-rw-r--r--community/accountsservice/APKBUILD43
1 files changed, 27 insertions, 16 deletions
diff --git a/community/accountsservice/APKBUILD b/community/accountsservice/APKBUILD
index 4e72a1012cf..f632f4cbe08 100644
--- a/community/accountsservice/APKBUILD
+++ b/community/accountsservice/APKBUILD
@@ -1,44 +1,55 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=accountsservice
-pkgver=0.6.55
-pkgrel=0
+pkgver=23.13.9
+pkgrel=2
pkgdesc="D-Bus interface for user account query and manipulation"
-options="!check" # No testsuite
url="https://www.freedesktop.org/software/accountsservice/"
arch="all"
license="GPL-3.0-or-later"
-depends_dev="glib-dev gobject-introspection-dev polkit-dev"
+depends_dev="gobject-introspection-dev"
makedepends="
$depends_dev
- intltool
- meson
elogind-dev
+ glib-dev
+ meson
+ polkit-dev
+ vala
"
subpackages="$pkgname-dev $pkgname-lang lib$pkgname:libs"
source="https://www.freedesktop.org/software/accountsservice/accountsservice-$pkgver.tar.xz
musl-fgetspent_r.patch
musl-wtmp.patch
+ opt-tests.patch
"
+# mocklibc fails to build with implicits
+options="!check"
build() {
- meson \
- --prefix=/usr \
- -Dlibdir=lib \
+ abuild-meson \
+ -Db_lto=true \
-Dsystemdsystemunitdir=no \
- -Dsystemd=false \
-Delogind=true \
-Dintrospection=true \
-Ddocbook=false \
-Dgtk_doc=false \
- output
- ninja -C output
+ -Dadmin_group=wheel \
+ -Dtests="$(want_check && echo true || echo false)" \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test --print-errorlogs --no-rebuild -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="c12e6a8e80f9b087f97238da4734d2d3a14a7c5cbd870a32a04b00116f176c818c39fb886f6dc72c3e93c136b0c2074ddf8f77e20431fa3bd54f138bea9d262d accountsservice-0.6.55.tar.xz
+sha512sums="
+c6eb543ce2e07b61bbdfa454e388949bc688517be0536b14f30c66383ed105b15d3fab8b6c62b1eaa08f67d9bdc29b928729d9f7c704f47de4decf0de8e12f89 accountsservice-23.13.9.tar.xz
469392beca8f5941eafaa193c4fcb0472770ee4183ce520416a1b5d6abafe0e201990eb74d06bfbd9e20af08e55aff5f0031f267083f6c6879f0fe4e5028103c musl-fgetspent_r.patch
-7b41a5fd4c2ab178762902d137ebf6eb6edbf97bae9255d17c4380c8c738b159aa25a2e51c31f740789560f17850c71b0bb60ee792a2a87be6b60cb5c89d7efc musl-wtmp.patch"
+6d81caed730473d5c94d575c580a236b4267b374bf50588860922a7ecbeef0b2a1d50124fa3ae195c4f26abe8c3bd6df2aea6d27a0ce23e99acef9fff3eb9652 musl-wtmp.patch
+cc5ea18d885ccc5a85f5f4191d3157f3953878af289a9cabc373afea67726042144d66fd9f8d08dac7090fc23037ab98adb4101e8378a16ab2eb04043c88378f opt-tests.patch
+"