aboutsummaryrefslogtreecommitdiffstats
path: root/community/accountsservice/musl-wtmp.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/accountsservice/musl-wtmp.patch')
-rw-r--r--community/accountsservice/musl-wtmp.patch16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/accountsservice/musl-wtmp.patch b/community/accountsservice/musl-wtmp.patch
index 4393c0209ab..f9dd264802a 100644
--- a/community/accountsservice/musl-wtmp.patch
+++ b/community/accountsservice/musl-wtmp.patch
@@ -1,13 +1,15 @@
+the assert expects a working /var/log/wtmp at build time
+diff --git a/meson.build b/meson.build
+index 4a509e7..f995d28 100644
--- a/meson.build
+++ b/meson.build
-@@ -82,8 +82,7 @@ if cc.has_header_symbol('utmpx.h', 'WTMPX_FILENAME', prefix: '#define _GNU_SOURC
- elif cc.has_header_symbol('paths.h', '_PATH_WTMPX')
+@@ -103,8 +103,7 @@ elif cc.has_header_symbol('paths.h', '_PATH_WTMPX')
+
config_h.set('PATH_WTMP', '_PATH_WTMPX')
else
-- assert(run_command('test', '-e', '/var/log/utx.log').returncode() == 0, 'Do not know which filename to watch for wtmp changes')
-- config_h.set_quoted('PATH_WTMP', '/var/log/utx.log')
-+ config_h.set_quoted('PATH_WTMP', '/var/log/wtmp')
+- path_wtmp = '/var/log/utx.log'
+- assert(run_command('test', '-e', path_wtmp, check: false).returncode() == 0, 'Do not know which filename to watch for wtmp changes')
++ path_wtmp = '/var/log/wtmp'
+ config_h.set_quoted('PATH_WTMP', path_wtmp)
endif
- # compiler flags
-