aboutsummaryrefslogtreecommitdiffstats
path: root/community/adw-gtk3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/adw-gtk3/APKBUILD')
-rw-r--r--community/adw-gtk3/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/adw-gtk3/APKBUILD b/community/adw-gtk3/APKBUILD
new file mode 100644
index 00000000000..c0ff22018e4
--- /dev/null
+++ b/community/adw-gtk3/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: knuxify <knuxify@gmail.com>
+# Maintainer: knuxify <knuxify@gmail.com>
+pkgname=adw-gtk3
+pkgver=5.3
+pkgrel=0
+pkgdesc="The theme from libadwaita ported to GTK-3"
+url="https://github.com/lassekongo83/adw-gtk3"
+arch="noarch"
+license="LGPL-2.1-or-later"
+makedepends="meson sassc"
+source="https://github.com/lassekongo83/adw-gtk3/archive/refs/tags/v$pkgver/adw-gtk3-$pkgver.tar.gz"
+options="!check" # no test suite
+
+build() {
+ abuild-meson \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="
+8a887a9d3253b929a78e3afaa13de25a7de3601ba81ad3f15769e331128e16092b61c592dc4059cb0af3059adacf06cf754b0c72ee4f275078afd47b89a12f82 adw-gtk3-5.3.tar.gz
+"