aboutsummaryrefslogtreecommitdiffstats
path: root/community/age/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/age/APKBUILD')
-rw-r--r--community/age/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/age/APKBUILD b/community/age/APKBUILD
new file mode 100644
index 00000000000..a76843f1cf2
--- /dev/null
+++ b/community/age/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=age
+pkgver=1.1.1
+pkgrel=11
+pkgdesc="Simple, modern and secure encryption tool"
+url="https://github.com/FiloSottile/age"
+license="BSD-3-Clause"
+arch="all"
+makedepends="go"
+subpackages="$pkgname-doc"
+source="https://github.com/FiloSottile/age/archive/v$pkgver/age-$pkgver.tar.gz"
+options="net" # Go modules
+
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
+build() {
+ mkdir bin
+ go build -ldflags "-X main.Version=$pkgver" -o bin ./cmd/...
+}
+
+check() {
+ go test ./...
+}
+
+package() {
+ install -Dm755 bin/* -t "$pkgdir"/usr/bin
+ install -Dm644 doc/*.1 -t "$pkgdir"/usr/share/man/man1
+}
+
+sha512sums="
+bee02208453982b6403382c1e351ba28cbe80942702e7a35de89c3ae9a640c26ad1ee8239feb3726eac5df4210a5fc6375d40623162cad033965bd2eb0f7ce1e age-1.1.1.tar.gz
+"