aboutsummaryrefslogtreecommitdiffstats
path: root/community/age/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/age/APKBUILD')
-rw-r--r--community/age/APKBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/community/age/APKBUILD b/community/age/APKBUILD
index b6d3c826e72..a76843f1cf2 100644
--- a/community/age/APKBUILD
+++ b/community/age/APKBUILD
@@ -2,20 +2,20 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=age
-pkgver=1.0.0
-pkgrel=5
+pkgver=1.1.1
+pkgrel=11
pkgdesc="Simple, modern and secure encryption tool"
url="https://github.com/FiloSottile/age"
license="BSD-3-Clause"
arch="all"
-options="net" # for downloading Go modules
makedepends="go"
subpackages="$pkgname-doc"
source="https://github.com/FiloSottile/age/archive/v$pkgver/age-$pkgver.tar.gz"
+options="net" # Go modules
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -modcacherw"
-export CGO_ENABLED=0
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
mkdir bin
@@ -27,10 +27,10 @@ check() {
}
package() {
- install -Dm755 -t "$pkgdir"/usr/bin bin/*
- install -Dm644 -t "$pkgdir"/usr/share/man/man1 doc/*.1
+ install -Dm755 bin/* -t "$pkgdir"/usr/bin
+ install -Dm644 doc/*.1 -t "$pkgdir"/usr/share/man/man1
}
sha512sums="
-77ea1af03a76339f4e934222bc9fc6119698080d0e03011c79b25119e0e8a1e6c0772ede5069cd63bde48cfaa4d355c897912741680e8b0c52d4c518182c2f7f age-1.0.0.tar.gz
+bee02208453982b6403382c1e351ba28cbe80942702e7a35de89c3ae9a640c26ad1ee8239feb3726eac5df4210a5fc6375d40623162cad033965bd2eb0f7ce1e age-1.1.1.tar.gz
"