aboutsummaryrefslogtreecommitdiffstats
path: root/community/aisleriot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/aisleriot/APKBUILD')
-rw-r--r--community/aisleriot/APKBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/community/aisleriot/APKBUILD b/community/aisleriot/APKBUILD
index c6e3c1d0c45..c3a8360a395 100644
--- a/community/aisleriot/APKBUILD
+++ b/community/aisleriot/APKBUILD
@@ -1,35 +1,44 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer:
pkgname=aisleriot
-pkgver=3.22.13
+pkgver=3.22.31
pkgrel=0
pkgdesc="Solitaire and other card games for GNOME"
url="https://wiki.gnome.org/Apps/Aisleriot"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all"
license="GPL-3.0-or-later"
options="!strip" # guille libraries cannot be stripped
depends="guile"
-makedepends="meson bash librsvg-dev guile-dev libxml2 libxml2-dev libxml2-utils
- itstool gtk+3.0-dev libcanberra-dev gmp-dev"
+depends_doc="yelp"
+makedepends="
+ bash
+ gmp-dev
+ gtk+3.0-dev
+ guile-dev
+ itstool
+ libcanberra-dev
+ librsvg-dev
+ libxml2-dev
+ meson
+ "
subpackages="$pkgname-doc $pkgname-lang"
-source="https://gitlab.gnome.org/GNOME/aisleriot/-/archive/$pkgver/aisleriot-$pkgver.tar.gz
- fix-bash-shebang.patch"
+source="https://gitlab.gnome.org/GNOME/aisleriot/-/archive/$pkgver/aisleriot-$pkgver.tar.gz"
build() {
abuild-meson \
-Dtheme_kde=false \
- -Dsound=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="62dd72063566056c7b94142e77f101d3b226319b89ad093b1076b2176aac0716eefed4ffcefc7c95a1e8eafcdffc1eec4d269784726e38010a6c07693c5c84fd aisleriot-3.22.13.tar.gz
-9db40fb258e8d70de8d1763eaf08fc1c9b79291efff8018556f2a18d40dd66c0f73b37083199bee6e41130766b91b124e539afed2a8ccde8105e34a0bc8f1f43 fix-bash-shebang.patch"
+sha512sums="
+758334764743c87a601cce23165f14ac10a7b03600938f89b6a713525304045ace55b47434ed978b910616c5f4ca19fd5ebbf52bc518e3d2c37e7bf55308ff83 aisleriot-3.22.31.tar.gz
+"