aboutsummaryrefslogtreecommitdiffstats
path: root/community/aisleriot/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/aisleriot/APKBUILD')
-rw-r--r--community/aisleriot/APKBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/community/aisleriot/APKBUILD b/community/aisleriot/APKBUILD
index 690b54a55b9..c3a8360a395 100644
--- a/community/aisleriot/APKBUILD
+++ b/community/aisleriot/APKBUILD
@@ -1,29 +1,38 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer:
pkgname=aisleriot
-pkgver=3.22.17
+pkgver=3.22.31
pkgrel=0
pkgdesc="Solitaire and other card games for GNOME"
url="https://wiki.gnome.org/Apps/Aisleriot"
-arch="all !s390x !mips !mips64 !riscv64" # limited by librsvg -> rust
+arch="all"
license="GPL-3.0-or-later"
options="!strip" # guille libraries cannot be stripped
depends="guile"
-makedepends="meson bash librsvg-dev guile-dev libxml2 libxml2-dev libxml2-utils
- itstool gtk+3.0-dev libcanberra-dev gmp-dev"
+depends_doc="yelp"
+makedepends="
+ bash
+ gmp-dev
+ gtk+3.0-dev
+ guile-dev
+ itstool
+ libcanberra-dev
+ librsvg-dev
+ libxml2-dev
+ meson
+ "
subpackages="$pkgname-doc $pkgname-lang"
source="https://gitlab.gnome.org/GNOME/aisleriot/-/archive/$pkgver/aisleriot-$pkgver.tar.gz"
build() {
abuild-meson \
-Dtheme_kde=false \
- -Dsound=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -31,5 +40,5 @@ package() {
}
sha512sums="
-42571cacceffdc1c912b2b122e44dbb2ad045f636259d2c645e8501ac456bad44b784d108cf7a20c78451b9a3c457a97a089205495c8036e9c5333fcabac6b45 aisleriot-3.22.17.tar.gz
+758334764743c87a601cce23165f14ac10a7b03600938f89b6a713525304045ace55b47434ed978b910616c5f4ca19fd5ebbf52bc518e3d2c37e7bf55308ff83 aisleriot-3.22.31.tar.gz
"