aboutsummaryrefslogtreecommitdiffstats
path: root/community/akonadi-calendar/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/akonadi-calendar/APKBUILD')
-rw-r--r--community/akonadi-calendar/APKBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/community/akonadi-calendar/APKBUILD b/community/akonadi-calendar/APKBUILD
index efe8c8c4fff..281b2cf3351 100644
--- a/community/akonadi-calendar/APKBUILD
+++ b/community/akonadi-calendar/APKBUILD
@@ -1,17 +1,20 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=akonadi-calendar
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="Akonadi calendar integration"
# armhf blocked by extra-cmake-modules
-# ppc64le, s390x, mips64 and riscv64 blocked by kmailtransport -> libkgapi -> qt5-qtwebengine
-arch="all !armhf !ppc64le !s390x !mips64 !riscv64"
+# ppc64le, s390x, riscv64, armv7 blocked by kmailtransport -> libkgapi -> qt6-qtwebengine
+arch="all !armhf !ppc64le !s390x !riscv64 !armv7"
url="https://community.kde.org/KDE_PIM"
license="LGPL-2.0-or-later"
depends_dev="
- akonadi-contacts-dev>=$pkgver
- akonadi-dev>=$pkgver
+ akonadi-contacts-dev
+ akonadi-dev
kcalendarcore-dev
kcalutils-dev
kcodecs-dev
@@ -23,31 +26,34 @@ depends_dev="
kmailtransport-dev
kwidgetsaddons-dev
kxmlgui-dev
+ messagelib-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-calendar-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
-options="!check" # Broken
+_repo_url="https://invent.kde.org/pim/akonadi-calendar.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-calendar-$pkgver.tar.xz"
+
+replaces="kalendar>1.0.0"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "kcalcoreserializertest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-ff955aac313a5f5a452ba060809324fa4ce32f70d59246e9b68209595bbe5360f7fe6df15b99b90d05cb759021ff3bc515ca8539f92e8f80e7e3260245f4e903 akonadi-calendar-21.08.2.tar.xz
+ff1baa1080e759b42412ec996f47aa5dae7152bba9e1a8a845e2b16337a43c8d5f31214db5f581c38dc5ca9c3b5a072a6c2b3d50fa277d1540ce626ab5b202b6 akonadi-calendar-24.02.2.tar.xz
"