aboutsummaryrefslogtreecommitdiffstats
path: root/community/akonadi-notes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/akonadi-notes/APKBUILD')
-rw-r--r--community/akonadi-notes/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/akonadi-notes/APKBUILD b/community/akonadi-notes/APKBUILD
index c0421b68c52..88da84d05c1 100644
--- a/community/akonadi-notes/APKBUILD
+++ b/community/akonadi-notes/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=akonadi-notes
-pkgver=22.08.0
+pkgver=24.02.2
pkgrel=0
pkgdesc="Libraries and daemons to implement management of notes"
# armhf blocked by extra-cmake-modules
@@ -11,14 +14,15 @@ license="LGPL-2.0-or-later"
depends_dev="
ki18n-dev
kmime-dev
- qt5-qtbase-dev
- samurai
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-notes-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/akonadi-notes.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-notes-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -29,8 +33,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -38,5 +41,5 @@ package() {
}
sha512sums="
-63fee5ea3f9d1af77df6800c1ad118ec4d00eb261f12b8aef1ea7f0582310433a3d0ce57251d56633d5291071de036a2c91e7df65f5dce3b504bd2442a16b26b akonadi-notes-22.08.0.tar.xz
+38cc2e0c1d10ce47708d8f255a48162bcb51c4a053aa1ffc9124a9307b53d0bec5abe7133bfd8a207cf27ff06caf74347c8f35c0c84dd2b6d358d1a164698a61 akonadi-notes-24.02.2.tar.xz
"