aboutsummaryrefslogtreecommitdiffstats
path: root/community/akonadi-notes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/akonadi-notes/APKBUILD')
-rw-r--r--community/akonadi-notes/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/akonadi-notes/APKBUILD b/community/akonadi-notes/APKBUILD
index 8cc1a8234b8..88da84d05c1 100644
--- a/community/akonadi-notes/APKBUILD
+++ b/community/akonadi-notes/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=akonadi-notes
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="Libraries and daemons to implement management of notes"
# armhf blocked by extra-cmake-modules
@@ -11,30 +14,32 @@ license="LGPL-2.0-or-later"
depends_dev="
ki18n-dev
kmime-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
extra-cmake-modules
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-notes-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/akonadi-notes.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-notes-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-2432077d1336a432cc77b553c9e1b0446a2d99a31f588ea865c3a242419dccf9a3a23086ee5ecb91380a8d55aeb9041f6428c903f06bc472e9997a7310abd82c akonadi-notes-21.04.3.tar.xz
+38cc2e0c1d10ce47708d8f255a48162bcb51c4a053aa1ffc9124a9307b53d0bec5abe7133bfd8a207cf27ff06caf74347c8f35c0c84dd2b6d358d1a164698a61 akonadi-notes-24.02.2.tar.xz
"