aboutsummaryrefslogtreecommitdiffstats
path: root/community/akonadi-search
diff options
context:
space:
mode:
Diffstat (limited to 'community/akonadi-search')
-rw-r--r--community/akonadi-search/APKBUILD46
1 files changed, 31 insertions, 15 deletions
diff --git a/community/akonadi-search/APKBUILD b/community/akonadi-search/APKBUILD
index 97ebb858d50..178fa78f0fe 100644
--- a/community/akonadi-search/APKBUILD
+++ b/community/akonadi-search/APKBUILD
@@ -1,18 +1,23 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=akonadi-search
-pkgver=20.12.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="Libraries and daemons to implement searching in Akonadi"
# armhf blocked by extra-cmake-modules
-# mips and mips64 blocked by akonadi
+# riscv64 blocked by akonadi
# s390x blocked by multiple KDE Frameworks
-arch="all !armhf !mips !mips64 !s390x"
+# ppc64le blocked by qt6-qtwebengine -> akonadi
+arch="all !armhf !s390x !riscv64 !ppc64le"
url="https://community.kde.org/KDE_PIM"
-license="(GPL-2.0-only OR GPL-3.0-only) AND (LGPL-2.1-only OR LGPL-3.0-only)"
+license="( GPL-2.0-only OR GPL-3.0-only ) AND ( LGPL-2.1-only OR LGPL-3.0-only )"
depends_dev="
- akonadi-dev>=$pkgver
- akonadi-mime-dev>=$pkgver
+ akonadi-dev
+ akonadi-mime-dev
+ corrosion
kcalendarcore-dev
kcmutils-dev
kconfig-dev
@@ -23,19 +28,28 @@ depends_dev="
kio-dev
kmime-dev
krunner-dev
- qt5-qtbase-dev
+ ktextaddons-dev
+ qt6-qtbase-dev
xapian-core-dev
"
-makedepends="$depends_dev extra-cmake-modules"
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-search-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/akonadi-search.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/akonadi-search-$pkgver.tar.xz"
+options="net" # Required to download Rust crates
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_QCH=ON
cmake --build build
}
@@ -61,6 +75,8 @@ check() {
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="cbb9bb579b0545198ebc145d41ca3ffdc84a5cdab00941ef133c5d2fba2e720eefdb4ea52edfa065bcd2baffe5a612c15058fd5d7a2106c8728ad4ff6e531de0 akonadi-search-20.12.2.tar.xz"
+sha512sums="
+9c157bc1fbc231f84ef5ccd37eb50e80207e794d0971a3c65fce438491000cf05b7f9b9da34f7285bf7c7323a1195b4cbbde1044436c785f408cec7d8e30d679 akonadi-search-24.02.2.tar.xz
+"