aboutsummaryrefslogtreecommitdiffstats
path: root/community/akonadiconsole/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/akonadiconsole/APKBUILD')
-rw-r--r--community/akonadiconsole/APKBUILD50
1 files changed, 27 insertions, 23 deletions
diff --git a/community/akonadiconsole/APKBUILD b/community/akonadiconsole/APKBUILD
index 8f61c789b11..6bf4fbfe86d 100644
--- a/community/akonadiconsole/APKBUILD
+++ b/community/akonadiconsole/APKBUILD
@@ -1,57 +1,61 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=akonadiconsole
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, ppc64le, mips64 and riscv64 blocked by akonadi
-# ppc64le blocked by calendarsupport
-arch="all !armhf !s390x !ppc64le !mips64 !riscv64"
+# s390x, ppc64le and riscv64 blocked by akonadi
+# ppc64le and armv7 blocked by calendarsupport
+arch="all !armhf !s390x !ppc64le !riscv64 !armv7"
url="https://kontact.kde.org/"
pkgdesc="Application for debugging Akonadi Resources"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
+ akonadi-contacts-dev
+ akonadi-dev
+ akonadi-search-dev
+ calendarsupport-dev
extra-cmake-modules
- qt5-qtbase-dev
+ kcalendarcore-dev
+ kcompletion-dev
kcompletion-dev
kconfig-dev
kconfigwidgets-dev
+ kcontacts-dev
+ kcrash-dev
kdbusaddons-dev
kdoctools-dev
ki18n-dev
+ kio-dev
kitemmodels-dev
+ kitemviews-dev
+ kmime-dev
ktextwidgets-dev
kwidgetsaddons-dev
kxmlgui-dev
- kcrash-dev
- kcompletion-dev
- kitemviews-dev
- kio-dev
- akonadi-dev
- kcontacts-dev
- kcalendarcore-dev
- kmime-dev
- akonadi-contacts-dev
- calendarsupport-dev
- messagelib-dev
libkdepim-dev
- akonadi-search-dev
+ messagelib-dev
+ qt6-qtbase-dev
+ samurai
xapian-bindings
"
checkdepends="xvfb-run"
+_repo_url="https://invent.kde.org/pim/akonadiconsole.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/akonadiconsole-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -59,5 +63,5 @@ package() {
}
sha512sums="
-e5cc5cd6e8815dc80bd1c79373e4b86e250cc0fcd8d4fede7e11856cebd6b50348e8f781db2f328e196d8b15219e14e3e0cfd69ca70c09a357bfe8360048f37a akonadiconsole-21.12.1.tar.xz
+c45a23185083fc16e7f4406b16e35a9bcdb9975d3e3a40e6bc58af64ea745fd7f141ad3de4b03df056833a119fdf17467fe7b20e612efaf44df9b2528548f768 akonadiconsole-24.02.2.tar.xz
"