aboutsummaryrefslogtreecommitdiffstats
path: root/community/alex/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/alex/APKBUILD')
-rw-r--r--community/alex/APKBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/community/alex/APKBUILD b/community/alex/APKBUILD
index 90afc9fe0dd..9dcf4aa9efd 100644
--- a/community/alex/APKBUILD
+++ b/community/alex/APKBUILD
@@ -1,21 +1,19 @@
# Contributor: River Dillon <oss@outerpassage.net>
# Maintainer: River Dillon <oss@outerpassage.net>
pkgname=alex
-pkgver=3.2.6
-pkgrel=2
+pkgver=3.5.0.0
+pkgrel=0
pkgdesc="lexical analyser generator for Haskell"
url="https://www.haskell.org/alex/"
-arch="x86_64" # limited by ghc
+arch="x86_64 aarch64" # limited by ghc
license="BSD-3-Clause"
makedepends="ghc libffi-dev"
subpackages="$pkgname-doc"
-source="
- https://hackage.haskell.org/package/alex-$pkgver/alex-$pkgver.tar.gz
- https://www.haskell.org/alex/doc/alex-doc-html-3.0.tar.gz
- fix-tests-ghc-9.0.patch
- "
+source="https://hackage.haskell.org/package/alex-$pkgver/alex-$pkgver.tar.gz"
build() {
+ # ghc version path
+ export PATH="$PATH:/usr/lib/llvm14/bin"
runhaskell Setup.hs configure \
"--prefix=/usr" \
"--datasubdir=$pkgname" \
@@ -32,11 +30,8 @@ package() {
docdir="usr/share/doc/$pkgname"
runhaskell Setup.hs copy "--destdir=$pkgdir"
rm "$pkgdir/$docdir/LICENSE" # no need to include a standard license
- install -Dm644 -t "$pkgdir/$docdir/html/" "$srcdir/$pkgname"/*
}
sha512sums="
-05b6e55e9a1c348aea599d1130780a3d2a0a7c5f1db00b2c98bd34737cac9d48842fb1b1f98947a99d99013f94e39a6ffee1af8546f02fb2d32fcf362ff0f83c alex-3.2.6.tar.gz
-c9497e9b6c80d79d29bd5b1d05cf4077c30c2d94b9c6c321145ca104db204deb96db66f8abba0ad2e849556eda8b901aa6181935e8aca81ff9ffc676d19f87dd alex-doc-html-3.0.tar.gz
-9e8236a3e08add1b2c8ed97da636de900d3f562df2a9dc5496bdf5578908d700c1106cf8ee6b86e4244c02e64b66caa1289b298d66bccc441dae9a3b76dda2d9 fix-tests-ghc-9.0.patch
+c1da20dd14a79e74a500a9b10e405cca707a56423574a7cff8410d0ba5a7ab890090da13b7cb34e7646091398b276101281590ecb7bf2b55d25a240360b8fb95 alex-3.5.0.0.tar.gz
"