aboutsummaryrefslogtreecommitdiffstats
path: root/community/ali/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ali/APKBUILD')
-rw-r--r--community/ali/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/ali/APKBUILD b/community/ali/APKBUILD
index d9fcb1ae22c..2b932c08990 100644
--- a/community/ali/APKBUILD
+++ b/community/ali/APKBUILD
@@ -1,11 +1,11 @@
# Contributor: Marvin Preuss <marvin@xsteadfastx.org>
# Maintainer: Marvin Preuss <marvin@xsteadfastx.org>
pkgname=ali
-pkgver=0.7.3
+pkgver=0.7.5
# this is used for the help command to print the commit.
# needs to be changed on every release.
-_rev=22d6aed
-pkgrel=0
+_rev=c0aa677
+pkgrel=21
pkgdesc="Generate HTTP load and plot the results in real-time"
url="https://github.com/nakabonne/ali"
arch="all"
@@ -14,8 +14,10 @@ options="chmod-clean"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/nakabonne/ali/archive/refs/tags/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
export GOFLAGS="$GOFLAGS -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build \
@@ -34,5 +36,5 @@ package() {
install -Dm755 $pkgname "$pkgdir"/usr/bin/"$pkgname"
}
sha512sums="
-d10cfb882707a8a366982316247edefdf88bf2f2c3f5f4c554c6d3834edbe587ff9a7de7e128b1c742593ed4f1a145e9ed4b2dc2e7ef7b26c058beb3e1576360 ali-0.7.3.tar.gz
+6ae745556bec663abcb2a8d6c5e090fdd5e6b5a8bb889f85c528f749de79eb0e33d794265a801983f8de81629e19a1a38fe147e5095108310b1a353766866ff3 ali-0.7.5.tar.gz
"