aboutsummaryrefslogtreecommitdiffstats
path: root/community/ali/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ali/APKBUILD')
-rw-r--r--community/ali/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/community/ali/APKBUILD b/community/ali/APKBUILD
index 73720b27d7c..864f5879a63 100644
--- a/community/ali/APKBUILD
+++ b/community/ali/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.7.5
# this is used for the help command to print the commit.
# needs to be changed on every release.
_rev=c0aa677
-pkgrel=4
+pkgrel=20
pkgdesc="Generate HTTP load and plot the results in real-time"
url="https://github.com/nakabonne/ali"
arch="all"
@@ -14,8 +14,10 @@ options="chmod-clean"
makedepends="go"
source="$pkgname-$pkgver.tar.gz::https://github.com/nakabonne/ali/archive/refs/tags/v$pkgver.tar.gz"
-export GOPATH="$srcdir"
export GOFLAGS="$GOFLAGS -modcacherw"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
go build \